Subject: Re: [pkix] 2560bis

From: Peter Yee <[email-masked]>
Date: Wed, 01 Aug 2012 15:26:53 -0700

A as well.

		-Peter

On 7/29/12 10:13 AM, "Stephen Kent" <[email-masked]> wrote:

>Folks,
>
>Recent messages exchanges point to significant disagreement about the
>future direction
>for this doc. At the March meeting Stefan presented a proposal for how
>to move
>ahead, as outlined in his slides. As noted in the minutes, the audience
>(at the mic)
>included one indication of support for this streamlined approach, and
>one expression
>of concern. Not a lot of interest.
>
>Work on this doc has dragged on for 2 years now. In October of 2011
>Santosh argued that
>version -04 of the doc was, in his opinion, a step backwards, adding
>more confusion to
>RFC 2560 vs. clarifying it. Stefan agreed (in a message in March of
>2012), and
>thus he created the current, stripped-down version of the doc (-05)
>which was published
>recently.
>
>Given the mixed response to this version, it's not clear that the WG
>members who are interested
>in OCSP clarifications are in agreement on how to proceed.
>
>So, let's begin a straw poll on the topic.  Here are the options I am
>offering:
>
>     A - continue to work with the -05 version as the basis for an RFC
>     B - revert to the -04 version as the basis for an RFC
>     C - don't publish a clarifications document for OCSP
>     D - the respondent volunteers to work on a new version of 2560bis
>
>Please send your replies to the list starting now. The straw poll will
>close
>in two weeks, on August 12. While there are many other, legitimate
>comments one could
>offer, I am interested only in replies to this multiple choice straw
>poll (i.e., no
>essay replies :-) )
>
>Thanks,
>
>Steve
>
>
>_______________________________________________
>pkix mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/pkix
>

---

From: Simon Josefsson <[email-masked]>
Date: Thu, 02 Aug 2012 01:13:53 +0200

>     D - the respondent volunteers to work on a new version of 2560bis

A

/Simon

---

From: [email-masked]
Date: Mon, 6 Aug 2012 14:35:18 +0200

Steve,

I vote for D; i.e. :

D - the respondent volunteers to work on a new version of 2560bis.

I hope to be able to deliver such a new version within two weeks from now.

I plan to add explanations:
   - for OCSP clients when they build a request,
   - for OCSP clients when they verify a response.

As an example, explanations are missing to explain how to process the 
responderID field from a ResponseData.

I plan to add requirements related to key rollover :
    1 - CA key rollover (without delegated OCSP responder),
    2 - delegated OCSP responders:
          - OCSP key rollover (without CA key rollover),
          - CA key rollover without a new OCSP key, and
          - CA key rollover with a new OCSP key.

I plan to work from version -05 which is not "good enough", but 
much better than version -04 with all its annexes.

Denis

De :    Stephen Kent <[email-masked]>
A :     pkix <[email-masked]>
Date :  29/07/2012 19:13
Objet : [pkix] 2560bis
Envoyé par :    [email-masked]

Folks,

Thanks,

Steve