Subject: Re: [pkix] [Editorial Errata Reported] RFC4055 (5325)

From: Russ Housley <[email-masked]>
Date: Fri, 13 Apr 2018 12:59:06 -0400

Yes, the correction is appropriate.  That said, I do not think an implementor will be confused, so I suggest a "Hold for Future Update"

Russ

> On Apr 13, 2018, at 12:40 PM, RFC Errata System <[email-masked]> wrote:
> 
> The following errata report has been submitted for RFC4055,
> "Additional Algorithms and Identifiers for RSA Cryptography for use in the Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) Profile".
> 
> --------------------------------------
> You may review the report below and at:
> http://www.rfc-editor.org/errata/eid5325
> 
> --------------------------------------
> Type: Editorial
> Reported by: Ryan Sleevi <[email-masked]>
> 
> Section: 4055
> 
> Original Text
> -------------
> If the keyUsage extension is present in a certificate conveys an RSA
> public key with the id-RSAES-OAEP object identifier, then the
> keyUsage extension MUST contain only the following values:
> 
> 
> Corrected Text
> --------------
> If the keyUsage extension is present in a certificate that conveys an
> RSA public key with the id-RSAES-OAEP object identifier, then the
> keyUsage extension MUST contain only the following values:
> 
> 
> Notes
> -----
> The certificate, rather than the keyUsage extension, conveys the id-RSAES-OAEP OID.
> 
> This was likely a typo based on the wording of the previous paragraph, "When a certificate conveys an RSA public key". This aligns the language with the paragraph earlier in this section, "If the keyUsage extension is present in an end-entity certificate that conveys an RSA public key".
> 
> Instructions:
> -------------
> This erratum is currently posted as "Reported". If necessary, please
> use "Reply All" to discuss whether it should be verified or
> rejected. When a decision is reached, the verifying party  
> can log in to change the status and edit the report, if necessary. 
> 
> --------------------------------------
> RFC4055 (draft-ietf-pkix-rsa-pkalgs-03)
> --------------------------------------
> Title               : Additional Algorithms and Identifiers for RSA Cryptography for use in the Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) Profile
> Publication Date    : June 2005
> Author(s)           : J. Schaad, B. Kaliski, R. Housley
> Category            : PROPOSED STANDARD
> Source              : Public-Key Infrastructure (X.509)
> Area                : Security
> Stream              : IETF
> Verifying Party     : IESG

---

From: Ryan Sleevi <[email-masked]>
Date: Fri, 13 Apr 2018 13:19:33 -0400

Indeed, I doubt any implementer will be confused - and only noticed it
while reading aloud the requirements to someone else and realizing it
sounded weird :)

On Fri, Apr 13, 2018 at 12:59 PM, Russ Housley <[email-masked]> wrote:

> Yes, the correction is appropriate.  That said, I do not think an
> implementor will be confused, so I suggest a "Hold for Future Update"
>
> Russ
>
>
> > "Additional Algorithms and Identifiers for RSA Cryptography for use in
> the Internet X.509 Public Key Infrastructure Certificate and Certificate
> Revocation List (CRL) Profile".
> >
> > This was likely a typo based on the wording of the previous paragraph,
> "When a certificate conveys an RSA public key". This aligns the language
> with the paragraph earlier in this section, "If the keyUsage extension is
> present in an end-entity certificate that conveys an RSA public key".
> >
> > Instructions:
> > -------------
> > Title               : Additional Algorithms and Identifiers for RSA
> Cryptography for use in the Internet X.509 Public Key Infrastructure
> Certificate and Certificate Revocation List (CRL) Profile