Subject: RE: [pmtud] RE: [dccp] PMTU issues

From: "Phelan, Tom" <[email-masked]>
Date: Fri, 14 Nov 2003 11:06:02 -0500

Hi All,

Excuse my naivete about PMTUD, but it occurs to me that there's a different
approach DCCP could take that wouldn't involve lost probe packets.  If
anyone has any experience with this type of scheme, please chime in ...

Roughly, the scheme goes like this:

o The initial PMTU is set to the MTU of the first hop.

o The transmitting DCCP does *not* set the DF bit in data packets.

o The receiving IP tells the receiving DCCP about packets that needed
reassembly, including the fragment size.

o The receiving DCCP communicates the new PMTU back to the transmitting DCCP
in an option.

Tom P.

-----Original Message-----
From: [email-masked]
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked];
[email-masked]
Sent: 11/14/2003 10:21 AM
Subject: Re: [pmtud] RE: [dccp] PMTU issues

> This conversation about UDP apps has inspireed me to specificlly cover
that 
> case in the next iteration.  Has anybody tried to implement pmtud
using UDP?
> I have a hunch that there are some API gotchas for current OS's.

	UDP is a unreliable data transport, so loss of packet due to
PMTU is
	okay.  *BSD can do PMTUD for UDP without much change (set DF=1
in
	udp_output)

itojun

_______________________________________________
pmtud mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pmtud

---

From: John Heffner <[email-masked]>
Date: Fri, 14 Nov 2003 11:11:33 -0500 (EST)

> o The receiving DCCP communicates the new PMTU back to the transmitting DCCP

Interesting, but I think this will not work with IPv6.

  -John