Subject: PCIM Extensions

From: Mahadevan Iyer <[email-masked]>
Date: Sun, 14 Jan 2001 20:37:49 -0800 (PST)

Hello All,

Context
=======
  I am working on an information model for a policy
application related to provisioning of VPN's over an
IP network(IPVPN Policy Information Model).

  Each IPVPN has connectivity, security and QoS
components. I am attempting to use the constructs
defined in the QPIM as far as possible.

Details
=======
  There were 3 requirements (among others) which I
could not resolve using the QPIM constructs. I would
like to address them to the group investigating
extensions to PCIM. 
  The hope is that the application can use
standardized extensions to satisfy these reqirements.
This would help limit the new constructs being defined
in the IPVPN model to the application specific
details.

  1. There needs to be a means to associate aggregate
conditions at the policy group level to narrow the
search for a matching policy. (There have been many
emails explaining this requirement on the mailing
list)

  2. There are 3 types of policy domains which need to
be supported in the application viz. Administrative,
Functional and Enforcement. Organizing the containment
according to one of these domains does not solve the
problem of the remaining two domains. The three
domains could be completely overlapping or mutually
exclusive. 
     There needs to be an uniform means to map all
three domains.

  3. There needs to be a means to formally specify the
policy target(some overlap with the enforcement
domain) in the policyrule. I am looking for something
that is stronger than a policy condition variable
type. The logic that led to the creation of
"PolicyTimePeriodCondition", instead of adding a
policy condition variable type, could be applied out
here.

Looking for ...
===============

1. Feedback on relevence of these requirements in
other policy applications
2. Feedback on whether these should be addressed in
the extensions
3. Feedback on how they(if the answer to 2 is yes)
could be addressed in extensions.

Thanks

__________________________________________________
Do You Yahoo!?
Get email at your own domain with Yahoo! Mail. 
http://personal.mail.yahoo.com/

---

From: "Lee Rafalow" <[email-masked]>
Date: Mon, 15 Jan 2001 10:15:27 -0500

Mahadevan,
> emails explaining this requirement on the mailing

I think the requirement is now understood, it's just the solution that needs
further discussion.

>      There needs to be an uniform means to map all

Say more.

> policy condition variable type, could be applied out

What are the functions you're looking for that are not provided by
PolicyRole?

Lee

Lee M. Rafalow
Voice: 1-919-254-4455; Fax: 1-919-254-6243
IBM Internet Technology Management
IBM Corporation
P.O. Box 12195, BRQA/502
RTP, NC 27709 USA
Alternate email: [email-masked]
Home email: [email-masked]