Subject: include MPLS information model as work item

From: Marcus Brunner <[email-masked]>
Date: Fri, 16 Feb 2001 17:48:00 +0100

Dear all,

We ask for inclusion of the MPLS information model and the corresponding 
policy model as a work item in the TE-WG.

The draft in the second version can be found under
http://www.ietf.org/internet-drafts/draft-chadha-policy-mpls-te-01.txt

Marcus

- --------------------------------------
Dr. Marcus Brunner
C&C Research Laboratories
NEC Europe Ltd.

E-Mail: [email-masked]
WWW:    http://www.ccrle.nec.de/
personal home page: http://www.tik.ee.ethz.ch/~brunner

Adenauerplatz 6
D-69115 Heidelberg
Germany

Phone: +49 (0)6221/ 9051129
Fax:   +49 (0)6221/ 9051155

---

From: "Youcef Dahmane (LMC)" <[email-masked]>
Date: Fri, 16 Feb 2001 17:28:53 -0500

> -----Original Message-----
> From:	[email-masked]
> [SMTP:[email-masked]]
> Sent:	Friday, February 16, 2001 4:18 PM
> To:	'Jim Boyle'; 'Marcus Brunner'
> Cc:	'traffic engineering WG'; 'Policy Mailing List'
> Subject:	RE: include MPLS information model as work item
> 
> tewg covers the te related MIBs  so I would think that it should cover the
> te related policy work.
> 
> IMHO the policy wg folks are focused on the generic policy issues -e.g.
> how
> to structure a policy definition, policy protocol religions (e.g. COPS vs
> SNMP vs LDAP vs XML) etc. What is more interesting to discuss here is what
> are the appropriate policies to use when operating a network for traffic
> engineering purposes?
> 
> We can have a discussion about relative priorities, but with a trail of
> internet drafts on related subjects in the past year, from folks in at
> least
> five different companies, I think there is demonstrated demand for some
> progress in this area.
> 
> regards
> Steven Wright, Ph.D.
> Network Architecture
> Science and Technology
> BellSouth Telecommunications
> phone (404) 332-2194
> fax (404) 529-8025
> 
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]On Behalf Of Jim
> > Boyle
> > Sent: Friday, February 16, 2001 1:58 PM
> > To: Marcus Brunner
> > Cc: traffic engineering WG; Policy Mailing List
> > Subject: Re: include MPLS information model as work item
> >
> >
> >
> >
> >
> > It currently isn't in our charter, nor does there appear to
> > be an immenent
> > demand for this type of interaction with the network elements, judging
> > from the response in the WG meetings (and the list traffic).
> > Perhaps a
> > policy WG (or individual work) might be the better place to
> > show how one
> > could use, for instance, RFC2749 type of techniques to
> > control either TE
> > cores, or LSP based L2 VPNs.  But currently we have our hands full
> > documenting current uses, practices, and pressing demands.
> >
> > regards,
> >
> > Jim
> >
> >
> >
> > On Fri, 16 Feb 2001, Marcus Brunner wrote:
> >
> > > -----BEGIN PGP SIGNED MESSAGE-----
> > > Hash: SHA1
> > >
> > > Dear all,
> > >
> > -----BEGIN PGP SIGNATURE-----
> > Version: Mulberry PGP Plugin v2.0
> > Comment: processed by Mulberry PGP Plugin
> >
> > iQA/AwUBOo1Lt1hvF0PcuRgqEQJLbgCdFc71Q5pQvWg0Ig7LJWBZzTkGz2MAoOWe
> > PYZGnFnsd2OPFz+GqAI3avgc
> > =wbMS
> > -----END PGP SIGNATURE-----
> >
> 
> 
>

---

From: Randy Bush <[email-masked]>
Date: Fri, 16 Feb 2001 18:25:12 -0800

bert may choose to speak for policy, but this is not within the scope of
tewg.

randy, with AD hat on

---

> This topic has been discussed at the Pittsburgh and the San Diego
> meetings of the Policy WG. The consensus there was that work
> on a policy model for MPLS TE should be done in a workgroup
> where the subject matter experts for MPLS TE reside - for the
> same reason that SNMP MIBs are developed by the technology
> experts rather than in the SNMPv3 WG.
> 
> I don't believe that there was a lack of interest in MPLS TE
> policy at the San Diego tewg meeting. There was a reasonable
> show of hands of people who were interested in seeing this
> work pursued. 
> 
> Ritu
> 
> 
> >It currently isn't in our charter, nor does there appear to be an immenent
> >from the response in the WG meetings (and the list traffic).  Perhaps a
> >policy WG (or individual work) might be the better place to show how one
> >could use, for instance, RFC2749 type of techniques to control either TE

---

From: "Robert Moore" <[email-masked]>
Date: Fri, 23 Feb 2001 09:12:59 -0500

Randy,

Let me try to articulate at least my confusion.  Like a MIB,
a Policy information model for a specific technology like
MPLS stands at the intersection of two different fields.
There's no "right" answer to the question of where the work
to define such a model should be done: it's wholly a matter
of IETF/IESG policy(!).  For MIBs, the policy for some time
was that the work would be done in MIB-specific WGs, most
of which were collected into the Network Management Area.
Then the policy was changed, and the responsibility for
defining MIBs was distributed out into the WGs defining the
various technologies to be managed.

With Policy information models, we seem to be getting
conflicting signals from you and Bert as to what the
IETF/IESG policy is.  (Bert, if I'm misrepresenting your
position, I'm sure you'll speak up.)  I think Bert has said
that we won't do technology-specific Policy information
models in the Policy Framework WG -- they'll instead be the
responsibility of the WGs defining the technologies.  You
seem to be saying exactly the opposite: that this
responsibility does not lie with these WGs, at least not in
this case.

Since this is an IETF policy question, there's no objective
right answer that people can divine.  We need the IESG to
say which way it's going to be.

I don't know that this is something that poisson even needs
to be involved with.  I don't remember if they were involved
with the decision to distribute the responsibility for
defining MIBs to the technology-specific WGs.  Even if they
were, though, this case strikes me as just a second
application of a principle/precedent that was already
established with MIBs.

Regards,
Bob

Bob Moore
IBM Networking Software
+1-919-254-4436
[email-masked]

Randy Bush <[email-masked]>@raleigh.ibm.com on 02/22/2001 05:26:00 PM

Please respond to Randy Bush <[email-masked]>

Sent by:  [email-masked]

To:   Ravichander Vaidyanathan <[email-masked]>
cc:   [email-masked], [email-masked]
Subject:  RE: include MPLS information model as work item

> Since there is no attempt to explain why the work is out of scope

the work is out of scope because it is not in the wg's charter which you
will find at <http://ietf.org/html.charters/tewg-charter.html>.  you might
also review the mailing list archive from when the charter was developed
and discussed.  you may also find rfc 2418 helpful in understanding the wg
process in the ietf.

and we discuss these processes and how we might change them in the poisson
working group, not here.

randy

---

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Fri, 23 Feb 2001 18:07:04 +0100

Bob... this is what I ghave been saying and still say, and I believe
Randy and I are in agreement on this:

> >I think we are understanding each other as follows:
> >
> > > - Policy FW WG only does framework and core model/schema
> > > - Policy FW WG also does a technology specific model/schema
> > >   for QoS... This is to prove the concept.
> > > - If other WGs want to also do a Policy model/schema, then fine
> > >   we (IESG) will probably approve.
> > > - If other WGs do not want to do Policy model/schema, then we
> > >   (IESG) will not enforce that now.
> > >
> >So the question on the table is:
> >   - is there indeed a WG that really wants to do the MPLS
> >     information model now.
> >Not if a few people want it but if a lot of people want it
> >(i.e. WG consensus?).
> >
> >Even if a lot of people want it... we need to make sure that the
> >plate of the target WG does not get overloaded.
> 
Now... if we decide that it is the TE-WG, then that means one has
to get that WG to accept that it is a work-item that gets enuf
priority to be chosen over (or in addition to) other work-items that are
already in their charter.

From the email I have seen, it seems that the TE-WG chairs and the
responsible AD are not convinced that they want to ADD this work
item to their charter now.

Bert

> ----------
> From: 	Robert Moore[SMTP:[email-masked]]
> Reply To: 	Robert Moore
> Sent: 	Friday, February 23, 2001 3:12 PM
> To: 	Randy Bush
> Cc: 	Ravichander Vaidyanathan; [email-masked]; [email-masked]

---

From: Randy Bush <[email-masked]>
Date: Sat, 24 Feb 2001 11:13:53 -0800

[ note tewg list removed.  enough pollution is enough ]

> Randy, or Bert, do you have any objection to the advocates, for mpls policy
> work, making a request for a bof on this subject?

yup.  same one i have had all along.  you have not finished what was on your
FIRST plate.  and there was clear aggrement at the last minneapolis meeting
that you would not expand beyond it until it was complete.

for supposedly object oriented folk, it is interesting that there seems to
be some problem getting the message. :-)

randy

---

From: Randy Bush <[email-masked]>
Date: Sat, 24 Feb 2001 11:35:50 -0800

> My impression is that this is a different set of people that want to work
> on the mpls policy stuff, than have been participating for the last two
> years in the policy and qos policy work.

glad to see new blood.  but this is the same old body.

> So, my interpretation of your message, is that you want to see the proof
> of concept (that is, the policy model sub-classed and applied to qos),
> that the policy framework working group promised in our charter a long
> time ago, before you will be convinced that additional policy work is
> worthwhile in a different discipline, regardless of what working group or
> area it is chartered in.

'zactly!

randy