Subject: RE: example of a Policy Core Inofrmation Model to XML mapping

From: "Bouarich, Reda" <[email-masked]>
Date: Wed, 21 Feb 2001 10:53:45 +0100

Ok, but in a PDP <----> PEP architecture, I understand that the PDP can
retrieve it's policies from the LDAP repositery (this policies are LDAP
standardized classes) and use them to reply to a PEP Request.
What I don't understand, is what the PDP will do with an XML descriptions of
classes since it can construct its Decision based on the LDAP policy-DIT! 
Thanks.
Reda.

-----Original Message-----
From: Andrea Westerinen [mailto:[email-masked]]
Sent: Tuesday, February 20, 2001 8:16 PM
To: Bouarich, Reda; 'Andrey Mishchenko'
Cc: [email-masked]
Subject: RE: example of a Policy Core Inofrmation Model to XML mapping

No, not the same roles.  An LDAP repository is just that - a repository of
information with defined access mechanisms.  The XML description of classes
is only an encoding.  This is very different.

Andrea

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Bouarich, Reda
Sent: Tuesday, February 20, 2001 8:59 AM
To: 'Andrey Mishchenko'
Cc: [email-masked]'
Subject: RE: example of a Policy Core Inofrmation Model to XML mapping

Hi Andrey,

Regarding to your reply, it seems that the LDAP repositery and the XML
description play the same role?
Is it true?
	regards,

Reda Bouarich
Compaq Telecom Engineering
tel +33 4 92 95 68 03
    +33 6 64 63 00 34

-----Original Message-----
From: Andrey Mishchenko [mailto:[email-masked]]
Sent: Friday, February 16, 2001 5:35 PM
To: [email-masked]
Subject: RE: example of a Policy Core Inofrmation Model to XML mapping

Larry & Reda,

Why may one want to use XML to represent policies
if they are initially stored in the LDAP-based repository?
Is this useful to aggregate all policy-related information,
such as reusable condition variables and actions in the
single object?

Thanks,

Andrey Mishchenko
[email-masked]

> Reda,
>
> Is your Policy data implemented in an LDAP-accessible repository?
>
> If it is, you could retrieve the information as XML, via a DSML
> facility, such as Castor or JNDI's DSML SPI. Once you have the
> DSML, you might be only one or two XSL transformations away from
> the particular XML format you desire.
>
> Although it is not Policy-specific, this article is a good tutorial
> on the use of DSML and XSL transformation:
>
> http://www.javaworld.com/javaworld/jw-11-2000/jw-1110-dsml_p.html
>
>
> "Bouarich, Reda" wrote:
> >
> > Dear All,
> > I am trying to specify a certain policy (if a bandwidth overload occurs
> > between 9am and 6pm then limit the ftp transfert
> > to 100 kb/sec for example) using the DMTF Policy COre Information Model.
> > First I have to map my policy properties on the standardized
> policy classes
> > defined by the DMTF then I have to map this Information model to XML.
> > Can anyone tell me where can I find some kind of concrete examples
> > representing such mapping cause it is the first time I do that
> and it not
> > clear in my mind!!.
> > Thanks a lot.
> > Reda Bouarich.
>
> --
> #::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::|
> # Larry Bartz                           |                              |
> #  [email-masked]      | Ooo, ooo,                    |
> #                                       | Ooo, ooo, oooooo!            |
> #                                       | I've got a gnu attitude!     |
> #  voice (317) 226-7060                 |                              |
> #  FAX   (317) 226-6378                 |                              |
> #::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::|
>

---

From: "Andrey Mishchenko" <[email-masked]>
Date: Wed, 21 Feb 2001 18:35:06 +0300

Yes, LDAP repository and XML representation play different roles.

But I think XML framework could help only if it was possible to use
XML to retrieve complex objects (for example, policy with associated
reusable filters). But, as I understood, existing technology (DSML
and its implementations) does not offers such functionality.
So, XML can only serve as a wrapper for the LDAP classes,
and one can easy use his own mapping instead of XML without
any disadvantages.

Am I right?

Andrey Mishchenko
[email-masked]

> Sent: Wednesday, February 21, 2001 12:54 PM
> To: 'Andrea Westerinen'