Subject: [Policy] Policy WG I-D Last Call: draft-ietf-policy-core-schema-12.txt

From: Ed Ellesson <[email-masked]>
Date: Fri, 12 Oct 2001 16:19:40 -0400

The latest revision of the Policy Framework LDAP Core Schema is in the I-D
repository.   

This revision reflects all known issues and comments, including those
received as a result of the IESG-commissioned review of the previous version
of this document (which also passed through a previous WG last call
process).   

This note commences a two week working group last call, intended to bring
forth any last, remaining new issues, which may have crept in as a result of
the changes made to address the IESG directory experts' review.  After any
such issues are resolved according to working group consensus, we will be
re-submitting this document to the IESG for approval as a proposed standard.

This working group last call ends at COB on Mon, Oct. 29.  

http://www.ietf.org/internet-drafts/draft-ietf-policy-core-schema-12.txt

You can also expect to soon see a note to the list documenting the changes
made from the last version of this document.   

Thanks, 

Ed Ellesson, with Joel Halpern
Chairs, Policy Framework WG

_______________________________________________
Policy mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/policy

---

From: "John Strassner" <[email-masked]>
Date: Fri, 12 Oct 2001 18:47:06 -0600

FYI, here is a changelog to accompany the latest revision of the PCLS.

Everyone,

this is a summary of the changes made between the -11
and the -12 versions of PCLS.

1. Stability of the DMTF References
This issue has been resolved. The DMTF web site has
been updated, one reference has been correspondingly
updated, and the other reference has been changed.

2. Mismatched OIDs for Content Rules
This version of the PCLS no longer has content rules,
so this issue is moot.

3. DIT Structure and Content Rules
This version of the PCLS removes both DIT Structure
Rules as well as DIT Content Rules. However, the PCLS
text now includes, for the appropriate classes,
descriptions of how to build both DIT Structure Rules
and DIT Content Rules, as well as guidelines to ensure
that both will be able to be implemented for X.500 as
well as LDAP systems.

4. Request to Add Ordering and Substring Matching Rules
Ordering and Substring Matching Rules have been added
for all appropriate classes in the PCLS.

5. DESC Field
The PCLS has been changed in two regards. First,
normative text has been added in front of the
definition of every class and attribute in the PCLS
to ensure that the PCLS is not dependent on information
in the DESC field. Second, the DESC fields for classes
and attributes have been shortened to conform with
standard usage of a short description. Every effort
has been made to ensure that the resulting DESC fields
are still useful.

6. Standard Prefixing
The PCLS has been changed to use the prefix "pcim"
consistently for both classes and attributes.
Previously, it was a combination of no prefix and the
prefixes "ptp" and "policy".

7. Definition of "Policy"
Text has been added in the PCLS to define the PCLS use
of the term "policy", and to ensure that the reader
does not confuse the use of "policy" in the PCLS with
the use of "policy" in X.501.

8. Schema Definitions
This version of the PCLS has restructured the
organization of the class and attribute definitions so
that for each object class that is defined, its
attributes are then defined next. If the class has
subclasses that are grouped together (e.g., the Policy
Group classes), then the definitions of these subclasses
follow next. Each of the subclasses will have its
attributes defined next to it.

9. 2252 Syntax Conformance
This version of the PCLS has moved the note that
states that the RFC2252 syntax used has been line-
wrapped for readability to a more prominent position
in the document.

10. Abstract
This version of the PCLS has shortened the abstract
considerably, while ensuring that all pertinent
information remains in the body of the memo.

11. Potential Referential Integrity Concerns
This version of the PCLS adds explicit text documenting
possible referential integrity concerns if the developer
uses some optional mechanisms in the draft. It also
more clearly states the benefits of these optional
mechanisms.

12. Non-Normative Appendix.
This version of the PCLS has added an explicit statement
in the Appendix stating that the Appendix is not
normative.

13. Statement Concerning OIDs from IANA
This version of the PCLS has moved the existing statement
about OIDs being required from IANA to the beginning of
the document, and has added a second statement to this
effect as well as a more complete definition of the
conventions used in the document to identify OIDs.

14. Constraints
This version of the PCLS specifies additional constraints
on various data types (e.g., this integer has values that
are valid from 1..10) and has added text to instruct
servers and applications what to do if a value outside
of this range is encountered.

15. The Policy Class Definition
This version of the PCLS changed the definition of the
attributes of this class from:
    MAY ( cn $ policyKeywords )
to
    MAY ( cn $ dlmCaption $ dlmDescription $
          orderedCimKeys $ pcimKeywords )

16.  Reference to DMTF working group
This version of the PCLS updated the name of the
applicable DMTF working group from "Service Level
Agreement WG" to "Policy WG".

17. DMTF Reference Updates
This version of the PCLS updates references [9] and
[10] as appropriate.

18. Consistent use of PCLS
This version of the PCLS updates all references to this
document as "PCLS".

19. "DN Pointer"
This version of the PCLS has replaced the use of this
term with different sets of more explicit terminology
throughout the draft.

20. Correction of classes vs. instances
This version of the PCLS corrects some inaccurate
wording in various places in the document to clarify
when classes vs. instances are being discussed.

21. Auxiliary classes
This version of the PCLS adds additional clarification
about auxiliary classes.

22. SuperiorStructureRules
This version of the PCLS discusses
SuperiorStructureRules.

23. Clarification on Aux Class Attachment
This version of the PCLS clarifies that the
pcimConditionAuxClass and pcimActionSuxClasses, and their
subclasses, can be attached to three different structural
classes.

24. Typographical errors
This version of the PCLS has fixed various typographical
errors throughout the document.

regards,
John & Bob & Ryan & Ed

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Ed Ellesson
Sent: Friday, October 12, 2001 2:20 PM
To: [email-masked]'
Cc: 'Wijnen, Bert (Bert)'
Subject: [Policy] Policy WG I-D Last Call:
draft-ietf-policy-core-schema-12.txt

This revision reflects all known issues and comments, including those
received as a result of the IESG-commissioned review of the previous
version
of this document (which also passed through a previous WG last call
process).

This note commences a two week working group last call, intended to bring
forth any last, remaining new issues, which may have crept in as a result
of
the changes made to address the IESG directory experts' review.  After any
such issues are resolved according to working group consensus, we will be
re-submitting this document to the IESG for approval as a proposed
standard.

Thanks,

---

From: "Larry S. Bartz" <[email-masked]>
Date: Wed, 24 Oct 2001 12:50:00 -0500

Ed Ellesson wrote:
[snip]
> http://www.ietf.org/internet-drafts/draft-ietf-policy-core-schema-12.txt
[snip]

This draft is sleek, streamlined, and self-consistent. Most importantly,
it is a faithful expression of rfc3060.

I concur with the resolution of issues addressed by this most recent
draft, as documented in John Strassner's changelog message, archived
at  http://atm.tut.fi/list-archive/policy/msg00552.html

As far as I'm concerned, PCLS is ready. PCLS is complete. PCLS is
enough to serve as the foundation for production implementation and
use.

In particular, I do not want PCIMe to cloud the IESG's consideration
of PCLS. IESG should approve draft-ietf-policy-core-schema-12.txt
as a proposed standard.

What's the IETF motto? "Rough consensus, working code", right? 

It looks like the "consensus" part is nailed down. I haven't seen
any dissents to this draft.

As for "working code", I've been using my own tweaked versions of
draft-10 and draft-11 for some time. This draft (12) covers all of
my tweaks.

IESG should approve draft-ietf-policy-core-schema-12.txt as a proposed
standard.

--
#::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::|
# Larry Bartz                           |                              |
#  [email-masked]      | Ooo, ooo,                    |
#                                       | Ooo, ooo, oooooo!            |
#                                       | I've got a gnu attitude!     |
#  voice (317) 226-7060                 |                              |
#  FAX   (317) 226-6378                 |                              |
#::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::|