Subject: RE: [Policy] Is anyone doing a DTD

From: "Andrea Westerinen" <[email-masked]>
Date: Wed, 17 Oct 2001 23:25:59 -0700

Already answered that one in the original reply.  It is for the generic
CIM - and the reasons are copied from my earlier note:

"IMHO, it is useful to maintain a single DTD that addresses the core
constructs of the model, so that basic infrastructure tools can be built and
deployed once. Taking this approach, the DTD does not have to change every
time that a class or property is added.  Since basic processing semantics
(directed by the tags) remain constant, new unknown tags do not have to
ignored. You always have backward compatibility with your existing
infrastructure (since your tags are constant). Obviously, the specialized
code that addresses specific semantics (for example, PolicyActionXYZ) must
be added separately. But, this is true in any case.  Another advantage is
that this approach aligns with DSML to allow similar processing independent
of the repository."

Andrea

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Bruce Greenblatt
Sent: Wednesday, October 17, 2001 5:15 PM
To: Andrea Westerinen; Paul Denning; [email-masked]
Subject: RE: [Policy] Is anyone doing a DTD

But, is this for the Policy CIM or the "generic CIM"?

> -----Original Message-----
> From: Andrea Westerinen [mailto:[email-masked]]
> Sent: Wednesday, October 17, 2001 11:28 AM
> To: Paul Denning; [email-masked]
> Subject: RE: [Policy] Is anyone doing a DTD
>
>
> FYI.  The DMTF is also working on providing an XML Schema, in
> addition to the DTD.  XML Schemas are much more expressive.
>
> Andrea
>
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Paul Denning
> Sent: Friday, October 12, 2001 2:15 PM
> To: [email-masked]
> Subject: Re: [Policy] Is anyone doing a DTD
>
>
> At 01:24 PM 2001-10-12, Bruce Greenblatt wrote:
> >I am in the process of writing a XML DTD corresponding to the policy
> >model in RFC 3060.  I figured that I'd ask if anyone else is
> doing this
> >so that I don't duplicate work.  I didn't see anything in
> the mailing
> >list archives.
> >
> >Thanks,
> >
> >Bruce
>
> My 2 cents worth:  I recommend developing an XML Schema
> rather than a DTD.
>
> Paul
>
>
>
> _______________________________________________
> Policy mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/policy
>
>
> _______________________________________________
> Policy mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/policy
>

_______________________________________________
Policy mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/policy

_______________________________________________
Policy mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/policy

---

From: "Bruce Greenblatt" <[email-masked]>
Date: Wed, 17 Oct 2001 17:15:24 -0700