Subject: Re: [Policy] managed element definition [sic]

From: "Robert Moore" <[email-masked]>
Date: Mon, 19 Nov 2001 09:50:04 -0500

(I had intended to copy the list on this reply to Pedro.)

Regards,
Bob

Bob Moore
Advanced Design and Technology
Application Integration Middleware Division
IBM Software Group
+1-919-254-4436
[email-masked]

----- Forwarded by Robert Moore/Raleigh/IBM on 11/19/01 09:48 AM -----
                                                                                           
                    Robert Moore                                                           
                                         To:     "Da Silva, Pedro"                         
                    11/19/01 09:48       <[email-masked]>                        
                    AM                   cc:                                               
                                         From:   Robert Moore/Raleigh/IBM@IBMUS            
                                         Subject:     Re: [Policy] managed element         
                                         definition [sic](Document link: Robert Moore)     

                                                                                           

Pedro,

The short answer to any of these "Can it be ...?" questions
is "Yes, it can."  Pardoning the MOF format, here's the
definition of ManagedElement from the CIM spec:

// ==================================================================
// ManagedElement
// ==================================================================
   [Abstract, Description (
     "ManagedElement is an abstract class that provides a common "
     "superclass (or top of the inheritance tree) for the "
     "non-association classes in the CIM Schema.")]
class CIM_ManagedElement {
      [MaxLen (64), Description (
        "The Caption property is a short textual description (one-"
        "line string) of the object.") ]
   string Caption;
      [Description (
        "The Description property provides a textual description of "
        "the object.") ]
   string Description;
};

So ManagedElement abstracts out *everything*, leaving, for
reasons of convenience, only the two textual description
properties.  It is the superclass for logical elements,
physical elements, users, policies, and everything else in
the CIM model.

Regards,
Bob

Bob Moore
Advanced Design and Technology
Application Integration Middleware Division
IBM Software Group
+1-919-254-4436
[email-masked]

                    "Da Silva,                                                                
                    Pedro"                 To:     "[email-masked]'" <[email-masked]>      
                    <pdasilva@orches       cc:                                                
                    tream.com>             Subject:     [Policy] managed element definition   
                    Sent by:                [sic]                                             
                    policy-admin@iet                                                          
                    f.org                                                                     

                    11/19/01 08:37                                                            
                    AM                                                                        

I can't seem to find a definition for the term 'managed element'. Most docs
mention 'e.g. interface' but I would imagine that a managed element is not
restricted to being something physical and specially not restricted to an
interface.
Can it be a logical element such as 'interface and direction' or a broader
physical/logical entity?

thanks,
Pedro

_______________________________________________
Policy mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/policy

_______________________________________________
Policy mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/policy

---

From: "Lee Rafalow" <[email-masked]>
Date: Mon, 19 Nov 2001 11:13:33 -0500

Pedro, Since you mention "e.g., interface," I assume you're refering to
managed element as used in the PCIMe aggregation into PolicyRoleCollection;
that is, managed elements that have a role in administering the
policies--the policy consumers.  If that's the case, then there's a subset
of the "any" that Bob referred to in his response.  To my knowledge, we have
not defined that subset in any document, but I find it useful to think of
resource managers.  So, for example, you may well have a resource manager
that has the roles of: "10/100 ethernet, "intranet," and "ingress," but the
resource manager itself (the managed element, e.g., interface, that has the
roles) may not have a property that specifies it is only for ingress.

IHTH, Lee