Subject: RE: [Policy] Re: IP Protocol value range

From: "Robert Moore" <[email-masked]>
Date: Tue, 5 Feb 2002 12:56:20 -0500

Let me propose an update to the PCIMe text.  If this isn't exactly right,
it should at least be specific enough for people to comment on.
It's a complete replacement for section 5.12.19:

     NAME                PolicySNAPTypeVariable
     DESCRIPTION         The value of the Sub-Network Access Protocol
                         (SNAP) Type field for 802.2 SNAP encapsulation.

                         ALLOWED VALUE TYPES:
                           - PolicyIntegerValue (0..65535)
                           - PolicyBitStringValue (16 bit)

     DERIVED FROM        PolicyImplicitVariable
     ABSTRACT            FALSE
     PROPERTIES          (none)

Regards,
Bob

Bob Moore
Advanced Design and Technology
Application Integration Middleware Division
IBM Software Group
+1-919-254-4436
[email-masked]

                      "Ron Cohen"                                                                          
                      <[email-masked]>         To:       "'Mircea Pana'" <[email-masked]>,       
                                                Robert Moore/Raleigh/IBM@IBMUS                             
                      02/05/02 06:54 AM        cc:       <[email-masked]>, "'IETF Policy'"             
                                                <[email-masked]>, <[email-masked]>                 
                                               Subject:  RE: [Policy] Re: IP Protocol value range          

Mircea, Bob

PCIMe defines:

PolicySNAPVariable: The protocol number over a Sub-Network Access
Protocol (SNAP) SAP encapsulation.

Explanation:

IEEE 802.2 defines two encapsulations, following the Ethernet length
field:

- One with 3 bytes, SSAP, DSAP and CNTRL. The first two are represented
by the PolicySourceSAPVariable and PolicyDestinationSAPVariable.
- The second called the 802.2 SNAP encapsulation, and adds 5 bytes,
where the last two bytes are called the SNAP type. This is the
equivalent of the Ethernet Type. The intention was that the
PolicySNAPVariable would represent this two byte SNAP type field.

I suggest that we rename this variable to PolicySNAPTypeVriable and
remove the current ambiguity.

Ron

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Mircea Pana
> Sent: Monday, February 04, 2002 5:36 PM
> To: Robert Moore
> Cc: [email-masked]; IETF Policy; [email-masked]
> Subject: Re: [Policy] Re: IP Protocol value range
>
>
> ...and just to add to my confusion, RFC1042 defines the *same* SNAP
> header as
> "an extension of the LLC header called the Sub-Network Access Protocol
> (SNAP)" :-0
>
> So, a reference to the actual definitions (RFC, IEEE etc.) may help if
> added in PCIMe. IMO, it is less important what exactly this (or other)
> PolicyVariable represents, more important is to define it
> unambiguously.
>
> Regards,
> Mircea.
>
>
> Robert Moore wrote:
> >
> > >SNAP actually stands for "IEEE 802.1a SubNetwork Attachment Point".
> > See
> > >http://www.ietf.org/rfc/rfc1483.txt "4.1. LLC Encapsulation for
> > Routed
> > >Protocols" for example. The SNAP header includes two fields: OUI (3
> > >octets) and PID (2 octets).
> > >
> > >I have two comments here:
> > >1. IMO, PCIMe incorrectly describes SNAP as "Sub-Network Access
> > >Protocol".
> > >2. Was it intended for the PCIMe class "PolicySNAPVariable" to
> > represent
> > >only the PID part of the SNAP header (2 octets)? Or should
> it reflect
> > >the entire header: OUI+PID (5 octets).
> >
> > To be honest, I don't know what we meant to refer to with
> > PolicySNAPVariable.  (I think this class came from Cisco - in
> > any case, I know it didn't come from IBM.)  Some possibilities:
> >
> > Currently in PCIMe: Sub-Network Access Protocol.
> >
> > Mircea's suggestion: IEEE 802.1a SubNetwork Attachment Point.
> >
> > On acronymfinder.com: Subnetwork Access Protocol,
> > Standard Network Access Protocol (in bold, for some
> > reason), Small Network Access Package, and a bunch
> > of other options that are plainly not what we're
> > talking about.
> >
> > Maybe Andrea, or Yoram, or Yoram, or Ron, or John can tell
> > us what we meant when we defined PolicySNAPVariable.
> > And maybe they'll even agree! :-)
> >
> > Regards,
> > Bob
> >
> > Bob Moore
> > Advanced Design and Technology
> > Application Integration Middleware Division
> > IBM Software Group
> > +1-919-254-4436
> > [email-masked]
>
> _______________________________________________
> Policy mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/policy
>

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 05 Feb 2002 15:52:24 -0500

If we are going to do that, we should add a PolicySNAPOIDVariable as 
well.  If you are looking at SNAP/SAP encapsulated information, you must 
check the OID for 0 before you can treat the last two bytes as an etherType.
Yours,
Joel M. Halpern

At 12:56 PM 2/5/02 -0500, Robert Moore wrote:
>NAMEPolicySNAPTypeVariable DESCRIPTIONThe value of the Sub-Network Access 
>Protocol                     (SNAP) Type field for 802.2 SNAP encapsulation.
>
>ALLOWED VALUE TYPES:  - PolicyIntegerValue (0..65535)  - 
>PolicyBitStringValue (16 bit)
>
>DERIVED FROMPolicyImplicitVariable ABSTRACTFALSE  PROPERTIES(none)
>
>
>Regards,
>Bob
>
>Bob Moore
>d821c.jpg"Ron Cohen" <[email-masked]>
>
>
>d8356.jpg
>d836d.jpg
>"Ron Cohen" <[email-masked]>
>
>02/05/02 06:54 AM
>
>d8380.jpg
>
>To:"'Mircea Pana'" <[email-masked]>, Robert Moore/Raleigh/IBM@IBMUS
>cc:<[email-masked]>, "'IETF Policy'" <[email-masked]>, 
><[email-masked]>
>Subject:RE: [Policy] Re: IP Protocol value range
>
>
>Mircea, Bob
>
>
>PCIMe defines:
>
> <https://www1.ietf.org/mailman/listinfo/policy>https://www1.ietf.org/mailm 
> an/listinfo/policy
> >
>
>