Subject: [Ppm] Robert Wilton's No Objection on charter-ietf-ppm-00-00: (with COMMENT)

From: Robert Wilton via Datatracker <[email-masked]>
Date: Thu, 03 Feb 2022 07:29:15 -0800

Robert Wilton has entered the following ballot position for
charter-ietf-ppm-00-00: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/charter-ietf-ppm/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I think that it would be helpful if the work includes operational deployment
considerations, i.e., under what scenarios these protocols can be deployed and
what privacy properties are preserved/lost.  Perhaps this is meant to already
be covered by "The resulting documents shall clearly describe abuse cases and
remaining attacks which are not prevented or mitigated by the protocol.", but
possibly it could be more explicit about covering deployment considerations?

---

From: Roman Danyliw <[email-masked]>
Date: Thu, 3 Feb 2022 15:52:33 +0000

Hi Rob!

> -----Original Message-----
> From: Ppm <[email-masked]> On Behalf Of Robert Wilton via
> Datatracker
> Sent: Thursday, February 3, 2022 10:29 AM
> To: The IESG <[email-masked]>
> Cc: [email-masked]; [email-masked]
> Subject: [Ppm] Robert Wilton's No Objection on charter-ietf-ppm-00-00: (with
> COMMENT)
> 
> When responding, please keep the subject line intact and reply to all email
> addresses included in the To and CC lines. (Feel free to cut this introductory
> paragraph, however.)
> 
> 
> 
> what privacy properties are preserved/lost.  Perhaps this is meant to already be
> covered by "The resulting documents shall clearly describe abuse cases and

Not in the same exact words, but the residual "risks" (privacy or otherwise) will be documented.  To ensure these that abuses and residual risks were not forgotten there is an explicit marker here in the charter as it was strongly requested during the PRIV BOF at IETF 112.

Is the thinking that these abuse cases and Privacy/Security Considerations would be clearer if tied to specific deployments in the text?

Roman