Subject: Re: subnet allocation request

From: Vernon Schryver <[email-masked]>
Date: Thu, 12 Aug 1999 22:48:49 -0600 (MDT)

> From: Juha Heinanen <[email-masked]>

> ...
> just for information (if someone plans to sell adsl equipment to me),
> below is the packet format of the ipcp subnet option that is currently
> implemented in my network.

> ...
>     where Type = 0x90 and Length = 0x06.

Does whoever stole type IPCP 0x90 also allocate random IP addresses?
(and I don't mean out of RFC 1918).
Do they also run their own DNS root and use whatever names that seem cool?
How about IP protocol numbers?

Why don't we just disband the IANA?  Who needs it?  Everyone can just pick
random numbers and everything will work just fine.

Personally, I wouldn't want my name associated with a thing like that,
certainly not such positive words.

Vernon Schryver    [email-masked]

---

From: Randy Turner <[email-masked]>
Date: Fri, 13 Aug 1999 08:31:13 -0700

My interpretation of section 2 of the "Subnet Selection Option for DHCP" draft
implies that the DHCP server must return a subnet based upon the base address that
the "client specifies" in the  request. Basically, all I would like to specify in
the request is "Please allocate me a /30 subnet. I don't really care the specific
prefix that is used".

Randy

John Bray wrote:

> On Thu, 12 Aug 1999, Randy Turner wrote:
>
> >
> > Thanks for the replies,
> >
> > I will work with whoever is interested to see that an extension like the one
> > I described is advanced through the DHCP WG. The existing subnet option in
> > DHCP would not meet my requirements, since I really don't want to specify up
> > front what subnet I want to use. Instead, I would like the DHCP server to
> > figure out an available subnet and allocate it to me. If anyone is
> > interested and has similar requirements, I would appreciate your comments on
> > how this option should operate.
>
> I'm sorry, I must have missed something.  Since when does a DHCP
> client "specify up front" the subnet it wants to use?  This option
> (along with other configuration paramters) is returned by the server
> to the client in the DHCP reply.
>
> Please explain again why this doesn't meet your needs.
>
> John
>
> >
> > I will subsequently move this discussion to the DHCP WG.
> >
> > Thanks again,
> > Randy
> >
> >
> >
> >
> > > -----Original Message-----
> > > From:       Juha Heinanen [SMTP:[email-masked]]
> > > Sent:       Thursday, August 12, 1999 9:03 PM
> > > To: Randy Turner
> > > Cc: [email-masked]'
> > > Subject:    subnet allocation request
> > >
> > > randy,
> > >
> > > i wrote the i-d and the idea was like you described, i.e., the ppp
> > > client could ask during the ipcp negotiation phase a subnet of a certain
> > > (possibly any) size instead of a single ip address.  the "consensus" of
> > > the wg was that ipcp is not the right means to negotiate the subnet, but
> > > that bootp or dhcp inform should be used instead and since there already
> > > exists a subnet option both in boopt and dhcp, nothing was left to be
> > > standardized.
> > >
> > > what has happened in practice though is that some (adsl) router vendors
> > > actually went and implemented an ipcp subnet option and i'm very happy
> > > about it, since it solves my real problem.  if some vendors come up with
> > > the bootp or dhcp solution, that would be fine with me too, since i
> > > don't care how the problem is solved as long as it is done.
> > >
> > > -- juha
> > > ------------------------------------------------------------------
> > >
> > >      0                   1                   2                   3
> > >      0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
> > >     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
> > >     |     Type      |    Length     |             Mask
> > >     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
> > >             Mask (cont)         |
> > >     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
> > >

---

From: Vernon Schryver <[email-masked]>
Date: Fri, 13 Aug 1999 09:45:36 -0600 (MDT)

> From: Randy Turner <[email-masked]>
> To: John Bray <[email-masked]>
> Cc: [email-masked]

> the request is "Please allocate me a /30 subnet. I don't really care the specific

But don't you need or at least prefer a block that includes the IP address
that your system has negotiated by using IPCP?  If you get a /30 that
is completely unrelated to the IP address of your end of the PPP link,
things will at least seem a little more complicated.