Subject: Re: Usage of ML Endpoint Discriminator Option

From: Vernon Schryver <[email-masked]>
Date: Wed, 25 Aug 1999 14:47:53 -0600 (MDT)

> From: "John R. Martz" <[email-masked]>

> > When I don't have Endpoint Discriminators, I like to identify the MP
> > bundle by the IP address at the far end.  In fact, I like to make
> > the remote IP address the primary identification of the bundle, since
> > you always have a remote IP address, but many not have other info.
>
> This may be a pointless counter-point, but the peer doesn't have
> to give you an IP address, correct?

In principle, but rarely in practice with good implementations.

> One of the things I intiailly screwed up and had to fix in my IPCP
> negotiation was connecting to a router. Routers typically don't want to
> give you their IP address because it expects it'll just be
> forwarding/routing all the IP packets sent to it.

Not so.  Today the router will also want to talk at least RADIUS, TACUS,
SNMP, telnet, BOOTP, DHCP, DNS, syslog, TFTP, and lots of routing protocols
and will need and use an IP address of its own.

>                                                   Consequently,
> a dedicated router is likely to send you an IPCP cfg-request with
> no options.

In principle, that's legal.  However, I don't remember ever hearing of a
non-junk implementation that does that, particularly for an IP router
instead of bridge.  It's too useful and too easy to send the router's IP
address.  Where have you seen empty IPCP Configure-Requests?

Vernon Schryver    [email-masked]

---

From: "John R. Martz" <[email-masked]>
Date: Thu, 26 Aug 1999 12:11:25 -0400

> Where have you seen empty IPCP Configure-Requests?

Vernon,

In our case we were using an IBM 2210 router. But I'm sure ... that is I don't really know, but I'd
bet a small amount of money on it being true ... that this scenario is also quit possible with other
routers still in common use today.

Yes, you can configure the 2210 to have a local IP address. And depending on what you're doing this
might be the "better" thing to do. My point was just that I don't think I can always assume that the
remote peer is going to tell me it's IP address. That's just too big a leap for me.

(Customers are notorious for wanting to do things I personally don't think are very reasonable. Not
so long ago I was called for a customer who had an old "clunker" 2400 baud IBM modem that AS/400 PPP
wasn't working with. He could have simply switched to a Sporster 28.8 (or such) and both eliminated
the problem and increased his throughput for what I considered a very negligible cost. But nope. He
had an IBM modem and he darn well expected it to work with an IBM system! How could I say no?? :)

-john martz ([email-masked])
IBM AS/400 TCP/IP PPP (and stuff)