Subject: RE: about L2TP stack of protocols

From: RABARISON Dina CNET/DTD/LAN <[email-masked]>
Date: Tue, 7 Sep 1999 18:37:27 +0200

Thanks for your answer (Walter and Ignacio), I agree with the fact that
UDP/IP itself can be transported over ATM or FR, or ... 

So, I was expected in having UDP/IP/PPP/L2TP/(ATM or FR) in the case of
UDP/IP.

With the configuration PPP/L2TP/UDP/IP/... in what case ? which interest ?
advantages ? Isn't it a risk of overhead ? 

thanks for your advice,
			Dina

> ----------
> De : 	Klausberger Walter[SMTP:[email-masked]]
> Date :	mardi 7 septembre 1999 18:26
> A :	'RABARISON Dina CNET/DTD/LAN'
> Cc :	[email-masked]; [email-masked]'
> Objet :	AW: about L2TP stack of protocols
> 
> Hi Dina,
> 
> L2TP can be used over UDP/IP or FR or ATM. I think that's what figure 3.0
> refers to. UDP/IP itself can again be transported over ATM or FR or ....
> This figure only shows that Control Messages are handled different to Data
> Messages inside the L2TP stack.
> 
> Hope that covers your question.
> 
> with best regards
> Walter
> 
> > -----Ursprüngliche Nachricht-----
> > Von: RABARISON Dina CNET/DTD/LAN
> > [mailto:[email-masked]]
> > Gesendet am: Dienstag, 07. September 1999 18:19
> > An: [email-masked]
> > Betreff: about L2TP stack of protocols
> > 
> > Hi, 
> > 
> > My question concerns the RFC 2661 (L2TP), more especially, 
> > figure 3.0, L2TP
> > Protocol Structure. 
> > 
> > What does this figure exactly represent ? Is it the stack of 
> > protocols of
> > L2TP ?
> > So, how to understand that UDP packet transport is in the 
> > same level as ATM,
> > ... 
> > 
> > Is it that we've got in one case  .../PPP/L2TP/(ATM or FR) 
> > and in other case
> > .../PPP/L2TP/UDP/IP/... ?
> > 
> > Thanks in advance, 
> > Best Regards
> > 
> > 		Dina		
> >  
> > 
> > 
>

---

From: James Carlson <[email-masked]>
Date: 07 Sep 1999 14:42:17 -0400

> So, I was expected in having UDP/IP/PPP/L2TP/(ATM or FR) in the case of

Yes, that's what it looks like if the *application* is doing UDP over
IP over PPP over L2TP running on ATM or Frame Relay.

The L2TP document doesn't describe all the ways you can run
applications over protocols that run over PPP.  It just describes how
to run PPP over some other network.

> With the configuration PPP/L2TP/UDP/IP/... in what case ? which interest ?

It allows you to run L2TP over the general Internet or any other IP
network so that you can tunnel PPP across it.

> advantages ? Isn't it a risk of overhead ? 

Yes, 28 bytes of overhead plus whatever your chosen link-layer below
IP adds.

-- 
James Carlson, System Architect                     <[email-masked]>
IronBridge Networks / 55 Hayden Avenue   71.246W   Vox:  +1 781 372 8132
Lexington MA  02421-7996 / USA           42.423N   Fax:  +1 781 372 8090
"PPP Design and Debugging" --- http://people.ne.mediaone.net/carlson/ppp