Subject: picking an MRRU for MP

From: "John R. Martz" <[email-masked]>
Date: Fri, 26 May 2000 15:32:38 -0400

Folks,

Would appreciate getting opinions/advice on how to select the Multilink Protocol MRRU value to offer
for negotiation to the remote peer. I'm not sure I'm considering all the pros and cons involved.

I also have next to no experience with the choices made by other PPP-MP implementations for the
MRRU. I see that when negotiating MP over a single link, Windows 2000 Professional uses the default
MRU value of 1500 and specifies an MRRU of 1614. Anyone know ... or want to speculate ... on why
1614 would be chosen for the MRRU.

The more I think about this the more I lean towards making the MRRU choice a customer configuration
choice. That way I can blame it on the customer if the chosen value is "bad". <g>

-john martz
IBM AS/400 TCP/IP PPP (and stuff)

---

From: James Carlson <[email-masked]>
Date: Fri, 26 May 2000 15:41:21 -0400 (EDT)

John R. Martz writes:
> Would appreciate getting opinions/advice on how to select the
> Multilink Protocol MRRU value to offer for negotiation to the remote
> peer. I'm not sure I'm considering all the pros and cons involved.

As long as you do the negotiation correctly and you allow the user to
configure desired values, it's hard to see how you can go too terribly
wrong here.

> I also have next to no experience with the choices made by other
> PPP-MP implementations for the MRRU. I see that when negotiating MP
> over a single link, Windows 2000 Professional uses the default MRU
> value of 1500 and specifies an MRRU of 1614. Anyone know ... or want
> to speculate ... on why 1614 would be chosen for the MRRU.

1524 is a very common MRRU among MP implementations.  I've also seen
1540 on a few others.  1614 is rather special, and I don't see a
particular reason for it.

> The more I think about this the more I lean towards making the MRRU
> choice a customer configuration choice. That way I can blame it on
> the customer if the chosen value is "bad". <g>

Yep.  Of course, you'll still want *some* kind of default.  Since MP
is most often used with ISDN, and since the compression protocols
commonly used on ISDN (primarily STAC) can also expand by a few bytes,
it's probably a good idea to set the default to 1500 (the world's IP
MTU ;-}) plus a few bytes.  1524 would be an unsurprising number.

-- 
James Carlson, Internet Engineering       <[email-masked]>
SUN Microsystems / 1 Network Drive         71.234W   Vox +1 781 442 2084
MS UBUR02-212 / Burlington MA 01803-2757   42.497N   Fax +1 781 442 1677
"PPP Design and Debugging" --- http://people.ne.mediaone.net/carlson/ppp