Subject: CMU copyright on pppd bits

From: Paul Mackerras <[email-masked]>
Date: Sun, 3 Jun 2001 11:23:24 +1000 (EST)

It has recently been drawn to my attention that much of the pppd
package that I maintain has a copyright notice on it that doesn't
permit modification.  Here is an example:

/*
 * Copyright (c) 1989 Carnegie Mellon University.
 * All rights reserved.
 *
 * Redistribution and use in source and binary forms are permitted
 * provided that the above copyright notice and this paragraph are
 * duplicated in all such forms and that any documentation,
 * advertising materials, and other materials related to such
 * distribution and use acknowledge that the software was developed
 * by Carnegie Mellon University.  The name of the
 * University may not be used to endorse or promote products derived
 * from this software without specific prior written permission.
 * THIS SOFTWARE IS PROVIDED ``AS IS'' AND WITHOUT ANY EXPRESS OR
 * IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
 * WARRANTIES OF MERCHANTIBILITY AND FITNESS FOR A PARTICULAR PURPOSE.
 */

This is extremely embarrassing for me, if I can't get these notices
changed I will have to stop maintaining and distributing pppd.

Most of the files with this kind of notice are copyright Carnegie
Mellon University.  Is there anyone from CMU on this list?  If so, can
you tell me who to approach to get the notice changed?

Paul.

---

From: Patrick Klos <[email-masked]>
Date: Sun, 3 Jun 2001 11:09:22 -0400

> * WARRANTIES OF MERCHANTIBILITY AND FITNESS FOR A PARTICULAR PURPOSE.

From the text of this notice, it's fair to assume that they expect people
to "redistribute and use" this code, as well as "derive" other code from
this code.  By granting the right to "use" and "derive" software from this
code, they have to expect that people will modify this code in some way,
shape or form.  The only restriction I see placed on any code derived
from this code is that is must include this copyright notice indicating
it was indeed derived from some CMU based code, and that you can't use
the name of CMU as part of your marketing.  It seems pretty straightforward
to me.

>changed I will have to stop maintaining and distributing pppd.

Even if you felt this way, how much CMU code are you using in pppd?  I can't 
imagine it would be a whole lot?  Would it be easier to remove any code you
derived from CMU code and remove the notices altogether?

Patrick
============================================================================
    Patrick Klos                           Email: [email-masked]
    Klos Technologies, Inc.                Web:   http://www.klos.com/
============================================================================

---

From: Karl Fox <[email-masked]>
Date: Sat, 02 Jun 2001 21:50:17 -0400

Hi Paul,

Yes, I once used that same software for similar purposes.  I don't see, 
however, any restriction on modification.  If you're referring to the 
requirement that a) CMU be acknowledged and b) CMU's name not be used to 
promote derivative products, then I'm pretty sure there's a middle ground.  
We put CMU's name in the acknowledgements section of our documentation, but 
we didn't go around saying, "Hey, this is CMU code, so you should buy it."

I don't think you have anything to worry about.

Karl

>you tell me who to approach to get the notice changed?

Karl Fox <[email-masked]>
Key fingerprint = 4159 B4AD 339D 4E2A 255F  9CC4 9DA9 CB4B B16D E2B1