Subject: MPLS compressed Protocol ID

From: Shahram Davari <[email-masked]>
Date: Tue, 11 Sep 2001 14:41:21 -0700

Hi,

We know from RFC3032 that the PPP protocol ID (PID) for MPLS Unicast and multicast are 0x0281 and 0x0283 respectively. If PID compression is used, do we use "0x81" and "0x83" respectively?

Yours,
Shahram Davari
Product Research Engineer
Internet Routing Division
PMC-Sierra, Inc. (Ottawa)
Phone: (613) 271-4018
Fax:   (613) 271-3138

---

From: Archie Cobbs <[email-masked]>
Date: Tue, 11 Sep 2001 16:07:45 -0700

Shahram Davari 
> We know from RFC3032 that the PPP protocol ID (PID) for MPLS Unicast and multicast are 0x0281 and 0x0283 respectively. If PID compression is used, do we use "0x81" and "0x83" respectively?

Those ID's are not compressible, because they have a non-zero
first byte. So they must be sent as two bytes.

In general, the protocol ID is a sequence of even bytes terminated
by an odd byte, with an arbitrary number of zero bytes prepended.
So for PPP, if the protocol has zero in the first byte, you only
need to send the second byte.

-Archie

__________________________________________________________________________
Archie Cobbs     *     Packet Design     *     http://www.packetdesign.com