Subject: Re: PPP over AAL2 to Proposed Standard

From: Thomas Narten <[email-masked]>
Date: Tue, 06 Nov 2001 14:26:51 -0500

Karl Fox <[email-masked]> writes:

> The PPPEXT Working Group recommends that PPP over AAL2 
> (draft-ietf-pppext-ppp-over-aal2-01.txt) be advanced to Proposed Standard.

In reviewing this document, I don't have any major issues. One
question:

> This proposal uses two UUI code-points as follows:
> 
>    UUI Code-point       Packet Content
>    ++++++++++++++       ++++++++++++++
> 
>    27                   non-final packet.
> 
>    26                   final packet. 

Does the use of these code-point/values need approval from anyone, or
are these codes defined by the applications using AAL2?

Also,

> ITU-T I.366.1 and I.366.2 define Service Specific Convergence Sub-

Would be good to have a pointer into the reference section for this

> I.363.2.  This layer specifies packet formats and procedures to encode 

Ditto

Finally, the document needs a security considerations section.

Thomas

---

From: Bruce A Thompson <[email-masked]>
Date: Wed, 07 Nov 2001 19:35:42 -0800

>are these codes defined by the applications using AAL2?

The use of these code points in our draft is the same as what has already been defined in the SSSAR sub layer of I.366.1, so there is no approval required.

This paragraph is referring to these standards as a whole, not specific sections of these standards. There is one statement below this paragraph that refers to a specific section of I.366.1. It's this statement:
>This proposal uses the SSSAR sublayer of I.366.1 for transport.

We'll add the section reference for this statement.

>Finally, the document needs a security considerations section.

We will add it.

        Bruce T

>Thomas 

Bruce Thompson
Cisco Systems
email: [email-masked]
office: (408)527-0446
home office: (408)868-0112
San Jose, CA