Subject: Echo reply

From: "Affan Ahmed" <[email-masked]>
Date: Tue, 19 Mar 2002 04:30:49 -0800

hello,
I just want to ask a very basic question regarding the lcp echo req packet. If u recv it in LCP opened state while generating the echo reply do u copy the magic number in the req or pass on your own magic number.

Similarly do we differentiate b/w discard req packets rcvd in states other than opened, or do we discard all packets no matter when they come?

Hoping for a reply.
---
Best Regards
Affan Ahmed

2,000,000,000 Web Pages--you only need 1. Save time with My Lycos.
http://my.lycos.com

---

From: Archie Cobbs <[email-masked]>
Date: Tue, 19 Mar 2002 10:16:00 -0800

> I just want to ask a very basic question regarding the lcp echo req packet. If u recv it in LCP opened state while generating the echo reply do u copy the magic number in the req or pass on your ow…

I believe the rules are:

- Only send an echo reply when in the OPENED state
- Always use your magic number when transmitting
- Only verify magic numbers when in the OPENED state

> Similarly do we differentiate b/w discard req packets rcvd in states other than opened, or do we discard all packets no matter when they come?

Discard requests are always discarded. However, the magic number
should still be checked (if in the OPENED state).

-Archie

__________________________________________________________________________
Archie Cobbs     *     Packet Design     *     http://www.packetdesign.com