Subject: Why only link-local-address ??

From: "Anil Kumar Reddy" <[email-masked]>
Date: Thu, 6 Mar 2003 23:18:15 +0530

Hi All,

	As IPV6CP negotiates _only_ the interface identifier
	for link local address,	we should have some other
	mechanisms to assign global addresses to PPP ends.
	Examples of such mechanisms are: sending a router
	advertisement (RA) of certain prefix or manual allotment
	of address etc.

	Is there a strong reason for the decision of having only
	the interface-identifier in IPV6CP negotiation ?? Why
	shouldn't we have a prefix option in IPV6CP ?? Sorry, if
	this topic is discussed already. If so, please direct
	me to locate the answer.

	Thanks in advance for your response.

Regards,
Anil

---

From: Bernard Aboba <[email-masked]>
Date: Thu, 6 Mar 2003 09:23:00 -0800 (PST)

Because once the link comes up it is expected that normal Ip addressing
and configuration mechanisms will be used, such as RS/RA, DHCPv6, etc.

That's one reason why IPCPv6 "extensions" are not needed (though they have
been proposed).

---

From: "Anil Kumar Reddy" <[email-masked]>
Date: Fri, 7 Mar 2003 11:59:37 +0530

Hi Bernard,

	Instead of depending on RA/DHCPv6 server to present, why
	shouldn't we have an optional prefix option in IPV6CP,
	similar to RA mechanism. This makes the required functionality
	integrated into the pppd (PPP daemon). What do you feel ??

Regards,
Anil

: -----Original Message-----
: From: Bernard Aboba [mailto:[email-masked]]
: Sent: Thursday, March 06, 2003 10:53 PM
: To: Anil Kumar Reddy
: Cc: [email-masked]
: Subject: Re: Why only link-local-address ??
: 
: 
: Because once the link comes up it is expected that normal Ip 
: addressing
: and configuration mechanisms will be used, such as RS/RA, DHCPv6, etc.
: 
: That's one reason why IPCPv6 "extensions" are not needed 
: (though they have
: been proposed).
: 
: On Thu, 6 Mar 2003, Anil Kumar Reddy wrote:
: 
: > Hi All,
: >
: > 	As IPV6CP negotiates _only_ the interface identifier
: > 	for link local address,	we should have some other
: > 	mechanisms to assign global addresses to PPP ends.
: > 	Examples of such mechanisms are: sending a router
: > 	advertisement (RA) of certain prefix or manual allotment
: > 	of address etc.
: >
: > 	Is there a strong reason for the decision of having only
: > 	the interface-identifier in IPV6CP negotiation ?? Why
: > 	shouldn't we have a prefix option in IPV6CP ?? Sorry, if
: > 	this topic is discussed already. If so, please direct
: > 	me to locate the answer.
: >
: > 	Thanks in advance for your response.
: >
: > Regards,
: > Anil
: >
: >
: >
: 
: