Subject: RE: Why only link-local-address ??

From: "Jari Arkko (LMF)" <[email-masked]>
Date: Fri, 7 Mar 2003 09:53:05 +0100

Well, an "RA server" is always present anyway, because
if you want to get somewhere, you need a router, and
IPv6 routers are required to send Router Advertisements.
DHCPv6 usage is optional.

Jari

-----Original Message-----
From: Anil Kumar Reddy [mailto:[email-masked]]
Sent: 7. maaliskuuta 2003 8:30
To: 'Bernard Aboba'
Cc: [email-masked]
Subject: RE: Why only link-local-address ??

Hi Bernard,

	Instead of depending on RA/DHCPv6 server to present, why
	shouldn't we have an optional prefix option in IPV6CP,
	similar to RA mechanism. This makes the required functionality
	integrated into the pppd (PPP daemon). What do you feel ??

Regards,
Anil

: -----Original Message-----
: From: Bernard Aboba [mailto:[email-masked]]
: Sent: Thursday, March 06, 2003 10:53 PM
: To: Anil Kumar Reddy
: Cc: [email-masked]
: Subject: Re: Why only link-local-address ??
: 
: 
: Because once the link comes up it is expected that normal Ip 
: addressing
: and configuration mechanisms will be used, such as RS/RA, DHCPv6, etc.
: 
: That's one reason why IPCPv6 "extensions" are not needed 
: (though they have
: been proposed).
: 
: On Thu, 6 Mar 2003, Anil Kumar Reddy wrote:
: 
: > Hi All,
: >
: > 	As IPV6CP negotiates _only_ the interface identifier
: > 	for link local address,	we should have some other
: > 	mechanisms to assign global addresses to PPP ends.
: > 	Examples of such mechanisms are: sending a router
: > 	advertisement (RA) of certain prefix or manual allotment
: > 	of address etc.
: >
: > 	Is there a strong reason for the decision of having only
: > 	the interface-identifier in IPV6CP negotiation ?? Why
: > 	shouldn't we have a prefix option in IPV6CP ?? Sorry, if
: > 	this topic is discussed already. If so, please direct
: > 	me to locate the answer.
: >
: > 	Thanks in advance for your response.
: >
: > Regards,
: > Anil
: >
: >
: >
: 
:

---

From: "Anil Kumar Reddy" <[email-masked]>
Date: Fri, 7 Mar 2003 21:42:38 +0530

Hi Jari,

You mean to say, the router functionality should be running on
the PPP end (ISP) or it should be having RA/DHCPv6 server 
running on it ?? 

Take the following setup of ISP neither acting as a router nor
having RA/DHCPv6 server, and there is a separate router:

            [User]<------->[ISP]<--->[router]--

In such case, the RA sent by router will not be forwarded by ISP,
so there is no way of User getting a global address. So, we may
have to depend on other alternatives like DHCPv6.

If ISP is always acting as a router, then this option is not
required. When you say that this option is not required then
that enforces ISP to be a router/DHCPv6-server.

My suggestion was to integrate a minimal functionality similar to
RA in IPV6CP, as an option, when RA/DHCPv6 is not available.

Please correct me, if I am wrong at anything.

Regards,
Anil

: -----Original Message-----
: From: Jari Arkko (LMF) [mailto:[email-masked]]
: Sent: Friday, March 07, 2003 2:23 PM
: To: [email-masked]'; 'Bernard Aboba'
: Cc: [email-masked]
: Subject: RE: Why only link-local-address ??
: 
: 
: 
: Well, an "RA server" is always present anyway, because
: if you want to get somewhere, you need a router, and
: IPv6 routers are required to send Router Advertisements.
: DHCPv6 usage is optional.
: 
: Jari
: 
: -----Original Message-----
: From: Anil Kumar Reddy [mailto:[email-masked]]
: Sent: 7. maaliskuuta 2003 8:30
: To: 'Bernard Aboba'
: Cc: [email-masked]
: Subject: RE: Why only link-local-address ??
: 
: 
: Hi Bernard,
: 
: 	Instead of depending on RA/DHCPv6 server to present, why
: 	shouldn't we have an optional prefix option in IPV6CP,
: 	similar to RA mechanism. This makes the required functionality
: 	integrated into the pppd (PPP daemon). What do you feel ??
: 
: Regards,
: Anil
: 
: : -----Original Message-----
: : From: Bernard Aboba [mailto:[email-masked]]
: : Sent: Thursday, March 06, 2003 10:53 PM
: : To: Anil Kumar Reddy
: : Cc: [email-masked]
: : Subject: Re: Why only link-local-address ??
: : 
: : 
: : Because once the link comes up it is expected that normal Ip 
: : addressing
: : and configuration mechanisms will be used, such as RS/RA, 
: DHCPv6, etc.
: : 
: : That's one reason why IPCPv6 "extensions" are not needed 
: : (though they have
: : been proposed).
: : 
: : On Thu, 6 Mar 2003, Anil Kumar Reddy wrote:
: : 
: : > Hi All,
: : >
: : > 	As IPV6CP negotiates _only_ the interface identifier
: : > 	for link local address,	we should have some other
: : > 	mechanisms to assign global addresses to PPP ends.
: : > 	Examples of such mechanisms are: sending a router
: : > 	advertisement (RA) of certain prefix or manual allotment
: : > 	of address etc.
: : >
: : > 	Is there a strong reason for the decision of having only
: : > 	the interface-identifier in IPV6CP negotiation ?? Why
: : > 	shouldn't we have a prefix option in IPV6CP ?? Sorry, if
: : > 	this topic is discussed already. If so, please direct
: : > 	me to locate the answer.
: : >
: : > 	Thanks in advance for your response.
: : >
: : > Regards,
: : > Anil
: : >
: : >
: : >
: : 
: : 
:

---

From: James Carlson <[email-masked]>
Date: Fri, 7 Mar 2003 17:09:41 -0500

> the PPP end (ISP) or it should be having RA/DHCPv6 server 

Yes.  As long as it's visible to the PPP peer, it doesn't matter where
it is.

>             [User]<------->[ISP]<--->[router]--

That box labeled as "ISP" *is* a router.  If it's not advertising,
then it's broken.

> that enforces ISP to be a router/DHCPv6-server.

What else could that ISP box be?  It's got an IP link (over PPP) on
one side, and an IP link on the other.  Looks like an IP router.

Does it think it's a bridge of some sort?  If so, then it has a
responsibility to forward along appropriate messages, including the
advertisements from the local router.  I don't think that's a good way
to scale a network, but, then, I'm not designing that equipment.

> RA in IPV6CP, as an option, when RA/DHCPv6 is not available.

I strongly disagree.

Consider this: suppose instead of PPP (a link layer technology), we
were talking about Ethernet.  Do you expect your Ethernet driver to
negotiate a default router for you?  Or figure out where your DNS
servers might be?

The same protocols that work on IP over Ethernet work as well with IP
over PPP.  Instead of having *two* mechanisms -- one used when you're
attaching to one link layer (router advertisements), but a completely
unrelated mechanism on another link layer (a new PPP option) -- it's
best to have exactly one mechanism.

-- 
James Carlson, Solaris Networking         <[email-masked]>
Sun Microsystems / 1 Network Drive         71.234W   Vox +1 781 442 2084
MS UBUR02-212 / Burlington MA 01803-2757   42.497N   Fax +1 781 442 1677