Subject: Re: [ppsp] Mobility Requirements for PPSP

From: "zhangyunfei" <[email-masked]>
Date: Tue, 7 Sep 2010 17:31:48 +0800

This is a good starting point in discussing the mobility requirements in PPSP. I suggest to consider how to merge these requirements in the existing PPSP requirements draft.
Some comments on the drafts are as follows:
In section 3.1, the current scope of Peer to Peer protocol is on signaling without involving real content transfer. The sentence should be revised as” this bandwidth asymmetry should be considered for the Tracker-Peer protocol (e.g. as part of Peer status parameters reported to the Tracker),and may also affect Peer protocol in the peer information negotiation.
In section 3.2, the difference between two kinds of mobile nodes should be pointed: One kind is the mobile terminals and the other is the laptop with 3G/4G data cards. The latter has no battery problem.  
Section 3.3 is a common problem for both fixed and mobile network，not a specific problem for mobile network. Suggest to delete this paragraph.
In section 3.4, as explained in PPSP workshop, this problem will be alleviated in a cache-before-play process in PPSP streaming systems. So the key problem in PPSP protocol is how fast the peer needs to report its IP address change
Section4 shows no explicit requirements to the protocols. More direct requirements on the protocols should be stated and merged in section 3. 

BR
Yunfei

zhangyunfei
2010-09-07

发件人： Rahman, Akbar
发送时间： 2010-08-20 11:03:36
收件人： [email-masked]
抄送： Zuniga, Juan Carlos
主题： [ppsp] Mobility Requirements for PPSP

Sorry,  resending  again  with  a  proper  subject  title  to  the  email.

________________________________

From:  [email-masked]  on  behalf  of  Rahman,  Akbar
Sent:  Thu  8/19/2010  10:59  PM
To:  [email-masked]
Cc:  Zuniga,  Juan  Carlos
Subject:  [ppsp]  (no  subject)

Hi,

We  were  scheduled  to  present  our  mobility  requirements  for  PPSP  at  IETF  78,  but  unfortunately  the  PPSP  meeting  ran  out  of  time.  However,  we  believe  our  Internet-Draft  is  in  good  shape  and  we  propose  adding  the  mobility  requirements  to  draft-zong-ppsp-reqs.

?                Our  presentation  can  be  found  at:

o      mobile  use  case  of  PPSP  and  requirements   <http://sam.interdigital.com/exchweb/bin/redir.asp?URL=http://www.ietf.org/proceedings/78/slides/ppsp-3.pptx >

?                Our  latest  draft  can  be  found  at:

o      http://datatracker.ietf.org/doc/draft-lu-ppsp-mobile/   <http://sam.interdigital.com/exchweb/bin/redir.asp?URL=http://datatracker.ietf.org/doc/draft-lu-ppsp-mobile/ >

Our  Internet-Draft  update  fully  addresses  the  questions  raised  off  line  and  at  the  Beijing  China  Mobile  Workshop  on  PPSP.

Your  comments  will  be  very  much  appreciated.

Regards,

Akbar  and  Juan  Carlos

_______________________________________________
ppsp  mailing  list
[email-masked]
https://www.ietf.org/mailman/listinfo/ppsp

_______________________________________________
ppsp  mailing  list
[email-masked]
https://www.ietf.org/mailman/listinfo/ppsp

---

From: Song Haibin <[email-masked]>
Date: Thu, 09 Sep 2010 12:03:34 +0800

IMO, the mobility issue is one of the general issues in IETF.  We can pick
one existing mature protocol in IETF or just leave it as an open issue. 

Xie Xie,
Haibin

From: [email-masked] [mailto:[email-masked]] On Behalf Of
zhangyunfei
Sent: Tuesday, September 07, 2010 5:32 PM
To: Rahman, Akbar; [email-masked]
Cc: Zuniga, Juan Carlos
Subject: Re: [ppsp] Mobility Requirements for PPSP

This is a good starting point in discussing the mobility requirements in
PPSP. I suggest to consider how to merge these requirements in the existing
PPSP requirements draft.

In section 3.1, the current scope of Peer to Peer protocol is on signaling
without involving real content transfer. The sentence should be revised as”
this bandwidth asymmetry should be considered for the Tracker-Peer protocol
(e.g. as part of Peer status parameters reported to the Tracker),and may
also affect Peer protocol in the peer information negotiation.

In section 3.2, the difference between two kinds of mobile nodes should be
pointed: One kind is the mobile terminals and the other is the laptop with
3G/4G data cards. The latter has no battery problem.  

Section 3.3 is a common problem for both fixed and mobile network，not a
specific problem for mobile network. Suggest to delete this paragraph.

In section 3.4, as explained in PPSP workshop, this problem will be
alleviated in a cache-before-play process in PPSP streaming systems. So the
key problem in PPSP protocol is how fast the peer needs to report its IP
address change

Section4 shows no explicit requirements to the protocols. More direct
requirements on the protocols should be stated and merged in section 3. 

BR

Yunfei

  _____  

zhangyunfei

2010-09-07

  _____  

发件人： Rahman, Akbar

收件人： [email-masked]

抄送： Zuniga, Juan Carlos

To:  [email-masked]

Cc:  Zuniga,  Juan  Carlos

 

Hi,

We  were  scheduled  to  present  our  mobility  requirements  for  PPSP  at
IETF  78,  but  unfortunately  the  PPSP  meeting  ran  out  of  time.
However,  we  believe  our  Internet-Draft  is  in  good  shape  and  we
propose  adding  the  mobility  requirements  to  draft-zong-ppsp-reqs.

o      mobile  use  case  of  PPSP  and  requirements
<http://sam.interdigital.com/exchweb/bin/redir.asp?URL=http://www.ietf.org/p
roceedings/78/slides/ppsp-3.pptx >

o      http://datatracker.ietf.org/doc/draft-lu-ppsp-mobile/
<http://sam.interdigital.com/exchweb/bin/redir.asp?URL=http://datatracker.ie
tf.org/doc/draft-lu-ppsp-mobile/ >

Our  Internet-Draft  update  fully  addresses  the  questions  raised  off
line  and  at  the  Beijing  China  Mobile  Workshop  on  PPSP.

 

Regards,

Akbar  and  Juan  Carlos

ppsp  mailing  list

[email-masked]

 

ppsp  mailing  list

[email-masked]

---

From: "zhangyunfei" <[email-masked]>
Date: Thu, 9 Sep 2010 14:07:24 +0800

Haibin,
   The current draft doesn't discuss how to deal with he node mobility in PPSP senario.Rather to the best of my understanding,it's discussing what parameters should be reflected in peer protocol and tracker protocol to convey mobile related information.Am I right?Arbar?

BR
Yunfei

zhangyunfei
2010-09-09

发件人： Song Haibin
发送时间： 2010-09-09 12:03:51
收件人： 'zhangyunfei'; 'Rahman, Akbar'; [email-masked]
抄送： 'Zuniga, Juan Carlos'
主题： RE: [ppsp] Mobility Requirements for PPSP

IMO, the mobility issue is one of the general issues in IETF.  We can pick one existing mature protocol in IETF or just leave it as an open issue. 
 
Xie Xie,
Haibin
 
From: [email-masked] [mailto:[email-masked]] On Behalf Of zhangyunfei
Sent: Tuesday, September 07, 2010 5:32 PM
To: Rahman, Akbar; [email-masked]
Cc: Zuniga, Juan Carlos
Subject: Re: [ppsp] Mobility Requirements for PPSP

BR
Yunfei

zhangyunfei
2010-09-07

发件人： Rahman, Akbar

 

Hi,

 

 

 

Regards,

Akbar  and  Juan  Carlos

---

From: "Rahman, Akbar" <[email-masked]>
Date: Thu, 9 Sep 2010 02:29:21 -0400

Yunfei,

Yes, you are right.  Our current draft is identifying requirements for the peer and tracker protocol to handle mobile node issues like asymmetrical bandwidth, battery status, geo-location, etc. 

We do NOT propose mobility protocols like Mobile IP or Proxy Mobile IP.  We have just recorded some informative details in the Appendix on MIP and P-MIP but we are not proposing any requirements to PPSP for these as per earlier comments and the discussion at the Beijing workshop.

Hope that this clarifies the issue.

Akbar

P.S. I will be responding shortly to your other email which provided detailed comments on our draft.

From: zhangyunfei [mailto:[email-masked]] 
Sent: Thursday, September 09, 2010 2:07 AM
To: Song Haibin; Rahman, Akbar; [email-masked]
Cc: Zuniga, Juan Carlos
Subject: Re: RE: [ppsp] Mobility Requirements for PPSP

Haibin,

BR

Yunfei

zhangyunfei

2010-09-09

发件人： Song Haibin

Xie Xie,
Haibin

 

BR

Yunfei

zhangyunfei

2010-09-07

发件人： Rahman, Akbar

收件人： [email-masked]

抄送： Zuniga, Juan Carlos

To:  [email-masked]

Cc:  Zuniga,  Juan  Carlos

 

Hi,

 

 

Regards,

Akbar  and  Juan  Carlos

ppsp  mailing  list

[email-masked]

 

ppsp  mailing  list

[email-masked]

---

From: jlei <[email-masked]>
Date: Thu, 09 Sep 2010 13:28:27 +0200

Hi, Akbar, yunfei, and all:

I would totally agree with Akbar that PPSP should not intend to propose
any mobility protocols but focus on possible extensions or specific
requirements to the existing mobility protocols. Identifying some
potential existing mobility protocols and then, relying on them to
support mobility in PPSP scenarios would be good idea.

Question to the draft: In Section 4 is there any specific requirements
to the protocols? I suppose there should be some or?

B.R.

Jun
>
> Yunfei,
>
> Yes, you are right. Our current draft is identifying requirements for
> the peer and tracker protocol to handle mobile node issues like
> asymmetrical bandwidth, battery status, geo-location, etc.
>
> We do NOT propose mobility protocols like Mobile IP or Proxy Mobile
> IP. We have just recorded some informative details in the Appendix on
> MIP and P-MIP but we are not proposing any requirements to PPSP for
> these as per earlier comments and the discussion at the Beijing workshop.
>
> *From:* zhangyunfei [mailto:[email-masked]]
> *Sent:* Thursday, September 09, 2010 2:07 AM
> *To:* Song Haibin; Rahman, Akbar; [email-masked]
> *Cc:* Zuniga, Juan Carlos
> *Subject:* Re: RE: [ppsp] Mobility Requirements for PPSP
>
> Haibin,
>
> The current draft doesn't discuss how to deal with he node mobility in
> PPSP senario.Rather to the best of my understanding,it's discussing
> what parameters should be reflected in peer protocol and tracker
> protocol to convey mobile related information.Am I right?Arbar?
>
> BR
>
> Yunfei
>
> ------------------------------------------------------------------------
>
> zhangyunfei
>
> 2010-09-09
>
> ------------------------------------------------------------------------
>
> *发件人：* Song Haibin
>
> *发送时间：* 2010-09-09 12:03:51
>
> *收件人：* 'zhangyunfei'; 'Rahman, Akbar'; [email-masked]
>
> *抄送：* 'Zuniga, Juan Carlos'
>
> *主题：* RE: [ppsp] Mobility Requirements for PPSP
>
> IMO, the mobility issue is one of the general issues in IETF. We can
> pick one existing mature protocol in IETF or just leave it as an open
> issue.
>
> Xie Xie,
> Haibin
>
> *From:* [email-masked] [mailto:[email-masked]] *On
> Behalf Of *zhangyunfei
> *Sent:* Tuesday, September 07, 2010 5:32 PM
> *To:* Rahman, Akbar; [email-masked]
> *Cc:* Zuniga, Juan Carlos
> *Subject:* Re: [ppsp] Mobility Requirements for PPSP
>
> This is a good starting point in discussing the mobility requirements
> in PPSP. I suggest to consider how to merge these requirements in the
> existing PPSP requirements draft.
>
> In section 3.1, the current scope of Peer to Peer protocol is on
> signaling without involving real content transfer. The sentence should
> be revised as” this bandwidth asymmetry should be considered for the
> Tracker-Peer protocol (e.g. as part of Peer status parameters reported
> to the Tracker),and may also affect Peer protocol in the peer
> information negotiation.
>
> In section 3.2, the difference between two kinds of mobile nodes
> should be pointed: One kind is the mobile terminals and the other is
> the laptop with 3G/4G data cards. The latter has no battery problem.
>
> Section 3.3 is a common problem for both fixed and mobile network，not
> a specific problem for mobile network. Suggest to delete this paragraph.
>
> alleviated in a cache-before-play process in PPSP streaming systems.
> So the key problem in PPSP protocol is how fast the peer needs to
> report its IP address change
>
> ------------------------------------------------------------------------
>
> zhangyunfei
>
> 2010-09-07
>
> ------------------------------------------------------------------------
>
> *发件人：* Rahman, Akbar
>
> *发送时间：* 2010-08-20 11:03:36
>
> *收件人：* [email-masked]
>
> *抄送：* Zuniga, Juan Carlos
>
> *主题：* [ppsp] Mobility Requirements for PPSP
>
> IETF 78, but unfortunately the PPSP meeting ran out of time. However,
> we believe our Internet-Draft is in good shape and we propose adding
> the mobility requirements to draft-zong-ppsp-reqs.
>
> <http://sam.interdigital.com/exchweb/bin/redir.asp?URL=http://www.ietf.org/proceedings/78/slides/ppsp-3.pptx
> >
>
> <http://sam.interdigital.com/exchweb/bin/redir.asp?URL=http://datatracker.ietf.org/doc/draft-lu-ppsp-mobile/
> >
>
> ------------------------------------------------------------------------
>

-- 
Dr. Jun Lei
Research Associate

Address:
Georg-August-Universitaet Goettingen
Institut fuer Informatik
Telematics Group
Lotzestrasse 16-18
37083 Goettingen 

Fax: +49 (551) 39-1 44 03
Tel: +49 (551) 39-1 35 78

Email: [email-masked]

---

From: Hui Deng <[email-masked]>
Date: Fri, 10 Sep 2010 09:44:18 +0800

which level mobility you are talking about?
Network layer or PPSP layer?

-Hui

在 2010年9月9日 下午7:28，jlei <[email-masked]>写道：

> > <
> http://sam.interdigital.com/exchweb/bin/redir.asp?URL=http://www.ietf.org/proceedings/78/slides/ppsp-3.pptx
> > >
> >
> > <
> http://sam.interdigital.com/exchweb/bin/redir.asp?URL=http://datatracker.ietf.org/doc/draft-lu-ppsp-mobile/
> > >
> >

---

From: "Rahman, Akbar" <[email-masked]>
Date: Thu, 9 Sep 2010 22:15:15 -0400

Hi Jun,

Thanks for your feedback.  Our current draft does not yet contain the explicit requirements to support Mobile Nodes for PPSP as it was concentrating on defining the problems.  However, as Yunfei suggested in his email, it is now time to write the formal requirements for Mobile Nodes and consider adding them to the PPSP Requirements draft (draft-zong-ppsp-reqs).
 
I will send out an email by next week with some proposed text for the requirements for supporting Mobile Nodes with PPSP.  You and the group can then review them at that point.
 
Sincerely,

Akbar

From: jlei [mailto:[email-masked]]
Sent: Thu 9/9/2010 7:28 AM
To: Rahman, Akbar
Cc: zhangyunfei; [email-masked]; Zuniga, Juan Carlos
Subject: Re: [ppsp] Mobility Requirements for PPSP

B.R.

Jun
> *???:* Song Haibin
> *????:* 2010-09-09 12:03:51
>
> *???:* 'zhangyunfei'; 'Rahman, Akbar'; [email-masked]
>
> *??:* 'Zuniga, Juan Carlos'
>
> *??:* RE: [ppsp] Mobility Requirements for PPSP
>
> be revised as" this bandwidth asymmetry should be considered for the
> Section 3.3 is a common problem for both fixed and mobile network,not
> *???:* Rahman, Akbar
> *????:* 2010-08-20 11:03:36
>
> *???:* [email-masked]
>
> *??:* Zuniga, Juan Carlos
>
> *??:* [ppsp] Mobility Requirements for PPSP
>

--
Dr. Jun Lei
Research Associate

Address:

---

From: "Rahman, Akbar" <[email-masked]>
Date: Thu, 9 Sep 2010 22:27:23 -0400

Hi Hui,

We are talking about the impacts of mobility to the PPSP layer.  For example, if the Mobile Node supports asymetrical uplink/downlink bandwidth then how should the PPSP tracker and peer protocol handle this?  Also, if the IP address of the device changes then how fast should the PPSP peer report this to the other PPSP peers?

Sincerely,
 
Akbar

From: Hui Deng [mailto:[email-masked]]
Sent: Thu 9/9/2010 9:44 PM
To: jlei
Cc: Rahman, Akbar; [email-masked]; Zuniga, Juan Carlos
Subject: Re: [ppsp] Mobility Requirements for PPSP

-Hui

? 2010?9?9? ??7:28,jlei <[email-masked]>??:

	
	
	B.R.
	
	Jun

	

	--
	Dr. Jun Lei
	Research Associate
	
	Address:

---

From: Hui Deng <[email-masked]>
Date: Fri, 10 Sep 2010 10:46:59 +0800

Hi Akbar,

for the 1st, either adsl or 3GPP are asymetrical, how does MN dfifferenriate
it?
2nd one, ppsp peer is not awared of IP address changing?

I guess that you already have the proposal on this, sounds interesting.

-Hui
2010/9/10 Rahman, Akbar <[email-masked]>

> Hi Hui,
>
>
> We are talking about the impacts of mobility to the PPSP layer.  For
> example, if the Mobile Node supports asymetrical uplink/downlink bandwidth
> then how should the PPSP tracker and peer protocol handle this?  Also, if
> the IP address of the device changes then how fast should the PPSP peer
> report this to the other PPSP peers?
>
>
> Sincerely,
>
> Akbar
>
>
>        > P.S. I will be responding shortly to your other email which
> provided
>        > detailed comments on our draft.
>        >
> However,

---

From: "Rahman, Akbar" <[email-masked]>
Date: Fri, 17 Sep 2010 11:31:51 -0400

Hi Yunfei/Ning

We have updated our draft to reflect all the good comments from Yunfei, Hui, Jun and others have made:

http://www.ietf.org/internet-drafts/draft-lu-ppsp-mobile-03.txt

You will see that in our conclusions (section 4) we have proposed that the following requirements be added

 to the "Basic Requirements to PPSP Node" section of [I-D.zong-ppsp-reqs]:

   PPSP.REQ-1: Change in IP address of a Peer device MUST immediately be

   reported via the Tracker Protocol and Peer Protocol

   PPSP.REQ-2: Available uplink and downlink bandwidth of a Peer device

   SHOULD be reported via the Tracker Protocol and Peer Protocol

   PPSP.REQ-3: Battery status of a Peer device SHOULD be reported via

   the Tracker Protocol and Peer Protocol

   PPSP.REQ-4: Location of a Peer device SHOULD be reported via the

   Tracker Protocol and Peer Protocol

Do you agree?

Akbar

From: zhangyunfei [mailto:[email-masked]] 
Sent: Tuesday, September 07, 2010 5:32 AM
To: Rahman, Akbar; [email-masked]
Cc: Zuniga, Juan Carlos
Subject: Re: [ppsp] Mobility Requirements for PPSP

BR

Yunfei

zhangyunfei

2010-09-07

发件人： Rahman, Akbar

收件人： [email-masked]

抄送： Zuniga, Juan Carlos

To:  [email-masked]

Cc:  Zuniga,  Juan  Carlos

 

Hi,

 

 

Regards,

Akbar  and  Juan  Carlos

ppsp  mailing  list

[email-masked]

 

ppsp  mailing  list

[email-masked]

---

From: "David A. Bryan" <[email-masked]>
Date: Fri, 17 Sep 2010 11:51:34 -0400

While I think this could be really useful, for number 2, we need to be
careful to make it clear this is a best guess on the part of the peer
(to be used for guidance), and should consider the performance
implications of measuring bandwidth. If we had a requirement, I'd
probably want it to be a "MAY" rather than a "SHOULD".

It is very, very difficult to accurately measure available bandwidth
(particularly passively). There are entire conferences dedicated to
the problem (http://www.pam2010.ethz.ch/) and passively measuring
available bandwidth was actually the subject of an entire doctoral
dissertation in my research group in grad school. Measuring by
saturating the connection can be more accurate, but consumes a great
deal of bandwidth, of course. It is also possible (in many cases
probable) that a measurement may not be 100% accurate (due to traffic
shaping; "ramp" behavior where an ISP allows short duration
high-bandwidth transmissions, but not decreases bandwidth for longer
transmissions; competing traffic on shared access lines; different
bandwidth between different pair-wise connections of the peer; etc).
Finally, a peer could simply lie (assuming the peer makes the
measurement), and I don't think we want to add to the load of the
tracker by having it initiate the measurements (which opens the
question of who will the peer measure traffic against?)

I'm definitely not saying it is a bad idea to allow peers to provide
some guidance here, but measuring bandwidth, particularly something
ephemeral like available bandwidth is a really, really hard thing to
do. We have to make it clear this is at best guidance.

Also, we should consider the interaction with ALTO here. There is
already a group working on mechanisms to determine how best to select
peers, so we may be able to leverage that here.

Again, not against the idea of providing this as optional guidance,
just pointing out some of the many reasons this data may not be as
accurate (or obtainable) as one might think, so relying on it may be
questionable.

David

2010/9/17 Rahman, Akbar <[email-masked]>:
> without involving real content transfer. The sentence should be revised as"

---

From: jlei <[email-masked]>
Date: Sun, 19 Sep 2010 14:21:42 +0200

Dear Akbar, David and all:

Thanks for the update and comments. Please see inline.
> bandwidth between different pair-wise connections of the peer; etc).
You are absolutely right that it is very hard to provide accurate
meansurement of available bandwidth. However, I would assume that an
estimated available bandwidth is enough under the current situation.
Besides, the report of bandwidth to the PPSP system (e.g. tracker) is
already used, for instance, Joost, PPStream. Moreover, peers are
encouraged to report the available bandwidth through some "incentive"
mechanisms (e.g. high quality of provided video, shorter service
connection time).
> question of who will the peer measure traffic against?)
In order to avoid forgery issue, a possible solution here could be
collaborative estimation/measurement from neighboring peers. If the peer
delibrately manipulates the bandwidth, it might be difficult to rely on
peer itself, and therefore network monitoring is necessary.
> peers, so we may be able to leverage that here.
I agree to consider locality-awareness in peering selection though it
may rely on some assistance from ISP or some other assumptions.

To [Akbar]: It might be better to clearly state which kind of "location
information of peer" should be used here. For example, is it a relative
location, a network level location or even geographical location.

B.R.

Jun

-- 
Dr. Jun Lei
Research Associate

Address:

---

From: "Rahman, Akbar" <[email-masked]>
Date: Tue, 21 Sep 2010 09:42:48 -0400

Hi David,

Thank you for your insightful comments.  I agree with your suggestion to make the
Bandwidth requirement a "MAY" instead of "SHOULD".  I will make this change in
my next update of the draft.

Akbar 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of David A. Bryan
Sent: Friday, September 17, 2010 11:52 AM
To: Rahman, Akbar
Cc: zhangyunfei; [email-masked]; [email-masked]; Zuniga, Juan Carlos
Subject: Re: [ppsp] Mobility Requirements for PPSP

David

---

From: "Rahman, Akbar" <[email-masked]>
Date: Tue, 21 Sep 2010 09:46:52 -0400

Hi Jun,

Thank you for your excellent comments.  With regards to the question that
you asked:

I did give some examples in section 3.4 "Geo-Targeting".  However, for the requirement
I did not want to specify a specific method.  Whoever works on the solution can decide
on what is the best location method/information to use. 

Sincerely,

Akbar

-----Original Message-----
From: jlei [mailto:[email-masked]] 
Sent: Sunday, September 19, 2010 8:22 AM
To: David A. Bryan
Cc: Rahman, Akbar; [email-masked]; Zuniga, Juan Carlos
Subject: Re: [ppsp] Mobility Requirements for PPSP

B.R.

Jun

-- 
Dr. Jun Lei
Research Associate

Address:

---

From: jlei <[email-masked]>
Date: Tue, 21 Sep 2010 20:11:54 +0200

> on what is the best location method/information to use. 
Here, I prefer to mention is possible options of "location information
of a peer" which can be very useful for locality-awareness (if it will
be considered). However, if you would like to leave them to the
designers it is totally alright.

B.R.

Jun

-- 
Dr. Jun Lei
Research Associate

Address:

---

From: "Rahman, Akbar" <[email-masked]>
Date: Tue, 21 Sep 2010 14:52:27 -0400

Hi Ning,

I have updated our draft again after the email discussions with Brian and Jun.

http://www.ietf.org/id/draft-lu-ppsp-mobile-04.txt

   MAY be reported via the Tracker Protocol and Peer Protocol

I assume that you will be able to incorporate these requirements into [I-D.zong-ppsp-reqs] by the Beijing

IETF.  Please contact me if you need to discuss any issue.

Sincerely,

Akbar

From: [email-masked] [mailto:[email-masked]] On Behalf Of Rahman, Akbar
Sent: Friday, September 17, 2010 11:32 AM
To: zhangyunfei; [email-masked]
Cc: [email-masked]; Zuniga, Juan Carlos
Subject: Re: [ppsp] Mobility Requirements for PPSP

Hi Yunfei/Ning

 

Do you agree?

Akbar

 

BR

Yunfei

zhangyunfei

2010-09-07

发件人： Rahman, Akbar

收件人： [email-masked]

抄送： Zuniga, Juan Carlos

To:  [email-masked]

Cc:  Zuniga,  Juan  Carlos

 

Hi,

 

 

Regards,

Akbar  and  Juan  Carlos

ppsp  mailing  list

[email-masked]

 

ppsp  mailing  list

[email-masked]

---

From: "Xiao, Lin (NSN - CN/Beijing)" <[email-masked]>
Date: Sat, 25 Sep 2010 14:59:39 +0800

Hi Akbar,
 
Your draft listed the influences of mobility to P2P applications. I have to admit that they are really issues faced by applications especially by P2P in mobile environment. However, IMHO, should we proposed too much detailed requirements currently on optimization in [I-D.zong-ppsp-reqs]? Is it PPSPs' responsibility to solve them? I'm not saying we should not solve them. It's just not very clear to me at the moment.
 
In [I-D.zong-ppsp-reqs] we have given related high level requirements about the peer status reports/updates that covers those you proposed:
 
For tracker protocol:
PPSP.TP.REQ-2: The PPSP peers MUST implement the PPSP tracker
   protocol for sending PPSP tracker queries and periodical peer status
   reports/updates to PPSP tracker and receiving the corresponding
   replies from tracker.

For peer protocol:
PPSP.PP.REQ-6: The peer streaming status update information MAY be
   advertised among peers.

   Streaming status information should be related to the content
   delivery, including online time, link status, peer capability and
   other streaming parameters of the peer.  With this information, a
   peer can select more appropriate peers for content sharing based on
   some content sharing strategies and/or application requirements.

We avoid to specify the detailed status parameters in requirement stage, because we should be very carefully on selecting only few high value status for PPSP standardization to avoid PPSP being too heavy and complex to be implemented. We'd like to leave this detailed work to protocol design stage.
 
The first request you listed is to inform the IP change to tracker and peers. I think, as PPSP does not do mobility management, the connections should be rebuilt if the mobile node change another IP address. It's triggered automatically when the node find all the connection of a swarm to the peer are failed. A new request to the swarm will be sent by the mobile node to tracker. This procedure solves connection failure scenarios, including the IP change, server too busy or down, and so on, no matter the reason. IMHO, if we can solve the issue on application level easily, we'd better avoid the interaction with other layers for a light-weight PPSP protocol.
 
The second requirement may be included in PPSP.TP.REQ-2 and PPSP.PP.REQ-6. But as David said, it should not be a mandatory but a optional selection.
 
IMHO, I don't think battery information should be a mandatory, although it can be also included in PPSP.TP.REQ-2 and PPSP.PP.REQ-6. If PPSP should consider so detail as Battery issues, should we also consider things like Power utilization or CPU and storage capabilities? Can same battery level last same working time for different devices? I think, there should be some parameter to reflect the status of a peer. But the parameter should be a combination of lots of different factors, including battery. PPSP itself should not leverage the factors by itself which is a heavy burden. It may be solved by third party services, similar to ALTO. PPSP may use the result directly.
 
In [I-D.zong-ppsp-reqs], we also give the requirement:
 
PPSP.TP.REQ-7: The PPSP tracker MAY generate the peer list with the
   help of traffic optimization services, e.g.  Alto.

It can solve your fourth requirement, right?
 
Again, I must admit your concerns are very important for a better performance of PPSP.  But, shall we focus on basic signaling of Tracker and Peer protocols for resource locating and connection at the moment, and just give a high level requirement on peer status report? If we find anything related to optimization is really necessary for PPSP, we can do it together with the protocol designing. Anyway, your requirements have been involved in current requirement draft generally, right?

 
Best Regards,
Lin Xiao 

From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Rahman, Akbar
Sent: Wednesday, September 22, 2010 2:52 AM
To: [email-masked]
Cc: [email-masked]; Zuniga, Juan Carlos
Subject: Re: [ppsp] Mobility Requirements for PPSP

Hi Ning,

 

 

Sincerely,

Akbar

Hi Yunfei/Ning

 

Do you agree?

Akbar

 

BR

Yunfei

zhangyunfei

2010-09-07

发件人： Rahman, Akbar

收件人： [email-masked]

抄送： Zuniga, Juan Carlos

To:  [email-masked]

Cc:  Zuniga,  Juan  Carlos

 

Hi,

 

 

Regards,

Akbar  and  Juan  Carlos

ppsp  mailing  list

[email-masked]

 

ppsp  mailing  list

[email-masked]

---

From: "Rahman, Akbar" <[email-masked]>
Date: Tue, 28 Sep 2010 15:29:20 -0400

Hi Lin,

Thank you for your valuable comments.  I have cut out of your email your key points and have provided point by point feedback.

------ point #1 ---------

Is it PPSPs' responsibility to solve them (i.e. mobility)? I'm not saying we should not solve them. It's just not very clear to me at the moment.

Yes, it is part of the PPSP charter.  Specifically, from the charter:

“Peers are nodes that are actively sending and receiving streamed media content, 

and include both statically connected hosts as well as mobile devices with connectivity

and IP addresses that change over time.”

------ point #2 ---------

The first request you listed is to inform the IP change to tracker and peers. I think, as PPSP does not do mobility management, the connections should be rebuilt if the mobile node change another IP address.

No.  As you can see from my PPSP charter extract above, it is mandatory that PPSP must handle IP address change

------ point #3 ---------

The second requirement (i.e. available uplink/downlink bandwidth) may be included in PPSP.TP.REQ-2 and PPSP.PP.REQ-6. But as David said, it should not be a mandatory but a optional selection.

Okay.  But the current requirements must be made more explicit by adding reference to available bandwidth.  Otherwise we should make it a separate requirement as I originally proposed.   I have already made the bandwidth requirement optional as David suggested (i.e. it is a MAY requirement).

------ point #4 ---------

IMHO, I don't think battery information should be a mandatory, although it can be also included in PPSP.TP.REQ-2 and PPSP.PP.REQ-6.

Okay.  But again the requirements must be made more explicit by adding reference to battery status. Otherwise we should make it a separate requirement as I originally proposed.   I have already made the battery status a SHOULD requirement so it is not mandatory.  We can discuss making it a MAY requirement if you wish.

------ point #4 ---------

 

No.  I don’t see how this satisfies my requirement for location reporting.

--------------------------------

Sincerely,

Akbar

From: Xiao, Lin (NSN - CN/Beijing) [mailto:[email-masked]] 
Sent: Saturday, September 25, 2010 3:00 AM
To: Rahman, Akbar; [email-masked]
Cc: [email-masked]; Zuniga, Juan Carlos
Subject: RE: [ppsp] Mobility Requirements for PPSP

Hi Akbar,

For tracker protocol:

For peer protocol:

 

Best Regards,

Lin Xiao 

Hi Ning,

 

 

Sincerely,

Akbar

Hi Yunfei/Ning

 

Do you agree?

Akbar

 

BR

Yunfei

zhangyunfei

2010-09-07

发件人： Rahman, Akbar

收件人： [email-masked]

抄送： Zuniga, Juan Carlos

To:  [email-masked]

Cc:  Zuniga,  Juan  Carlos

 

Hi,

 

 

Regards,

Akbar  and  Juan  Carlos

ppsp  mailing  list

[email-masked]

 

ppsp  mailing  list

[email-masked]