Subject: Re: [ppsp] PPSP Requirements: PPSP.TP.REQ-4 (number of peers anddownloading bandwidth)

From: "Rahman, Akbar" <[email-masked]>
Date: Tue, 2 Nov 2010 13:45:54 -0400

Hi Ning,

I think that is an excellent way to proceed.  Thank you for considering
my comments and I look forward to seeing you in Beijing.

Sincerely,

Akbar

-----Original Message-----
From: Ning Zong [mailto:[email-masked]] 
Sent: Wednesday, October 27, 2010 8:33 PM
To: Rahman, Akbar; 'Martin Stiemerling'
Cc: [email-masked]
Subject: RE: [ppsp] PPSP Requirements: PPSP.TP.REQ-4 (number of peers
anddownloading bandwidth)

Hi, Akbar and Martin
Thank you very much for contributing to the requirement draft.
My suggestion is that I will put these requirement changes to our
presentation slides used on Beijing meeting so that we can get group
consensus about how to incorporate the suggested text into PPSP
requirement
drafts.
Although personally I agree with some of the changes, we need to get
group
consensus before adopting them into the WG draft, right?
Sorry for the late response and, hope to see you all in Beijing.

BR,
Ning Zong

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Rahman, Akbar
Sent: Wednesday, October 27, 2010 10:28 PM
To: Martin Stiemerling
Cc: [email-masked]
Subject: Re: [ppsp] PPSP Requirements: PPSP.TP.REQ-4 (number of peers
anddownloading bandwidth)

Thanks, Martin.

I will make your suggested changes for the battery status in the next
revision of my draft.  Or better yet, the PPSP Requirement draft will
incorporate your and my suggestions for adding the mobility requirements
into their WG draft (and I will no longer have to maintain my separate
draft)!

See you in Beijing.

Akbar

-----Original Message-----
From: Martin Stiemerling [mailto:[email-masked]] 
Sent: Wednesday, October 27, 2010 9:53 AM
To: Rahman, Akbar
Cc: [email-masked]
Subject: RE: [ppsp] PPSP Requirements: PPSP.TP.REQ-4 (number of peers
and downloading bandwidth)

Hi Akbar,

Just browsed the points and I tend to agree with most points. 

Mobility isn't covered at all in the requirements and not even reflected
any of them.

For the battery one - I guess it would make sense to say:
Peers SHOULD be able to add specific parameters to their tracker request

and to refine it in separate step to "this may include battery status
information."

Thanks,

  Martin

[email-masked]

NEC Laboratories Europe - Network Research Division
NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road,
London W3 6BL | Registered in England 2832014 

> -----Original Message-----
> From: Rahman, Akbar [mailto:[email-masked]]
> Sent: Wednesday, October 27, 2010 3:35 PM
> To: Martin Stiemerling
> Cc: [email-masked]
> Subject: RE: [ppsp] PPSP Requirements: PPSP.TP.REQ-4 (number of peers
> and downloading bandwidth)
> 
> Hi Martin,
> 
> 
> I agree with your comments.  Also please note that I have previously
> raised some other issues on the requirements for which I am still
> waiting for some feedback on (see attached link)
> 
> http://www.ietf.org/mail-archive/web/ppsp/current/msg00720.html
> 
> 
> Sincerely,
> 
> 
> Akbar
> 
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> Martin Stiemerling
> Sent: Wednesday, October 27, 2010 9:26 AM
> To: [email-masked]
> Subject: [ppsp] PPSP Requirements: PPSP.TP.REQ-4 (number of peers and
> downloading bandwidth)
> 
> Hi,
> 
> A clarifying question to the requirements draft's PPSP.TP.REQ-4. It
> says:
> PPSP.TP.REQ-4: The tracker request message MAY include parameter of
>    requested number of downloading peers or preferred downloading
>    bandwidth.
> 
> First, wouldn't it be better to specify:
> "The tracker request message SHOULD allow to include parameters set by
> the peer to further refine the request."
> 
> I guess that this is the actual intention of the requirements. The
next
> requirements below would be a refinement of the above requirement or
> examples:
> 
> Second, one more detailed requirement could be"
> "The tracker request message SHOULD allow to include parameters which
> denote the number of peers queried for."
> 
> Another requirement could be:
> "The tracker request message SHOULD allow to include parameters which
> denotes the minimum theoretical upload bandwidth of a peer."
> 
> 
>  Martin
> 
> [email-masked]
> 
> NEC Laboratories Europe - Network Research Division
> NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road,
> London W3 6BL | Registered in England 2832014
> 
> 
> _______________________________________________
> ppsp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ppsp
_______________________________________________
ppsp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ppsp

---

From: Martin Stiemerling <[email-masked]>
Date: Wed, 3 Nov 2010 12:39:25 +0000

Fine with me. 

However, there is no need to wait until we arrive at the meeting. The mailing list can simply do it.

  Martin

NEC Laboratories Europe - Network Research Division
NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014 

> Sent: Thursday, October 28, 2010 2:33 AM
> To: 'Rahman, Akbar'; Martin Stiemerling
> Cc: [email-masked]