Subject: [ppsp] Meeting minutes on the tracker protocol discussion

From: yunfei zhang <[email-masked]>
Date: Tue, 24 Sep 2013 22:23:30 +0800

Hi all,
    Below is the meeting minutes on the tracker protocol discussion. Please
feel free to update and comment on that.

BR
Yunfei
--------------------------------------------------
Topic: PPSP tracker protocol discussion
Date: Tuesday, September 24, 2013
Time: 9:00-10:00 pm, China Time (Beijing, GMT+08:00)
Attendees: Yunfei Zhang, Ning Zong, Rui Cruz, Dave Cottlehuber, Rachel
Huang, Jinwei Xia, Lingli Deng

1. Rui introduced the progress of the tracker protocol, FIND moving in the
base protocol.
2. Discussion on the open issues according to last IETF meeting notes.
3.Consensus
   3.1  In FIND message, adding an example of seeder to send the message to
show the message is both feasible for leecher and seeder.
    3.2  Encoding, moving XML/text/EXI/etc.. to the appendix. In main body,
just leaving the http as the communication model and semantics. In the
meanwhile, pointing out that the http message negotiates which encoding is
used.
    3.3  Explaining in the appendix  the reason behind the choice of the
number of the peers, the test result and the resulting single TCP packet to
carry(30 peers, XML can be carried in one TCP packet).
    3.4 The update version of the tracker protocol and the extended tracker
protocol are planned to be finished in mid of Oct and will submit for
mailing list discussion.
    3.5 Dave is happy to provide some use case in the mailing list?.

Thanks all for your attendence.

BR
Yunfei

2013/9/24 yunfei zhang <[email-masked]>

> Hi all,
>   According to the poll, we booked two time slots, Sep 24 as the primary
> time and Sep 26 as the backup in case there are left things to be
> discussed. See you in today's meeting.
>
> BR
> Yunfei
>
> 在 2013年9月24日星期二，Zongning 写道：
>
>  Hi, folks,****
>>
>> ** **
>>
>> Please find the below Webex meeting information for PPSP discussion
>> meeting (cont’ on Thursday).****
>>
>> ** **
>>
>> Thanks.****
>>
>> ** **
>>
>> -Ning****
>>
>> ** **
>>
>> ** **
>>
>> *From:* Cindy Morgan [mailto:[email-masked]]
>> *Sent:* Tuesday, September 24, 2013 12:52 AM
>> *To:* Zongning
>> *Subject:* Meeting invitation: PPSP (2)****
>>
>> ** **
>>
>>
>> Hello ,
>>
>> Cindy Morgan invites you to attend this online meeting.
>>
>> Topic: PPSP (2)
>> Date: Thursday, September 26, 2013
>> Time: 3:00 pm, China Time (Beijing, GMT+08:00)
>> Meeting Number: 640 234 433
>> Meeting Password: 1234
>>
>>
>> -------------------------------------------------------
>> To join the online meeting (Now from mobile devices!)
>> -------------------------------------------------------
>> 1. Go to
>> https://ietf.webex.com/ietf/j.php?ED=240588192&UID=1649785332&PW=NYTYzNDc0NDRm&RT=MiM0NQ%3D%3D
>> 2. If requested, enter your name and email address.
>> 3. If a password is required, enter the meeting password: 1234
>> 4. Click "Join".
>>
>> To view in other time zones or languages, please click the link:
>>
>> https://ietf.webex.com/ietf/j.php?ED=240588192&UID=1649785332&PW=NYTYzNDc0NDRm&ORT=MiM0NQ%3D%3D
>>
>> -------------------------------------------------------
>> To join the audio conference only
>> -------------------------------------------------------
>> Call-in toll number (US/Canada): 1-650-479-3208
>>
>> Access code:640 234 433
>>
>> -------------------------------------------------------
>> For assistance
>> -------------------------------------------------------
>> 1. Go to https://ietf.webex.com/ietf/mc
>> 2. On the left navigation bar, click "Support".
>>
>> You can contact me at:
>> [email-masked]
>> 1-510-492-4085
>>
>> To add this meeting to your calendar program (for example Microsoft
>> Outlook), click this link:
>>
>> https://ietf.webex.com/ietf/j.php?ED=240588192&UID=1649785332&ICS=MI&LD=1&RD=2&ST=1&SHA2=AAAAApeV430pICG7k8xU461fuTyZ9nL9gT9o3bxcxqHrxLI4&RT=MiM0NQ%3D%3D
>>
>> The playback of UCF (Universal Communications Format) rich media files
>> requires appropriate players. To view this type of rich media files in the
>> meeting, please check whether you have the players installed on your
>> computer by going to https://ietf.webex.com/ietf/systemdiagnosis.php.
>>
>> Sign up for a free trial of WebEx
>> http://www.webex.com/go/mcemfreetrial
>>
>> http://www.webex.com
>>
>> CCP:+16504793208x640234433#
>>
>> IMPORTANT NOTICE: This WebEx service includes a feature that allows audio
>> and any documents and other materials exchanged or viewed during the
>> session to be recorded. By joining this session, you automatically consent
>> to such recordings. If you do not consent to the recording, discuss your
>> concerns with the meeting host prior to the start of the recording or do
>> not join the session. Please note that any such recordings may be subject
>> to discovery in the event of litigation. ****
>>
>

---

From: Zongning <[email-masked]>
Date: Wed, 25 Sep 2013 00:21:26 +0000

Great minutes. Just minor change to the last item.

3.5 Dave is happy to provide some use case in the mailing list?.
=> Rui will reply the question from Stephan Maka about why using HTTP, as well as direct him to the list discussion. Dave would help on use cases then.

Thanks.

-Ning

From: yunfei zhang [mailto:[email-masked]]
Sent: Tuesday, September 24, 2013 10:24 PM
To: Zongning
Cc: ppsp
Subject: Meeting minutes on the tracker protocol discussion

Hi all,
    Below is the meeting minutes on the tracker protocol discussion. Please feel free to update and comment on that.
BR
Yunfei
--------------------------------------------------
Topic: PPSP tracker protocol discussion
Date: Tuesday, September 24, 2013
Time: 9:00-10:00 pm, China Time (Beijing, GMT+08:00)
Attendees: Yunfei Zhang, Ning Zong, Rui Cruz, Dave Cottlehuber, Rachel Huang, Jinwei Xia, Lingli Deng
1. Rui introduced the progress of the tracker protocol, FIND moving in the base protocol.
2. Discussion on the open issues according to last IETF meeting notes.
3.Consensus
   3.1  In FIND message, adding an example of seeder to send the message to show the message is both feasible for leecher and seeder.
    3.2  Encoding, moving XML/text/EXI/etc.. to the appendix. In main body, just leaving the http as the communication model and semantics. In the meanwhile, pointing out that the http message negotiates which encoding is used.
    3.3  Explaining in the appendix  the reason behind the choice of the number of the peers, the test result and the resulting single TCP packet to carry(30 peers, XML can be carried in one TCP packet).
    3.4 The update version of the tracker protocol and the extended tracker protocol are planned to be finished in mid of Oct and will submit for mailing list discussion.
    3.5 Dave is happy to provide some use case in the mailing list?.
Thanks all for your attendence.
BR
Yunfei

2013/9/24 yunfei zhang <[email-masked]<mailto:[email-masked]>>
Hi all,
  According to the poll, we booked two time slots, Sep 24 as the primary time and Sep 26 as the backup in case there are left things to be discussed. See you in today's meeting.

BR
Yunfei

Hi, folks,

Please find the below Webex meeting information for PPSP discussion meeting (cont’ on Thursday).

Thanks.

-Ning

From: Cindy Morgan [mailto:[email-masked]]
Sent: Tuesday, September 24, 2013 12:52 AM
To: Zongning
Subject: Meeting invitation: PPSP (2)

Hello ,

Topic: PPSP (2)

1. Go to https://ietf.webex.com/ietf/j.php?ED=240588192&UID=1649785332&PW=NYTYzNDc0NDRm&RT=MiM0NQ%3D%3D

Access code:640 234 433

You can contact me at:
[email-masked]
1-510-492-4085

To add this meeting to your calendar program (for example Microsoft Outlook), click this link:
https://ietf.webex.com/ietf/j.php?ED=240588192&UID=1649785332&ICS=MI&LD=1&RD=2&ST=1&SHA2=AAAAApeV430pICG7k8xU461fuTyZ9nL9gT9o3bxcxqHrxLI4&RT=MiM0NQ%3D%3D

The playback of UCF (Universal Communications Format) rich media files requires appropriate players. To view this type of rich media files in the meeting, please check whether you have the players installed on your computer by going to https://ietf.webex.com/ietf/systemdiagnosis.php.

http://www.webex.com

IMPORTANT NOTICE: This WebEx service includes a feature that allows audio and any documents and other materials exchanged or viewed during the session to be recorded. By joining this session, you automatically consent to such recordings. If you do not consent to the recording, discuss your concerns with the meeting host prior to the start of the recording or do not join the session. Please note that any such recordings may be subject to discovery in the event of litigation.