Subject: [precis] Oracle / ZFS note on normalization

From: Alan DeKok <[email-masked]>
Date: Sun, 18 Jan 2015 12:00:20 -0500

https://blogs.oracle.com/nico/entry/normalization_insensitivity_should_be_the

  They recommend storing the data / filename entered by the client as-is.  Then for comparisons, each client reads the filename, does normalization, and compares the normalized strings.

  This is the same conclusion we got to in the RADEXT NAI document:

https://tools.ietf.org/html/draft-ietf-radext-nai-15

  Is there a reference which makes this recommendation clear?  It would be good to help people create good solutions.

  If there isn’t a reference, should there be one?

  Alan DeKok.

---

From: Patrik Fältström <[email-masked]>
Date: Sun, 18 Jan 2015 18:11:08 +0100

> On 18 jan 2015, at 18:00, Alan DeKok <[email-masked]> wrote:
> 

Very english/us centric text when conclusions are drawn on how often issues might arrive.

That said, the thinking is not bad, but requires quite some thinking on various scenarios.

>  If there isn’t a reference, should there be one?

There must be much more work behind something like this, like looking at the various normalization forms, when matching actually happens (risk for creation of two different files, when later only one of them can be accessed -- and it might even be a random one of them) etc.

   Patrik