Subject: Re: [precis] [Technical Errata Reported] RFC7564 (4568)

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 4 May 2016 19:19:09 -0600

Something along the lines of the proposed text makes sense to me, and I 
plan to incorporate such text into 7564bis. I might prefer slightly 
different wording, such as:

    o  Preparation primarily entails ensuring that the characters in an
       individual string are allowed by the underlying PRECIS string
       class, and sometimes also entails applying one or more of the
       rules specified for a particular string class or profile thereof.
       Preparation can be appropriate for constrained devices that can to
       some extent restrict the characters in a string to a limited
       repertoire but that do not have the processing power or onboard
       memory to perform operations such as Unicode normalization.
       However, preparation does not ensure that an input string conforms
       to all of the rules for a string class or profile thereof.

Peter

On 1/21/16 6:29 AM, Barry Leiba wrote:
> Are there comments from the authors or working group on this errata report?
>
> Barry, ART AD
>
>
> On Sun, Dec 20, 2015 at 2:32 PM, RFC Errata System
> <[email-masked]> wrote:
>> The following errata report has been submitted for RFC7564,
>> "PRECIS Framework: Preparation, Enforcement, and Comparison of Internationalized Strings in Application Protocols".
>>
>> --------------------------------------
>> You may review the report below and at:
>> http://www.rfc-editor.org/errata_search.php?rfc=7564&eid=4568
>>
>> --------------------------------------
>> Type: Technical
>> Reported by: Sam Whited <[email-masked]>
>>
>> Section: 3
>>
>> Original Text
>> -------------
>> Preparation entails only ensuring that the characters in an
>> individual string are allowed by the underlying PRECIS string
>> class.
>>
>> Corrected Text
>> --------------
>> Preparation entails applying some or none of the rules specified for a
>> particular string class or profile thereof to an individual string, and
>> ensuring that characters in the resulting string are allowed by the
>> underlying PRECIS string class.
>>
>> Notes
>> -----
>> The original text makes it sound like preparation is ONLY validating that the characters in a string are allowed in the underlying PRECIS string class, however, some profiles (for example, see the UsernameCaseMapped profile) specify that some of the rules must be applied first (in the case of UsernameCaseMapped, preparation includes first applying the Width rule).
>>
>> Instructions:
>> -------------
>> This erratum is currently posted as "Reported". If necessary, please
>> use "Reply All" to discuss whether it should be verified or
>> rejected. When a decision is reached, the verifying party (IESG)
>> can log in to change the status and edit the report, if necessary.
>>
>> --------------------------------------
>> RFC7564 (draft-ietf-precis-framework-23)
>> --------------------------------------
>> Title               : PRECIS Framework: Preparation, Enforcement, and Comparison of Internationalized Strings in Application Protocols
>> Publication Date    : May 2015
>> Author(s)           : P. Saint-Andre, M. Blanchet
>> Category            : PROPOSED STANDARD
>> Source              : Preparation and Comparison of Internationalized Strings APP
>> Area                : Applications
>> Stream              : IETF
>> Verifying Party     : IESG
>>

---

From: Sam Whited <[email-masked]>
Date: Wed, 4 May 2016 20:26:35 -0500

On May 4, 2016 20:19, "Peter Saint-Andre" <[email-masked]> wrote:
> I might prefer slightly different wording, such as:
>

That sounds very clear to me and addresses my concerns.

Best,
Sam