Subject: PMP> Corrupt Figure 1 in

From: Ron Bergman <[email-masked]>
Date: Tue, 18 Jan 2000 10:33:31 -0800

Harry,

Figure 1 in the printer MIB draft is corrupted from the original
version in RFC 1759.  It shows the SNMP agent connecting
to the channel/interface rather than the Printer.

Part of the problem may be due to the margin setting.  The
IETF allows a 72 column wide document.  With a 12 point
font the left plus right margin would be 1.3 inches.  The
Printer MIB currently uses a 2 inch margin.  This may be
some of the reason that Randy Turner had to do much
reformatting of the document.

    Ron Bergman
    Hitachi Koki Imaging Solutions

---

From: "McDonald, Ira" <[email-masked]>
Date: Tue, 18 Jan 2000 10:55:25 -0800

Hi Harry and Ron,

The IETF also requires that the left margin be ZERO - that is, the first
character of titles begins in column one, with no leading spaces.  All
section
contents (text after section titles) is supposed to have exactly three
leading spaces (i.e., start in column 4).  And various other boilerplate
rules apply (e.g., IANA Considerations, Security Considerations, and
Internationalization sections are *mandatory* for all I-Ds).

Picking up my text scanning tools off the PWG site would probably
be helpful.  They are in the directory:

ftp://ftp.pwg.org/pub/pwg/tools

Pick up the 'readme.txt' and the tools:

'cscan' - Character scan (finds non-ASCII, 8-bit chars)
'maxln' - Checks maximum text line length
'strip' - Strips 8-bit and control chars out (use CAREFULLY)
'overx' - Folds together line fragments (terminated by
          CR rather than CR/LF) into one line (fixes
          damage done by writing to generic text device
          from MS Word

The tools are there as ANSI C source (.c) and also as DOS 
executables (.exe).

At a minimum, I suggest you ALWAYS use 'cscan' to find
any 8-bit characters your word processor left around
and use 'maxln' to check line lengths (lines with a
FF and 72 columns of text will check as 73 columns,
but the verbose mode will point these out - the IETF
strongly prefers that the first line of each page
be BLANK with only a FF and the header be second line).

Cheers,
- Ira McDonald (consulting architect at Sharp Labs America)
  High North Inc

-----Original Message-----
From: Ron Bergman [mailto:[email-masked]]
Sent: Tuesday, January 18, 2000 10:34 AM
To: Harry Lewis; [email-masked]
Subject: PMP> Corrupt Figure 1 in 

Harry,

    Ron Bergman