Subject: PMP> RE: MIME - Registration of all Printer MIB Print Document Formats (PD Ls) with IANA for IPP, UPnP, Bluetooth

From: "Hastings, Tom N" <[email-masked]>
Date: Thu, 18 Jan 2001 10:21:27 -0800

Thanks for the information about decimal 50 (Prescribe) and 39 (LIPS).

I've added this information to an updated version of the Print-MIME-tab.doc
file and will collect any additional information that anyone supplies to any
of these three mailing lists.

The current description of 39 (LIPS) is:  "LBP Image Processing System"

Any idea what LBP stands for?  Is there a better description of LIPS that
Canon would like to see?

Also is there a public reference to a specification, such as a manual or
standard, that could be added?  IANA likes to have references to the
complete spec.

Thanks,
Tom

-----Original Message-----
From: ueda shigeru [mailto:[email-masked]]
Sent: Tuesday, January 16, 2001 18:11
To: [email-masked]
Subject: Re: MIME - Registration of all Printer MIB Print Document
Formats (PD Ls) with IANA for IPP, UPnP, Bluetooth

Regarding Enum(decimal):50,

I believe Prescribe was originated by Kyocera.
The Standard language of their printers are PRESCRIBE II.

And also regarding Enum(decimal):39,LIPS is the Standard PDL originated
by Canon.

Regards.

Shigeru Ueda

Canon.

On Tue, 16 Jan 2001 15:14:51 -0800
"Hastings, Tom N" <[email-masked]> wrote:

> This message is in MIME format. Since your mail reader does not understand
> this format, some or all of this message may not be legible.
>
> ----------------------------------------------------------------
> Agenda topic for IPP telecon, Wednesday, 1/17/00, 10-12 PST and the UPnP,
> PWG, and IPP WG meetings, next week.
>
> There is an increasing interest in having MIME media types for each of the
> Printer MIB Print Document Formats.  For example, Bluetooth is using enums
> and bit masks to indicate the supported Print Document Formats.  They are
> using the Printer MIB enums, plus they have added 9 more allocating the
> numbers immediately after the last one we assigned. The SMTP, IPP, IPP
FAX,
> and UPnP Protocols use MIME Media types to indicate the document format.
It
> would be good for the Printer Working Group to keep the Printer MIB enums
> and the MIME Media types aligned.
>
> I have had an action item for over two years to register the Printer MIB
> Print Document Formats that don't have a MIME Media type already
registered.
> Perhaps the Bluetooth use is just the stimulus to get such a registry to
> actually happen.  I have attached a list of the MIME Media types from the
> following sources:
>
> RFC 1759, April 1994 (Interpreter Language Families):  3-46 ending with
XES
> - Xerox Escape Sequences
> IANA Registry of Printer Language Numbers:  3-49 (added PCL-XL, ART, and
> TIPSI)
> Printer MIB V2 (Internet-Draft, August 9, 2000): 3-59 ending with Fujitsu
> Printer Language
> Basic Printing Profile, V0.5, 11/22/2000 (Data Formats or PDL): 3-59, plus
> 60-68 (which add SPCL, VCard, VCal, VNote, VMessage, HTML, XHTML,
> XHTML-Basic, and XHTML-Print)
>
> The column headings are some of the suggested information that we would
have
> in the IANA Registry:
> Enum (decimal)
> Enum (hex)
> Name or Acronym
> MIME Media Type (already registered)
> Description, including full title
> Reference
> Company or Organization (without location, since it changes)
>
> Before much more work is done, I'd like to discuss the table and the
Issues
> that are flagged in yellow.
> I'd also like to discuss how to register the ones not already registered.
> Please send comments to the mailing list.
>
> The IANA Registration Procedures need to have the following information:
> MIME media type name :
> MIME subtype name :
> Required parameters :
> Optional parameters :
> Encoding considerations :
> Security considerations :
> Interoperability considerations :
> Published specification :
> Applications which use this media :
> Additional information :
> Person to contact for further information :
> Intended usage : Common or ???
> Author/Change controller:
>
> The document is a landscape document in .doc and .pdf format at:
>
> ftp://ftp.pwg.org/pub/pwg/ipp/new_MIME/Print-MIME-tab.pdf
> ftp://ftp.pwg.org/pub/pwg/ipp/new_MIME/Print-MIME-tab.doc
>
> Thanks,
> Tom
>
>  <<Print-Document-Format-MIME-media-types-table.doc>>
>

----------------------------------------------------------
               @@@ Technology Advancement Div.3
                Office Imaging Products Development Center 3
                               Canon.inc

                             Shigeru Ueda

                      TEL  81-3-3757-6540
                      E-mail : [email-masked]
-----------------------------------------------------------

---

From: Michael Sweet <[email-masked]>
Date: Thu, 18 Jan 2001 16:25:17 -0500

"Hastings, Tom N" wrote:
> ...
> Any idea what LBP stands for?  Is there a better description of
> LIPS that Canon would like to see?
> ...

LBP = Laser Beam Printer (set your phasers on stun! :)

-- 
______________________________________________________________________
Michael Sweet, Easy Software Products                  [email-masked]
Printing Software for UNIX                       http://www.easysw.com