Subject: RE: PMP> Updated PortMON MIB specification (that includes the res tructured 20050728 mib)

From: [email-masked]
Date: Mon, 1 Aug 2005 14:47:01 -0400

First on the list of name changes that need to be done....

Section 8 second bullett:  (ppmPortIEEE1284DeviceID => 
ppmPrinterIEEE1284DeviceID), 
and need to add ppmPrinterName.

Section 8:
I'm assuming that the reason that ppmPortDescription is not in the 
restructrued MIB is that we no longer needed
it once we added ppmPrinterName to the already exhisting 
ppmPortName......??

Jerry

"McDonald, Ira" <[email-masked]>
07/29/2005 12:34 PM

        To:     "[email-masked]'" <[email-masked]>, [email-masked]
        cc: 
        Subject:        RE: PMP> Updated PortMON MIB specification (that includes the res 
tructured 20050728 mib)

Hi,

About Jerry's comment below

"Please review since with the movement of objects from the Port to
the Printer table, some of the language might not make sense anymore."

- as I moved each object, I tried to carefully edit the DESCRIPTION and
REFERENCE clauses to convert from single port scope to printer scope
- but please _do_ think about these descriptions (everywhere in the MIB)
- and please read the new Requirements section carefully

Because we're pretty close to wrapping this document up and going to
Formal Vote for Candidate Standard.

Cheers,
- Ira (co-editor of Printer Port Monitor MIB)

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
[email-masked]
Sent: Friday, July 29, 2005 11:18 AM
To: [email-masked]
Subject: PMP> Updated PortMON MIB specification (that includes the
restructured 20050728 mib)

The changes include the restructuring of the requirements language,
the integration of the latest restructured mib,
hopefully catching all the names that changed from portxxx to printerxxx,
(e.g., portHrDeviceIndex to printerHrDeviceIndex), and updateing the
mib description the best I can.

Posted on the PWG FTP server in the PMP WG directories at:

ftp://ftp.pwg.org/pub/pwg/pmp/wd/lcrc-pmpportmib10-20050728.mib

ftp://ftp.pwg.org/pub/pwg/pmp/wd/lcrc-pmpportmib10-20050729.doc

ftp://ftp.pwg.org/pub/pwg/pmp/wd/lcrc-pmpportmib10-20050729.pdf

ftp://ftp.pwg.org/pub/pwg/pmp/wd/lcrc-pmpportmib10-20050729rev.pdf

Summary of changes:

(1) Please see Last Call issues in Appendix C.

Please review since with the movement of objects from the Port to
the Printer table, some of the language might not make sense anymore.

JT

---

From: "McDonald, Ira" <[email-masked]>
Date: Tue, 2 Aug 2005 09:30:14 -0700

Hi Jerry,

ppmPortDescription was deleted because its content was included
in a ppmPrinterName, ppmPortName, ppmPortProtocolType, etc., as
indicated in my previous note.

I'm probably not going to have any cycles to look at Port MIB
body text until at least this weekend.  I'll do my best.  Others
are welcome to step up and suggest edits (as Jerry did below).

Cheers,
- Ira

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
[email-masked]
Sent: Monday, August 01, 2005 2:47 PM
To: [email-masked]
Subject: RE: PMP> Updated PortMON MIB specification (that includes the res
tructured 20050728 mib)

Section 8: 
I'm assuming that the reason that ppmPortDescription is not in the
restructrued MIB is that we no longer needed 
it once we added ppmPrinterName to the already exhisting ppmPortName......??

Jerry 

        To:        "[email-masked]'" <[email-masked]>,
[email-masked] 
        cc:         
        Subject:        RE: PMP> Updated PortMON MIB specification (that
includes the res        tructured 20050728 mib)

Hi,

Cheers,

-----Original Message-----

Summary of changes:

JT

---

From: "Stuart Rowley" <[email-masked]>
Date: Mon, 22 Aug 2005 14:51:58 -0700

All,

On July 29, Ira said "Because we're pretty close to wrapping this
document up and going to Formal Vote for Candidate Standard."

On Aug 1, Jerry brought up a couple issues about name changes.

I have not seen any activity since then. Are there still plans to
finalize this MIB?

Thanks,

Stuart

Stuart Rowley, Network Product Mgr.
[email-masked]      925 849-3306     925 849-3399 (fax)

Kyocera Technology Development Inc.
1855 Gateway Blvd. Suite 400
Concord, CA 94520

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
McDonald, Ira
Sent: Friday, July 29, 2005 9:35 AM
To: [email-masked]'; [email-masked]
Subject: RE: PMP> Updated PortMON MIB specification (that includes the
res tructured 20050728 mib)

Hi,

Cheers,

-----Original Message-----

hopefully catching all the names that changed from portxxx to
printerxxx, 

Summary of changes:

JT

---

From: "McDonald, Ira" <[email-masked]>
Date: Tue, 23 Aug 2005 07:43:44 -0700

Hi Stuart,

My application to add 'unknown(2)' to 'PrtChannelTypeTC' was
submitted to IANA on Thursday 11 August (see previous note to
this list with the submission text).

AFTER that application is approved by our Designated Experts
(Bert Wijnen and Harry Lewis) and IANA has updated the IANA
Printer MIB (most of the textual conventions from RFC 3805),
we'll revise the Port MIB ASN.1 once more to use that TC for 
syntax of 'ppmPortProtocolType'.  At that time, we'll fix up
any loose ends of documentation.  Then, we'll take Port MIB
to Formal Vote.

OK?

Cheers,

PS - It's on my list to identify the documentation updates
still needed for the Port MIB - it's just a pretty long list
at the moment.

> From: Stuart Rowley [mailto:[email-masked]]
> Sent: Monday, August 22, 2005 5:52 PM
> To: [email-masked]
> Cc: McDonald, Ira; [email-masked]

---

From: "Stuart Rowley" <[email-masked]>
Date: Tue, 23 Aug 2005 07:54:54 -0700

OK, Ira. Thanks for your explanation.

Stuart

-----Original Message-----
From: McDonald, Ira [mailto:[email-masked]] 
Sent: Tuesday, August 23, 2005 7:44 AM
To: Stuart Rowley; [email-masked]
Cc: McDonald, Ira; [email-masked]
Subject: RE: PMP> Updated PortMON MIB specification (that includes the

Hi Stuart,

OK?

Cheers,