Subject: RE: PMP> MFP Alerts Questions

From: "Stuart Rowley" <[email-masked]>
Date: Thu, 1 Jun 2006 13:41:51 -0700

Hi Ron,

I have a few questions about the MFP Alerts draft.

1. If there are no groups for scanDeviceCover or scanDeviceInput, why is
there a group for scanDeviceMediaPath?

2. If, for example, the scanner document feeder cover was open, then the
prtAlertTable entry would include prtAlertGroup = 6 (Cover), but then
the prtAlertGroupIndex should point to a cover in the prtCover table. So
now I have scan device covers implemented in the printer MIB, but other
scan device subunits in the MFP MIB? 

3. In the examples in section 10.1.3 for the scanDeviceScanner group
there is Lamp Missing, subunitMissing(9) / subunitRemoved(26). What if I
have multiple subunits that could be missing? There is no way to tell
without using prtAlertGroupIndex to point to a table entry in the MFP
MIB?

Thanks,

Stuart

Stuart Rowley

Kyocera Technology Development

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of Bergman,
Ron
Sent: Thursday, June 01, 2006 8:49 AM
To: [email-masked]
Subject: PMP> MFP Alerts Teleconference Scheduled for June 8

The next teleconference for MFP Alerts is scheduled for June 8, 2006 at
11:00 AM EDT (8:00 AM PDT). 

Agenda: 
     1. Review previous meeting minutes 
     2. Continue review of the draft Alert Groups document 
     3. Start review of the Imaging System MIB 

The latest version of the Alert Groups document is at: 

ftp://ftp.pwg.org/pub/pwg/pmp/wd/wd-mfp-alert-groups10-20060601.pdf 

Meeting access: 
    1-866-365-4406
    Passcode: 2635888#

---

From: "Bergman, Ron" <[email-masked]>
Date: Tue, 6 Jun 2006 10:51:53 -0700

-----Original Message-----
From: Stuart Rowley [mailto:[email-masked]]
Sent: Thursday, June 01, 2006 5:56 PM
To: Bergman, Ron
Subject: RE: PMP> MFP Alerts Questions

Hi Ron,

Will you send your response to the PMP list, so others may see your answers?

I am thinking it is really weird to have the scanner covers, input, and media path defined in the print mib and other components defined in the MFP mib...

I suppose the description field could be used as a quick and dirty alternative to implementing the MFP mib. I would be interested in what Ira has to say.

Thanks,

Stuart

  _____  

From: Bergman, Ron [mailto:[email-masked]] 
Sent: Thursday, June 01, 2006 5:49 PM
To: Stuart Rowley
Subject: RE: PMP> MFP Alerts Questions

Hi Stuart,

1)  I do recall discussing this in the conference, but left it out of my notes.  Media path should not be a Scan Group.  I will remove in the next revision.

2)  That is correct.  So the covers table (or group) includes the Printer, Sacn Device, and Fax Device.  Same for the other common groups.

3)  Ira has said that this would be covered by the description field in the alert table.  I disagree and believe a MIB is necessary to properly define.  Do you agree?

Hope this helps.

    Regards,

    Ron

-----Original Message-----
From: Stuart Rowley [mailto:[email-masked]]
Sent: Thursday, June 01, 2006 1:42 PM
To: Bergman, Ron; [email-masked]
Subject: RE: PMP> MFP Alerts Questions

Hi Ron,

1. If there are no groups for scanDeviceCover or scanDeviceInput, why is there a group for scanDeviceMediaPath?

2. If, for example, the scanner document feeder cover was open, then the prtAlertTable entry would include prtAlertGroup = 6 (Cover), but then the prtAlertGroupIndex should point to a cover in the prtCover table. So now I have scan device covers implemented in the printer MIB, but other scan device subunits in the MFP MIB? 

3. In the examples in section 10.1.3 for the scanDeviceScanner group there is Lamp Missing, subunitMissing(9) / subunitRemoved(26). What if I have multiple subunits that could be missing? There is no way to tell without using prtAlertGroupIndex to point to a table entry in the MFP MIB?

Thanks,

Stuart

Stuart Rowley

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of Bergman, Ron
Sent: Thursday, June 01, 2006 8:49 AM
To: [email-masked]
Subject: PMP> MFP Alerts Teleconference Scheduled for June 8

The next teleconference for MFP Alerts is scheduled for June 8, 2006 at 11:00 AM EDT (8:00 AM PDT). 

Agenda: 

Meeting access: 
    1-866-365-4406
    Passcode: 2635888#

---

From: "McDonald, Ira" <[email-masked]>
Date: Tue, 6 Jun 2006 11:03:28 -0700

Hi,
 
My mistake about (3) below - of course prtAlertDescription can only
discriminate between multiple subunits for _humans_.  A proper MIB
is required (which is by the way named "Imaging System MIB", not
"MFP MIB") - the term "MFP" is used in WIMS/1.0 and the SM/2.0
update work only informatively - the authoritative term is "Imaging
System" (containing Agent, Manager, Services, Subunits, etc).
 
Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked] 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Bergman, Ron
Sent: Tuesday, June 06, 2006 1:52 PM
To: [email-masked]
Subject: FW: PMP> MFP Alerts Questions

-----Original Message-----
From: Stuart Rowley [mailto:[email-masked]]
Sent: Thursday, June 01, 2006 5:56 PM
To: Bergman, Ron
Subject: RE: PMP> MFP Alerts Questions

Hi Ron,

I am thinking it is really weird to have the scanner covers, input, and
media path defined in the print mib and other components defined in the MFP
mib...

I suppose the description field could be used as a quick and dirty
alternative to implementing the MFP mib. I would be interested in what Ira
has to say.

Thanks,

Stuart

   _____  

Hi Stuart,

1)  I do recall discussing this in the conference, but left it out of my
notes.  Media path should not be a Scan Group.  I will remove in the next
revision.

2)  That is correct.  So the covers table (or group) includes the Printer,
Sacn Device, and Fax Device.  Same for the other common groups.

3)  Ira has said that this would be covered by the description field in the
alert table.  I disagree and believe a MIB is necessary to properly define.
Do you agree?

Hope this helps.

    Regards,

    Ron

-----Original Message-----
From: Stuart Rowley [mailto:[email-masked]]
Sent: Thursday, June 01, 2006 1:42 PM
To: Bergman, Ron; [email-masked]
Subject: RE: PMP> MFP Alerts Questions

Hi Ron,

2. If, for example, the scanner document feeder cover was open, then the
prtAlertTable entry would include prtAlertGroup = 6 (Cover), but then the
prtAlertGroupIndex should point to a cover in the prtCover table. So now I
have scan device covers implemented in the printer MIB, but other scan
device subunits in the MFP MIB? 

3. In the examples in section 10.1.3 for the scanDeviceScanner group there
is Lamp Missing, subunitMissing(9) / subunitRemoved(26). What if I have
multiple subunits that could be missing? There is no way to tell without
using prtAlertGroupIndex to point to a table entry in the MFP MIB?

Thanks,

Stuart

Stuart Rowley

   _____  

Agenda: 

        HYPERLINK
"ftp://ftp.pwg.org/pub/pwg/pmp/wd/wd-mfp-alert-groups10-20060601.pdf"ftp://f
tp.pwg.org/pub/pwg/pmp/wd/wd-mfp-alert-groups10-20060601.pdf 

Meeting access: 
    1-866-365-4406
    Passcode: 2635888#

--
No virus found in this incoming message.
Checked by AVG Free Edition.
Version: 7.1.394 / Virus Database: 268.8.2/357 - Release Date: 6/6/2006

-- 
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.394 / Virus Database: 268.8.2/357 - Release Date: 6/6/2006