Subject: PWG-ANNOUNCE> ACTION - Ordered list of CIM MOF classes - due Wed 11 April

From: "McDonald, Ira" <[email-masked]>
Date: Thu, 5 Apr 2007 14:12:31 -0700

Hi,                                              Thursday (5 April 2007)

*** Action:    Send your ordered list of CIM MOF classes
*** Due Date:  End-of-day Wednesday 11 April 2007

*** To:        All PWG members
*** Reply To:  [email-masked]
*** Note:      Do NOT reply to [email-masked]

Background:  As a result of the slow CIM Core WG process, we urgently
need to reach concensus on the ORDER in which we will model the tables
from the Printer MIB (RFC 1759/3805) into CIM MOF classes, as described
in Rick Landau's document posted in the directory:

    ftp://ftp.pwg.org/pub/pwg/wims/cim

in the file:

    td_PrintClassGroupings_v09_20070208.pdf

Below is my own ordered list of CIM MOF classes:

(0)  CIM_PrintOutputTray - prtOutputTable - done - in progress at DMTF

(1)  CIM_PrintInputTray - prtInputTable - done - not submitted to DMTF
(2)  CIM_PrintMarker - prtMarkerTable - done - not submitted to DMTF
(3)  CIM_PrintChannel - prtChannelTable - done - not submitted to DMTF

(4)  CIM_PrintSupply - prtMarkerSuppliesTable
(5)  CIM_PrintDeviceCover - prtCoverTable
(6)  CIM_PrintAlertLog - prtAlertTable
(7)  CIM_PrintAlertRecord - prtAlertEntry

(8)  CIM_PrintMediaPath - prtMediaPathTable
(9)  CIM_PrintInterpreter - prtInterpreterTable

(10) CIM_PrintColorant - prtMarkerColorantTable
(11) CIM_PrintConsoleLight - prtConsoleLightTable
(12) CIM_PrintConsoleDisplayBuffer - prtConsoleDisplayBufferTable

(13) CIM_Printer - prtGeneralTable - last - depends on all other classes

At the WIMS-CIM telecon on Thursday 12 April we will determine concensus
on the ordered list - Rick Landau and I will follow this concensus.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

-- 
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.5.446 / Virus Database: 268.18.26/746 - Release Date: 4/4/2007 1:09 PM

---

From: "Whittle, Craig" <[email-masked]>
Date: Tue, 10 Apr 2007 21:35:42 -0700

All:

Please note my recommended order for modeling Printer MIB tables to CIM
MOF classes below.

(1)  CIM_PrintInputTray - prtInputTable - done - not submitted to DMTF
(2)  CIM_PrintMarker - prtMarkerTable - done - not submitted to DMTF
(3)  CIM_PrintChannel - prtChannelTable - done - not submitted to DMTF
Note: If significant amount of work remains for prtChannelTable, the
priority could be lowered. 

(4)  CIM_PrintSupply - prtMarkerSuppliesTable
(5)  CIM_PrintAlertLog - prtAlertTable
(6)  CIM_PrintAlertRecord - prtAlertEntry
(7)  CIM_PrintMediaPath - prtMediaPathTable
(8)  CIM_PrintInterpreter - prtInterpreterTable
(9)  CIM_PrintDeviceCover - prtCoverTable

Best regards,

**CW

---

From: "Zehler, Peter" <[email-masked]>
Date: Wed, 11 Apr 2007 06:49:18 -0400

All:

(4)  CIM_PrintAlertLog - prtAlertTable
(5)  CIM_PrintAlertRecord - prtAlertEntry 
(6)  CIM_PrintSupply - prtMarkerSuppliesTable
(7)  CIM_PrintMediaPath - prtMediaPathTable
(8)  CIM_PrintInterpreter - prtInterpreterTable
(9)  CIM_PrintDeviceCover - prtCoverTable

Peter Zehler
XEROX
Xerox Research Center Webster
Email: [email-masked]
Voice: (585) 265-8755
FAX: (585) 265-7441
US Mail: Peter Zehler
Xerox Corp.
800 Phillips Rd.
M/S 128-25E
Webster NY, 14580-9701

---

From: Harry Lewis <[email-masked]>
Date: Wed, 11 Apr 2007 16:31:13 -0600

In doing the exercise... some thoughts...

1. I gave greater weight to stuff we added in Printer MIB v2 because if it 
wasn't so important... why'd we add it? 
2. I see a lot of people put prtGeneral last because it "depends on all 
other classes". But there are some very useful (independent) attributes in 
prtGeneral (like Name, S/N, Operator/ServicePerson etc.)
3. Where does hrPrinterDetectedErrorState fall in all of this? Not part of 
Printer MIB but... as you all know... one of my all time favorites ;-)
  - hrDeviceStatus, hrPrinterStatus, hrDeviceID and sysDescr... all 
fundamental (and so were referenced in the Printer MIB), 

My ordering of the list...

(0)  CIM_Printer - prtGeneralTable (contains valuable independent 
elements: example S/N)
(1)  CIM_PrintAlertLog - prtAlertTable
(2)  CIM_PrintAlertRecord - prtAlertEntry 
       I agree with Rick… these are inseparable
(3)  CIM_PrintInputTray - prtInputTable - done - not submitted to DMTF
(4)  CIM_PrintOutputTray - prtOutputTable - done - in progress at DMTF
(5)  CIM_PrintDeviceCover – prtCoverTable
(6)  CIM_PrintMarker - prtMarkerTable - done - not submitted to DMTF
(7)  CIM_PrintSupply - prtMarkerSuppliesTable
(8)  CIM_PrintConsoleDisplayBuffer – prtConsoleDisplayBufferTable
(9)  CIM_PrintColorant - prtMarkerColorantTable
(10) CIM_PrintConsoleLight – prtConsoleLightTable
(11) CIM_PrintMediaPath - prtMediaPathTable
(12) CIM_PrintInterpreter - prtInterpreterTable
(13) CIM_PrintChannel - prtChannelTable - done - not submitted to DMTF

---------------------------------------------- 
Harry Lewis 
IBM STSM
Intellectual Property, Standards and Licensing
Chairman - ISTO Printer Working Group
303-924-5337
---------------------------------------------- 

"McDonald, Ira" <[email-masked]> 
Sent by: [email-masked]
04/05/2007 03:12 PM

To
<[email-masked]>
cc

Subject
PWG-ANNOUNCE> ACTION - Ordered list of CIM MOF classes - due Wed 11 April

*** To:        All PWG members

in the file:

Cheers,
- Ira

-- 
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.5.446 / Virus Database: 268.18.26/746 - Release Date: 4/4/2007 
1:09 PM

---

From: "McDonald, Ira" <[email-masked]>
Date: Thu, 12 Apr 2007 07:30:57 -0700

Hi Harry,

(1) Printer MIB v2 additions
    - in the great spreadsheet of properties, we all gave
      high rankings to _some_ of these (i.e., ServicePerson)
(2) prtGeneral last
    - because the default pointers will depend normatively
      (with ModelCorrespondence clauses which MUST NOT be
      black holes to pass CIM Core review) on the newly
      created Subunit classes that define 'Xxx.Id' (e.g.,
      prtInputIndex).
    - if we submit it earlier, they'll just reject it
(3) hrPrinterDetectedErrorState
    - already in CIM_Printer.DetectedErrorState
    - in CIM Refresh Phase 1, we added the new enum values
(4) hrDeviceStatus
    - already in CIM_LogicalDevice.Availability
    - which is the parent class of CIM_Printer
(5) hrPrinterStatus
    - already in CIM_Printer.PrinterStatus
      (we added the MappingStrings in CIM Refresh Phase 1)
(6) hrDeviceID 
    - not in CIM Model at all - completely out-of-scope
(7) sysDescr
    - not in CIM Model at all - completely out-of-scope

Cheers,
- Ira

-----Original Message-----
From: Harry Lewis [mailto:[email-masked]]
Sent: Wednesday, April 11, 2007 5:31 PM
To: McDonald, Ira
Cc: [email-masked]
Subject: Re: PWG-ANNOUNCE> ACTION - Ordered list of CIM MOF classes - due Wed 11 April

1. I gave greater weight to stuff we added in Printer MIB v2 because if it wasn't so important... why'd we add it? 
2. I see a lot of people put prtGeneral last because it "depends on all other classes". But there are some very useful (independent) attributes in prtGeneral (like Name, S/N, Operator/ServicePerson etc.) 
3. Where does hrPrinterDetectedErrorState fall in all of this? Not part of Printer MIB but... as you all know... one of my all time favorites ;-) 
  - hrDeviceStatus, hrPrinterStatus, hrDeviceID and sysDescr... all fundamental (and so were referenced in the Printer MIB), 

(0)  CIM_Printer - prtGeneralTable (contains valuable independent elements: example S/N) 

"McDonald, Ira" <[email-masked]> 
Sent by: [email-masked] 
04/05/2007 03:12 PM To<[email-masked]> 
cc
SubjectPWG-ANNOUNCE> ACTION - Ordered list of CIM MOF classes - due Wed 11 April

*** To:        All PWG members

in the file:

Cheers,
- Ira

-- 
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.5.446 / Virus Database: 269.3.0/758 - Release Date: 4/12/2007 11:52 AM

---

From: Harry Lewis <[email-masked]>
Date: Thu, 12 Apr 2007 08:56:16 -0600

Ira, thanks for the clarifications. I agree hr MIB is out of scope for 
this exercise of prioritizing Printer MIB Groups... I just wanted to make 
sure we weren't missing these fundamental properties. Sounds like we've 
already captured most of them. Only difficulty I feel we are left with is 
prtGeneral. I understand there are defaults that depend normatively on 
other subunits but there are also independent properties which I believe 
are utmost essential (eg... many of us felt printer s/n was a glaring 
omission from Printer MIB v1). Not sure how to resolve this. 
---------------------------------------------- 
Harry Lewis 
IBM STSM
Intellectual Property, Standards and Licensing
Chairman - ISTO Printer Working Group
303-924-5337
---------------------------------------------- 

04/12/2007 08:30 AM

To
Harry Lewis/Boulder/IBM@IBMUS
cc
<[email-masked]>
Subject
RE: PWG-ANNOUNCE> ACTION - Ordered list of CIM MOF classes - due Wed 11 
April

Hi Harry,

Cheers,
- Ira

-----Original Message-----
From: Harry Lewis [mailto:[email-masked]]
Sent: Wednesday, April 11, 2007 5:31 PM
To: McDonald, Ira
Cc: [email-masked]
Subject: Re: PWG-ANNOUNCE> ACTION - Ordered list of CIM MOF classes - due 
Wed 11 April

"McDonald, Ira" <[email-masked]> 
Sent by: [email-masked] 
04/05/2007 03:12 PM To<[email-masked]> 
cc
SubjectPWG-ANNOUNCE> ACTION - Ordered list of CIM MOF classes - due Wed 11 
April

*** To:        All PWG members

in the file:

Cheers,
- Ira

-- 
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.5.446 / Virus Database: 269.3.0/758 - Release Date: 4/12/2007 
11:52 AM