Subject: RE: pendingDelete and ok status

From: "Hollenbeck, Scott" <[email-masked]>
Date: Mon, 25 Nov 2002 07:15:36 -0500

> I am from CNNIC(.cn registry). In our .cn registry system, an 
> expired domain name will be
> in pendingDelete status after it expires(I discuss this issue 
> with you before
> and you give us this suggestion, thx. :-). Do you remember? 
> ). If the registry system
> receive a renew command for this domain during the special 
> pendingDelete preriod, it will
> be in ok status again.But I have a question now: 
> 
> In general, pend* means an atom action. A domain with 
> pendingDelete status
> will be deleted after days. But in the situation discussed 
> above, a domain name with
> pendingDelete status will be in two possible results: ok or deleted.
> 
> Do you think it is ambivalent for pendingDelete's semanteme?
> If yes, what is your suggestion? Please tell me if you have 
> any good idea. :-)
> 
> Best Regards,
> 
> Lu Wenzhe

As described in section 2.3 of the domain mapping draft, a domain can't be
in both pending* status and "ok" status.  If a <renew> command is received
before the domain is deleted, you should replace the "pendingDelete" status
with "ok" status, or just remove "pendingDelete" status if there is another
status values that would preclude setting "ok" status.

-Scott-

---

From: "wenzhe lu" <[email-masked]>
Date: Tue, 26 Nov 2002 09:27:41 +0800

Thx.  :-)

Lu Wenzhe

-----Original Message-----
From: Hollenbeck, Scott [mailto:[email-masked]]
Sent: Monday, November 25, 2002 8:16 PM
To: 'wenzhe lu'
Cc: [email-masked]
Subject: RE: pendingDelete and ok status

-Scott-