Subject: RE: Handling of External Host Objects

From: "Hollenbeck, Scott" <[email-masked]>
Date: Thu, 21 Nov 2002 10:07:26 -0500

> To alleviate the problems mentioned above let me propose the following
> changes
> to epp host and domain mapping documents:

If I understand this correctly you're suggesting a move back to the way
things were (more or less, with some limits to address the issues) before
the per-client thing came up, right?  I like the idea of consistency and
simplicity -- what do others think?

-Scott-

---

From: Hong Liu <[email-masked]>
Date: Thu, 21 Nov 2002 08:28:33 -0800 (PST)

Scott,

Sorry that I could not be in Atlanta to discuss this
topic in person. Was this issue discussed during the
provreg WG session? Any conlusion on this topic?

I certainly have my personal view on this, but I would
like to hear from your feedback first.

Cheers,

--Hong

--- "Hollenbeck, Scott" <[email-masked]>
> simplicity -- what do others think?

__________________________________________________
Do you Yahoo!?
Yahoo! Mail Plus – Powerful. Affordable. Sign up now.
http://mailplus.yahoo.com

---

From: Daniel Manley <[email-masked]>
Date: Tue, 26 Nov 2002 14:51:50 -0500

Another good compromise for external hosts.  Looks like it avoids 
("settles"?) some of the ambiguous ownership issues for external hosts. 
 It also keeps the domain transfer cans of worms locked and sealed.

Does anyone have meetings minutes for the discussion on external hosts 
in Atlanta?

Dan

-- 
Daniel Manley
Tucows, Inc.
Toronto, Canada
[email-masked]

---

From: Hong Liu <[email-masked]>
Date: Tue, 26 Nov 2002 16:21:12 -0800 (PST)

Dan, Scott, and Janusz,

As the person who re-opened this topic on the list, I
would also like to see a concrete proposal to get a
closure on this topic. It looks like the WG is leaning
towards reverting back to the single-copy model, but
is still unclear of how it should be done.

Whether external hosts are treated as an independent
object or an attribute to a domain object, the end
result seems to be the same: they are single-copy,
read-only entities by registrars once they are created
in the registry. This is the only sensible way to
avoid sponsorship monoply by any registrar who first
created an external host.

There are pros and cons for either approach. The
attribute approach is conceptually cleaner, but incurs
changes to many EPP commands such as create, update,
info, etc. The object approach is not as clean, but it
minimizes syntatical changes to EPP commands and keep
the host handling APIs similar. In the end, it really
boils down to the matter of taste. From implementation
point of view, the registry will create a DB object,
be it an attribute or object at the EPP level. 

--Hong

__________________________________________________
Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
http://mailplus.yahoo.com