Subject: RE: Handling of External Host Objects

From: Bruce Tonkin <[email-masked]>
Date: Mon, 4 Nov 2002 18:19:08 +1100

This makes sense to me.

An external host could be referred to in the same way that an email address
field is used.  
The registry is not authoritative for the email address, nor is it
authoritative for an external host where no glue records are created.

Regards,
Bruce

> -----Original Message-----
> From: Hollenbeck, Scott [mailto:[email-masked]]
> Sent: Sunday, November 03, 2002 12:08 PM
> To: [email-masked]'
> Subject: RE: Handling of External Host Objects
> 
> 
> One of the reasons I think that this external host thing 
> continues to be an
> issue is because it's a kludge.  I firmly believe that the 
> only objects that
> should exist in a repository are objects for which the repository is
> authoritative.  Other needed data should exist as attributes 
> of existing
> objects.
> 
> I suggested this concept related to external hosts back when 
> the topic first
> came up.  Some folks had issues with it, but I'll suggest it 
> again as an
> alternative.  In a nutshell:
> 
> - The only objects that should exist in a repository are 
> objects for which
> the repository is authoritative.
> 
> - Host objects should only be created in a repository that is 
> authoritative
> for the host.  In the case of hosts as name servers, 
> "authoritative" means
> that data in the repository (host name and address(es)) is 
> used to publish
> DNS glue and the repository is the legitimate source for that data.
> 
> - If an external host is needed for delegation purposes, it can be
> associated with a domain object as an attribute of the object 
> with no host
> object needed in advance.  There's no need to create an 
> external host object
> ahead of time, no need to worry about IP addresses, etc.
> 
> This solution does not allow object-based management of 
> external hosts,
> which means that renaming the external host would need to be done on a
> per-name basis.  It may address the other issues that people 
> have talked
> about on this thread, though.
> 
> I know this means that a domain can be associated with hosts 
> as objects and
> host as attributes and some people think that's inconsistent. 
>  I don't think
> it is if you agree with the first point above.
> 
> -Scott-
>

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Mon, 4 Nov 2002 10:24:44 -0500

> I assume that with the new external host approach domain 
> transfer process would
> be simplified. No error code 2305 for transfer requests and approvals.

It's premature to call what I wrote below "the new external host approach"
(it's still just a re-issue of a proposal that I'd like people to consider),
but yes, with this model there would be no need for object management errors
on transfers as currently described because there would be no need for the
per-registrar copies of external hosts.  An external host attribute would
just get carried along with all other domain object attributes.

-Scott-

> Regards,
> 
> Janusz Sienkiewicz
> 
> "Hollenbeck, Scott" wrote:
> 
> > authoritative.  Other needed data should exist as 
> attributes of existing
> > objects.
> >
> > I suggested this concept related to external hosts back 
> when the topic first
> > came up.  Some folks had issues with it, but I'll suggest 
> it again as an
> > - Host objects should only be created in a repository that 
> is authoritative
> > associated with a domain object as an attribute of the 
> object with no host
> > per-name basis.  It may address the other issues that 
> people have talked
> > I know this means that a domain can be associated with 
> hosts as objects and
> > host as attributes and some people think that's 
> inconsistent.  I don't think

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Thu, 21 Nov 2002 12:33:31 -0500

Yes, it was discussed.  No specific conclusions were reached other than we
need to continue discussion.

I tried to summarize the main points of your objection to the currently
documented approach, but I don't recall anyone in the room supporting the
change you've proposed.  Hence the need for more discussion.

If anyone else who was in the room heard it differently, please speak up.

-Scott-

> From: Hong Liu [mailto:[email-masked]]
> Sent: Thursday, November 21, 2002 11:29 AM
> Scott,
> Sorry that I could not be in Atlanta to discuss this
> topic in person. Was this issue discussed during the
> provreg WG session? Any conlusion on this topic?
> 
> I certainly have my personal view on this, but I would
> like to hear from your feedback first.
> 
> Cheers,
> 
> --Hong
> 
> --- "Hollenbeck, Scott" <[email-masked]>
> wrote:
> > > To alleviate the problems mentioned above let me
> > propose the following
> > > changes
> > > to epp host and domain mapping documents:
> > 
> > If I understand this correctly you're suggesting a
> > move back to the way
> > things were (more or less, with some limits to
> > address the issues) before
> > the per-client thing came up, right?  I like the
> > idea of consistency and
> > simplicity -- what do others think?
> > 
> > -Scott-
> 
> 
> __________________________________________________
> Do you Yahoo!?
> Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
> http://mailplus.yahoo.com
>