Subject: Re: [ietf-provreg] EPP Document Updates

From: Klaus Malorny <[email-masked]>
Date: Wed, 3 Aug 2005 20:35:50 +0200 (MEST)

Hollenbeck, Scott wrote:

 > [...]

> -Scott-

Hi Scott,

I did not read the whole thread, so it may have been mentioned there. Today, I 
discovered a small syntactic issue in the examples given in section 2.9. of RFC 
3733. The elements that are used to describe the disclosure are missing the 
final slash, as they are empty.

- - - 8< - - -
    <contact:name type="int">
    <contact:name type="loc">
    <contact:org type="int">
    <contact:org type="loc">
    <contact:addr type="int">
    <contact:addr type="loc">
    <contact:voice>
    <contact:fax>
    <contact:email>

    Example <contact:disclose> element, flag="0":

    <contact:disclose flag="0">
      <contact:email>
      <contact:voice>
    </contact:disclose>

    Example <contact:disclose> element, flag="1":

    <contact:disclose flag="1">
      <contact:name type="int">
      <contact:org type="int">
      <contact:addr type="int">
    </contact:disclose>
- - - 8< - - -

should read

- - - 8< - - -
    <contact:name type="int"/>
    <contact:name type="loc"/>
    <contact:org type="int"/>
    <contact:org type="loc"/>
    <contact:addr type="int"/>
    <contact:addr type="loc"/>
    <contact:voice/>
    <contact:fax/>
    <contact:email/>

    Example <contact:disclose> element, flag="0":

    <contact:disclose flag="0">
      <contact:email/>
      <contact:voice/>
    </contact:disclose>

    Example <contact:disclose> element, flag="1":

    <contact:disclose flag="1">
      <contact:name type="int"/>
      <contact:org type="int"/>
      <contact:addr type="int"/>
    </contact:disclose>
- - - 8< - - -

One thing that really puzzles me in this context is that a registrar cannot 
allow the disclosure of one component (that is normally not disclosed) and to 
disallow the disclosure of another component (that his normally disclosed) at 
the same time. But maybe I am just misunderstanding the wording. I think I have 
to reread this at a later point in time.

regards,

Klaus

___________________________________________________________________________
      |       |
      | knipp |                   Knipp  Medien und Kommunikation GmbH
       -------                           Technologiepark
                                         Martin-Schmeißer-Weg 9
      Dipl. Inf. Klaus Malorny           44227 Dortmund
      [email-masked]             Tel. +49 231 9703 0

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Thu, 4 Aug 2005 20:25:54 +0200 (MEST)

> In light of both changes in practice and interest from 
> practitioners, I
> would like to ask members of this list to express their 
> opinion and interest
> in the re-initiation of the provreg group.

I'm all for it IFF there is a suitable description formed of the work to
be done.  What I've seen so far is pretty sparse.

-Scott-