Subject: [provreg] Ways of querying for linked objects...

From: Francisco Obispo <[email-masked]>
Date: Tue, 31 May 2011 08:20:36 -0700

In RFC 5732 (Host Mapping for EPP), on the statuses section, there is:

-  linked

      The host object has at least one active association with another
      object, such as a domain object.  Servers SHOULD provide services
      to determine existing object associations.

There's no mention on how the server should provide theses services. In addition, I've seen several registries implement queries such as this using very different methods (extensions, SOAP, REST, etc.)

I'm also thinking on a use case, where a registrar my want to get the list of objects it sponsors.. there's no way in EPP to do this now.

Do yo guys think this is worth standardizing? I think this is the right kind of use for an extension.

Francisco Obispo 
ISC

---

From: Andrew Sullivan <[email-masked]>
Date: Tue, 31 May 2011 11:30:20 -0400

> I'm also thinking on a use case, where a registrar my want to get the list of objects it sponsors.. there's no way in EPP to do this now.

EPP seems pretty poorly designed for that kind of bulk-data reporting.
Note that IRIS was deisgned precisely to support that kind of query,
but nobody seems to use it.

A

-- 
Andrew Sullivan
[email-masked]

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Tue, 31 May 2011 11:39:17 -0400

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Andrew Sullivan
> Sent: Tuesday, May 31, 2011 11:30 AM
> To: [email-masked]
> Subject: Re: [provreg] Ways of querying for linked objects...
> 
> > I'm also thinking on a use case, where a registrar my want to get
the
> list of objects it sponsors.. there's no way in EPP to do this now.
> >
> 

We made a conscious decision to NOT include bulk query operations.

Scott

---

From: Klaus Malorny <[email-masked]>
Date: Tue, 31 May 2011 17:48:46 +0200

On 31/05/11 17:20, Francisco Obispo wrote:
> The host object has at least one active association with another object, such
> as a domain object.  Servers SHOULD provide services to determine existing
> object associations.
>
>
> There's no mention on how the server should provide theses services. In
> addition, I've seen several registries implement queries such as this using
> very different methods (extensions, SOAP, REST, etc.)
>
> I'm also thinking on a use case, where a registrar my want to get the list of
> objects it sponsors.. there's no way in EPP to do this now.
>
> Francisco Obispo ISC

Hi,

sadly, if I remember correctly, once there was a discussion about such a feature 
while EPP was standardized, but it was turned down. Trying to establish such a 
feature in a standardized way is now an uphill fight -- registrars simply don't 
like to change their systems if they already have a proven way to do the job, 
even if it is a proprietary solution.

Also, what can you (as a registrar) do if you know what objects are linked to 
your object instead of the knowledge that these exist (via the "linked" status)? 
If you don't have any means EPP-wise to free your trapped objects, it is not 
that helpful, except that you can manually find out the e-mail addresses of the 
related registrars and beg them to disuse your objects.

Regards,

Klaus

---

From: Francisco Obispo <[email-masked]>
Date: Tue, 31 May 2011 08:55:06 -0700

Hi Scott,

Can you please share why this was the case?

Was an extension mechanism ever considered for such operations?

On May 31, 2011, at 8:39 AM, Hollenbeck, Scott wrote:
> _______________________________________________
> provreg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/provreg

Francisco Obispo 
ISC

---

From: Francisco Obispo <[email-masked]>
Date: Tue, 31 May 2011 08:59:21 -0700

On May 31, 2011, at 8:48 AM, Klaus Malorny wrote:

> Hi,
> 
> sadly, if I remember correctly, once there was a discussion about such a feature while EPP was standardized, but it was turned down. Trying to establish such a feature in a standardized way is now an uphill fight -- registrars simply don't like to change their systems if they already have a proven way to do the job, even if it is a proprietary solution.
> 

Well considering that they might be 500 new TLDs, with an unknown number of new registries out there, perhaps they should be considering it.

> Also, what can you (as a registrar) do if you know what objects are linked to your object instead of the knowledge that these exist (via the "linked" status)? If you don't have any means EPP-wise to free your trapped objects, it is not that helpful, except that you can manually find out the e-mail addresses of the related registrars and beg them to disuse your objects.
> 

Well I guess the regular EPP transform commands would do the job, it would be a matter of registry policy. 

Francisco Obispo 
ISC

---

From: Klaus Malorny <[email-masked]>
Date: Tue, 31 May 2011 18:06:12 +0200

> Was an extension mechanism ever considered for such operations?

A response of such a request could contain millions of objects in the worst 
case, and with ICANN's SLAs in mind, this is not a good idea ;-)

Of course, there are ways to deal with this.

Regards,

Klaus

---

From: Klaus Malorny <[email-masked]>
Date: Tue, 31 May 2011 18:28:33 +0200

On 31/05/11 17:59, Francisco Obispo wrote:
> Well considering that they might be 500 new TLDs, with an unknown number of
> new registries out there, perhaps they should be considering it.

valid point, agreed.

> a matter of registry policy.

If a domain sponsored by another registrar references one of your in-zone hosts, 
which then blocks the deletion of the containing domain, what can you do? 
Issuing update commands for these domains? Likely not.

The hard way would be to allow the deletion of the host despite being referenced 
by non-sponsored objects, with the side effect that the host is removed from all 
domains referring to it. But I guess this breaks the EPP standard somewhere, and 
would also be too risky to be executed without explicit consent (via special 
option or so).

Regards,

Klaus

---

From: Francisco Obispo <[email-masked]>
Date: Tue, 31 May 2011 09:44:03 -0700

Well the same thing will happen, if a domain was to expire, and it had very popular Hosts associated with it.

Don't get me wrong.. I agree with you, but this is grey area that requires attention. 

On May 31, 2011, at 9:28 AM, Klaus Malorny wrote:

> If a domain sponsored by another registrar references one of your in-zone hosts, which then blocks the deletion of the containing domain, what can you do? Issuing update commands for these domains? Likely not.
> 
> The hard way would be to allow the deletion of the host despite being referenced by non-sponsored objects, with the side effect that the host is removed from all domains referring to it. But I guess this breaks the EPP standard somewhere, and would also be too risky to be executed without explicit consent (via special option or so).
> 
> Regards,
> 
> Klaus

Francisco Obispo 
ISC

---

From: Andrew Sullivan <[email-masked]>
Date: Tue, 31 May 2011 12:45:02 -0400

On Tue, May 31, 2011 at 06:28:33PM +0200, Klaus Malorny wrote:

> If a domain sponsored by another registrar references one of your
> in-zone hosts, which then blocks the deletion of the containing
> domain, what can you do? Issuing update commands for these domains?
> Likely not.

At least one registry implementation I know of would automatically
change the name of such a host to be a lame delegation when such a
deletion of the superordinate domain was requested.  This was possible
partly because of pendingDelete.  (I should note, too, that I
personally think this is a really bad idea from a DNS point of view,
but I understand why the business reasons override that.)
 
> The hard way would be to allow the deletion of the host despite
> being referenced by non-sponsored objects, with the side effect that
> the host is removed from all domains referring to it. But I guess
> this breaks the EPP standard somewhere, and would also be too risky
> to be executed without explicit consent (via special option or so).

If you refer to a host inside a domain outside your control --
regardless of whether it is internal to the repository or external --
you're going to have a bad day when the superordinate domain is
deleted.  The sponsor of that domain is allowed to rename any hosts
inside it anyway, and your NS records in your zone are going to be
wrong at that point.  This is in effect either a reason never to do
that, or else a reason to believe that strong external contractual
rules are what will actually be effective here.

If you believe the latter, of course, then you believe there is
another channel besides EPP for communication between the sponsor and
the operator of the repository.  In that case, bulk operations and
information about links to objects you sponsor can both be delivered
outside EPP.

A

-- 
Andrew Sullivan
[email-masked]