Subject: [provreg] Followup: Restrictions on EPP host renames?

From: Seth Goldman <[email-masked]>
Date: Wed, 19 Dec 2012 15:00:54 -0500

Ok, so it's clear to me that host object renames should be supported by our
implementation. So I had some follow-up questions on the topic:

Can you rename a subordinate host object to be under a different domain?
(e.g. ns1.example.com to ns1.otherdomain.com)
Can you rename an external host object to be subordinate? (e.g.
ns1.example.org to ns1.example.com)
Can you rename a subordinate host object to be external? (e.g.
ns1.example.com to ns1.example.org)

The RFC doesn't seem to say anything on these questions. Is this just a
server defined policy? Or should are all of the above be allowed?

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Wed, 19 Dec 2012 20:09:05 +0000

5732 doesn't ask or answer those questions because they are very definitely tied to policy and/or operational considerations.

Scott

From: [email-masked] [mailto:[email-masked]] On Behalf Of Seth Goldman
Sent: Wednesday, December 19, 2012 3:01 PM
To: [email-masked]
Subject: [provreg] Followup: Restrictions on EPP host renames?

Ok, so it's clear to me that host object renames should be supported by our implementation. So I had some follow-up questions on the topic:

Can you rename a subordinate host object to be under a different domain? (e.g. ns1.example.com<http://ns1.example.com> to ns1.otherdomain.com<http://ns1.otherdomain.com>)
Can you rename an external host object to be subordinate? (e.g. ns1.example.org<http://ns1.example.org> to ns1.example.com<http://ns1.example.com>)
Can you rename a subordinate host object to be external? (e.g. ns1.example.com<http://ns1.example.com> to ns1.example.org<http://ns1.example.org>)

The RFC doesn't seem to say anything on these questions. Is this just a server defined policy? Or should are all of the above be allowed?

---

From: Michael Young <[email-masked]>
Date: Wed, 19 Dec 2012 15:41:19 -0500

See below

On 2012-12-19, at 15:00, Seth Goldman <[email-masked]> wrote:

> Can you rename a subordinate host object to be under a different domain? (e.g. ns1.example.com to ns1.otherdomain.com)

Hmmmm never considered that one what use case  do you think would incite that action?

> Can you rename an external host object to be subordinate? (e.g. ns1.example.org to ns1.example.com)

You could i guess but what's the gain when mass updates don't apply to external hosts? So I wouldn't 

> Can you rename a subordinate host object to be external? (e.g. ns1.example.com to ns1.example.org)
> 
No how would you handle existing glue records that are now not allowed?

> The RFC doesn't seem to say anything on these questions. Is this just a server defined policy? Or should are all of the above be allowed?

Some of this falls out to other DNS specific rfcs

> _______________________________________________
> provreg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/provreg

---

From: Francisco Obispo <[email-masked]>
Date: Wed, 19 Dec 2012 12:43:52 -0800

The whole change would have to live inside its own transaction, that is:

-remove ip addresses
-change the host name (cascade)
-check constraints before commit

> No how would you handle existing glue records that are now not allowed?

Francisco Obispo 
Director of Applications and Services - ISC
email: [email-masked]
Phone: +1 650 423 1374 || INOC-DBA *3557* NOC
PGP KeyID = B38DB1BE

---

From: "Gould, James" <[email-masked]>
Date: Wed, 19 Dec 2012 20:52:05 +0000

Seth,

My thoughts are included below prefixed with "JG-".

--

JG

James Gould
Principal Software Engineer
[email-masked]

703-948-3271 (Office)
12061 Bluemont Way
Reston, VA 20190
VerisignInc.com

From: Seth Goldman <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, December 19, 2012 3:00 PM
To: EPP Provreg <[email-masked]<mailto:[email-masked]>>
Subject: [provreg] Followup: Restrictions on EPP host renames?

JG - Yes, as long as the client sponsors both example.com and otherdomain.com.

JG – Yes, as long as you add the IP addresses to ns1.example.org in the same same update, the client sponsors example.com, and there are no links of domains sponsored by other registrars per RFC 5732.

JG – Yes, as long as you remove the IP addresses in the same update and ns1.example.org does not already exist.

JG – This is up to your server policy.

---

From: Michael Young <[email-masked]>
Date: Wed, 19 Dec 2012 17:57:26 -0500

And change the nature of any other in zone domains association to the host object from internal to external host

That could turn into a heavy mass function. I'd hate to make a client side mistake in submitting that type of transaction request - ouch

Michael Young

M:647-289-1220

---

From: Ed Pascoe <[email-masked]>
Date: Thu, 20 Dec 2012 08:33:48 +0200

On Thu, Dec 20, 2012 at 12:57 AM, Michael Young <[email-masked]> wrote:

> That could turn into a heavy mass function. I'd hate to make a client side
> mistake in submitting that type of transaction request - ouch
>
> Michael Young
>
> M:647-289-1220
>

 Exactly. This is a huge mine field. You don't know if the client didn't
expect the glue to move to the new name.

I find the rars always expect the most obscure possible interpretation you
didn't cater for. ;) The only sane option imho is to reject with a 2306 or
similar error for renaming subordinates.

Ed.

---

From: InterNetX - Volker Janzen <[email-masked]>
Date: Thu, 20 Dec 2012 09:09:05 +0100

Hi,

> (e.g. ns1.example.com to ns1.otherdomain.com)

this has to be possible, if you want to be able to delete the domain
name. We choose even another TLD and remove all host:addr elements.

> ns1.example.org to ns1.example.com)

Yes, if you manage example.com.

> ns1.example.com to ns1.example.org)

Yes, if you remove all host:addr elements.

Volker Janzen
Team Entwicklung

-- 
InterNetX GmbH
Maximilianstr. 6
93047 Regensburg
Germany

Tel: +49 941 59559-0
Fax: +49 941 59579-050

www.internetx.com
www.facebook.com/InterNetX
www.twitter.com/InterNetX

Geschäftsführer/CEO: Thomas Mörz
Amtsgericht Regensburg, HRB 7142

GPG-Key: 0x186C5F77
GPG-Fingerprint: 392E 8730 FE23 DCE8 8878 8524 5361 BCCC 186C 5F77