Subject: [provreg] launch:phase requirement for Sunrise FCFS

From: "Wodjenski, Sharon" <[email-masked]>
Date: Mon, 3 Jun 2013 18:05:21 +0000

Hi Everybody,

We've run into a condition during development and are seeking feedback/guidance from the group.

This case is specific to First Come, First Served Sunrises, and the delete/update commands.

When we read this in the spec:

2.2.  Launch Phases

   The server MAY support multiple launch phases sequentially or
   simultaneously.  The <launch:phase> element MUST be included by the
   client to define the target launch phase of the command.

We interpreted that to mean that the launch:phase  was mandatory, and would come in with each command in the extension.

Currently, the XSD for the delete/update commands do not support the application id being optional.  And of course, for a FCFS registration, the application id is not needed/used.

     <element name="update" type="launch:idContainerType"/>

     <element name="delete" type="launch:idContainerType"/>

     <!--

     Common container of id (identifier) element

     -->

     <complexType name="idContainerType">

       <sequence>

         <element name="phase" type="launch:phaseType"/>

         <element name="applicationID" type="launch:applicationIDType"/>

       </sequence>

     </complexType>

So, the question from a client perspective is:

1.        Is the launch:phase, and therefore the extension, mandatory for all commands and the XSD should be modified so that the application id is optional (as it is in the Info command)?

Or

2.       For FCFS update/delete commands, the extension is not required at all, and therefore the launch:phase is not specified.

Thank you for your input on this topic.

Sharon

---

From: "Gould, James" <[email-masked]>
Date: Mon, 3 Jun 2013 22:26:01 +0000

Sharon,

The intention in the draft was #2 " For FCFS update/delete commands, the extension is not required at all, and therefore the launch:phase is not specified.".  It would be good to hear from others whether the extension should be included for update and delete commands for launch registrations.

--

JG

James Gould
Principal Software Engineer
[email-masked]

703-948-3271 (Office)
12061 Bluemont Way
Reston, VA 20190
VerisignInc.com

From: <Wodjenski>, Sharon <[email-masked]<mailto:[email-masked]>>
Date: Monday, June 3, 2013 2:05 PM
To: EPP Provreg <[email-masked]<mailto:[email-masked]>>
Subject: [provreg] launch:phase requirement for Sunrise FCFS

Hi Everybody,

We’ve run into a condition during development and are seeking feedback/guidance from the group.

2.2.  Launch Phases

     <!--

     -->

       <sequence>

       </sequence>

     </complexType>

Or

Sharon

---

From: "Wodjenski, Sharon" <[email-masked]>
Date: Tue, 11 Jun 2013 19:39:34 +0000

As we have not received any feedback, we will take Jim's suggestion and not require the launch extension and launch:phase for update/delete commands in FCFS Sunrise.

Jim - could you please update the text in the next revision to clarify this point?

Thanks,

Sharon

From: Gould, James [mailto:[email-masked]]
Sent: Monday, June 03, 2013 6:26 PM
To: Wodjenski, Sharon; [email-masked]'
Subject: Re: [provreg] launch:phase requirement for Sunrise FCFS

Sharon,

--

JG

James Gould
Principal Software Engineer
[email-masked]<mailto:[email-masked]>

703-948-3271 (Office)
12061 Bluemont Way
Reston, VA 20190
VerisignInc.com

Hi Everybody,

2.2.  Launch Phases

     <!--

     -->

       <sequence>

       </sequence>

     </complexType>

Or

Sharon

---

From: Seth Goldman <[email-masked]>
Date: Mon, 17 Jun 2013 15:01:27 -0400

I think the idea of the launch update/delete commands is to support
operations on applications. If you've already provisioned the domain
(presumably you have since it's FCFS), then the standard version of update
and delete should be sufficient, in which case you don't need to specify
either a phase or an application id.

On Tue, Jun 11, 2013 at 3:39 PM, Wodjenski, Sharon <
[email-masked]> wrote:

>  As we have not received any feedback, we will take Jim’s suggestion and
> not require the launch extension and launch:phase for update/delete
> commands in FCFS Sunrise.****
>
> ** **
>
> Jim – could you please update the text in the next revision to clarify
> this point?****
>
> ** **
>
> Thanks,****
>
> ** **
>
> Sharon****
>
> ** **
>
> *From:* Gould, James [mailto:[email-masked]]
> *Sent:* Monday, June 03, 2013 6:26 PM
> *To:* Wodjenski, Sharon; [email-masked]'
> *Subject:* Re: [provreg] launch:phase requirement for Sunrise FCFS****
>
> ** **
>
> Sharon,****
>
> ** **
>
> The intention in the draft was #2 " For FCFS update/delete commands, the
> extension is not required at all, and therefore the launch:phase is not
> specified.".  It would be good to hear from others whether the extension
> should be included for update and delete commands for launch registrations.
>  ****
>
> ** **
>
> -- ****
>
>  ****
>
> JG****
>
>  ****
>
> ****
>
>  ****
>
> James Gould****
>
> Principal Software Engineer****
>
> [email-masked]****
>
>  ****
>
> 703-948-3271 (Office)****
>
> 12061 Bluemont Way****
>
> Reston, VA 20190****
>
> VerisignInc.com****
>
> ** **
>
> *From: *<Wodjenski>, Sharon <[email-masked]>
> *Date: *Monday, June 3, 2013 2:05 PM
> *To: *EPP Provreg <[email-masked]>
> *Subject: *[provreg] launch:phase requirement for Sunrise FCFS****
>
> ** **
>
>  Hi Everybody,****
>
>  ****
>
> We’ve run into a condition during development and are seeking
> feedback/guidance from the group.****
>
>  ****
>
> This case is specific to First Come, First Served Sunrises, and the
> delete/update commands.****
>
>  ****
>
> When we read this in the spec:****
>
>  ****
>
> 2.2.  Launch Phases****
>
>  ****
>
>    The server MAY support multiple launch phases sequentially or****
>
>    simultaneously.  The <launch:phase> element MUST be included by the****
>
>    client to define the target launch phase of the command. ****
>
>  ****
>
> We interpreted that to mean that the launch:phase  was mandatory, and
> would come in with each command in the extension.****
>
>  ****
>
> Currently, the XSD for the delete/update commands do not support the
> application id being optional.  And of course, for a FCFS registration, the
> application id is not needed/used.****
>
>  ****
>
>      <element name="update" type="launch:idContainerType"/>****
>
>      <element name="delete" type="launch:idContainerType"/>****
>
>  ****
>
>      <!--****
>
>      Common container of id (identifier) element****
>
>      -->****
>
>      <complexType name="idContainerType">****
>
>        <sequence>****
>
>          <element name="phase" type="launch:phaseType"/>****
>
>          <element name="applicationID" type="launch:applicationIDType"/>****
>
>        </sequence>****
>
>      </complexType>****
>
>  ****
>
> So, the question from a client perspective is:****
>
>  ****
>
> **1.       ** Is the launch:phase, and therefore the extension, mandatory
> for all commands and the XSD should be modified so that the application id
> is optional (as it is in the Info command)? ****
>
> Or****
>
> **2.       **For FCFS update/delete commands, the extension is not
> required at all, and therefore the launch:phase is not specified.****
>
>  ****
>
> Thank you for your input on this topic.****
>
>  ****
>
> Sharon****
>
>  ****
>
>
> _______________________________________________
> provreg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/provreg
>
>

---

From: "Wodjenski, Sharon" <[email-masked]>
Date: Mon, 17 Jun 2013 19:33:52 +0000

Thank you for the confirmation Seth.

Sharon

From: Seth Goldman [mailto:[email-masked]]
Sent: Monday, June 17, 2013 3:01 PM
To: Wodjenski, Sharon
Cc: Gould, James; [email-masked]
Subject: Re: [provreg] launch:phase requirement for Sunrise FCFS

I think the idea of the launch update/delete commands is to support operations on applications. If you've already provisioned the domain (presumably you have since it's FCFS), then the standard version of update and delete should be sufficient, in which case you don't need to specify either a phase or an application id.

On Tue, Jun 11, 2013 at 3:39 PM, Wodjenski, Sharon <[email-masked]<mailto:[email-masked]>> wrote:
As we have not received any feedback, we will take Jim's suggestion and not require the launch extension and launch:phase for update/delete commands in FCFS Sunrise.

Thanks,

Sharon

From: Gould, James [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Monday, June 03, 2013 6:26 PM
To: Wodjenski, Sharon; [email-masked]<mailto:[email-masked]>'
Subject: Re: [provreg] launch:phase requirement for Sunrise FCFS

Sharon,

--

JG

James Gould

703-948-3271 (Office)
12061 Bluemont Way
Reston, VA 20190
VerisignInc.com

Hi Everybody,

2.2.  Launch Phases

     <!--

     -->

       <sequence>

       </sequence>

     </complexType>

Or

Sharon

_______________________________________________
provreg mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/provreg

---

From: "Gould, James" <[email-masked]>
Date: Mon, 17 Jun 2013 19:45:21 +0000

Sharon,

We can add some clarifying text to the next version of the draft.  I don't believe that this change alone warrants a new draft version, so we can wait to include it with other updates.

Thanks,

--

JG

James Gould

703-948-3271 (Office)
12061 Bluemont Way
Reston, VA 20190
VerisignInc.com

From: <Wodjenski>, Sharon <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, June 11, 2013 3:39 PM
To: James Gould <[email-masked]<mailto:[email-masked]>>, EPP Provreg <[email-masked]<mailto:[email-masked]>>
Subject: RE: [provreg] launch:phase requirement for Sunrise FCFS

As we have not received any feedback, we will take Jim’s suggestion and not require the launch extension and launch:phase for update/delete commands in FCFS Sunrise.

Jim – could you please update the text in the next revision to clarify this point?

Thanks,

Sharon

From: Gould, James [mailto:[email-masked]]
Sent: Monday, June 03, 2013 6:26 PM
To: Wodjenski, Sharon; [email-masked]<mailto:[email-masked]>'
Subject: Re: [provreg] launch:phase requirement for Sunrise FCFS

Sharon,

--

JG

James Gould

703-948-3271 (Office)
12061 Bluemont Way
Reston, VA 20190
VerisignInc.com

Hi Everybody,

2.2.  Launch Phases

     <!--

     -->

       <sequence>

       </sequence>

     </complexType>

Or

Sharon