Subject: [provreg] Contacts after a Domain Transfer

From: Seth Goldman <[email-masked]>
Date: Thu, 20 Jun 2013 12:04:40 -0400

What do registrars typically do about contacts sponsored by a different
registrar after a domain transfer? This situation seems undesirable, as it
prevents the gaining registrar from updating registrant contact information
in the future. Do registrars just make a new contact as a matter of course?
Or do they try to transfer over the existing contact? The former seems more
likely, as the latter will not work if there are other domains with
references to that contact object on the losing registrar.

---

From: Ofer Nave <[email-masked]>
Date: Thu, 20 Jun 2013 12:08:19 -0400

As an EPP noob, I'm confused by the same thing (being able to 'transfer' 
a contact object).

I get the point of transferring a domain name because it represents 
ownership, like a title or deed.  It can only be 'owned' by a single 
registrar at a time.  But a contact is merely a data structure.  
Shouldn't contacts and hosts just be copied automatically by the gaining 
registrar in the case of a domain transfer?  What does it mean to 
'transfer' a contact, as opposed to merely copying the data?

-ofer

On 06/20/2013 12:04 PM, Seth Goldman wrote:
> What do registrars typically do about contacts sponsored by a 
> different registrar after a domain transfer? This situation seems 
> undesirable, as it prevents the gaining registrar from updating 
> registrant contact information in the future. Do registrars just make 
> a new contact as a matter of course? Or do they try to transfer over 
> the existing contact? The former seems more likely, as the latter will 
> not work if there are other domains with references to that contact 
> object on the losing registrar.
>
>
> _______________________________________________
> provreg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/provreg

---

From: Christopher Browne <[email-masked]>
Date: Thu, 20 Jun 2013 12:09:29 -0400

It's pretty common that the old contacts get left to moulder away, and the
registrar generally creates new contacts for their newly sponsored domain.

It seems remarkably common for old contacts to get left behind for a lot of
reasons; it appears some registrars create fresh contacts (using UUID-like
logic; there are likely not strictly enough bits in the clientID value to
actually use real UUIDs) every time *any* contact update takes place.

---

From: "Gould, James" <[email-masked]>
Date: Thu, 20 Jun 2013 16:11:19 +0000

Seth,

The Registrars typically reset the contacts on the domains after the domain transfer.  The contact objects sponsored by the gaining registrar could already exist, so creating new contact objects might not be necessary. A contact transfer could be done, but is not likely.

--

JG

James Gould
Principal Software Engineer
[email-masked]

703-948-3271 (Office)
12061 Bluemont Way
Reston, VA 20190
VerisignInc.com

From: Seth Goldman <[email-masked]<mailto:[email-masked]>>
Date: Thursday, June 20, 2013 12:04 PM
To: EPP Provreg <[email-masked]<mailto:[email-masked]>>
Subject: [provreg] Contacts after a Domain Transfer

What do registrars typically do about contacts sponsored by a different registrar after a domain transfer? This situation seems undesirable, as it prevents the gaining registrar from updating registrant contact information in the future. Do registrars just make a new contact as a matter of course? Or do they try to transfer over the existing contact? The former seems more likely, as the latter will not work if there are other domains with references to that contact object on the losing registrar.

---

From: Gavin Brown <[email-masked]>
Date: Thu, 20 Jun 2013 17:15:52 +0100

We've operated an EPP server since 2005, and have only ever seen a
single contact transfer request - which was cancelled shortly after
being submitted.

Gavin.

On 20/06/2013 17:04, Seth Goldman wrote:
> registrar after a domain transfer? This situation seems undesirable, as
> it prevents the gaining registrar from updating registrant contact
> information in the future. Do registrars just make a new contact as a
> matter of course? Or do they try to transfer over the existing contact?
> The former seems more likely, as the latter will not work if there are
> other domains with references to that contact object on the losing
> registrar.
> 
> 

-- 
Gavin Brown
Chief Technology Officer
CentralNic Ltd
Innovative, Reliable and Flexible Registry Services
for ccTLD, gTLD and private domain name registries
https://www.centralnic.com/

CentralNic Ltd is a company registered in England and Wales with company
number 4985780. Registered Offices: 35-39 Moorgate, London, EC2R 6AR.

---

From: Klaus Malorny <[email-masked]>
Date: Thu, 20 Jun 2013 18:33:04 +0200

On 20/06/13 18:08, Ofer Nave wrote:
> As an EPP noob, I'm confused by the same thing (being able to 'transfer' a
> contact object).
>
> I get the point of transferring a domain name because it represents ownership,
> like a title or deed.  It can only be 'owned' by a single registrar at a time.
> But a contact is merely a data structure.  Shouldn't contacts and hosts just be
> copied automatically by the gaining registrar in the case of a domain transfer?
> What does it mean to 'transfer' a contact, as opposed to merely copying the data?
>
> -ofer
>
>> prevents the gaining registrar from updating registrant contact information in
>> the future. Do registrars just make a new contact as a matter of course? Or do
>> they try to transfer over the existing contact? The former seems more likely,
>> as the latter will not work if there are other domains with references to that
>> contact object on the losing registrar.
>>

Hi,

I guess that nearly no registry has implemented the transfers of contacts. The 
benefit is neglectible and introduces some unwanted side effects. As Seth says, 
especially, automatically transferring contacts along with the domain is a 
really bad idea, as these contacts may still be linked with other domains of the 
losing registrar.

Automatic copying of contacts could be done, but this increases the garbage -- 
without copying, a registrar can theoretically reuse an existing contact for the 
very same person he has created earlier. Host objects cannot be copied, as the 
host's name is the (unique) key to the EPP object (contrary to the ID of the 
contact, which is not part of the content) and therefore no two hosts with the 
name may exist at the same time.

Another registry implementation approach is to use separate object/ID spaces for 
each registrar. A registrar cannot see/access any object of another registrar at 
all. In this case, copying is mandatory, or a new set of contacts must be 
already provided when the domain transfer is initiated (not possible in EPP 
without extensions).

Regards,

Klaus

---

From: Ofer Nave <[email-masked]>
Date: Thu, 20 Jun 2013 12:37:13 -0400

On 06/20/2013 12:33 PM, Klaus Malorny wrote:
>> ownership,
> I guess that nearly no registry has implemented the transfers of 
> contacts. The benefit is neglectible and introduces some unwanted side 
> effects. As Seth says, especially, automatically transferring contacts 
> along with the domain is a really bad idea, as these contacts may 
> still be linked with other domains of the losing registrar.
>
> Automatic copying of contacts could be done, but this increases the 
> garbage -- without copying, a registrar can theoretically reuse an 
> existing contact for the very same person he has created earlier. Host 
> objects cannot be copied, as the host's name is the (unique) key to 
> the EPP object (contrary to the ID of the contact, which is not part 
> of the content) and therefore no two hosts with the name may exist at 
> the same time.
>
> Another registry implementation approach is to use separate object/ID 
> spaces for each registrar. A registrar cannot see/access any object of 
> another registrar at all. In this case, copying is mandatory, or a new 
> set of contacts must be already provided when the domain transfer is 
> initiated (not possible in EPP without extensions).

Thanks, that definitely helps clarify a few things that were previously 
fuzzy to me.

-ofer

---

From: MICHAEL YOUNG <[email-masked]>
Date: Thu, 20 Jun 2013 12:37:27 -0400

These are much more common during bulk transfer operations, where one registrar buys the assets of another.  It is a needed function for that use case.

I've also seem some contact transfers around domain transfer operations but as Gavin said, its not common practise.

-Michael Young

>> other domains with references to that contact object on the losing

MICHAEL YOUNG
[email-masked]

---

From: mike <[email-masked]>
Date: Thu, 20 Jun 2013 19:00:38 +0200

All,

> I guess that nearly no registry has implemented the transfers of contacts. The benefit is neglectible and introduces some unwanted side effects. As Seth says, especially, automatically transferring contacts along with the domain is a really bad idea, as these contacts may still be linked with other domains of the losing registrar.

We've done the implementation for contact transfer but haven't found a use for it (yet)

> Automatic copying of contacts could be done, but this increases the garbage -- without copying, a registrar can theoretically reuse an existing contact for the very same person he has created earlier.

Contacts are duplicated on transfer and many rars replace these with their own for contact ID uniformity (I would guess), so we're facing a contact garbage collection sometime soon which should be fun...

> Host objects cannot be copied, as the host's name is the (unique) key to the EPP object (contrary to the ID of the contact, which is not part of the content) and therefore no two hosts with the name may exist at the same time.

Funnily enough; host objects are the only object in our registry that are unique to the rar only, i.e two rars can have the same hostname. We copy host objects (with some special control around subordinate and delegated hosts) on transfer as well as contacts. 

It might not be the neatest approach and requires some long term maintenance but it works well enough!

Regards,

Michael O'Connell
DNServices Registry Services

---

From: Andrew Sullivan <[email-masked]>
Date: Thu, 20 Jun 2013 13:08:09 -0400

> These are much more common during bulk transfer operations, where one registrar buys the assets of another.  It is a needed function for that use case.

But bulk transfer is usually not accomplished by retail EPP commands,
so that might not be a good reason for the functionality to be there.

My own view is that this is just a consequence of the data model
implicit in EPP, and sponosors ("registrars") would be crazy not to
set up contacts they control themselves and then replace the old
contact data with new after a domain transfer.  (Same thing of
external hosts.)

Best,

A

-- 
Andrew Sullivan
[email-masked]

---

From: Jan Saell <[email-masked]>
Date: Fri, 21 Jun 2013 00:14:31 +0200

Hi there!

As a regsistarar at .SE i can tell you how the .SE EPP server works.

Host objects are owned by the sponsoring client of the domain itself,
and when you do transfers the hosts in a domain gets transferred
automatically.

When doing a domain transfer, the contact object of the domain is copied
and set as the registrant of the domain.

This solves the problems with other domain belonging to the old contact
at the old registrar.

The new registrar gets a notification that the epp server has created a
new contact for that registrar, so to be able to updates its own database.

This usually leads to me as a registrar changing the domain registrant
to a new or existing contact object that I have. And hopefully deleting
the old one.

Not all registrars are deleting old ones so this leads to some "junk" in
the database, but there are a discussion about automatically deleting
old, unused ones.

Best regards
jan

> other domains with references to that contact object on the losing

- -- 
+-------------------------------------------------------------------
! Irial / YASK AB
! Att: Jan Saell
! Box 59, S-692 21 KUMLA, SWEDEN
! Tel: 019-58 25 15     Int +46-19 58 25 15     Fax +46-19 58 38 05
! E-mail: [email-masked]
! PGP Fingerprint: E957 23C8 9F51 0958 B9AD  7F18 404A 5DA1 F944 A08B

---

From: Ewout de Graaf <[email-masked]>
Date: Fri, 21 Jun 2013 09:35:05 +0200

Registrars SHOULD change contacts upon an incoming transfer, because the
same registrant might have more then one domain name from the same registry
with this registrar.

So upon incoming transfer of a domain name, a registrars software should
first check if this client owns other domain names, and re-use contact
information from those domain names on the incoming transfer.

Most registries create copies of contacts when a domain is transferred, so
if the client does not own other domain names, you might use these contacts
and insert the contact handles into your own database. Or you can create
new contacts, whatever you want. Please clean up the mess afterwards...

Kind regards,

Ewout de Graaf
mijndomein.nl

2013/6/21 Jan Saell <[email-masked]>

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> Hi there!
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.11 (GNU/Linux)
> Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/
>
> iEYEARECAAYFAlHDfscACgkQQEpdoflEoIsFhgCcDcv2x0btS9H9oj7xdr0ULe7w
> UaAAn1/OccK9bC2JMuAqUDz7cNkgIV/c
> =AnpZ
> -----END PGP SIGNATURE-----

---

From: Keith Gaughan <[email-masked]>
Date: Fri, 21 Jun 2013 11:40:13 +0100

> As an EPP noob, I'm confused by the same thing (being able to 'transfer' a

That's a matter of parsimony in the protocol: each object shares a
uniform interface, which helps establish a uniform set of abstractions.
That said, while the operation might be *possible*, but that doesn't
mean that registries necessarily have to support it.

> ownership, like a title or deed.

No. It's a transfer of *sponsorship*. Registrars *sponsor* objects, they
don't own them as such.

> It can only be 'owned' by a single registrar at a time.  But a contact
> is merely a data structure.  Shouldn't contacts and hosts just be

It's a matter of changing who has responsibility for the object in
question. But, as I said, not every object necessarily has to implement
every EPP operation. Typically, registries don't allow the explicit
transfer of host objects and contacts, though it's technically possible
in the protocol.

Contacts may also be tied to multiple domains or none, so it doesn't
make sense that, if a domain is transferred, all its associated contacts
are also transferred.

> What does it mean to 'transfer' a contact, as opposed to merely

If the registry supports contact transfers, it's a transfer of
responsibility for the object.

K.

-- 
Keith Gaughan, Development Lead
PGP/GPG key ID: 82AC3634
Blacknight Internet Solutions Ltd. <http://blacknight.com/>
12A Barrowside Business Park, Carlow, Ireland
Registered in Ireland, Company No.: 370845

---

From: Luis Muñoz <[email-masked]>
Date: Fri, 21 Jun 2013 11:09:29 -0400

On Jun 21, 2013, at 3:35 AM, Ewout de Graaf wrote:

> Or you can create

Is there any preferred way of doing this?

How about sending a poll message prior to purging "orphaned" objects after a reasonable time? What would that "reasonable" time be?

Best regards

-lem

---

From: Gavin Brown <[email-masked]>
Date: Fri, 21 Jun 2013 16:36:56 +0100

> How about sending a poll message prior to purging "orphaned" objects after a reasonable time? What would that "reasonable" time be?

Various server-side approaches were discussed on the regops list back in
2011:

http://nlnetlabs.nl/mailman/private/regops/2011-October/thread.html

G.

---

From: Patrik Fältström <[email-masked]>
Date: Sat, 22 Jun 2013 09:15:15 +0200

> How about sending a poll message prior to purging "orphaned" objects after a reasonable time? What would that "reasonable" time be?

I think the registry have to be very careful about making changes in the registry database as that is a mirror of what the registrar do have in its database. Just because a contact object in the registry database is orphaned from the registry point of view, maybe it is not in the registrar database. It might be used at a different registry. And as long as the individual the object is describing is a customer of the registrar, the registrar might when a new domain name is registered try to reuse the same object.

That said, the only reasonable way for a registry to remove objects I think are:

- Ensure the object has really been orphaned for quite some time (so that it does not create a race condition between creation of the object and registration of a domain name). This must be much longer than the longest time interval existing in the state machine in the registry.

- When the object is removed, inform via notification visible via poll.

- When a removed object is used, a special error code is used to inform on the matter so that the registrar know that in that specific case the fallback is to go back, create the object again, and then redo whatever operation failed.

   Patrik

---

From: Jan Saell <[email-masked]>
Date: Sat, 22 Jun 2013 10:12:26 +0200

I think that this is more or less exactly what .se is going to do except
the last point.

And also as a epp client programmer I can confirm that an object don’t
exists error code is sufficient. We dont need an extra error code for
this in my opinion.

My code knows that if you get an object dont exists error code when
trying to register a new domain, that it has do "re-create" the owner again.

- --

---

From: Ewout de Graaf <[email-masked]>
Date: Sat, 22 Jun 2013 10:36:40 +0200

2013/6/22 Patrik Fältström <[email-masked]>

> I think the registry have to be very careful about making changes in the
> registry database as that is a mirror of what the registrar do have in its
> database. Just because a contact object in the registry database is
> orphaned from the registry point of view, maybe it is not in the registrar
> database. It might be used at a different registry. And as long as the
> individual the object is describing is a customer of the registrar, the
> registrar might when a new domain name is registered try to reuse the same
> object.

I think a registry should *never* discard contact or other objects that
are sponsored by a registrar.

We as registrars keep our records, and if the registry deletes stuff, we
need to know it is deleted to update our records.

So if contacts are orphaned, registries should provide the registrars with
good lists of orphaned contacts and stimulate them to clean up their own
mess...

Regards,

Ewout de Graaf
mijndomein.nl