Subject: Re: [provreg] Fwd: New Version Notification for draft-brown-epp-fees-01.txt

From: Seth Goldman <[email-masked]>
Date: Thu, 24 Apr 2014 19:48:27 -0400

Hi Gavin,

I know this is very late in coming, but I do have a small piece of feedback
on the proposed extension. The <check> command in your draft can have
multiple <check> elements underneath the <extension> element, e.g.:

<?xml version="1.0" encoding="utf-8" standalone="no"?>
>   <epp xmlns="urn:ietf:params:xml:ns:epp-1.0">
>   <command>
>     <check>
>       <domain:check xmlns:domain="urn:ietf:params:xml:ns:domain-1.0">
>       ...
>       </domain:check>
>     </check>
>     <extension>
>       <fee:check xmlns:fee="urn:ietf:params:xml:ns:fee-0.4">
>       ...
>       </fee:check>
>       <fee:check xmlns:fee="urn:ietf:params:xml:ns:fee-0.4">
>       ...
>       </fee:check>
>       <fee:check xmlns:fee="urn:ietf:params:xml:ns:fee-0.4">
>       ...
>       </fee:check>
>     </extension>
>     <clTRID>ABC-12345</clTRID>
>   </command>
> </epp>

As far as I can tell, no other EPP extensions puts repeated types inside
the <extension> element (for either commands or responses). Instead, they
use a top-level container type, with repeated elements nested underneath
that, e.g.:

<?xml version="1.0" encoding="utf-8" standalone="no"?>
  <epp xmlns="urn:ietf:params:xml:ns:epp-1.0">
  <command>
    <check>
      <domain:check xmlns:domain="urn:ietf:params:xml:ns:domain-1.0">
      ...
      </domain:check>
    </check>
    <extension>
      <fee:check xmlns:fee="urn:ietf:params:xml:ns:fee-0.4">
        <fee:domain>
          <fee:name>example.tld</fee:name>
          ...
        </fee:domain>
        <fee:domain>
          <fee:name>example.com</fee:name>
          ...
        </fee:domain>
        <fee:domain>
          <fee:name>example.org</fee:name>
          ...
        </fee:domain>
      </fee:check>
    </extension>
    <clTRID>ABC-12345</clTRID>
  </command>
</epp>

I think if you modified your draft to follow this pattern, it would be more
in line with the convention used by other EPP extensions.

Cheers,
Seth

On Mon, Dec 9, 2013 at 1:18 PM, Gavin Brown <[email-masked]>wrote:

> Changes since the last version:
>
>    1.  Restore the <check> command extension; either <check> or <info>
>        can be used.
>
>    2.  added extension elements for <create>, <renew>, <transfer> and
>        <update> so that the server can reject the command if the fee is
>        incorrect.
>
> G.
>
> -------- Original Message --------
> Subject: New Version Notification for draft-brown-epp-fees-01.txt
> Date: Mon, 09 Dec 2013 09:58:47 -0800
> From: [email-masked]
> To: Gavin Brown <[email-masked]>
>
>
> A new version of I-D, draft-brown-epp-fees-01.txt
> has been successfully submitted by Gavin Brown and posted to the
> IETF repository.
>
> Filename:        draft-brown-epp-fees
> Revision:        01
> Title:           Registry Fee Extension for the Extensible Provisioning
> Protocol
> (EPP)
> Creation date:   2013-12-09
> Group:           Individual Submission
> Number of pages: 27
> URL:
> http://www.ietf.org/internet-drafts/draft-brown-epp-fees-01.txt
> Status:          http://datatracker.ietf.org/doc/draft-brown-epp-fees
> Htmlized:        http://tools.ietf.org/html/draft-brown-epp-fees-01
> Diff:            http://www.ietf.org/rfcdiff?url2=draft-brown-epp-fees-01
>
> Abstract:
>    This document describes an Extensible Provisioning Protocol (EPP)
>    extension mapping for registry fees.
>
>
>
>
>
> Please note that it may take a couple of minutes from the time of
> submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> The IETF Secretariat
>
>
> --
> Gavin Brown
> Chief Technology Officer
> CentralNic Group plc (LSE:CNIC)
> Innovative, Reliable and Flexible Registry Services
> for ccTLD, gTLD and private domain name registries
> https://www.centralnic.com/
>
> CentralNic Group plc is a company registered in England and Wales with
> company number 8576358. Registered Offices: 35-39 Moorgate, London,
> EC2R 6AR.
>
>
> _______________________________________________
> provreg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/provreg
>

---

From: Klaus Malorny <[email-masked]>
Date: Fri, 25 Apr 2014 10:26:47 +0200

On 25.04.2014 01:48, Seth Goldman wrote:
> Hi Gavin,
 >
 > [...]
 >
> As far as I can tell, no other EPP extensions puts repeated types inside the
> <extension> element (for either commands or responses). Instead, they use a
> top-level container type, with repeated elements nested underneath that, e.g.:
>
>            <fee:name>example.com <http://example.com></fee:name>
>            ...
>          </fee:domain>
>          <fee:domain>
>            <fee:name>example.org <http://example.org></fee:name>
>            ...
>          </fee:domain>
>        </fee:check>
>      </extension>
> I think if you modified your draft to follow this pattern, it would be more in
> line with the convention used by other EPP extensions.
>
> Cheers,
> Seth
>
>

Hi all,

I fully support Seth's suggestion, it would be better not to repeat the 
extension itself, but list the response for each domain within a single extension.

Regards,

Klaus

---

From: "Gould, James" <[email-masked]>
Date: Fri, 25 Apr 2014 12:52:01 +0000

+1, the elements of the extension should be contained under a single
extension element in the commands and responses.
-- 
 
JG

James Gould
Principal Software Engineer
[email-masked]
 
703-948-3271 (Office)
12061 Bluemont Way
Reston, VA 20190
VerisignInc.com

---

From: Gavin Brown <[email-masked]>
Date: Fri, 25 Apr 2014 15:00:10 +0100

Thanks Jim, Klaus and Seth - I will definitely look at following your
advice in the next version.

G.