Subject: Control words in the architecture draft

From: [email-masked]
Date: Wed, 2 Apr 2003 18:21:07 +0100

I have a question about section 5.4.3. of draft-ietf-pwe3-arch-02.txt. This
is the section that shows a PW over MPLS Generic Control Word. We already
have different control words for some applications, including TDM and some
of the ATM modes.

There was a lot of discussion back arount IETF 55 about whether the control
word should be moved from the individual encap drafts into the architecture
document, and if so what text should be moved. My understanding was that
the functionality of the control word could be described in the
architecture document (since this is generic), but that the positioning of
the bits and bytes would remain in the individual encap drafts. However,
the 'generic' control word shown in the architecture draft is not really
generic at all and does not accomodate the design decisions made for a
number of the encapsulations.

We could simply move all of the different control words into the
architecture draft, but that would be confusing since the encapsulations
would be spread across multiple documents.

Would it not be clearer for the architecture draft to describe the need for
and functonality of the control word, but to leave diagrams of its
structure to the individual encap drafts?

Regards,

Matthew

-----------------------------------------
Matthew Bocci
Office of the CTO
Alcatel Fixed Networks Division
-----------------------------------------

---

From: Shahram Davari <[email-masked]>
Date: Wed, 2 Apr 2003 09:57:55 -0800

Matthew,

I agree with you . It seems that figure 11 was corrected but not Figure 12.
My suggestion is to delete section 5.4.3, because as you said it is not generic,
and for example there is no structure pointer in it that is used for TDM/Sonet
draft, or that the size and position of other fields are not necessarily the same
in all PW types.

Yours,
-Shahram

PS- BTW I noticed that the PWE3 website lists older version of this draft, when
it was called draft-ietf-pwe3-protocol-layer-00.txt.

Danny, you may want to correct this.

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]]
>Sent: Wednesday, April 02, 2003 12:21 PM
>To: [email-masked]
>Subject: [PWE3] Control words in the architecture draft
>
>
>_______________________________________________
>pwe3 mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/pwe3
>

---

From: Stewart Bryant <[email-masked]>
Date: Wed, 02 Apr 2003 19:34:46 +0100

> draft, or that the size and position of other fields are not necessarily the same

I disagree.

Unless there are documented technical reasons to do otherwise the encaps
should follow the recommended style. This then leaves most of the encaps
to just specify their use of the flags. The only TECHNICAL case that I
have seen to use another CW dsign is the TDM need for a long pointer.

The revised version of 5.4.3 also discusses the need for discrimination
between IP and PW, and shows how the Martini CW design and the MPLS
payload identifier (needed for non-MArtini CWs) each achieve this.

Stewart

> Danny, you may want to correct this.

We will fix this.

Stewart

---

From: Shahram Davari <[email-masked]>
Date: Wed, 2 Apr 2003 10:51:34 -0800

I wonder how can one disagree with the following facts:

1) In ATM Encap draft you have 3 types of control word: (N:1=SDU, 1:1, PDU)
Note that in 1:1 and PDU mode the flags are after the length/sequence #.

2) Sonet draft does not use any FRG, PID or length, instead it uses a pointer

3) Ethernet draft does not use FRG, PID or length, instead these fields are reserved.

4) I am not sure any future PW could in fact use only the header that you have shown

Also it seems to me that since this draft is a WG draft, it needs WG consensus to
add/remove any text. So I assume you will wait for the consensus before adding
the text regarding PID that you mentioned.

-Shahram

>From: Stewart Bryant [mailto:[email-masked]]
>Sent: Wednesday, April 02, 2003 1:35 PM
>To: Shahram Davari
>Cc: [email-masked]'; [email-masked]
>Subject: Re: [PWE3] Control words in the architecture draft
>
>
>
>
>Shahram Davari wrote:
>> Matthew,
>>

---

From: Shahram Davari <[email-masked]>
Date: Wed, 2 Apr 2003 11:39:34 -0800

So you are proposing to change the 1:1 and PDU mode header as well as the SONET header
to match Bryant's control word?

-Shahram

>From: Eric Rosen [mailto:[email-masked]]
>Sent: Wednesday, April 02, 2003 2:38 PM
>To: Shahram Davari
>Cc: [email-masked]'; [email-masked]'; [email-masked]
>Shahram> In ATM Encap draft you have 3 types of control word: 
>
>Indeed, it's hard  to see how the  ATM draft can be advanced  
>in its current
>hodgepodge state.  Many people have pointed out how ridiculous 
>it is to have
>simply incorporated all the different proposals.
>
>Shahram>  Ethernet  draft does  not use  FRG, PID  or length,  
>instead these
>Shahram>  fields are reserved.  
>
>Well,  this is  an  example of  the  sort of  inconsequential 
>but  confusing
>differences that have crept in.  Specifying  this sort of 
>thing in one place
>is  supposed   to  eliminate  these  gratuitous   differences. 
>  There's  no
>substantive  difference between  the  ethernet draft  and  
>what Stewart  has
>proposed.
>
>
>
>
>

---

From: [email-masked]
Date: Thu, 3 Apr 2003 10:33:54 +0100

Stewart,

The fundamental problem is that I don't believe that bits and bytes
positioning in the control word should be in the architecture document.
This is an encap issue, and I would be quite happy to see technical
justifications for this added to the individual encap drafts for *all* of
the encapsulations. The position of the sequence number and flags is only
of concern to the PEs that would have to implement the rest of the
service-specific encapsulation anyway. The only thing that seems to be of
concern to the core routers is if we implement a PID, which I believe can
be accomodated in all the control word designs we have today (the 1:1 and
PDU modes in ATM have the first octet reserved, just as in Ethernet).

Cheers,

Matthew

                    Stewart                                                                                                                   
                    Bryant               To:     Shahram Davari <[email-masked]>                                               
                    <stbryant@cis        cc:     Matthew BOCCI/GB/ALCATEL@ALCATEL, [email-masked]                                              
                    co.com>              Subject:     Re: [PWE3] Control words in the architecture draft                                      
                    Sent by:                                                                                                                  
                    pwe3-admin@ie                                                                                                             
                    tf.org                                                                                                                    

                    03/04/2003                                                                                                                
                    09:35                                                                                                                     
                    Please                                                                                                                    
                    respond to                                                                                                                
                    stbryant                                                                                                                  

> Note that in 1:1 and PDU mode the flags are after the length/sequence #.

With no technical justification in the text, and against a background
of prior art that had useful properties for the Internet.

Perhaps it should go back for re-design?

> 2) Sonet draft does not use any FRG, PID or length, instead it uses a
pointer

Indeed, and the SONET draft describes the technical basis for this.

> 3) Ethernet draft does not use FRG, PID or length, instead these fields
are reserved.

This is just muddying the water. The draft needs only minor edits to
conform, and no implementation changes. I know that most Ethernets can
handle long frames, but to cover the general Ethernet case the draft
should have some text on FRG.

> 4) I am not sure any future PW could in fact use only the header that you
have shown

The important point is that the text sets a baseline. If there is a sound
reason to deviate from the baseline the text makes it clear that is OK. The
only issue is with encapsulations that deviate from the standard without
good
reason.

> the text regarding PID that you mentioned.

The changes have been discussed at two IETFs (look at the minutes), and on
the
mailing list.

Stewart

>>>I agree with you . It seems that figure 11 was corrected but
>>
>>not Figure 12.
>>
>>>My suggestion is to delete section 5.4.3, because as you
>>
>>said it is not generic,
>>
>>>and for example there is no structure pointer in it that is
>>
>>used for TDM/Sonet
>>
>>>draft, or that the size and position of other fields are not
>>
>>necessarily the same
>>
>>>in all PW types.
>>>
>>
>>I disagree.
>>
>>>PS- BTW I noticed that the PWE3 website lists older version
>>
>>of this draft, when
>>
>>>>From: [email-masked]
>>>
>>[mailto:[email-masked]]
>>
>>>>generic at all and does not accomodate the design decisions
>>>
>>made for a
>>

---

From: Shahram Davari <[email-masked]>
Date: Thu, 3 Apr 2003 07:27:00 -0800

>Perhaps it should go back for re-design?

That is a separate issue. What currently exist does not match your draft.
Perhaps you should start an thread and try to achieve a consensus to change all those
drafts before introducing a single generic header in architecture draft.

>Indeed, and the SONET draft describes the technical basis for this.

So, if SONET header, which is different than Generic PW header, is OK then what does "Generic PW header mean"?

>should have some text on FRG.

I again suggest that you first try to achieve consensus on changing this
draft and not assume such consensus in advance.

>only issue is with encapsulations that deviate from the 
>standard without good
>reason.

I am not sure the position of bits/bytes should be part of the architecture
draft. Perhaps you could mention that it is desirable to have a single
control word.

>The changes have been discussed at two IETFs (look at the 
>minutes), and on the 
>mailing list.

There is a difference between "discussion" and "consensus".
I don't remember any consensus on this subject. In fact when
Yaakov Stein in IETF 55 suggested a single control word for
all PW types, it was heavily objected.

-Shahram

---

From: "Yaakov Stein" <[email-masked]>
Date: Thu, 3 Apr 2003 18:47:56 +0300

> justifications for this added to the individual encap drafts 
> for *all* of the encapsulations. 

Matthew, 

While I think you are right in principle
that an architecture document should not get into
the bit positions, we simply don't have any other
common document for all encapsulations
where this could be put.

Unlike all the other encap issues, the control word 
is rather generic in functionality (although each
service will have its own flags).
I don't see any reason for each encap type to 
specify its own bit positionings for essentially
the same information.

We are a single WG and should be able to
come up with a single solution for all
the parts which are common to all the services.

Y(J)S

---

From: Eric Rosen <[email-masked]>
Date: Thu, 03 Apr 2003 11:21:43 -0500

Shahram> In fact  when Yaakov  Stein in IETF  55 suggested a  single control
Shahram> word for all PW types, it was heavily objected. 

I'd  have said  "lightly objected",  I  think there  were only  a couple  of
objections.  

In judging consensus, one has to  take into account more than just the noise
level; to  judge lack  of consensus, I  think one  has to take  into account
whether there are technical arguments on both sides. 

On the  issue of the  ethernet draft,  I have yet  to see an  objection from
anyone who  has been involved  with that draft  or even anyone who  has ever
shown interest in that draft.  So the  issue of "but we'd have to change the
picture in the ethernet encaps draft" is just a red herring.

I think that  WG consensus is required in order to  advance a document along
the process.  But  I don't think it is required for  every single release of
the document.  I also think that  WG consensus is a criterion applied to the
technical content of  the document, not necessarily to the  way in which the
documents are  organized, or to the  way in which the  agreed upon technical
material is divided among the set of documents. 

Matthew> the 1:1 and PDU modes in ATM have the first octet reserved, just as
Matthew> in Ethernet 

I  couldn't find  this  in the  ATM encaps  draft;  where does  it say  that
exactly?

---

From: [email-masked]
Date: Fri, 4 Apr 2003 10:28:03 +0100

Eric,

With regard to your point about the 1:1 and PDU modes in the ATM draft, the
length field is not used for either of these modes because the length is
always greater than the minimum transfer unit on an ethernet link.
Therefore,  this field becomes reserved and is set to all zeros (I agree
that the text in the current version of the draft needs to be clarified).
This means that there are 4 bits in exactly the same position as the
martini control word that could be used for PID.

Bets regards,

Matthew

                                                                                                                                              
                    Eric Rosen                                                                                                                
                    <erosen@cisco        To:     Shahram Davari <[email-masked]>                                               
                    .com>                cc:     "[email-masked]'" <[email-masked]>, Matthew BOCCI/GB/ALCATEL@ALCATEL, [email-masked] 
                    Sent by:             Subject:     Re: [PWE3] Control words in the architecture draft                                      
                    pwe3-admin@ie                                                                                                             
                    tf.org                                                                                                                    

                    03/04/2003                                                                                                                
                    17:21                                                                                                                     
                    Please                                                                                                                    
                    respond to                                                                                                                
                    erosen                                                                                                                    

Shahram> In fact  when Yaakov  Stein in IETF  55 suggested a  single
control
Shahram> word for all PW types, it was heavily objected.

I'd  have said  "lightly objected",  I  think there  were only  a couple
of
objections.

In judging consensus, one has to  take into account more than just the
noise
level; to  judge lack  of consensus, I  think one  has to take  into
account
whether there are technical arguments on both sides.

On the  issue of the  ethernet draft,  I have yet  to see an  objection
from
anyone who  has been involved  with that draft  or even anyone who  has
ever
shown interest in that draft.  So the  issue of "but we'd have to change
the
picture in the ethernet encaps draft" is just a red herring.

I think that  WG consensus is required in order to  advance a document
along
the process.  But  I don't think it is required for  every single release
of
the document.  I also think that  WG consensus is a criterion applied to
the
technical content of  the document, not necessarily to the  way in which
the
documents are  organized, or to the  way in which the  agreed upon
technical
material is divided among the set of documents.

Matthew> the 1:1 and PDU modes in ATM have the first octet reserved, just
as
Matthew> in Ethernet

I  couldn't find  this  in the  ATM encaps  draft;  where does  it say
that
exactly?

---

From: "Yaakov Stein" <[email-masked]>
Date: Sun, 6 Apr 2003 08:59:42 +0300

Matthew, 

> Eric,
> 
> With regard to your point about the 1:1 and PDU modes in the 
> ATM draft, the length field is not used for either of these modes because 
> the length is always greater than the minimum transfer unit on an ethernet link.

Why?

>From section 6.6 (ATM VCC Cell Transport Service) 
for the 1:1 single cell VCC case we have
 a 48 byte payload,
 one byte "ATM specific", 
 three more bytes for the "optional" SN and length
  (and I think the diagram in atm-encap is misleading,
   since the text states that the content is optional, 
   but the field still remains with zeros)
 four bytes for the PW header
 four bytes for the MPLS transport header (if there is one)
 for a total of 60 bytes (but possibly only 56).

So the length may be less than 64,
and can even be less than 64 and nonunique.

> Therefore,  this field becomes reserved and is set to all zeros.

That's an interpretation, but not clear in the text.

> martini control word that could be used for PID.

But that would completely undermine the mechanism presently used for
determining whether the length is used.

Y(J)S

---

From: [email-masked]
Date: Mon, 7 Apr 2003 13:44:43 +0100

Yakov,

Please see below for clarification.

Best regards,

Matthew

                    "Yaakov                                                                                        
                    Stein"               To:     Matthew BOCCI/GB/ALCATEL@ALCATEL, <[email-masked]>              
                    <yaakov_s@rad        cc:     <[email-masked]>, "Shahram Davari"                                 
                    .com>                <[email-masked]>, <[email-masked]>                     
                                         Subject:     RE: [PWE3] Control words in the architecture draft           
                    06/04/2003                                                                                     
                    06:59                                                                                          

Matthew,

Why?

MB> Yes, but in 1:1 single cell mode you know that there is only one cell,
so you implicitly know how long the payload is. Therefore, the length field
is redundant.

MB> I agree that this needs clarifying.

MB > The length is never used in 1:1 or PDU mode.

Y(J)S

---

From: "Ghassem Koleyni" <[email-masked]>
Date: Mon, 7 Apr 2003 10:26:24 -0400

Yaakov,

When discussing minimum length of 64 octets you should consider size of
Ethernet header too. So, when a single cell (48 octets, plus any octets
containing complete or partial PCI) is transported, the minimum length
exceeds 64.

Best regards, 

Ghassem Koleyni                             Nortel Networks
Tel: (613) 763-4154                           3500 Carling Ave.
Fax: (613) 765-6295                          Ottawa, Canada K1Y 4H7
Internet: [email-masked]     http://www.nortelnetworks.com 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, April 07, 2003 8:45 AM
To: Yaakov Stein
Cc: [email-masked]; [email-masked]; Shahram Davari; [email-masked]
Subject: RE: [PWE3] Control words in the architecture draft

Yakov,

Best regards,

Matthew

                    "Yaakov

                    Stein"               To:     Matthew
BOCCI/GB/ALCATEL@ALCATEL, <[email-masked]>             
                    <yaakov_s@rad        cc:     <[email-masked]>, "Shahram
Davari"                                
                    .com>                <[email-masked]>,
<[email-masked]>                    
                                         Subject:     RE: [PWE3] Control
words in the architecture draft          
                    06/04/2003

                    06:59

Matthew,

Why?

Y(J)S

---

From: "Yaakov Stein" <[email-masked]>
Date: Tue, 8 Apr 2003 08:55:31 +0300

Ghassem, 
 
I stand corrected.
 
Taking the 2 MACs, length, and FCS into account, 
the minimum length is 46 bytes, conveniently below
the 48 bytes of the ATM cell payload.
 
So there is never a need to use a length field 
in any ATM-over-X-over-Ethernet packet.
 
Y(J)S

-----Original Message-----
From: Ghassem Koleyni [mailto:[email-masked]]
Sent: Monday, April 07, 2003 5:26 PM
To: [email-masked]'; Yaakov Stein
Cc: [email-masked]; [email-masked]; Shahram Davari; [email-masked]
Subject: RE: [PWE3] Control words in the architecture draft

Yaakov, 

When discussing minimum length of 64 octets you should consider size of Ethernet header too. So, when a single cell (48 octets, plus any octets containing complete or partial PCI) is transported, the minimum length exceeds 64.

Best regards, 

-----Original Message----- 
From: [email-masked] [ mailto:[email-masked]] 
Sent: Monday, April 07, 2003 8:45 AM 
To: Yaakov Stein 
Cc: [email-masked]; [email-masked]; Shahram Davari; [email-masked] 
Subject: RE: [PWE3] Control words in the architecture draft 

Yakov, 

Best regards, 

Matthew 

                    "Yaakov                                                                                       

Matthew, 

Why? 

Y(J)S