Subject: RE: Re: SONET/SDH header issues and proposed resolution (l ong)

From: Sasha Vainshtein <[email-masked]>
Date: Tue, 15 Apr 2003 20:03:00 +0200

Andy and Stewart,
Please see some questions/comments inline.

----------------------------------------------------------------------------
--------
With best regards,
                          Sasha Vainshtein
email:   [email-masked] <mailto:[email-masked]> 
phone:  +972-3-7659993 (office)
            +972-8-9254948 (home)
            +972-58-674833 (cellular)

> -----Original Message-----
> From: Andrew G. Malis [mailto:[email-masked]]
... snipped ...
> 
>     To disambiguate the PW from an IP flow the PW MAY either employ
>
I suggest to replace MAY with SHOULD in the statement above. IMO, this 
would be consistent with the text below.
>
>     the Generic PW Control Word shown in Figure 12 or an MPLS payload
>     type identifier (see Section 5.4.4):
> 
>           0                   1                   2           
>         3
>           0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 
> 6 7 8 9 0 1
>          
> +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>          |0 0 0 0|          Specified by PW Encapsulation     
>            |
>          
> +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
> 
>          Figure 12: Generic PW Control Word
> 
>     Note that not all PWE3 encapsulations over MPLS use this 
> control word 
> format.
>     For example, the SONET/SDH encapsulation uses a different 
> control word 
> format.
>
I would add that some encapsulations do not use CW at all, and
some use RTP header.
>
>     In the general case, if the MPLS payload does not begin 
> with a control word
>     as illustrated in Figure 12, then the payload MUST begin 
> with an MPLS 
> payload
>     type identifier.  There is one exception to this 
> requirement; if a service
>     provider is not using ECMP, then the provider SHOULD be 
>
I am not sure this text in unambiguous. E.g., the (PW) service
provider may noy use ECMP. However, the PW may be tunneled across
a carrier's carrier network (providing this service to the provider
of the PW servvice) and this network may use ECMP without the PW
service provider being aware of the fact.

Hence I suggest the following alternative text:

--------alternative text begins --------------------
The PW service provider MAY suppress, by configuration, the usage
of the MPLS PID at the two ends of the PW (taking full responsibility
for possible side effects of ECMP being used in the network between
the pair of PEs terminating such a PW).
--------alternative text ends   --------------------

>
> able to use
>     provisioning to suppress the transmission of the MPLS 
> payload type 
> identifier.
... snipped to the end ...

---

From: Shahram Davari <[email-masked]>
Date: Tue, 15 Apr 2003 11:37:38 -0700

>I would add that some encapsulations do not use CW at all, and

Stewart, I think you need to clarify whether RTP header should be before or after
the CW. Currently section 5.4.2 shows it after the CW. In other words we need to clarify whether
PW is a payload of RTP or RTP is a payload of PW?

>--------alternative text ends   --------------------

As you said since in a multi-provider environment no one can guarantee
that ECMP won't be used, then MPLS PID should be necessary. So I think
Andy's text is capturing that very well.

-Shahram