Subject: Re: PWE3 requirements draft, version 5

From: Mustapha Aissaoui <[email-masked]>
Date: Wed, 02 Apr 2003 12:19:02 -0500

Akiva,
sorry for this late reply but I a catching up with my emails. See below.

Mustapha.
-----------

Akiva Sadovski wrote:

> Mustapha, Xipeng and all,
>
> About:
>
> > >  > Section 5.3: paragraph 8, last sentence says: "If a PE needs to
> > >  > generate and send a maintenance message to a remote PE, the
> > >  > maintenance message MUST be sent via the control plane,
> > not via the
> > >  > PW"
>
>   IMHO maintenance information may be passed from PE to PE not only in
> separate messages
> but also via CW bits (f.ex. N and P bits in draft-ietf-pwe3-sonet-01).
> Should this kind of
> communication be restricted or prohibited ? I doubt...
>
> Have i missed something ?

If is is in the control word, then I would assume it is inband since the
maintenance information is sent within the same channel as the user
information.

>
>
> > -----Original Message-----
> > From: Mustapha Aissaoui [mailto:[email-masked]]
> > Sent: Wednesday, March 19, 2003 8:26 PM
> > To: Xipeng Xiao
> > Cc: [email-masked]; Thomas D. Nadeau
> > Subject: Re: [PWE3] PWE3 requirements draft, version 5
> >
> >
> > Xipeng,
> > when OAM messages are sent inband, they travel within the PW. You
> > are referring to out-of-band maintenance. We should allow both
> > inband and out-of-band maintenance messages.
> >
> > Mustapha.
> > -----------
> > Xipeng Xiao wrote:
> > >
> > > Mustapha,
> > >
> > > Thank you for your comments!  One response below.
> > >
> > >  > Section 5.3: paragraph 8, last sentence says: "If a PE needs to
> > >  > generate and send a maintenance message to a remote PE, the
> > >  > maintenance message MUST be sent via the control plane,
> > not via the
> > >  > PW"
> > >  > Where does this requirement come from? This is too
> > restrictive. We
> > >  > should allow the option to send a maintenance message
> > over the PW.
> > >
> > > A maintenance message is a control plane thing.  It has to
> > stay inside the control plane.
> > >
> > > We will consider your other suggestions.
> > _______________________________________________
> > pwe3 mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/pwe3
> >

---

From: Akiva Sadovski <[email-masked]>
Date: Mon, 7 Apr 2003 17:59:55 +0200

Mustapha,
  (also cleaning my mailbox)
  thank you for your clarifications,

so the PE-generated maintenance "messages" may be sent to the remote PE:
-- via the control plane 
-- via the data plane along with payload
-- as the PW's CW flags 

however, the draft-ietf-pwe3-requirements specifies only one way of
maintenance messages
sending - via the control plane. Why ? What's wrong with signalling local AC
states via
the CW flags ?

thanks,
  Akiva

> Sent: Wednesday, April 02, 2003 7:19 PM
> To: Akiva Sadovski
> Cc: Xipeng Xiao; [email-masked]; Thomas D. Nadeau