Subject: RE: PWE3 requirements

From: "Xipeng Xiao" <[email-masked]>
Date: Thu, 3 Apr 2003 15:40:18 -0800

Hi Stewart,

I will look into this.

regards,

XiPeng

 > -----Original Message-----
 > From: Stewart Bryant [mailto:[email-masked]]
 > Sent: Monday, March 31, 2003 8:27 AM
 > To: Xipeng Xiao; Danny McPherson; Prayson Pate; [email-masked]
 > Subject: PWE3 requirements
 > 
 > 
 > 
 > 
 > The Requirements document says nothing about the issue
 > of a PW aliasing an IP packet (the CW PID issue). It
 > is clear from comments on the list that a PW that
 > does not take this into account will be subject to
 > disruption when traversing an ECMP enabled MPLS core, and
 > I raised concerns about psamp/ipfix.
 > 
 > I think that there needs to be a requirement added to
 > to the effect that a PW must operate correctly over a PSN
 > that provides ECMP, and a possibly a requirement that
 > allows IP flow monitoring. Whether this gets resolved in
 > PWE3 or in MPLS is OoS, but as PWE3 is the first payload
 > that he IETF has defined that has this problem, it
 > generates the requirement.
 > 
 > Something like:
 > 
 > "If the PSN uses an ECMP or IP flow recognition method,
 > then the PW encapsulation must use a method discriminating
 > between itself and an IP flow"
 > 
 > My personal view is that we should always provide the
 > discrimination (because that is future proof), but the
 > text I suggest above says:
 > 
 > "Discriminate if your network needs it. How you discriminate
 > is up to you i.e. in the CW or by an MPLS extension"
 > 
 > Stewart
 > 
 >

---

From: "Yaakov Stein" <[email-masked]>
Date: Sun, 6 Apr 2003 09:06:00 +0300

> At the moment we only have 3 payload types, IPv4, IPv6 and PW.
> We cannot make the assumption that there will not be another
> of interest to a core router at some time in the future.
> 

I still really don't understand why "PW" is a type.

As splendidly explained in the architecture draft,
there are many different types of PWs.
Some have real-time constraints, some don't.
Some require sequencing, some don't.
Etc.

Why are these completely different PWs more alike
than IPv4 and IPv6, which are equivalent services
with equivalent requirements, differing only in the length
of their headers?

Y(J)S

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 07 Apr 2003 09:45:21 +0100

> I still really don't understand why "PW" is a type.

Well technically it is a class.

> with equivalent requirements, differing only in the length

The issue is that we are stealing IP's very small
historic version number space to discriminate IP from PW.
If you want fine grained distinction the MPLS payload
identifier can carry it.

Perhaps the better way to look at it is:

0x0        Undisclosed MPLS payload
0x1        Identified by MPLS payload identifier
0x2        Reserved for allocation by IANA
0x3        Reserved for allocation by IANA
0x4        IPv4
0x5        ?????
0x6        IPv6
0x7..0xF   Reserved for allocation by IANA

Stewart

> 
> 
> Y(J)S
> 
> 
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
> 
>

---

From: "Yaakov Stein" <[email-masked]>
Date: Mon, 7 Apr 2003 16:51:50 +0300

> 0x7..0xF   Reserved for allocation by IANA

Agreed.

I suggest putting that specifically into the architecture draft.

Then, later drafts can suggest how best to use the limited
identifier space.

Y(J)S