Subject: Re: Control words in the architecture draft

From: Eric Rosen <[email-masked]>
Date: Wed, 02 Apr 2003 14:37:31 -0500

Shahram> In ATM Encap draft you have 3 types of control word: 

Indeed, it's hard  to see how the  ATM draft can be advanced  in its current
hodgepodge state.  Many people have pointed out how ridiculous it is to have
simply incorporated all the different proposals.

Shahram>  Ethernet  draft does  not use  FRG, PID  or length,  instead these
Shahram>  fields are reserved.  

Well,  this is  an  example of  the  sort of  inconsequential but  confusing
differences that have crept in.  Specifying  this sort of thing in one place
is  supposed   to  eliminate  these  gratuitous   differences.   There's  no
substantive  difference between  the  ethernet draft  and  what Stewart  has
proposed.

---

From: Luca Martini <[email-masked]>
Date: Wed, 02 Apr 2003 15:54:50 -0700

Shahram Davari wrote:
> I wonder how can one disagree with the following facts:
> 
> 1) In ATM Encap draft you have 3 types of control word: (N:1=SDU, 1:1, PDU)
> Note that in 1:1 and PDU mode the flags are after the length/sequence #.
> 
> 2) Sonet draft does not use any FRG, PID or length, instead it uses a pointer
> 
> 3) Ethernet draft does not use FRG, PID or length, instead these fields are reserved.
> 
> 4) I am not sure any future PW could in fact use only the header that you have shown
> 

the reserved field can be easily converted to PID, since that is why we were 
keeping them reserved. If a field is not used for a particular protocol the CW 
still fits the general architecture.

> Also it seems to me that since this draft is a WG draft, it needs WG consensus to
> add/remove any text. So I assume you will wait for the consensus before adding
> the text regarding PID that you mentioned.
> 
Yes, but I have not seen much opposition, only lot's of arguing, but it seems 
to me that we have not made a sufficient argument for not using this PID.

All we have is "we could do better". But right now , without major changes to 
the working and deployed code this simple solution can work pretty well.

Maybe we should have renamed it as I proposed a while back to class of traffic, 
  (COT) not PID would that make it better ? :-)

Luca

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 03 Apr 2003 09:35:18 +0100

> Note that in 1:1 and PDU mode the flags are after the length/sequence #.

With no technical justification in the text, and against a background
of prior art that had useful properties for the Internet.

Perhaps it should go back for re-design?

> 2) Sonet draft does not use any FRG, PID or length, instead it uses a pointer

Indeed, and the SONET draft describes the technical basis for this.

> 3) Ethernet draft does not use FRG, PID or length, instead these fields are reserved.

This is just muddying the water. The draft needs only minor edits to
conform, and no implementation changes. I know that most Ethernets can
handle long frames, but to cover the general Ethernet case the draft
should have some text on FRG.

> 4) I am not sure any future PW could in fact use only the header that you have shown

The important point is that the text sets a baseline. If there is a sound
reason to deviate from the baseline the text makes it clear that is OK. The
only issue is with encapsulations that deviate from the standard without good
reason.

> the text regarding PID that you mentioned.

The changes have been discussed at two IETFs (look at the minutes), and on the 
mailing list.

Stewart

> 
> -Shahram
> 
> 
>>-----Original Message-----
>>From: Stewart Bryant [mailto:[email-masked]]
>>Sent: Wednesday, April 02, 2003 1:35 PM
>>To: Shahram Davari
>>Cc: [email-masked]'; [email-masked]
>>Subject: Re: [PWE3] Control words in the architecture draft
>>
>>
>>
>>
>>Shahram Davari wrote:
>>
>>>Matthew,
>>>
>>>I agree with you . It seems that figure 11 was corrected but 
>>
>>not Figure 12.
>>
>>>My suggestion is to delete section 5.4.3, because as you 
>>
>>said it is not generic,
>>
>>>and for example there is no structure pointer in it that is 
>>
>>used for TDM/Sonet
>>
>>>draft, or that the size and position of other fields are not 
>>
>>necessarily the same
>>
>>>in all PW types.
>>>
>>
>>I disagree.
>>
>>Unless there are documented technical reasons to do otherwise 
>>the encaps
>>should follow the recommended style. This then leaves most of 
>>the encaps
>>to just specify their use of the flags. The only TECHNICAL case that I
>>have seen to use another CW dsign is the TDM need for a long pointer.
>>
>>The revised version of 5.4.3 also discusses the need for discrimination
>>between IP and PW, and shows how the Martini CW design and the MPLS
>>payload identifier (needed for non-MArtini CWs) each achieve this.
>>
>>Stewart
>>
>>
>>
>>
>>
>>>Yours,
>>>-Shahram
>>>
>>>PS- BTW I noticed that the PWE3 website lists older version 
>>
>>of this draft, when
>>
>>>it was called draft-ietf-pwe3-protocol-layer-00.txt.
>>>
>>>Danny, you may want to correct this.
>>>
>>
>>We will fix this.
>>
>>Stewart
>>
>>
>>>
>>>
>>>
>>>>-----Original Message-----
>>>>From: [email-masked] 
>>>
>>[mailto:[email-masked]]
>>
>>>>Sent: Wednesday, April 02, 2003 12:21 PM
>>>>To: [email-masked]
>>>>Subject: [PWE3] Control words in the architecture draft
>>>>
>>>>
>>>>I have a question about section 5.4.3. of 
>>>>draft-ietf-pwe3-arch-02.txt. This
>>>>is the section that shows a PW over MPLS Generic Control Word. 
>>>>We already
>>>>have different control words for some applications, including 
>>>>TDM and some
>>>>of the ATM modes.
>>>>
>>>>There was a lot of discussion back arount IETF 55 about 
>>>>whether the control
>>>>word should be moved from the individual encap drafts into the 
>>>>architecture
>>>>document, and if so what text should be moved. My 
>>>>understanding was that
>>>>the functionality of the control word could be described in the
>>>>architecture document (since this is generic), but that the 
>>>>positioning of
>>>>the bits and bytes would remain in the individual encap 
>>>>drafts. However,
>>>>the 'generic' control word shown in the architecture draft is 
>>>>not really
>>>>generic at all and does not accomodate the design decisions 
>>>
>>made for a
>>
>>>>number of the encapsulations.
>>>>
>>>>We could simply move all of the different control words into the
>>>>architecture draft, but that would be confusing since the 
>>>>encapsulations
>>>>would be spread across multiple documents.
>>>>
>>>>Would it not be clearer for the architecture draft to describe 
>>>>the need for
>>>>and functonality of the control word, but to leave diagrams of its
>>>>structure to the individual encap drafts?
>>>>
>>>>Regards,
>>>>
>>>>Matthew
>>>>
>>>>
>>>>
>>>>-----------------------------------------
>>>>Matthew Bocci
>>>>Office of the CTO
>>>>Alcatel Fixed Networks Division
>>>>-----------------------------------------
>>>>
>>>>_______________________________________________
>>>>pwe3 mailing list
>>>>[email-masked]
>>>>https://www1.ietf.org/mailman/listinfo/pwe3
>>>>
>>>
>>>_______________________________________________
>>>pwe3 mailing list
>>>[email-masked]
>>>https://www1.ietf.org/mailman/listinfo/pwe3
>>>
>>>
>>
>>
> 
>