Subject: RE: Accept draft-nadeau-pwe3-vccv-01.txt as a WG document?

From: "David Allan" <[email-masked]>
Date: Wed, 16 Jul 2003 09:54:25 -0400

None Tom????? Were we in the same room?

> -----Original Message-----
> From: Thomas D. Nadeau [mailto:[email-masked]] 
> Sent: Wednesday, July 16, 2003 9:51 AM
> To: [email-masked]
> Cc: 'George Swallow'; [email-masked]; 'Danny McPherson'; 
> 'Monique Morrow (mmorrow)'
> Subject: [PWE3] Accept draft-nadeau-pwe3-vccv-01.txt as a WG document?
> 
> 
> 
> 	There was a good show of hands
> (fronts only) in favor of support to adopt 
> the draft-nadeau-pwe3-vccv-01.txt as a
> PWE3 working group document, and none
> against. The chairs asked that we "take 
> it to the list" to confirm.
> 
> 	--Tom
> 
> 
> 
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
>

---

From: Danny McPherson <[email-masked]>
Date: Wed, 16 Jul 2003 07:56:18 -0600

Although I didn't see any hands it seems there may have been one (some).

If anyone has objections to adopting VCCV as a WG item please speak say so
now.

-danny

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Wed, 16 Jul 2003 10:07:34 -0400

My appologies. I might not have seen
you when I looked around.

	--Tom

> From: David Allan [mailto:[email-masked]] 
> Sent: Wednesday, July 16, 2003 9:54 AM
> To: [email-masked]'; [email-masked]
> Subject: RE: [PWE3] Accept draft-nadeau-pwe3-vccv-01.txt as a 
> WG document?
> 
>

---

From: "David Allan" <[email-masked]>
Date: Wed, 16 Jul 2003 10:26:20 -0400

There was other than me that I saw...presumably if they have an issue,
they'll speak up. 

My concern would be how the L2TP aspects are coordinated with that WG if
there are LSP-PING modifications specifically for L2TP. VCCV currently
adopts MPLS and IP tools that are sourced elsewhere. I'd appreciate if Mark
T. or some other suitably qualified individual commented.

cheers
Dave

> Sent: Wednesday, July 16, 2003 10:08 AM
> To: Allan, David [CAR:NS00:EXCH]; [email-masked]

---

From: [email-masked]
Date: Wed, 16 Jul 2003 18:47:21 +0100

Tom....just so you are clear....we don't want any of this stuff.  We want to
manage the *LSPs* in a consistent manner *irrespective* of the client.  The
PWE3 stuff is now completely overblown...what ought to be simple
client->server adaptation has now too many functional components.  None of
which are strictly required *if* the truly broken stuff (which lies
elsewhere) is deprecated, and we accept that MPLS is not = IP...if not true
why bother with MPLS at all?  There are no sound arch reasons why XoverIP
must be the same as XoverMPLS....and IP and MPLS can provide different
functional behaviours and this 'good' not 'bad'.
 
We'll live with the problems of LDP mp2p for now, but please don't keep
building on them like this is 'right' for the future.
 
I am particulary curious to know why, for p2p LSPs, you can't accept Y.1711
as a solution (and which is complete in terms of defects and availability
definitions) but instead feel compelled to draft a further OAM solution for
the 'adapatation' layer (which is far from complete)......and which as I
stated should have very little functionality of this sort anyway.
 
regards, Neil

-----Original Message-----
From: David Allan [mailto:[email-masked]]
Sent: 16 July 2003 14:54
To: [email-masked]'; [email-masked]
Cc: 'George Swallow'; [email-masked]; 'Danny McPherson'; 'Monique Morrow
(mmorrow)'
Subject: RE: [PWE3] Accept draft-nadeau-pwe3-vccv-01.txt as a WG document?

> From: Thomas D. Nadeau [ mailto:[email-masked]
<mailto:[email-masked]> ] 
> it to the list" to confirm. 
<https://www1.ietf.org/mailman/listinfo/pwe3>

---

From: "Busschbach, Peter B (Peter)" <[email-masked]>
Date: Thu, 17 Jul 2003 04:51:50 -0400

Tom,

I have two comments on the draft:

1) Regarding the MPLS case, I think there should be an option to indicate that the reply message should be sent over the "return LSP", i.e. the other half of the PW under test. The LSP-ping draft doesn't allow for the option to send a reply through the MPLS data plane, and hence the option should be added to the VCCV draft.

2) On the mailing list we discussed the option of uni-directional connectivity checks. This is covered by the "no-reply" option, which you explicitly mention in the draft. However, IMO you need a more complete description if you would want to use this option for propoer fault managent. E.g. (1) how do the sender and receiver agree on the frequency of sending messages; (2) when do you declare a failure? How many messages do you need to miss to conclude that the PW is down and how many messages do you need to receive to conclude that it is back up?

Otherwise, I agree with making this draft a WG document.

Peter

> Cc: 'George Swallow'; [email-masked]; 'Danny McPherson'; 'Monique
> Morrow (mmorrow)'

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 17 Jul 2003 07:11:25 -0400

Hi Peter,
 
> 1) Regarding the MPLS case, I think there should be an option 
> to indicate that the reply message should be sent over the 
> "return LSP", i.e. the other half of the PW under test. The 
> LSP-ping draft doesn't allow for the option to send a reply 
> through the MPLS data plane, and hence the option should be 
> added to the VCCV draft.

	Yes, this was an omission on our part. Will fix in
the next revision.
 
> 2) On the mailing list we discussed the option of 
> uni-directional connectivity checks. This is covered by the 
> "no-reply" option, which you explicitly mention in the draft. 
> However, IMO you need a more complete description if you 
> would want to use this option for propoer fault managent. 
> E.g. (1) how do the sender and receiver agree on the 
> frequency of sending messages; (2) when do you declare a 
> failure? How many messages do you need to miss to conclude 
> that the PW is down and how many messages do you need to 
> receive to conclude that it is back up?

	Agreed.

	Thanks for your comments.

	--Tom

---

From: [email-masked]
Date: Sat, 19 Jul 2003 16:03:23 +0200

hi thomas, i agree to make this a wg document,

also one or two comments that you may want to take
into account in the next revision:

- in the following sentence, i guess that LSR refers to
   the receving PE "In this case, the LSR SHOULD increment
   an error counter and optionally issues a system and/or
   SNMP notification to indicate to the system administrator
   that a mis-configuration exists."

- in section 4.2.1 it is difficult to map the description
   of the tlv with the field, additional details wouldn't
   be superfluous here

- i don't see what you mean by the following sentence
   "The requesting PE MAY indicate multiple *IP control*
   IP control channel options."

- seems appropriate to indicate to which spec. you refer
   to "older" in the following sentence "This last method
   MUST be supported by all PEs in order to handle backward-
   compatibility with older PEs."

- does the following mean that you would allow for a
   complete review "If the requesting PE wishes to continue,
   it may choose different options and try to signal the
   PE again." you may want to recommend a preferred method
   here ?

some edito's:
- i would explain a bit more what's meant by the last part
   of the following sentence "Packets sent across this
   channel are IP packets, allowing maximum flexibility."
   in ... ?
- "These messages, referred
    to as VCCV messages, are exchanged only after the desire to
    exchange such traffic has been negotiated between the PEs
    (see section 8)."
   -> section 8 is "references"
- vccv parameters cc types (same for the vc types):
   "0x1  OAM Flag set in PWE header
    0x2  MPLS Router Alert Label"
   is it 0x01 or Ox10 ?

thanks,
- dimitri.

Thomas D. Nadeau wrote:

>>>Cc: 'George Swallow'; [email-masked]; 'Danny 
>>
>>McPherson'; 'Monique 
>>
>>>Morrow (mmorrow)'
>>>Subject: [PWE3] Accept draft-nadeau-pwe3-vccv-01.txt as a 
>>
>>WG document?
>>
>>>
>>>

-- 
Papadimitriou Dimitri
E-mail : [email-masked]
Private: http://www.rc.bel.alcatel.be/~papadimd/index.html
E-mail : [email-masked]
Public : http://psg.com/~dpapadimitriou/
Address: Fr. Wellesplein 1, B-2018 Antwerpen, Belgium
Phone  : +32 3 240-8491

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Tue, 22 Jul 2003 15:08:18 -0400

Thanks for the comments. Will incorporate them
in the next edits.

	--Tom

> From: [email-masked] 
> [mailto:[email-masked]] 
> Sent: Saturday, July 19, 2003 10:03 AM
> To: [email-masked]
> Cc: 'Busschbach, Peter B (Peter)'; [email-masked]; 'George 
> Swallow'; [email-masked]; 'Danny McPherson'; 'Monique 
> Morrow (mmorrow)'
> Subject: Re: [PWE3] Accept draft-nadeau-pwe3-vccv-01.txt as a 
> WG document?
> 
>