Subject: STTP - slides for IETF-57

From: Alik Shimelmits <[email-masked]>
Date: Wed, 16 Jul 2003 03:11:28 +0200

Yaakov,
I just looked at your slides and very "emotional" description of CESoPSN.

I would propose for fairness sake at least to mention that STTP actually for

emulation of unstructured T1/E1 borrows CESoPSN approach, i.e. "raw
encapsulation" 
and not AAL1-based. And I agree that it is simple approach.

That somehow contradicts with draft-anavi-..-05, paragraph 4 that states:
"Raw encapsulation is only advisable for high quality networks carrying 
unstructured TDM traffic... AAL1 is thus best for unstructured 
trunks...". 

CESoPSN is simple - you somehow mentioned on the list that RAD has
implemented 
CESoPSN in its product as a "one-time effort to supply small remote 
boxes to interoperate with CESoPSN central site for a given sales
opportunity" - 
I would say that this also means that it was relatively "simple" to
implement that.

Regards
	Alik

---

From: "Yaakov Stein" <[email-masked]>
Date: Wed, 16 Jul 2003 10:32:43 +0300

Alik, 

> I just looked at your slides and very "emotional" description of CESoPSN.

I wasn't aware of the emotional aspects.

> emulation of unstructured T1/E1 borrows CESoPSN approach, i.e. "raw encapsulation" 

STPP is actually based on the raw mode of draft-anavi,
(which has been there for a long time)
i.e. it does not need any frame locking.
I am glad that the latest draft-vainshtein
has at long last come around to allowing this as well.

I gave definite default values for payload sizes
that are important for certain implementations.
This was to make it easier for you to accept it.
If this seems somehow improper to you,
then I am much happier with a constant 256 bytes default length,
or even better 47*N.

> unstructured TDM traffic... AAL1 is thus best for unstructured trunks...". 

It is an attempt at a compromise mode for CERTAIN CASES.
I still say that when the going gets hard (i.e. network imperfections,
CAS signaling, etc) it is insufficient.
But, for a large subset of cases STPP is good enough.

> CESoPSN is simple - you somehow mentioned on the list that RAD has implemented
> boxes to interoperate with CESoPSN central site for a given sales opportunity" - 
> I would say that this also means that it was relatively "simple" to implement that.

Actually, as you well know, it wasn't as easy as we expected,
and we needed the help of an Axerra engineer to get it interoperable.
How to handle the RTP was a particularly sticky issue.

STPP is truly simple - just chop any hunk of TDM,
stick on a control word and ship it out. 
I added a few constrictions to get your support.

Y(J)S