Subject: RE: Status signaling in draft-ietf-pwe3-control-protocol-0 3.txt

From: "David Allan" <[email-masked]>
Date: Mon, 14 Jul 2003 10:39:06 -0400

Luca:

> > a) There is no mechanism (implicit/explicit) by which a PE will find
> >    out what is the capability/intent of the remote PE 
> (whether it supports
> >    status TLV or not).
> This point did not get enough support. We do not feel that we 
> need a protocol 
> to decide if the PW status notification message is used or 
> not. For backward compatibility an implementation specific 
> local setting can 
> definitely be used to achieve the correct behavior.

This adds to a providers provisioning burden in any sort of multi-vendor or
multi-provider network. Consider this support for a negotiation option.

cheers
Dave

<snipped to end>

---

From: "Hamid Ould-Brahim" <[email-masked]>
Date: Tue, 15 Jul 2003 07:42:55 -0400

Luca,

> to decide if the PW status notification message is used or not.
> For backward compatibility an implementation specific local 
> setting can 

The proposal assumes that both PEs have apriori knowledge
that they both support status signaling (i.e., no capability signaling). 
This implies that the proposal works only for double-sided 
provisioning model and does not work for other
provisioning models used in layer-2 VPNs such as a single-sided
provisioning with an auto-discovery mechanism.

In the case when a VPN auto-discovery is used, the PE does not
have apriori knowledge of the remote PE it needs to
establish a PW to, so it can't know whether that PE
supports or not status signaling, therefore signaling the capability
is one way of conveying that information.

The status signaling should work with multiple provisioning
models (that are as well supported by PW signaling draft).

Hamid.

---

From: Luca Martini <[email-masked]>
Date: Wed, 16 Jul 2003 05:21:21 -0600

yes,
As I said before I am not completely opposed to have some kind of status 
indication negotiation.
However please note that the current proposal makes status signaling mandatory 
, or PW status will not work.
So in the current proposal , if a ISP need PW status signaling all devices in 
the network must support this PW status notification message. Note that in some 
network/technologies this might not be a requirement.
we will talk about this in the meeting this afternoon.

Luca

---

From: "Hamid Ould-Brahim" <[email-masked]>
Date: Wed, 16 Jul 2003 09:16:53 -0400

Luca,

> we will talk about this in the meeting this afternoon.

Agreed.

Hamid.