Subject: confusing text in fragmentation draft

From: "Yaakov Stein" <[email-masked]>
Date: Wed, 3 Dec 2003 08:45:38 +0200

Andy, 

I find the text in draft-ietf-pwe3-fragmentation-03
describing the setting of the fragmentation indication bits 
to be extremely confusing.

The architecture draft states that the control word
potentially contains a two-bit field called FRG.

The fragmentation draft talks about two one-bit fields.
Furthermore, it first explains the RFC 1990 conventions, 
but then goes on to say we are inverting them.

It never explicitly spells out the meaning that IS used.

Although I agree that sentient beings could decypher this,
and make the connection between the two 1-bit fields
and the one 2-bit field in a finite amount of time,
I would prefer something like this:

FRG
00	indicates that the entire (un-fragmented) payload is carried in a single packet 
01	indicates the packet carrying the first fragment
10	indicates the packet carrying the last fragment 
11	indicates a packet carrying an intermediate fragment.

You could, of course, keep the explanatory text as to why
we use these particular combinations.

Y(J)S

---

From: "Andy Malis" <[email-masked]>
Date: Wed, 3 Dec 2003 04:38:50 -0800

Stewart,
 
You probably haven't yet seen my reply to Yaakov.  I intend to add his table to the text.  However, I think the discussion of RFC 1990 is useful, because it references the earlier work for those not aware of it, and answers the question (should it arise in the future from people already familiar with RFC 1990) as to why the bits are inverted.  There are many RFC 1990 implementations, and I expect this could end up being a popular question years from now if the text is removed.
 
Cheers,
Andy

	-----Original Message----- 
	From: Stewart Bryant [mailto:[email-masked]] 
	Sent: Wed 12/3/2003 7:17 AM 
	To: Yaakov Stein 
	Cc: Andy Malis; PWE3 (IETF) 
	Subject: Re: [PWE3] confusing text in fragmentation draft

	Actually I think that we should consider simplifying the
	whole of section 3 to remove the RFC-1990 tutorial,
	and replace it with a direct description of what we
	do and why. I think that we should use Yaakov's text
	to directly specify the meaning of the bits.
	
	Stewart

	
	Yaakov Stein wrote:
	
	> ???????????????????????????????????????j)b?   b??p{?z????!??l????
	> ???_????f??f??X??)ߣ?p
	>
	>

---

From: "Yaakov Stein" <[email-masked]>
Date: Wed, 3 Dec 2003 14:40:55 +0200

Andy/Stewart, 

I agree that the explanation of WHY the bits
are inverted vis a vis 1990 is useful.

I just think that it should be an explanatory
note AFTER an explanation of what the bits do,
rather than a cryptic algorithm of how
to figure out what the bits should be.

Y(J)S

> From: Andy Malis [mailto:[email-masked]]
> Sent: Wednesday, December 03, 2003 2:39 PM
> To: [email-masked]; Yaakov Stein
> Cc: PWE3 (IETF)
> Subject: RE: [PWE3] confusing text in fragmentation draft
> 
> 
> Stewart,
>  
> You probably haven't yet seen my reply to Yaakov.  I intend 
> to add his table to the text.  However, I think the 
> discussion of RFC 1990 is useful, because it references the 
> earlier work for those not aware of it, and answers the 
> question (should it arise in the future from people already 
> familiar with RFC 1990) as to why the bits are inverted.  
> There are many RFC 1990 implementations, and I expect this 
> could end up being a popular question years from now if the 
> text is removed.
>  
> Cheers,
> Andy
>