Subject: Re: confusing text in fragmentation draft

From: Stewart Bryant <[email-masked]>
Date: Wed, 03 Dec 2003 13:17:10 +0000

Andy Malis wrote:

> Stewart,
>  
> You probably haven't yet seen my reply to Yaakov.  
> I intend to add his table to the text.  However, 
> I think the discussion of RFC 1990 is useful, 
> because it references the earlier work for those 
> not aware of it, and answers the question 
> (should it arise in the future from people 
> already familiar with RFC 1990) as to why the 
> bits are inverted.  There are many RFC 1990 
> implementations, and I expect this could end up 
> being a popular question years from now if the text is removed.

Yes we did cross-over.

I would still ask that we look at simplifying the
section to make it more readable for someone who
just wants to know how PW fragmentation works.
Perhaps this could be dome by moving the RFC1990
discussion to an appendix?

Stewart

>  
> Cheers,
> Andy
> 
> 	-----Original Message----- 
> 	From: Stewart Bryant [mailto:[email-masked]] 
> 	Sent: Wed 12/3/2003 7:17 AM 
> 	To: Yaakov Stein 
> 	Cc: Andy Malis; PWE3 (IETF) 
> 	Subject: Re: [PWE3] confusing text in fragmentation draft
> 	
> 	
> 
> 
> 	Actually I think that we should consider simplifying the
> 	whole of section 3 to remove the RFC-1990 tutorial,
> 	and replace it with a direct description of what we
> 	do and why. I think that we should use Yaakov's text
> 	to directly specify the meaning of the bits.
> 	
> 	Stewart
> 	
> 	
> 	
> 	
> 	Yaakov Stein wrote:
> 	
> 	> Andy,
> 	>
> 	> I find the text in draft-ietf-pwe3-fragmentation-03
> 	> describing the setting of the fragmentation indication bits
> 	> to be extremely confusing.
> 	>
> 	> The architecture draft states that the control word
> 	> potentially contains a two-bit field called FRG.
> 	>
> 	> The fragmentation draft talks about two one-bit fields.
> 	> Furthermore, it first explains the RFC 1990 conventions,
> 	> but then goes on to say we are inverting them.
> 	>
> 	> It never explicitly spells out the meaning that IS used.
> 	>
> 	> Although I agree that sentient beings could decypher this,
> 	> and make the connection between the two 1-bit fields
> 	> and the one 2-bit field in a finite amount of time,
> 	> I would prefer something like this:
> 	>
> 	> FRG
> 	> 00    indicates that the entire (un-fragmented) payload is carried in a single packet
> 	> 01    indicates the packet carrying the first fragment
> 	> 10    indicates the packet carrying the last fragment
> 	> 11    indicates a packet carrying an intermediate fragment.
> 	>
> 	>
> 	> You could, of course, keep the explanatory text as to why
> 	> we use these particular combinations.
> 	>
> 	> Y(J)S
> 	> ???????????????????????????????????????j)b?   b??p{?z????!??l????
> 	> ???_????f??f??X??)ߣ?p
> 	>
> 	>
> 	
> 	
>

---

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 04 Dec 2003 07:12:03 -0500

Stewart,

OK, I hear you ....

Cheers,
Andy

--------

---

From: "W. Mark Townsley" <[email-masked]>
Date: Thu, 04 Dec 2003 18:19:11 +0100

An appendix for 1990 sounds like a good idea to me.

Thanks,

- Mark

Andrew G. Malis wrote:
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
>