Subject: Re: MPLS PWs over IP: Text for draft-ietf-pwe3-control-protocol-04.txt

From: Rahul Aggarwal <[email-masked]>
Date: Tue, 2 Dec 2003 14:00:33 -0800 (PST)

Hi Eric,

On Mon, 1 Dec 2003, Eric Rosen wrote:

>
> draft> Any sort  of PSN tunnel can  be used, as  long as it is  possible to
> draft> transmit MPLS packets  through it.  The PSN tunnel  can itself be an
> draft> LSP, but  it could equally  well be an  IP tunnel, a GRE  tunnel, an
> draft> IPsec  tunnel, or  any other  sort of  tunnel which  can  carry MPLS
> draft> packets. Procedures  for setting up and maintaining  the PSN tunnels
> draft> are outside the scope of this document.
>
> Rahul> Can we replace the last sentence in the above with the following:
>
> Rahul>    Procedures for setting up and maintaining the PSN tunnels with GRE
> Rahul>    or IP are specified in [MPLS-OVER-IP-GRE].
>
> Since this change is not needed for technical correctness, I would prefer to
> leave the draft as is.
>

>From the WG minutes:

<minutes> Luca Martini - Said that it is contained in control document
<minutes> Rahul - will follow up, but not sure that it is in control
           document
<minutes> Luca - send me a paragraph

Luca had said that there is merit in the approach and asked me to send
any suggested clarification. I agree that the earlier proposed text was
verbose and included procedures for IPsec which is not in scope of the
control document.

However the above proposed change is needed for *completeness* as
in the case where MPLS PWs are carried over IP or GRE tunnels
the proposed change points to a specific existing IETF document
that specifies how to encapsulate MPLS over IP/GRE.

thanks,
rahul

---

From: "Yaakov Stein" <[email-masked]>
Date: Wed, 3 Dec 2003 18:37:17 +0200

Stewart and all, 

There seem to be two anomalies regarding MPLS over IP PWs:

1) The PWE charter states that we need an encapsulation document
   for "MPLS (over IP or L2TP only)"
   but also states
   "PWE3 pseudo wires will have the same specification
   for all underlying PSNs (i.e. there will not be specific adaptation
   of a pseudo wire technology for MPLS that is distinct from what is
   used for IP and L2TP).
   These requirements seem mutually contradictory.

2) We have an agreed upon PW multiplexing method
   for MPLS PWs, but not for IP PWs.
   (This one applies to all IP PWs, not just MPLS ones).

However, I do not believe that specifying procedures
only for the GRE case is what we need here.

We should either start treating all the IP varieties separately 
(i.e. specify L2TP-IP PWs, IPSec PWs, GRE PWs, etc)
or leave the text as it is.

Y(J)S

---

From: Yakov Rekhter <[email-masked]>
Date: Wed, 03 Dec 2003 12:09:12 -0800

Luca,

> Yakov,
> 
> I see here two problems. the first is that we need to transport MPLS 
> over IP/GRE/IPSEC/L2TPV3, and this is is a useful problem to work on.

Let's not re-invent the wheel - there is no need "to work on" the problem 
of how to transport MPLS over IP/GRE, as it is a *solved* problem 
(draft-ietf-mpls-in-ip-or-gre-03.txt).

> The second is this particular section of text in the control draft. The 
> proposed text is not enought to solve the first problem , and solving 
> the MPLS over IP problem is not what this draft is about.

Here is the proposed text:

  Procedures for setting up and maintaining the PSN tunnels with GRE
  or IP are specified in [MPLS-OVER-IP-GRE].

You are certainly correct that the proposed text "is not enough to
solve the first problem" - it just points to the IETF document that
does solve the first problem (or to be more precise the subset of the
first problem). So, what's wrong with that ?

And I certainly agree with you that "solving the MPLS over IP problem
is not what this draft is about".

> The draft already suggests that PW can be used over MPLS over IP or 
> something else, and it's enought.

Disagree on "it's enough". Since the draft talks about MPLS over
IP/GRE and there is an existing IETF solution on how to transport
MPLS over IP/GRE, the draft should reference it.

> So I would like to leave this text as is, and solve the MPLS over 
> "IPsomething" problem in a separate document. We can probably get all 
> this done by the next IETF meeting. ;-)

So, I hope you would support Rahul's (separate) draft on MPLS over IPSec.

Yakov.

---

From: "Yaakov Stein" <[email-masked]>
Date: Sun, 7 Dec 2003 09:07:01 +0200

> The PSN tunnel can be an LSP, but it could equally well be some
> form of IP based tunnel which can carry MPLS packets. Procedures
> for setting up and maintaining the PSN tunnels are outside the
> scope of this document.

Well, first that which should be a that.

More importantly, why the requirement for carrying MPLS packets?
Why not carrying the PW label, control word and PW payload?

By saying MPLS packet I assume that you are trying to state
that the mandated method of sending the PW label is an MPLS shim header.

If this is so, let's state this specifically, and state that other methods
(e.g. UDP port numbers, L2TP, etc) are not allowed.

If not, the wording is "off".

Y(J)S

---

From: "Yaakov Stein" <[email-masked]>
Date: Thu, 11 Dec 2003 09:56:34 +0200

Try this:

Any PSN tunnel that could be used for the transport of MPLS packets
is acceptable. In particular, the PSN tunnel may itself be an LSP, 
but other tunnel types are equally admissible. 
Procedures for setup and maintenance of PSN tunnels,
as well as the MPLS packet encapsulation formats, 
are beyond the scope of the present document.