Subject: Re: confusing text in fragmentation draft

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 03 Dec 2003 06:44:48 -0500

Yaakov,

Thanks to you and Ron for reviewing the draft.

I don't see an inconsistency between the architecture draft talking in 
general terms about a two-bit field for fragmentation, and the 
fragmentation draft getting into the details of the individual bits by 
discussing them as two one-bit fields.  That said, I  like your table 
below, and will add it to the next revision.  Thanks for the suggestion.

Cheers,
Andy

------------

At 12/3/2003 08:45 AM +0200, Yaakov Stein wrote:
>Andy,
>
>I find the text in draft-ietf-pwe3-fragmentation-03
>describing the setting of the fragmentation indication bits
>to be extremely confusing.
>
>The architecture draft states that the control word
>potentially contains a two-bit field called FRG.
>
>The fragmentation draft talks about two one-bit fields.
>Furthermore, it first explains the RFC 1990 conventions,
>but then goes on to say we are inverting them.
>
>It never explicitly spells out the meaning that IS used.
>
>Although I agree that sentient beings could decypher this,
>and make the connection between the two 1-bit fields
>and the one 2-bit field in a finite amount of time,
>I would prefer something like this:
>
>FRG
>00      indicates that the entire (un-fragmented) payload is carried in a 
>single packet
>01      indicates the packet carrying the first fragment
>10      indicates the packet carrying the last fragment
>11      indicates a packet carrying an intermediate fragment.
>
>
>You could, of course, keep the explanatory text as to why
>we use these particular combinations.
>
>Y(J)S

---

From: Stewart Bryant <[email-masked]>
Date: Wed, 03 Dec 2003 12:17:03 +0000

Actually I think that we should consider simplifying the
whole of section 3 to remove the RFC-1990 tutorial,
and replace it with a direct description of what we
do and why. I think that we should use Yaakov's text
to directly specify the meaning of the bits.

Stewart

Yaakov Stein wrote:

> 00	indicates that the entire (un-fragmented) payload is carried in a single packet 
> ???????????????????????????????????????j)b?	b??p{��?z????!??l????
> ???_????f??f??X??)ߣ?p
> 
>