Subject: Re: Re: MPLS PWs over IP: Text for draft-ietf-pwe3-control-protocol-04.txt

From: "W. Mark Townsley" <[email-masked]>
Date: Wed, 03 Dec 2003 21:55:32 +0100

Yakov Rekhter wrote:
> 
> Here is the proposed text:
> 
>   Procedures for setting up and maintaining the PSN tunnels with GRE
>   or IP are specified in [MPLS-OVER-IP-GRE].

Rahul's proposal was also to remove this text:

"Procedures for setting up and maintaining the PSN tunnels are outside the scope 
of this document."

Which is why I said the proposal changes the scope of the document.

- Mark

---

From: Rahul Aggarwal <[email-masked]>
Date: Wed, 3 Dec 2003 15:45:48 -0800 (PST)

Hi Mark,

> Which is why I said the proposal changes the scope of the document.

How about replacing

   The PSN tunnel can itself be an LSP, but it could equally well
   be an IP tunnel, a GRE tunnel, an IPsec tunnel, or any other sort of
   tunnel which can carry MPLS packets. Procedures for setting up and
   maintaining the PSN tunnels are outside the scope of this document.

with

   The PSN tunnel can itself be an LSP, but it could equally well
   be an IP tunnel [MPLS-OVER-IP-GRE], a GRE tunnel [MPLS-OVER-IP-GRE],
   an IPsec tunnel, or any other sort of tunnel which can carry MPLS
   packets. Procedures for setting up and maintaining the PSN tunnels
   are outside the scope of this document.

Thanks,
rahul

> - Mark
>
>
>
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
>

---

From: "W. Mark Townsley" <[email-masked]>
Date: Thu, 04 Dec 2003 18:36:13 +0100

>    are outside the scope of this document.

Better. However, *if* we are going to hit the text here turn what was a set of 
loose and unbounded examples into a list of specific references, I'd like to go 
ahead and add L2TPv3 as an example of "any other sort of tunnel which can carry 
MPLS packets" and include a reference to draft-townsley-l2tpv3-mpls-01.txt. For 
consistency, we would need to reference your upcoming MPLS over IPsec 
encapsulation draft as well. I find it arbitrary to reference some examples and 
not others.

I'm also fine with just leaving the text as is.

- Mark

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 04 Dec 2003 18:13:13 +0000

W. Mark Townsley wrote:

> Better. However, *if* we are going to hit the text here turn what was a 
> set of loose and unbounded examples into a list of specific references, 
> I'd like to go ahead and add L2TPv3 as an example of "any other sort of 
> tunnel which can carry MPLS packets" and include a reference to 
> draft-townsley-l2tpv3-mpls-01.txt. For consistency, we would need to 
> reference your upcoming MPLS over IPsec encapsulation draft as well. I 
> find it arbitrary to reference some examples and not others.
> 

Or alternatively should we further de-scope the draft by removing
all specifics?

After all it's up to other WGs how we carry MPLS over IP.

Perhaps something like:

The PSN tunnel can be an LSP, but it could equally well be some
form of IP based tunnel which can carry MPLS packets. Procedures
for setting up and maintaining the PSN tunnels are outside the
scope of this document.

- Stewart

---

From: Rahul Aggarwal <[email-masked]>
Date: Fri, 5 Dec 2003 10:49:40 -0800 (PST)

Hi Mark,

> loose and unbounded examples into a list of specific references, I'd like to go

It is sill a set of unbounded examples. References are being added, to
relevant IETF documents, where possible.

> MPLS packets" and include a reference to draft-townsley-l2tpv3-mpls-01.txt.

draft-townsley-l2tpv3-mpls-01.txt is not a MPLS WG document.
MPLS-OVER-IP-GRE is.

> For consistency,

In this case MPLS over IP is the set. MPLS over IP/GRE is a subset with an
existing IETF document that describes the solution. For rest of the
subset there is no existing IETF document that describes the solution. But
that does not mean that we shouldn't reference the MPLS over IP/GRE
subset.

> we would need to reference your upcoming MPLS over IPsec
> encapsulation draft as well.

As I meantioned above, it is not an existing IETF doucument.

> I find it arbitrary to reference some examples and
> not others.
>

All possible examples are being listed *if* they are existing IETF
documents. That is a consistant approach and is not aribtrary.

rahul

---

From: "W. Mark Townsley" <[email-masked]>
Date: Mon, 08 Dec 2003 14:27:05 +0100

> draft-townsley-l2tpv3-mpls-01.txt is not a MPLS WG document.

There is no requirement that I know of for a non-normative reference to be on 
the IETF Standards Track.

> As I meantioned above, it is not an existing IETF doucument.

I logically assumed that if you thought GRE and IP needed a reference in the 
document to be clear, IPsec would as well.

- Mark

---

From: Luca Martini <[email-masked]>
Date: Mon, 08 Dec 2003 17:11:14 -0700

Rahul,

other then the fact that this will block the document pending  
[MPLS-OVER-IP-GRE] , this is ok with me.
( however, I sense that consensus is to leave the text as is )
I would not worry about this too much at this point. I really want to 
see what the IESG/ADs have to say about these documents. I have a 
feeling that we'll have to edit these documents once more. We can then 
add all the references we want.

Luca

---

From: Rahul Aggarwal <[email-masked]>
Date: Tue, 9 Dec 2003 13:22:05 -0800 (PST)

Hi Luca,

On Mon, 8 Dec 2003, Luca Martini wrote:

> [MPLS-OVER-IP-GRE] ,

MPLS-OVER-IP-GRE is in last call. Hence this may not be an issue.

> this is ok with me.

Great !

> add all the references we want.

Its your call to add the MPLS-OVER-IP-GRE reference now or in the next round  of editing.
Though it may be simpler to add the reference before getting the IESG/ADs
to review it.

Thanks,
rahul

---

From: Eric Rosen <[email-masked]>
Date: Wed, 10 Dec 2003 08:50:52 -0500

Luca> however, I sense that consensus is to leave the text as is

Rahul> Its your  call to  add the MPLS-OVER-IP-GRE  reference now or  in the
Rahul> next round of editing.  

Not unless the WG agrees to the change! 

Given that (a)  the control protocol spec has already  passed last call, (b)
no  technical  problem has  been  raised, and  (c)  the  proposed change  is
controversial, I see no reason why any such change should be made. 

As there  hasn't been  any new information  or substantive new  arguments in
some weeks,  how about  a ruling  from the WG  chairs so  we can  close this
issue?

---

From: Stewart Bryant <[email-masked]>
Date: Wed, 10 Dec 2003 14:46:26 +0000

Danny and I discussed this issue face to face yesterday.

We believe that PWE3 should be agnostic as to the method
used to carry an MPLS label over an IP network.

We therefore suggest that the way forward is to change
the text under discussion in

draft-ietf-pwe3-control-protocol-04.txt

to make it neutral in this respect.

- Stewart