Subject: RE: Comments on VCCV-01

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 03 Feb 2004 11:18:44 -0500

Shahram and Dave,

I'm catching up on the list and I saw your emails regarding Y.1711 as a 
VCCV option.  Given Y.1711's use of a reserved label, I would like a better 
understanding of exactly how one would implement Y.1711 in a pseudowire - 
especially what the PDUs would look like and the general theory of 
operation.  Is the Y.1711 label expected to work if it's not the top label 
in the stack?  I don't think it's well specified enough to just add another 
codepoint to the VCCV document.  Also, would you want Y.1711 in VCCV to be 
optional or required in implementations?

Thanks,
Andy

-----------

At 1/29/2004 07:12 AM -0800, Shahram Davari wrote:
> >> I'd also like to see
> >> 1711 as an option to the CV types field  (on the assumption the
> >> ITU will seek a PPP DLL).
> >
> >       If the working group desires such a mode to be
> >added, then we can, but lets hear from the WG before we
> >do this.
> >
>  I am in favor of adding 1711 mode.
>
>-Shahram
>
>_______________________________________________
>pwe3 mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "David Allan" <[email-masked]>
Date: Wed, 4 Feb 2004 04:11:51 -0500

HI Andy:

Y.1711 used with VCCV would use the PW PID as an alternative to the reserved
label (and a PPP DLL value to be assigned). A draft requesting such a value
will be posted shortly, and the requisite changes to 1711 are parked on the
living list awaiting the IANA assignment. A further change would be required
to PW setup procedures to synchronize TTSI values.

IMO as VCCV procedures negotiate capability, 1711 support would not be a
MUST any more than the other options.

cheers
Dave

> -----Original Message-----
> From: Andrew G. Malis [mailto:[email-masked]] 
> Sent: Tuesday, February 03, 2004 11:19 AM
> To: Shahram Davari; Allan, David [CAR:NS00:EXCH]
> Cc: [email-masked]'; [email-masked]; 'Rahul Aggarwal'; 
> 'Monique Morrow (mmorrow)'; 'George Swallow (swallow)'
> Subject: RE: [PWE3] Comments on VCCV-01
> 
> 
> Shahram and Dave,
> 
> > >> 1711 as an option to the CV types field  (on the 
> assumption the ITU 
> > >> will seek a PPP DLL).
> > >

---

From: Sasha Vainshtein <[email-masked]>
Date: Wed, 4 Feb 2004 11:24:39 +0200

David and all,
Please see a brief comment inline.
 
With best regards,
                                   Sasha Vainshtein
email:     [email-masked] <mailto:[email-masked]> 
tel:       +972-3-7659993 (office)
           +972-8-9254948 (res.)
           +972-58-674833 (cell.)

-----Original Message-----
From: David Allan [mailto:[email-masked]]
Sent: Wednesday, February 04, 2004 11:12 AM
To: 'Andrew G. Malis'; Shahram Davari
Cc: [email-masked]'; [email-masked]; 'Rahul Aggarwal'; 'Monique Morrow
(mmorrow)'; 'George Swallow (swallow)'
Subject: RE: [PWE3] Comments on VCCV-01

HI Andy: 

Y.1711 used with VCCV would use the PW PID as an alternative to the reserved
label (and a PPP DLL value to be assigned).  

[Sasha] Please note that most PW encapsulations defined today do not use PW
PID because hey have chosen to use the ECMP-safe control word. Can you
please explain how this can be resolved without changing all the PW
encapsulation formats?

A draft requesting such a value will be posted shortly, and the requisite
changes to 1711 are parked on the living list awaiting the IANA assignment.
A further change would be required to PW setup procedures to synchronize
TTSI values.

cheers 
Dave 

> From: Andrew G. Malis [ mailto:[email-masked]
<mailto:[email-masked]> ] 
> optional or required in implementations? 
<https://www1.ietf.org/mailman/listinfo/pwe3>  
<https://www1.ietf.org/mailman/listinfo/pwe3>

---

From: [email-masked]
Date: Wed, 4 Feb 2004 09:36:34 -0000

My take too Dave, ie alternative to reserved label not 'in addition' to it.
 
regards, Neil

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of David Allan
Sent: 04 February 2004 09:12
To: 'Andrew G. Malis'; Shahram Davari
Cc: [email-masked]'; [email-masked]; 'Rahul Aggarwal'; 'Monique Morrow (mmorrow)'; 'George Swallow (swallow)'
Subject: RE: [PWE3] Comments on VCCV-01

HI Andy: 

Y.1711 used with VCCV would use the PW PID as an alternative to the reserved label (and a PPP DLL value to be assigned). A draft requesting such a value will be posted shortly, and the requisite changes to 1711 are parked on the living list awaiting the IANA assignment. A further change would be required to PW setup procedures to synchronize TTSI values.

IMO as VCCV procedures negotiate capability, 1711 support would not be a MUST any more than the other options. 

cheers 
Dave 

> From: Andrew G. Malis [ mailto:[email-masked]]

---

From: "David Allan" <[email-masked]>
Date: Wed, 4 Feb 2004 04:58:12 -0500

Sasha:

My understanding of the next revision of VCCV is that the PW PID (first
nybble 0x01) is the exclusive mechanism for distinguishing OAM flows as
there are no bits universally available in the CW (first nybble 0x00). Not
clear what the issue is?

Dave

-----Original Message-----
From: Sasha Vainshtein [mailto:[email-masked]] 
Sent: Wednesday, February 04, 2004 4:25 AM
To: Allan, David [CAR:NS00:EXCH]
Cc: [email-masked]'; [email-masked]; 'Rahul Aggarwal'; 'Monique Morrow
(mmorrow)'; 'George Swallow (swallow)'; 'Andrew G. Malis'; Shahram Davari
Subject: RE: [PWE3] Comments on VCCV-01

David and all,

With best regards,
                                   Sasha Vainshtein
email:     [email-masked]

-----Original Message-----
From: David Allan [mailto:[email-masked]]
Sent: Wednesday, February 04, 2004 11:12 AM
To: 'Andrew G. Malis'; Shahram Davari
Cc: [email-masked]'; [email-masked]; 'Rahul Aggarwal'; 'Monique Morrow

HI Andy:

---

From: Sasha Vainshtein <[email-masked]>
Date: Wed, 4 Feb 2004 12:13:42 +0200

Dave,
The current PWE3 Architecture draft defines the PW PID  as following:
<quote>

PWE3 Payload Type Identifier (PWE3-PID) -  An identifier used to distinguish
between an MPLS IP payload and a CW that is not ECMP safe.

<end quote>
It further explains in Section 5.4.4 that:
<quote>

If technical considerations result in a PW control word that may alias an IP
packet, the control word SHOULD be preceded by an PWE3 payload type
dentifier (PWE3 PID).

<end quote>
This does not, IMO, cover usage of the first nibble of the ECMP-safe CW. Nor
is the PPP DLL relevant for ECMP-safe PWs.
If your intention was to use the first nibble of an ECMP-safe CW in
Y.1711-based PW OAM to distinguish OAM packets (first nibble = '0001') from
the data packets (first nibble = '0000'), this is OK with me. But please
don't refer to it as "PW PID"!
With best regards,
                                   Sasha Vainshtein
email:     [email-masked] <mailto:[email-masked]> 
tel:       +972-3-7659993 (office)
           +972-8-9254948 (res.)
           +972-58-674833 (cell.)

-----Original Message-----
From: David Allan [mailto:[email-masked]]
Sent: Wednesday, February 04, 2004 11:58 AM
To: Sasha Vainshtein
Cc: [email-masked]'; [email-masked]; 'Rahul Aggarwal'; 'Monique Morrow

Sasha: 

Dave 

-----Original Message----- 
From: Sasha Vainshtein [ mailto:[email-masked] <mailto:[email-masked]> ]

David and all, 

With best regards, 
                                   Sasha Vainshtein 
email:     [email-masked] 

-----Original Message----- 
From: David Allan [ mailto:[email-masked]
<mailto:[email-masked]> ] 
Sent: Wednesday, February 04, 2004 11:12 AM 
To: 'Andrew G. Malis'; Shahram Davari 
Cc: [email-masked]'; [email-masked]; 'Rahul Aggarwal'; 'Monique Morrow
(mmorrow)'; 'George Swallow (swallow)' 
Subject: RE: [PWE3] Comments on VCCV-01 

HI Andy:

---

From: "David Allan" <[email-masked]>
Date: Wed, 4 Feb 2004 05:26:30 -0500

Hi Sasha:

Where I think there may be confusion is that the text in the arch document
does not appear to cover the VCCV usage case, unless an OAM PDU falls under
the category of non ECMP safe CW. IMHO that would be a stretch given the
definition of CW offered. I think the arch draft may require clarfication on
this point after the next revision of VCCV is posted.

rgds
Dave

-----Original Message-----
From: Sasha Vainshtein [mailto:[email-masked]] 
Sent: Wednesday, February 04, 2004 5:14 AM
To: Allan, David [CAR:NS00:EXCH]
Cc: [email-masked]'; [email-masked]; 'Rahul Aggarwal'; 'Monique Morrow

Dave,

-----Original Message-----
From: David Allan [mailto:[email-masked]]
Sent: Wednesday, February 04, 2004 11:58 AM
To: Sasha Vainshtein
Cc: [email-masked]'; [email-masked]; 'Rahul Aggarwal'; 'Monique Morrow

Sasha: 

-----Original Message----- 
From: Sasha Vainshtein [mailto:[email-masked]] 
Sent: Wednesday, February 04, 2004 4:25 AM 
To: Allan, David [CAR:NS00:EXCH] 
Cc: [email-masked]'; [email-masked]; 'Rahul Aggarwal'; 'Monique Morrow

David and all, 
-----Original Message----- 
From: David Allan [mailto:[email-masked]] 
Sent: Wednesday, February 04, 2004 11:12 AM 
To: 'Andrew G. Malis'; Shahram Davari 
Cc: [email-masked]'; [email-masked]; 'Rahul Aggarwal'; 'Monique Morrow

HI Andy:

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Wed, 4 Feb 2004 09:03:34 -0500

I think Andy is asking how you envision y1711 being
used as a "mode" in VCCV. For example, since there
is no real packet format defined for y1711, how to
you envision VCCV will encapsulate it, etc...? 
In essence, the existing payloads of VCCV are
recycled from other (well specified) places.
 
    --Tom

-----Original Message-----
From: David Allan [mailto:[email-masked]] 
Sent: Wednesday, February 04, 2004 4:58 AM
To: 'Sasha Vainshtein'
Cc: [email-masked]'; [email-masked]; 'Rahul Aggarwal'; 'Monique
Morrow (mmorrow)'; 'George Swallow (swallow)'; 'Andrew G. Malis';
Shahram Davari
Subject: RE: [PWE3] Comments on VCCV-01

Sasha: 

My understanding of the next revision of VCCV is that the PW PID (first
nybble 0x01) is the exclusive mechanism for distinguishing OAM flows as
there are no bits universally available in the CW (first nybble 0x00).
Not clear what the issue is?

Dave 

-----Original Message----- 
From: Sasha Vainshtein [mailto:[email-masked]] 
Sent: Wednesday, February 04, 2004 4:25 AM 
To: Allan, David [CAR:NS00:EXCH] 
Cc: [email-masked]'; [email-masked]; 'Rahul Aggarwal'; 'Monique
Morrow (mmorrow)'; 'George Swallow (swallow)'; 'Andrew G. Malis';
Shahram Davari

David and all, 

With best regards, 
                                   Sasha Vainshtein 
email:     [email-masked] 

-----Original Message----- 
From: David Allan [mailto:[email-masked]] 
Sent: Wednesday, February 04, 2004 11:12 AM 
To: 'Andrew G. Malis'; Shahram Davari 
Cc: [email-masked]'; [email-masked]; 'Rahul Aggarwal'; 'Monique
Morrow (mmorrow)'; 'George Swallow (swallow)' 
Subject: RE: [PWE3] Comments on VCCV-01 

HI Andy: 
Y.1711 used with VCCV would use the PW PID as an alternative to the
reserved label (and a PPP DLL value to be assigned).  

[Sasha] Please note that most PW encapsulations defined today do not use
PW PID because hey have chosen to use the ECMP-safe control word. Can
you please explain how this can be resolved without changing all the PW
encapsulation formats?

A draft requesting such a value will be posted shortly, and the
requisite changes to 1711 are parked on the living list awaiting the
IANA assignment. A further change would be required to PW setup
procedures to synchronize TTSI values.

---

From: "David Allan" <[email-masked]>
Date: Wed, 4 Feb 2004 09:09:13 -0500

Hi Tom:

I have to admit I am not quite grokking your comment. Cannot parse "no real
packet format defined for..."

I envision the stack being

	PSN label
	PW label
	PW PID (avec PPP DLL)
	1711 PDU

cheers
Dave

-----Original Message-----
From: Thomas D. Nadeau [mailto:[email-masked]] 
Sent: Wednesday, February 04, 2004 9:04 AM
To: Allan, David [CAR:NS00:EXCH]; 'Sasha Vainshtein'
Cc: [email-masked]; 'Rahul Aggarwal'; 'Monique Morrow (mmorrow)'; 'George
Swallow (swallow)'; 'Andrew G. Malis'; 'Shahram Davari'
Subject: RE: [PWE3] Comments on VCCV-01

    --Tom

-----Original Message-----
From: David Allan [mailto:[email-masked]] 
Sent: Wednesday, February 04, 2004 4:58 AM
To: 'Sasha Vainshtein'
Cc: [email-masked]'; [email-masked]; 'Rahul Aggarwal'; 'Monique Morrow

Sasha: 

-----Original Message----- 
From: Sasha Vainshtein [mailto:[email-masked]] 
Sent: Wednesday, February 04, 2004 4:25 AM 
To: Allan, David [CAR:NS00:EXCH] 
Cc: [email-masked]'; [email-masked]; 'Rahul Aggarwal'; 'Monique Morrow

David and all, 
-----Original Message----- 
From: David Allan [mailto:[email-masked]] 
Sent: Wednesday, February 04, 2004 11:12 AM 
To: 'Andrew G. Malis'; Shahram Davari 
Cc: [email-masked]'; [email-masked]; 'Rahul Aggarwal'; 'Monique Morrow

HI Andy:

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Wed, 4 Feb 2004 10:19:51 -0500

And where does that stack go?  What is the
1711 PDU format you refer to?
 
    --Tom

-----Original Message-----
From: David Allan [mailto:[email-masked]] 
Sent: Wednesday, February 04, 2004 9:09 AM
To: [email-masked]'; 'Sasha Vainshtein'
Cc: [email-masked]; 'Rahul Aggarwal'; 'Monique Morrow (mmorrow)'; 'George

Hi Tom: 

I have to admit I am not quite grokking your comment. Cannot parse "no
real packet format defined for..." 

        PSN label 
        PW label 
        PW PID (avec PPP DLL) 
        1711 PDU 

cheers 
Dave 

-----Original Message----- 
From: Thomas D. Nadeau [mailto:[email-masked]] 
Sent: Wednesday, February 04, 2004 9:04 AM 
To: Allan, David [CAR:NS00:EXCH]; 'Sasha Vainshtein' 
Cc: [email-masked]; 'Rahul Aggarwal'; 'Monique Morrow (mmorrow)'; 'George

    --Tom 

-----Original Message----- 
From: David Allan [mailto:[email-masked]] 
Sent: Wednesday, February 04, 2004 4:58 AM 
To: 'Sasha Vainshtein' 
Cc: [email-masked]'; [email-masked]; 'Rahul Aggarwal'; 'Monique

Sasha: 

Dave 

-----Original Message----- 
From: Sasha Vainshtein [mailto:[email-masked]] 
Sent: Wednesday, February 04, 2004 4:25 AM 
To: Allan, David [CAR:NS00:EXCH] 
Cc: [email-masked]'; [email-masked]; 'Rahul Aggarwal'; 'Monique

David and all, 
-----Original Message----- 
From: David Allan [mailto:[email-masked]] 
Sent: Wednesday, February 04, 2004 11:12 AM 
To: 'Andrew G. Malis'; Shahram Davari 
Cc: [email-masked]'; [email-masked]; 'Rahul Aggarwal'; 'Monique

HI Andy:

---

From: "David Allan" <[email-masked]>
Date: Wed, 4 Feb 2004 10:31:20 -0500

Hi Tom:

You asked some questions....

>    And where does that stack go?   

If by go, you mean how is it forwarded...between PEs. Same path anything
else using the VCCV control channel would take.

> What is the 1711 PDU format you refer to?

It is specified in ITU-T recommendation Y.1711 (2002)

You may want to ask George, he suggested this was possible during his MPLS
2003 presentation last October (I think you were there). Simply re-affirmed
my estimation.

rgds
Dave