Subject: Re: PWE3 new WG items? PW QoS

From: Scott W Brim <[email-masked]>
Date: Fri, 20 Feb 2004 10:43:53 -0500

Busschbach, Peter B (Peter) allegedly wrote on 2/20/2004 10:15:

>>Actually PW stitching can be implemented entirely using 
>>existing pseudowire 
>>signaling procedures (using LDP or L2TP) without any new 
>>protocol or extension. 
>>  The signaling protocol is not an issue.
>>    
>>
>
>Hi Wei,
>
>I respectfully disagree. The fact that we have a signaling protocol to set up single PW segments doesn't mean that it is clear how to establish multi-segment PWs. 
>
You're both right depending on clarification and problem scoping.  We
know how to set up multiple PWs, and "stitching" them might be purely a
PE issue.  However, whether that solves the problem or not depends on
the answers to your questions (and others). 

>- Are segments set up in a random order or is there a need for a certain sequence of message?
>  
>
For scaling and robustness you can't require a certain order of setup.

>- Is it necessary to use the same values for Interface Parameters on each segment?
>
>- Is VCCV used on single segments or end-to-end? If the latter, do intermediate points monitor or do they blindly forward the packets?
>
>- In case a segment goes down, are alarm signals sent to the end-points of the multi-segment PW or is the error handled locally?
>  
>
PW-specific alarms should be constrained to just the extent of that
particular PW.  Alarms for protocols that use that PW obviously extend
further.

>All these, and probably more, need to be specified. On the other hand, if we decide that a multi-segment PW is essentially an LSP that can be set up with RSVP-TE, the RSVP-TE spec provides most of the answers.
>  
>
Unlikely :-). 

swb

---

From: Wei Luo <[email-masked]>
Date: Fri, 20 Feb 2004 15:20:28 -0800

Hi Peter,

Actually we are in agreement on what specific issues need to be resolved for PW 
stitching.  We literally listed the same stuff.  What we might disagree is how 
to solve these problems.

You seem to be advocating that RSVP is the cure for all these issues, but I am 
more inclined to have the working group define the scope of the problems first, 
and then we could decide whether they can be solved by implementation specific 
mechanisms or a new protocol procedure is necessary.  The current protocol 
procedures are sufficient for multi-semgent PWs signaling in the sense that they 
can handle end-to-end setup, teardown, notification, and etc. with proper 
implementation at the stitching points.

---Wei

Busschbach, Peter B (Peter) wrote:
> I respectfully disagree. The fact that we have a signaling protocol to set up single PW segments doesn't mean that it is clear how to establish multi-segment PWs. E.g.
> 
> Peter
>>With regard to PW stitching, this working group probably 
>>should focus on the 
>>operational issues with regard to PW stitching, such as 
>>whether Attachment 
>>Circuit interworking is needed at the stitching point, how to 
>>interwork between 
>>different PSN types, sequencing, multi-hop VCCV, Inter-AS 
>>considerations and 
>>other network management subjects.
>>
>>---Wei
>>
>