Subject: Re: New PWE3 Charter Items: SPVC Interworking

From: Scott W Brim <[email-masked]>
Date: Mon, 23 Feb 2004 12:05:34 -0500

On Mon, Feb 23, 2004 04:31:40PM -0000, [email-masked] allegedly wrote:
> We therefore believe that the general interworking of technologies such as FR, ATM, ethernet, SDH, etc:
> -	is not applicable to the Internet,
> -	will not have wide deployment on the Internet, and
> -	will not form part of the infrastructure of the Internet
> 
> Therefore the topic of service interworking is out of scope of the IETF and thus also out of scope of the PWE3 WG.

My personal opinion: I think interworking had better be in scope or the
IETF will leaving it out rather soon.  Issues in interworking of FR,
ATM, etc. are not IETF issues ... except where they imply requirements
for IETF technology, including pseudowires.  That includes this case.  I
would not want the IETF to decide how to translate service parameters
between pseudowire client technologies (and it hasn't), but
establishment and management of pseudowires goes far beyond that.
Finally, because of the IETF's long history with Ethernet, it should
continue to be involved there as well.

---

From: Scott W Brim <[email-masked]>
Date: Mon, 23 Feb 2004 12:14:55 -0500

> IETF will leaving it out rather soon.  Issues in interworking of FR,
          ^^^
(insert "regret")

---

From: Eric Rosen <[email-masked]>
Date: Tue, 24 Feb 2004 10:19:12 -0500

> the general interworking of technologies such as FR, ATM, ethernet, SDH

Certainly the  interworking of these  technologies with each other  would be
out of scope of the IETF. 

I think what  is being discussed though is the interworking  of one of these
technologies, at a network boundary,  with a PWE3-based emulation of itself.
That's a bit more difficult to  rule out based on abstract considerations of
the IETF mission.

---

From: Ping Pan <[email-masked]>
Date: Tue, 24 Feb 2004 12:29:09 -0800

Scott W Brim wrote:

> for IETF technology, including pseudowires.  

This is the key. When customers hooking up Ethernet, ATM, SONET/SDH and 
Frame Relay interfaces into PE's, they use pseudowires to transport data 
over the backbone. To interwork among different interfaces, the idea is 
simply of having targeted LDP to carry proper information between PE's 
at PW setup and modification time.

My personal view is to consider interworking as a "multi-protocol" 
extension to PWE3. There is no point of arguing what IETF should or 
should not do, because IETF also has a long history of evolving itself 
to support all sorts of data.

> That includes this case.  I
> between pseudowire client technologies (and it hasn't), 

Agree.

> but

- Ping

---

From: Peter Willis <[email-masked]>
Date: Fri, 27 Feb 2004 09:24:21 +0000

Colleagues,

Just to reinforce this message. It is clear that service interworking and even 
PWE3 is clearly outside the scope of the IETF. Clear in that we've already 
seen the pecuilar requests for PWE3 to consider congestion management. 

There are lots of very good engineers attend the PWE3 WG who also attend other 
standards bodies and forums. It seems that the work of these good engineers
 is being constrained by the IETF "constitution". 

I think SPVC Interworking is a specific example of an aspect of PWE3 that would be done better in another standards body or forum.

Peter Willis,
Office of BT Group CTO.

> > I'd like to see us add SPVC interworking to our charter.  
> > 
> > In talking to a fair number of service providers I've gotten 
> > the message
> > that deploying PWE3 is a bit of a non-starter without a reasonable
> > migration plan.  I think we would be foolish to leave this 
> > piece to some
> > other organization or to vendor proprietary means.
> > 
> > ....George
> 
> We have discussed the topic of service interworking extensively within BT, and we agree that it is an important facet of a service providers migration plan towards a converged multi-service core network. Service interworking must consider all aspects of the data-plane, control-plane and NMS/OSS for all the technologies considered (and it is therefore more far-reaching than just S-PVC considerations).
> 
> However, we do not believe the IETF is the appropriate forum for conducting this work.  Our reasons for saying this are that draft-alvestrand-ietf-mission-00.txt states:
> "The mission of the IETF is to produce high quality, relevant technical and engineering documents that influence the way people design, use and manage the Internet in such a way as to make the Internet work better."
> 
> It then defines the scope of the Internet as:
> "protocols and practices for which secure and scalable implementations are expected to have wide deployment and interoperation on the Internet, or to form part of the infrastructure of the Internet."  
> 
> Ben
> -- 
> Ben Niven-Jenkins
> IP Networking Specialist, BT Exact
> 
> e-mail: [email-masked]
> tel: +44(0) 1473 648225
> fax: +44(0) 1473 620109
> 
> pp34/161 B81 Callisto House, Adastral Park, Martlesham, Ipswich IP5 3RE, UK
> 
> BT Exact is a trademark of British Telecommunications plc
> Registered office: 81 Newgate Street London EC1A 7AJ
> Registered in England no. 1800000
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
>