Subject: Re: draft-bryant-mcpherson-pwe3-cw-00.txt WG request

From: Mustapha Aissaoui <[email-masked]>
Date: Wed, 18 Aug 2004 10:52:03 -0400

Peter,
I agree with your proposal. One clarification though: strictly
speaking the PTI on OAM packets is only required when ECMP or other
load balancing schemes could split the OAM and data packets over
different paths. Otherwise, the router alert label should be
sufficient and this will not require the use of the control word on
data packets if not required by the encapsulation. Thus, we have the
following two options:

1. If PTI is used on OAM packets, CW is mandatory on data packets.

2. Otherwise, use router alert label on OAM packets and data packets
will just follow the encapsulaiton requirements, i.e., CW may or may
not be required.

Also, I would like to have draft-bryant-mcpherson-pwe3-cw-00.txt add
a statement to encourage future PW encapsulations to continue using
the all zero nibble immediately following the bottom of the label
stack for data packets.

Mustapha.
---------
> "Busschbach, Peter B (Peter)" wrote:
> 
> Florin,
> 
> You write: "On the other hand we need the extensibility provided
> by a PTI/PID:  VCCV is just an instantiation of a PTI if you think
> about it, just the formats need to be aligned".
> 
> I agree that VCCV is one instantiation of a protocol that could be
> carried over a PW. However, the point I raised in an earlier email
> is whether there are other instantiations. Because, if VCCV is the
> *only* instantation, you don't need a PID, but just a way to
> differentate VCCV traffic from the PW payload traffic.
> 
> That said, this email thread has made a few things clear:
> 
> 1) As Mustapha observed, even if you don't need to identify the PW
> payload traffic, you might still need to differentiate between
> different types of OAM traffic
> 
> 2) As you observed, if you run VCCV traffic over a Pseudo Wire,
> then a Control Word , be it CW or PTI, must necessarily preceed
> all payload and OAM traffic.
> 
> 3)  draft-bryant-mcpherson-pwe3-cw-00.txt states: "If technical
> considerations result in a PW Control Word that could be mistaken
> for an IP packet, the Control Word SHOULD be preceded by a PWE3
> PTI." However, as we all seem to agree on, a CW will never be
> mistaken for an IP packet.
> 
> Therefore, rather than proposing a PTI that preceded a CW, I think
> the following solution would be sufficient and more elegant:
> 
> If the PW does not carry VCCV traffic, a CW is only mandatory if
> specified in the relevant encapsulation draft
> 
> If the PW carries VCCV traffic, then:
> 
> a) all payload traffic MUST be preceded by a Control Word that
> starts with 0000
> 
> b) all VCCV traffic MUSTbe preceded by an "OAM Protocol
> Identifier" (OPI), which has the following format:
> 
>     [0001 | resv | protocol id],
> 
> where protocol id identifies one of the following protocols: LSP
> Ping, ICMP, BFD, Y.1711, other(?).
> 
> Peter
> 
>      -----Original Message-----
>      From: Florin Balus [mailto:[email-masked]]
>      Sent: Thursday, August 12, 2004 12:42 PM
>      To: Busschbach, Peter B (Peter); Stewart Bryant
>      Cc: [email-masked]; Jeffrey Sugimoto
>      Subject: RE: [PWE3]
>      draft-bryant-mcpherson-pwe3-cw-00.txt WG request
> 
>      Peter,
>      See in-line...
> 
>      Stewart,
>      There might be another motivator for a mandatory
>      CW/consolidation under PTI: assuming we have a PW type
>      that does not mandate a CW (ATM N to one cell
>      mode) couldn't we get payloads that are mistaken also
>      for 0001/VCCV packets - e.g. VPI 64 in an ATM cell could
>      be interpreted by the receiving PE as 0001? (thanks Jeff
>      for bringing this up)
> 
>      Regards,
>      Florin
> 
>           -----Original Message-----
>           From: Busschbach, Peter B (Peter)
>           [mailto:[email-masked]]
>           Sent: Wednesday, August 11, 2004 2:41 PM
>           To: Balus, Florin [CAR:6955:EXCH]; Stewart
>           Bryant
>           Cc: [email-masked]
>           Subject: RE: [PWE3]
>           draft-bryant-mcpherson-pwe3-cw-00.txt WG
>           request
> 
>           Florus,
> 
>           Draft-allan-mpls-pid-00.txt  is not accessible
>           anymore. I don't recall what rationale it gave
>           for the need for a PTI.
>           FB: Dave addressed the need for an MPLS PID
>           one year ago from an overall MPLS perspective:
>           e.g. issues arisen from loadsharing on TE link
>           bundles or ECMP in LDP network,  OAM
>           extensibility, Multiprotocol over MPLS...
> 
>           Draft-bryant-mcpherson-pwe3-cw-00.txt mentions
>           ECMP as the sole reason for an additional
>           control word. However, introducing PTI to
>           solve the issues related to ECMP seems
>           overkill. It would be good if we can clearly
>           state why we need a PTI.
>           FB I agree with you that the justification in
>           section 4 for PTI versus CW + VCCV could be
>           improved. On the other hand we need the
>           extensibility provided by a PTI/PID:  VCCV is
>           just an instantiation of a PTI if you think
>           about it, just the formats need to be aligned.
>           Whether or not is a good idea to move the PW
>           user data to 0001 format is to be debated. We
>           need to make sure though the 2 formats could
>           coexist in a network in the mean time.
> 
>           Peter
> 
>                -----Original Message-----
>                From: Florin Balus
>                [mailto:[email-masked]]
>                Sent: Wednesday, August 11, 2004
>                2:17 PM
>                To: Stewart Bryant
>                Cc: [email-masked]
>                Subject: RE: [PWE3]
>                draft-bryant-mcpherson-pwe3-cw-00.txt
>                WG request
> 
>                Stewart,
> 
>                We did promote the idea of a PID/PTI
>                - see Dave Allan's
>                draft-allan-mpls-pid-00.txt on the
>                subject. Also I think the
>                explanation of ECMP issue
>                (disambiguate from IP/MPLS packets
>                etc) and the overall proposed
>                solution are valid.
> 
>                I just wanted to clarify some
>                technicalities to make sure we
>                clearly identify where we are headed
>                to - i.e. what changes are required
>                in other PWE3 drafts.
> 
>                Assuming we have in the same network
>                PEs that support both formats:
>                 - the CW [(0000 CW stuff)(data) &
>                the current VCCV format (0001 PA
>                PPP_DLL)(OAM payload))]
>                 - and the newly defined PTI (0001
>                PTI)(data/VCCV payload/?whatever?).
>                In the same time let's assume other
>                PEs will accept just the PTI - being
>                part of those implementations that
>                do not support 0000. How are we
>                going to ensure the 2 sets of PEs
>                will be able to negotiate in the
>                control plane the right format?
> 
>                Currently we do have in each of the
>                2 L2 FECs (PWID and Generalized ID)
>                just one bit to determine whether or
>                not the CW should be used - see
>                draft-ietf-pwe3-control-protocol-07.txt
>                section 5.1 and 5.2.2. 0001
>                implicitly meant up to now VCCV
>                format. How do we differentiate the
>                other 2 possibilities (PTI yes/no)?
> 
>                Also just to make sure I understood
>                correctly: there are some PW types
>                for which the CW is REQUIRED (e.g.
>                ATM N to 1 Cell Mode and AAL5 SDU
>                Frame Mode - see
>                draft-ietf-pwe3-atm-encap-05.txt
>                section 4.3.2). For a PE that will
>                implement the PTI format are we
>                saying the PW frames (after the 2
>                labels) will look like this: (0001
>                PTI)(0000 CW stuff)(data)?
> 
>                Is VCCV/OAM going to be
>                differentiated in the same way, just
>                re-using what is already defined:
>                i.e. (0001  PTI)(0001 PA
>                PPP_DLL)(OAM payload)? If not I
>                assume we will need to clarify the
>                PTI code points that are going to be
>                used for VCCV/OAM payload?
> 
>                Thanks for clarifying the above
>                points.
>                Regards,
>                Florin
> 
>                -----Original Message-----
>                From: [email-masked]
>                [mailto:[email-masked]] On
>                Behalf Of Stewart Bryant
>                Sent: Monday, August 09, 2004 7:54
>                AM
>                To: [email-masked]
>                Subject: [PWE3]
>                draft-bryant-mcpherson-pwe3-cw-00.txt
>                WG request
> 
>                The authors request that
> 
>                http://www.ietf.org/internet-drafts/draft-bryant-mcpherson-pwe3-cw-00.txt
> 
>                be adopted as a WG item with its
>                title changed to
> 
>                PWE3 MPLS Control Word
> 
>                - Stewart
> 
>                _______________________________________________
> 
>                pwe3 mailing list
>                [email-masked]
>                https://www1.ietf.org/mailman/listinfo/pwe3
> 
>    ------------------------------------------------------------
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Wed, 18 Aug 2004 11:45:03 -0400

> 1. If PTI is used on OAM packets, CW is mandatory on data packets.

	I am not sure if you need to explicitly make it mandatory, but
it probably will not hurt. This has been the implicit assumption
all along that those of us working on VCCV have told people. There
is no free lunch -- if you want OAM, turn on the CW on that PW.

	--Tom