Subject: QoS - Was: Re: PW to PSN tunnel mapping

From: Benny Ammitzbøll <[email-masked]>
Date: Wed, 18 Aug 2004 14:42:28 +0200

Luca,

When you say "QoS class", does that also imply bandwidth and burst
parameters? The only reason I operate with more than one PSN tunnel is
because of QoS. There seems to be no QoS considerations for PW's, except - I
assume - static setup? It would make obvious sense to do policing on the PW
in the PE's since the PW service is what you sell to the end customer.

/Benny

-----Original Message-----
From: Luca Martini [mailto:[email-masked]]
Sent: 17. august 2004 23:54
To: Benny Ammitzbøll
Cc: [email-masked]; [email-masked]
Subject: Re: PW to PSN tunnel mapping

Benny Ammitzbøll wrote:

>The draft-ietf-pwe3-control-protocol-08.txt mentions that the PW are set up
>to run inside a "PSN tunnel" and there is some talk about how this can
>happen by pushing an extra MPLS label etc. But there is nothing that says
>how a PE knows which PSN tunnel a PW belongs to? Is this supposed to be
>static configuration? Or is the assumption that there is only one PSN
tunnel
>between two PEs - this would be a bad assumption since there would most
>likely be more than one PSN tunnel, with different QoS parameters.
>
>
>
>
In general this is done by static local configuration.  The more popular
implemetations use the MPLS EXP bit to mark QoS class , and only one PSN
tunnel. There are implementations that can use a separate RSVP tunnel
for each PW if needed.
PW are then  configured locally to use a specific PSN tunnel.
Luca

>Benny Lønstrup Ammitzbøll, M.Sc.E.E.
>T|Pack A/S
>Lautrupbjerg 7-11
>DK-2750 Ballerup, Denmark
>Phone: (+45) 44732100
>Direct: (+45) 44732140
>mailto:[email-masked] - www.tpack.net
>
>
>

---

From: "Shah, Himanshu" <[email-masked]>
Date: Wed, 18 Aug 2004 11:29:15 -0400

I discussed PW QOS signaling in the last IETF meeting at San Diego.
You may want to checkout - 

http://www.ietf.org/internet-drafts/draft-shah-pwe3-pw-qos-signaling-00.txt

/himanshu

> From: Benny Ammitzbøll [mailto:[email-masked]]
> Sent: Wednesday, August 18, 2004 8:42 AM
> To: Luca Martini; [email-masked]; [email-masked]
> Subject: QoS - Was: Re: PW to PSN tunnel mapping
> 
> 
> Luca,
>

---

From: Luca Martini <[email-masked]>
Date: Wed, 18 Aug 2004 09:57:54 -0600

>in the PE's since the PW service is what you sell to the end customer.
Yes policing in the PE only. Then for traffic engineering , and 
appropriate QoS treatment in the core different PSN tunnels might be used.

Luca