Subject: LDP Signalling for PWs

From: "Diego Caviglia" <[email-masked]>
Date: Mon, 13 Dec 2004 10:29:23 +0100

Hi all,
              ID draft-ietf-pwe3-control-protocol-13 states that ...The PEs
will establish an LDP session using the Extended Discovery .." it is not
clear to me why I can't use basic discovery mechansim given that I have
e.g. an MPLS tunnel between the two PEs and thus a can tunnel Hello packets
between the LSP peers.

What am I missing?

Thanks.

Regards

Diego

---

From: "Gandhi, Upma" <[email-masked]>
Date: Mon, 13 Dec 2004 05:49:43 -0800

Even though after setting up of this tunnel, they seems to be adjacent
but other PE is still unaware of topology of other end.
   Can someone else put the light on this ?

Thanks & Regards
Upma

-----Original Message-----
From: Diego Caviglia [mailto:[email-masked]] 
Sent: Monday, December 13, 2004 6:52 PM
To: Gandhi, Upma
Cc: [email-masked]
Subject: RE: [PWE3] LDP Signalling for PWs

Seems that there is a misunderstanding.

w.r.t. the following picture

         |<-------------- Emulated Service ---------------->|
         |                                                  |
         |          |<------- Pseudo Wire ------>|          |
         |          |                            |          |
         |          |    |<-- PSN Tunnel -->|    |          |
         | PW End   V    V                  V    V  PW End  |
         V Service  +----+                  +----+  Service V
   +-----+    |     | PE1|==================| PE2|     |    +-----+
   |     |----------|............PW1.............|----------|     |
   | CE1 |    |     |    |                  |    |     |    | CE2 |
   |     |----------|............PW2.............|----------|     |
   +-----+  ^ |     |    |==================|    |     | ^  +-----+
         ^  |       +----+                  +----+     | |  ^
         |  |   Provider Edge 1         Provider Edge 2  |  |
         |  |                                            |  |
   Customer |                                            | Customer
   Edge 1   |                                            | Edge 2
            |                                            |
            |                                            |
    Attachment Circuit (AC)                    Attachment Circuit (AC)
    native ethernet service                    native ethernet service

Supposing that the PSN Tunnel is already in place referring to the
set-up of the PW that must be done using LDP why I can't behave as the
twp PEs are diretly connected given that there is a tunnel between them?

Regards

Diego

"Gandhi, Upma" <[email-masked]> on 13/12/2004 14.16.12

---

From: Luca Martini <[email-masked]>
Date: Mon, 13 Dec 2004 15:08:03 -0700

Diego,

Extended discovery means that the UDP hello packets to port 646 will 
have a destination IP address that is the remote PE's address.
Basic discovery involves sending the UDP hello packets to port 646 to 
destination address 224.0.0.2 ( the all routers multicast address ).
Packets to address 224.0.0.2 will not travel any further then the 
immediate neighbors.
Normally there is not MPLS FEC for 224.0.0.2

Luca

Diego Caviglia wrote:

>_______________________________________________
>pwe3 mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/pwe3
>
>  
>

---

From: Luca Martini <[email-masked]>
Date: Mon, 13 Dec 2004 15:12:15 -0700

I'm not sure where to start ....
The tunnel is not an "all purpose tunnel". Only IP packets that match 
the specific FEC will be put into the tunnel.
So only packets directed to specific IP addresses will traverse the tunnel.
There is no "adjacency" between the two PE.

Luca

Gandhi, Upma wrote:

>To:    "Diego Caviglia" <[email-masked]>
>cc:    <pwe3-bounces" [email-masked]"@smtpoutuk02.marconi.com>
>
>Then there is a need to extend those tunneling technology i.e RSVP-TE or
>any other technology  to send Pwid/PW type mapping which is used in
>figuring out L2 technology/ or understanding L2 technology i.e ATM/FR
>for which PWE3 is a transportation method.
>   Without this mapping other PE won't be able to understand L2 beneth
>that.
>
>Sent: Monday, December 13, 2004 6:36 PM
>To: Gandhi, Upma
>Cc: pwe3-bounces" [email-masked]"@smtpoutuk02.marconi.com
>My understanding is that the MPLS tunnel can be set-up also using
>RSVP-TE moreover the tunnel can be every kind of tunnel, MPLS is just a
>possible implementation.
>
>Supposing that I have already in place a tunnel between two PEs and I
>want to set-up a session why I can't use basic discovery?  By means of
>the tunnel the two end-point are adjacent.
>
>Regards.
>
>Diego
>
>
>
>"Gandhi, Upma" <[email-masked]> on 13/12/2004 14.01.27
>
>To:    "Diego Caviglia" <[email-masked]>
>cc:    "<pwe3-bounces" <[email-masked]>
>
>But MPLS tunnel  would internally be using LDP Extended discovery method
>to create the MPLS tunnel (assuming that its not static MPLS
>tunnel) for the same reason of not being in same AS or same topology or
>different ISPs.
>
>
>
>Sent: Monday, December 13, 2004 6:08 PM
>To: Gandhi, Upma
>Cc: <pwe3-bounces
>Subject: RE: [PWE3] LDP Signalling for Pws
>
>
>Hi Ghandi,
>              thank you for your reply, but I think I didn't make myself
>clear.
>
>My question is why I have to use the LDP extended discovery procedure,
>that is designed for non adjacent peers?
>
>In my view, given that I have a tunnel (e.g. an MPLS tunnel), the two
>LDP peers can be viewed as adjacent and thus I can use basic discovery.
>
>Regards
>
>Diego
>
>
>
>"Gandhi, Upma" <[email-masked]> on 13/12/2004 12.46.17
>
>To:    "Diego Caviglia" <[email-masked]>
>cc:    <[email-masked]>
>
>Hello Diego,
>To support PWE3, LDP has been extended which helps in negotiating PW
>type which further helps in determining different L2.
>To transport L2 messages over PSN network, one extra layer of control
>word has been added and to properly interpret L2 message and so Control
>word  i.e ATM, ETHERNET, Frame Relay LDP has been extended for some TLV
>i.e Pwid/generalized PWid which is used to understand how L2 would be
>interpreted.
>  As far as some basic discovery mechanism is concerned, since these PE
>might not be directly connected or immediate peer or of same topology,
>
>There is need for some session management between them. Since LDP
>already support this, it is being extended , even RSVP-TE is also in
>consideration.
>
>Thanks & Regards
>Upma
>
>From: [email-masked] [mailto:[email-masked]] On Behalf Of
>Diego Caviglia
>Sent: Monday, December 13, 2004 2:59 PM
>To: [email-masked]
>Subject: [PWE3] LDP Signalling for PWs
>
>Hi all,
>              ID draft-ietf-pwe3-control-protocol-13 states that ...The
>PEs will establish an LDP session using the Extended Discovery .." it is
>not clear to me why I can't use basic discovery mechansim given that I
>have e.g. an MPLS tunnel between the two PEs and thus a can tunnel Hello
>packets between the LSP peers.
>
>What am I missing?
>
>Thanks.
>
>Regards
>
>Diego
>
>
>

---

From: "Shah, Himanshu" <[email-masked]>
Date: Mon, 13 Dec 2004 17:41:52 -0500

If you allow tunnel (lets say RSVP-TE based) to be 
a logical IP i/f, one could conceivably send 
regular LDP hello to discover the remote PE.

This would be no different than if the target 
LDP peer were to be on the direct link (adjacent).

However, in order to differentiate topology based
LDP (link hello) from PWE3 signaling LDP (targetted), you have to
set the LDP Hello with t-bit set and send it
on unicast LDP Peer ID.

Unless of course, you recognize the i/f as tunnel
and 
1) use the tunnel end-point address as the unicast
address
2) send targetted hello

then you achieve what you intended.

/himanshu

> From: Luca Martini [mailto:[email-masked]]
> Sent: Monday, December 13, 2004 5:08 PM
> To: Diego Caviglia
> Cc: [email-masked]
> Subject: Re: [PWE3] LDP Signalling for PWs
> 
> 
> Diego,
>

---

From: "Diego Caviglia" <[email-masked]>
Date: Tue, 14 Dec 2004 10:13:39 +0100

Shah,
              thank for your replay, I agree with you.

May be could be useful to state that in the LDP signalling draft.

What is the feeling of the list on that matter?

Diego

"Shah, Himanshu" <[email-masked]> on 13/12/2004 23.41.52

---

From: Stewart Bryant <[email-masked]>
Date: Tue, 14 Dec 2004 11:21:51 +0000

We are really trying to get the control draft to RFC,
and therefore to restrict the changes, and that
means taking a hard line on anything except
protocol design errors.

This looks more like an applicability issue than a
correctness issue, and as perhaps we should
put it in an applicability draft?

- Stewart

Diego Caviglia wrote:
> To:    "'Luca Martini'" <[email-masked]>, Diego Caviglia
>        <[email-masked]>
> cc:    [email-masked]
> 
>>>             ID draft-ietf-pwe3-control-protocol-13 states
>>
>>that ...The PEs
>>
>>>will establish an LDP session using the Extended Discovery
>>
>>.." it is not
>>
>>>clear to me why I can't use basic discovery mechansim given
>>
>>that I have
>>
>>>e.g. an MPLS tunnel between the two PEs and thus a can
>>
>>tunnel Hello packets
>>
>>>between the LSP peers.
>>>
>>>What am I missing?
>>>
>>>Thanks.
>>>
>>>Regards
>>>
>>>Diego
>>>
>>>
>>>

---

From: "Diego Caviglia" <[email-masked]>
Date: Tue, 14 Dec 2004 12:30:27 +0100

Stewart,
                   no problem from my side I see that the ID is number 13
and thus is better to restrict the modify.

Purpose of my proposal is to state somewhere, an applicability ID could be
good, that is possible, using the procedure Shah depicted in his mail, to
use a tunnel to transport the Hello messages.

Regards

Diego

Stewart Bryant <[email-masked]> on 14/12/2004 12.21.51

---

From: Luca Martini <[email-masked]>
Date: Tue, 14 Dec 2004 09:36:07 -0700

Diego,

What Himanshu described still involves putting multicast into the rsvp 
tunnel. I do not believe that this is the practice today.
It can be done , but there is no significant advantage to just using the 
extended discovery mechanism. You should keep in mind that normal 
behavior is to actually put all the LDP packets into the MPLS LSP 
between the 2 PEs. ( regardless if it is RSVP sin galled or LDP signaled ).

Luca

Diego Caviglia wrote:

>To:    Diego Caviglia <[email-masked]>
>cc:    [email-masked], pwe3 <[email-masked]>, " <lmartini"
>       <[email-masked]>
>

---

From: "Shah, Himanshu" <[email-masked]>
Date: Tue, 14 Dec 2004 12:08:53 -0500

Nope.

I meant that router intelligently recognizes that
logical IP interface is a "tunnel" and hence for
targetted LDP purposes, send targetted hello to 
unicast IP address (which is the tunnel endpoint's
IP address). 

So if you are doing, topology LDP, you would send
link hello (a way to have LDP work across RSVP-TE
cloud using this tunnel) and at the same time if you 
are doing PWE3 signaling, you would also send targetted 
hello for extended discovery (using unicast IP address).

Hope this clears up.

Either way, I don't think there is any need to change
pwe3-control draft, because this would either be
an implementation detail or a suggested possibility in
applicability draft as Stewart suggested.

/himanshu

> Sent: Tuesday, December 14, 2004 11:36 AM
> To: Diego Caviglia
> Cc: Stewart Bryant <stbryant; Shah, Himanshu; pwe3 <pwe3

---

From: "Shah, Himanshu" <[email-masked]>
Date: Tue, 14 Dec 2004 12:21:51 -0500

One more clarification....

Granted that one could very well do basic 
discovery using multicast IP address and
then exchange PW FECs over this tunnel.

The only reason for still doing extended
discovery using targetted hello is to 
remain interoperable with tons of those PEs
out there who specifically support extended
discovery even when a remote PE is directly
connected via a "tunnel" or a direct link.

IMO.

himanshu

> From: Shah, Himanshu 
> Sent: Tuesday, December 14, 2004 12:09 PM
> To: 'Luca Martini'; Diego Caviglia
> Cc: Stewart Bryant <stbryant; pwe3 <pwe3

---

From: Cheng-Yin Lee <[email-masked]>
Date: Tue, 14 Dec 2004 15:57:59 -0500

Himanshu,

"Shah, Himanshu" wrote:

> discovery using multicast IP address

over a tunnel/logical IP interface.
Agree with the above and I believe it is what Diego suggested.

There seems to be some advantage in using basic discovery over a tunnel in
that it is not necessary to configure a PE with the remote PE addresses for
PW signaling ...

> connected via a "tunnel" or a direct link.

Agree there is no need to change this feature for interoperablility
purposes, as long as the draft does not preclude other options.

Thanks
Cheng-Yin

---

From: "Diego Caviglia" <[email-masked]>
Date: Wed, 15 Dec 2004 08:27:14 +0100

Hi Cheng-Yin,
                              yes that was I had in mind.

Regards.

Diego

Cheng-Yin Lee <[email-masked]> on 14/12/2004 21.57.59

---

From: Sasha Vainshtein <[email-masked]>
Date: Wed, 15 Dec 2004 10:15:51 +0200

Diego, Che-Yin and all,
Please see a brief comment inline.

Regards,
                                  Sasha Vainshtein
email:                         [email-masked] <mailto:[email-masked]> 
phone:                       +972-3-7569993 (office)
fax:                            +972-3-6487779
mobile:                      +972-52-8674833 

> Sent: Wednesday, December 15, 2004 9:27 AM
> To: Cheng-Yin Lee <Cheng-Yin.Lee
> Cc: [email-masked]; [email-masked]; [email-masked]; 
> [email-masked]
> To:    "Shah, Himanshu" <[email-masked]>
> cc:    "'Luca Martini'" <[email-masked]>, "'Diego Caviglia'"
>        <[email-masked]>, "'pwe3 <pwe3'" <[email-masked]>,
>        "'Stewart Bryant <stbryant'" <[email-masked]>
> 
[Sasha] I do not see any advantage here. 
You know (one of) the IP address(es) of the remote PE
because you need it to configure the tunnel first.
And then you must configure the PE to use a specific 
tunnel LSP leading to the specific peer PE instead.

---

From: "Florin Balus" <[email-masked]>
Date: Wed, 15 Dec 2004 06:23:08 -0500

Before discussing whether or not it is worthwhile to support signaling PW
over LDP interfaces supported on top of PSN tunnels (using basic discovery):
it's worthwhile to keep LDP basic discovery option in scope for the PW
signaling even if it is just for the case of directly connected PEs! 

Why open up a new LDP session using targeted discovery between directly
connected PEs that already discovered each other using a basic discovery
phase? 
Florin

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Sasha Vainshtein
> Sent: Wednesday, December 15, 2004 3:16 AM
> To: 'Diego Caviglia'; Cheng-Yin Lee <Cheng-Yin.Lee
> Cc: [email-masked]; [email-masked]; [email-masked]; 
> [email-masked]
> > > > logical IP interface is a "tunnel" and hence for targetted LDP 
> > > > purposes, send targetted hello to unicast IP address 
> (which is the 
> > > > tunnel endpoint's IP address).
> > > >
> hello for 
> > > > extended discovery (using unicast IP address).
> > > >
> > > > Hope this clears up.
> > > >
> pwe3-control 
> > > > draft, because this would either be an implementation 
> detail or a 
> > > > suggested possibility in applicability draft as Stewart 
> suggested.
> > > >
> > > > /himanshu
> > > >
> > > > > What Himanshu described still involves putting multicast into 
> > > > > the rsvp tunnel. I do not believe that this is the practice 
> > > > > today. It can be done , but there is no significant 
> advantage to
> > > > > just using the
> > > > > between the 2 PEs. ( regardless if it is RSVP sin 
> galled or LDP 
> > > > > signaled ).
> > > > >
> > > > > Luca
> > > > >
> > > > >
> > > > > Diego Caviglia wrote:
> > > > >
> > > > > >Stewart,
> > > > > >We are really trying to get the control draft to RFC, and 
> > > > > >therefore to restrict the changes, and that means 
> taking a hard 
> > > > > >line on anything except protocol design errors.
> > > > > >
> correctness 
> > > > > >issue, and as perhaps we should put it in an applicability 
> > > > > >draft?
> > > > > >
> > > > > >- Stewart
> > > > > >
> > > > > >Diego Caviglia wrote:
> > > > > >
> > > > > >
> > > > > >>Shah,
> > > > > >>1) use the tunnel end-point address as the unicast address
> > > > > >>2) send targetted hello
> > > > > >>
> > > > > >>>>[email-masked] https://www1.ietf.org/mailman/listinfo/pwe3
> > > > > >>>>
> > > > > >>>>
> > > > > >>>>
> > > > > >>>>
> > > > > >>>>
> > > > > >>>[email-masked] https://www1.ietf.org/mailman/listinfo/pwe3
> > > > > >>>
> > > > > >>>
> > > > > >>>
> > > > > >>
> > > > > >>
> > > > > >>
> > > > > >>
> > > > > >>
> > > > > >>[email-masked] https://www1.ietf.org/mailman/listinfo/pwe3
> > > > > >>
> > > > > >>
> > > > > >>
> > > > > >>
> > > > > >
> > > > > >
> > > > > >
> > > > > >
> > > > > >
> > > > > >
> > > > >
> > > >
> > >

---

From: Luca Martini <[email-masked]>
Date: Mon, 20 Dec 2004 10:01:18 -0700

There is only one possible LDP session between 2 PEs.
Basic discovery does not apply to PWs. The PW end point MUST be known 
and configured, there therefore is no advantage in having basic discovery.

This is my last e-mail on this thread.
Luca

Florin Balus wrote:

>
> Before discussing whether or not it is worthwhile to support signaling 
> PW over LDP interfaces supported on top of PSN tunnels (using basic 
> discovery): it's worthwhile to keep LDP basic discovery option in 
> scope for the PW signaling even if it is just for the case of directly 
> connected PEs!
>
> Why open up a new LDP session using targeted discovery between 
> directly connected PEs that already discovered each other using a 
> basic discovery phase?
>
> Florin
>
>------------------------------------------------------------------------
>