Subject: RE: Re: I-D ACTION:draft-martini-pwe3-MH-PW-requirements-00.txt

From: Chris Metz <[email-masked]>
Date: Wed, 19 Jan 2005 15:06:41 -0800

At 11:28 AM 1/19/2005 -0500, David McDysan wrote:
>I recommend that the knowledge of a remote U-PE IP address (or at least a
>prefix associated with a domain) be not only mentioned in the use cases
>section, but also be stated as a mandatory (i.e., SHALL) requirement in the
>routing section.

Hey Dave-
I don't quite see how it should be a mandatory requirement for the
local (source) U-PE to learn the IP address of the remote (target) U-PE. At
a minimum the U-PE or any PE leading up to and including the
"penultimate PE" needs the IP address of the next_hop PE.

If we route the PW setup based on the /32 of the remote U-PE we might
bypass the desired intermediate S-PEs, no?

>Based upon other discussion on this thread, also suggest that use of other
>identifiers

.. and the IP address (or prefix) identifying the remote U-PE ...

>  (and associated authentication) for use in routing be stated as
>a desirable (SHOULD) requirement in the routing section.

Thanks ...

>Dave
>
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] On
> > Behalf Of dimitri papadimitriou
> > Sent: Sunday, December 19, 2004 6:34 PM
> > To: Chris Metz
> > Cc: [email-masked]; [email-masked];
> > [email-masked]; Alik Shimelmits; [email-masked];
> > [email-masked]; Luca Martini;
> > [email-masked]; [email-masked]; Sasha
> > Vainshtein; [email-masked];
> > [email-masked]; PWE3 WG (E-mail);
> > [email-masked]; [email-masked]; Sharon Galtzur;
> > Ping Pan; [email-masked]; [email-masked];
> > [email-masked]
> > Subject: Re: [PWE3] Re: I-D
> > ACTION:draft-martini-pwe3-MH-PW-requirements-00.txt
> >
> >
> > per section 5.2.1. of PW control: "The Attachment Identifier must be
> > unique in the context of the PE router in which the Forwarder
> > resides.
> > The combination <PE router, AI> must be globally unique."
> >
> > therefore, either the PE router is used (leaving AC selection being a
> > local process) or both are explicitly specified as part of
> > the request
> > or one identifies the ACs using their mapping in the CP as IP
> > addresses
> > since a reachable point can be translated with an IP prefix (at the
> > control plane level) whereas the corr. data plane end-point does not
> > have to terminate IP packets
> >
> > Chris Metz wrote:
> >
> > > At 03:51 PM 12/14/2004 -0700, Luca Martini wrote:
> > > <snip>
> > >
> > >
> > >>>    1. I think that the following statement in the "Use
> > Cases" section
> > >>>       requires clarification: "*At a minimum PW control
> > >>>       channel establishment requires knowledge of and
> > reachability to
> > >>>       the remote (ultimate) PE IP address*". I understand that
> > >>>       *reachability* of the remote ultuimate PE IP address may be
> > >>>       problematic in some cases; but do we really
> > envision the case
> > >>>       when a PE can be set up without the one of the ultimate PEs
> > >>>       possessing any *knowledge* about IP address of its remote
> > >>> peer?
> > >
> > >
> > > Yes ... especially if the MH-PW setup scheme is created in
> > such a way
> > > so that the source U-PE does not need to know the IP address of the
> > > remote U-PE. This may be for variety of reasons including security,
> > > scale, etc.
> > >
> > > We would need to include TAI that identifies the desired AC on the
> > > remote U-PE.
> > >
> > > Cheers ...
> > >
> > > <snip>
> > >
> > > _______________________________________________
> > > pwe3 mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/pwe3
> > >
> > > .
> > >
> >
> > _______________________________________________
> > pwe3 mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/pwe3
> >

---

From: David McDysan <[email-masked]>
Date: Wed, 19 Jan 2005 11:28:41 -0500

Based upon other discussion on this thread, also suggest that use of other
identifiers (and associated authentication) for use in routing be stated as
a desirable (SHOULD) requirement in the routing section.

Dave