Subject: Re: Re: I-D ACTION:draft-martini-pwe3-MH-PW-requirements-00.txt

From: "Thomas D. Nadeau" <[email-masked]>
Date: Fri, 28 Jan 2005 01:48:21 -0500

On Jan 27, 2005, at 10:50 AM, David McDysan wrote:

>
>
>> From: Thomas D. Nadeau [mailto:[email-masked]]
>>> Tom, Neil,
>>>
>>> A few comments in line below.
>>>
>>> Dave
>>>
>>>> From: [email-masked]
>> [mailto:[email-masked]] Thomas
>>>> D. Nadeau wrote 25 January 2005 15:46
>>>>> On Jan 25, 2005, at 9:51 AM, David McDysan wrote:
>>>>>
>>>>>> Trimming distro to PWE3.
>>>>>>
>>>>>> A few responses in line below related to the MH-PW requirements
>>>>>> discussion.
>>>>>>
>>>>>> Dave
>>>>>
>>>>>>> Hi Dave,
>>>>>>> David McDysan wrote 19 January 2005 16:29
>>>>>>>>
>>>>>>>> Neil,
>>>>>>>>
>>>>>>>> This would certainly be an issue for manual
>> provisioning of PWs.
>>>>>>>> When PEs use IP routing then the pre-provisioned
>>>>> existence of these
>>>>>>>> lower layer connections is confirmed periodically by
>>>>> in-band routing
>>>>>>>> protocol message exchange.
>>>>>>> NH=> I sincerely hope not!  That is, we must not use the
>>>>>>> control-plane to determine whether the data-plane is working.
>>>>>>
>>>>>> I disagree. "Control plane" has determined whether data plane is
>>>>>> working has done sucessfully in packet switched networks
>>>>> for decades.
>>>> NH=> You may like to observe that most co-cs mode networks
>> (like the
>>>> PSTN and SDH for example) have a packet-switched
>>>> control/management-plane network.  This does not, and
>> indeed cannot,
>>>> proxy for the OAM in the *traffic* data-plane.  The same
>> argument can
>>>> be applied to co-ps mode networks if these are using OOB
>>>> control/management.
>>>
>>> DM: Most packet switched networks use "inband" control and
>> avoid the
>>> additional complexity of needing to confirm that the data plane
>>> connections are congruent with the control plane
>> configuration. An SS7
>>> continutity check
>>> is an example of such additional complexity that is necessary with
>>> out-of-band control. Regarding advancing the MH-PW
>> requirements work, I
>>> suggest adding a requirement that the protocol be able to support
>>> "in-band"
>>> as well as "out-of-band" control. I would look for service providers
>>> advocating "out-of-band" control to articulate the associated
>>> requirements
>>> in greater detail. I plan to focus on requirements the "in-band"
>>> control for
>>> PW and MPLS. Hopefully, there will be some overlap in
>> requirements for
>>> "in-band" and "out-of-band," but I expect that there will also be
>>> differences.
>>>
>>>>>
>>>>> 	I think that might be because control plane messages
>>>>> might have been following the same path as data plane
>> messages. In
>>>>> those cases the control plane will usually detect failures;
>>>> however,
>>>>> once you break the two apart, all bets are off.
>>>> NH=> This is a normal behaviour in a cl-ps mode network.
>>>>>
>>>>>>>  This is a fundamental OAM requirement in both the co-ps
>>>> and co-cs
>>>>>>> modes.
>>>>>>
>>>>>> In my experience with packet switched networks, ATM
>> VPC/VCC style
>>>>>> continuity verification OAM detects a small set of
>> failures that a
>>>>> control plane
>>>>>> overlay does not. If the control plane is not reliably
>>>> establishing
>>>>>> "data
>>>>>> plane" forwarding relationships, then the problem is
>>>>> usually with the
>>>>>> implementation, not the architecture.
>>>>>
>>>>> 	Or with "fat fingers". *)  Many of the operators I have
>>>> talked to
>>>>> about troubles scenarios have told me that upwards of %80
>> of faults
>>>>> are caused by mis-configuration. So I would say that you are both
>>>>> correct in that what is really needed is both data plane
>> and control
>>>>> plane OAM, and specifically the combination of both to
>> verify each
>>>>> other's view of the world.  This seems to cover most of the cases.
>>>
>>> Tom, could you please say a little more about what you mean by
>>> "control plane OAM?"
>>
>> 	I mean things that pertain to the maintenance and
>> monitoring of the control plane.  An example of this would be
>> if you were using targeted LDP to signal the MH-PW, you would
>> want control plane to able to signal/relay certain status messages
>> from the MH PW.   You might want to check that if the
>> control plane hasn't sent back these messages, that the
>> data plane actually jives with this "up" status, for example.
>>
>> 	--Tom
>
> If you mean using (something like) VCCV to confirm data plane 
> "liveliness"
> state of the PW and comparing this with the state determined by the 
> control
> signaling protocol then I agree.

	Yes.

>  I think there are some additional
> requirements related to MH-PW that were mentioned on this thread that 
> relate
> to being able do this on a SH PW segment basis of a MH PW in support 
> of at
> least diagnostics and also performance measurement that I believe 
> should be stated as a requirement.

	Agreed.

	--tom

> Snipped to the end.

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Fri, 28 Jan 2005 01:49:05 -0500

On Jan 27, 2005, at 10:50 AM, David McDysan wrote:

> signaling protocol then I agree. I think there are some additional

	This is something we should talk about when we
can get together next (with Luca).  We figured out
how to do a lot of this already, just haven't
released it.

	--Tom