Subject: multiple mpls tunnels

From: "Kulkarni, Hrishikesh (Hrishikesh)" <[email-masked]>
Date: Tue, 1 Mar 2005 11:33:13 +0530

In a scenario wherein multiple tunnels exits between two  PE's.
If the pwe3 setup doest carry the outer tunnel info, how does the PE map the
data flow
from the inner label (pwe3 label) to the Attachment circuit flow in the CE.

rishi

Sample setup.

            LSP1
          ------------------>
             LSP2
          <-----------------
CE1====PE1                      PE2 ====CE2
          ------------------>
             LSP3
          <------------------
              LSP4

For an ATM pwe3, 
a typical router configuration would include,
-- going to the CE interface, and configuring the encapsulation type and
l2transport and vpi/vci
-- then providing the peer address and PWid will trigger the pwe3 setup.

The PE1 would select the lsp which provides reachability to PE2. and
vice-versa for PE2.

PE2 will program inner label advertised by PE1 ,   then PE1 and PE2 attach
it to there respective vpi/vci 
PE1 will program inner label advertised  by PE2,   then PE1 and PE2 attach
it to there respective vpi/vci 
say in this case , LSP1 and LSP2 are the tunnels selected for transport.

what happens if LSP2 goes down? what happens if LSP1 goes down? 
is the pwe3 re-established or the pwe3 data is passed on to other tunnels ,
lsp3 or lsp4 ?

---

From: "Busschbach, Peter B (Peter)" <[email-masked]>
Date: Tue, 1 Mar 2005 13:35:18 -0500

Rishi,

You asked "how does the PE map the data flow from the inner label (pwe3 label) to the Attachment circuit flow in the CE", but in the example that you give you seem to be exploring another issue.

To answer the first question: the association between an AC and a PW is either estiblished by the operator (in case the PWid FEC is used) or is encoded in the Generalized Id FEC. The association has nothing to do with the Tunnel LSP. 

Your second question seems to be: how can it be independent of the Tunnel LSP? Answer: the PW Label is unique for the egress PE. I.e. by just inspecting the PW Label, the egress PE knows which PW is belongs to and, because of the accociation between PW and AC, it knows for which AC the received payload is intended. The Tunnel LSP label is irrelevant and, in fact, because of PHP, may not even be present when the packet arrives at the egress PE.

But, you ask, what happens if the Tunnel LSP goes down? Then the ingress PE will need to carry the PW over a different tunnel LSP. Perhaps such a tunnel already exist, perhaps it needs to be established. It depends on your implementation. If the Tunnel LSP was established with certain QoS parameters and after a failure it can not be re-established, it is possible that the PW needs to be declared down, because of a failure in the server layer. However, the fact that a failure in the Tunnel LSP can influence the status of the PW does not necessarily mean that there is a fixed association between the two.

Hope this helps,

Peter

> -----Original Message-----
> From: Kulkarni, Hrishikesh (Hrishikesh) 
> Sent: Tuesday, March 01, 2005 1:03 AM
> To: [email-masked]
> Cc: Busschbach, Peter B (Peter); Kujur, Amulya Rajeev 
> (Amulya); Agiwal,
> Manoj (Manoj)
> Subject: multiple mpls tunnels
> 
> 
> If the pwe3 setup doest carry the outer tunnel info, how does 
> the PE map the data flow
> -- going to the CE interface, and configuring the 
> encapsulation type and l2transport and vpi/vci
> The PE1 would select the lsp which provides reachability to 
> PE2. and vice-versa for PE2.
> 
> PE2 will program inner label advertised by PE1 ,   then PE1 
> and PE2 attach it to there respective vpi/vci 
> PE1 will program inner label advertised  by PE2,   then PE1 
> and PE2 attach it to there respective vpi/vci 
> is the pwe3 re-established or the pwe3 data is passed on to 
> other tunnels , lsp3 or lsp4 ?
> 
> 
> 
> 
> 
> 
>            
>