Subject: IANA allocation

From: Stewart Bryant <[email-masked]>
Date: Mon, 14 Mar 2005 14:17:35 +0000

There was considerable debate at the IETF62 PWE3-WG mtg. about
the process for IANA allocation. We agreed that we would
continue the discussion on the list.

At the meeting there seemed to be consensus that all registry
entries that define fields that go in data packets such as
Channel Type (draft-ietf-pwe3-cw) REQUIRE the use of the
IETF consensus process.

At the meeting there also seemed to be consensus that the
registry entries that are used by the control protocol
would have two ranges:

1) IETF consensus
2) First come first served

We decided that vendor specific requirements would be covered
by FCFS.

We did not come to any conclusion on the sizes of the IETF consensus
and the FCFS ranges, although we did note that the currently
proposed IETF consensus range was small.

Perhaps we should allocate 50% to IETF consensus and 50% to FCFS?
That should give room for any anticipated vendor action, and yet
still ensure that space remains for any IETF action. We can
always - by IETF consensus - increase FCFS if we need to at
some time in the future.

We did not properly resolve the issue what level of documentation
is needed for FCFS. We got as far as saying that an IETF draft
needs to be written. However some folks were thought that we
needed to say that an RFC was required, whilst others said that
was tantamount to IETF consensus always being required.

Is there agreement that the above is a fair summary of where
we got to in the meeting?

Does anyone have a practical suggestion regarding the way we
specify the required FCFS documentation?

- Stewart

---

From: Sasha Vainshtein <[email-masked]>
Date: Mon, 14 Mar 2005 16:36:45 +0200

Stewart and all,
Please see below brief comments of a "side observer" 
(I have not been present at the IETF-62 PWE3 meeting).

Regards,
                                  Sasha Vainshtein
email:                         [email-masked] <mailto:[email-masked]> 
phone:                       +972-3-7569993 (office)
fax:                            +972-3-6487779
mobile:                      +972-52-8674833 

> -----Original Message-----
> From: Stewart Bryant [mailto:[email-masked]]
> Sent: Monday, March 14, 2005 4:18 PM
> To: pwe3
> Subject: [PWE3] IANA allocation
> 
> 
[Sasha] Sounds OK
> We decided that vendor specific requirements would be covered
[Sasha] IMO this depends on the resolution of the next question, namely
"what level of documentation is required for FCFS".
> proposed IETF consensus range was small.
[Sasha] Depends on the Registry. E.g., the PW Type is 15 bits
today, with 64 values reserved for the IETF consensus part.
After almost 4 years of the PWE3 activity we have succeeded
to use less than half of this space (1 - 0x19). Since I expect
that new PW Types will emerge at lower rate after the initial period,
the currently defined space should suffice for some 10 years.
If we decide to be really large and increase the IETF consensus space
to 256, this would be, IMO, as good as allocating 16K values
(never will be used up).
> was tantamount to IETF consensus always being required.
[Sasha] This is, indeed the key issue, and I agree with those who claim
that requireing an RFC for FCFS is tantamount to IETF consensus always
being required. IMHO posting of an I-D would suffice as a reasonable
compromise, especially since the Secretariat now leaves a tombstone in 
place of an expired RFC with the authors' email addresses.
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
>

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 14 Mar 2005 13:35:11 -0500

To agree with Sasha, there are non-IETF sites that store all internet 
drafts without expiring them, so old drafts are very easy to find.

And as Sasha said, depending on the size of the field, 50%/50% can be much 
larger than necessary for IETF consensus action.  So we should look at each 
registry individually, rather than one blanket rule for all of them.

Cheers,
Andy

---------

---

From: "Yaakov Stein" <[email-masked]>
Date: Tue, 15 Mar 2005 16:56:41 +0200

Stewart/Sasha

I find myself in the unusual position 
of having Sasha agreeing with what I proposed
at the meeting.

I believe that the effort of putting together
an ID that is accepted by the ID editor 
and the need to clearly explain the planned usage
to the WG is sufficient deterrent to 
frivolous allocation requests.

In addition, even if the ID disappears from the IETF site,
there are stable archives where the original proposal
may be viewed for an indefinite period.

I therefore believe that FCFS conditioned on
an ID is reasonable.

Regarding the number of PW types,
although agreeing in principle that we won't need many, 
I prefer to leave 1024, like the well-known ports.
In fact, I think we should call them well-known PW types.

Y(J)S