Subject: draft-martini-pwe3-mh-pw-requirements-01.txt to WG draft?

From: Stewart Bryant <[email-masked]>
Date: Thu, 17 Mar 2005 19:36:33 +0000

At the IETF62 PWE3 meeting, the consensus of the room was
to make

http://www.ietf.org/internet-drafts/draft-martini-pwe3-mh-pw-requirements-01.txt

a WG draft (see minutes of meeting).

This is a formal check to see whether the PWE3 list
concurs.

- Stewart

---

From: "Shah, Himanshu" <[email-masked]>
Date: Thu, 17 Mar 2005 15:39:29 -0500

Agreed.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Stewart Bryant
> Sent: Thursday, March 17, 2005 2:37 PM
> To: pwe3
> Cc: Danny McPherson
> Subject: [PWE3] draft-martini-pwe3-mh-pw-requirements-01.txt to WG
> draft?
> 
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
>

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 17 Mar 2005 16:55:28 -0500

Cool with me.

	--tom

> I agree.
>
> Alia
>
> At 02:36 PM 3/17/2005, Stewart Bryant wrote:

---

From: "Nurit Sprecher" <[email-masked]>
Date: Sun, 20 Mar 2005 10:38:26 +0200

I sent some comments to the authors of the draft, but unfortunately I
have got no response :-(.
Please see the attached mail.
Regards,
Nurit.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Stewart Bryant
Sent: Thursday, March 17, 2005 9:37 PM
To: pwe3
Cc: Danny McPherson
Subject: [PWE3] draft-martini-pwe3-mh-pw-requirements-01.txt to WG
draft?

http://www.ietf.org/internet-drafts/draft-martini-pwe3-mh-pw-requirement
s-01.txt

- Stewart

---

From: [email-masked]
Date: Tue, 22 Mar 2005 18:51:45 +0100

indeed, in-line with the last PWE3 WG meeting discussions, the proposed text update is sensible (the idea of co-existence becomes effectively a requirement in the present context) - i would even be more accurate by listing the setup mechanisms references

Rahul Aggarwal <[email-masked]>
Sent by: [email-masked]
03/21/2005 10:14 PST

To: Stewart Bryant <[email-masked]>
cc: pwe3 <[email-masked]>, Danny McPherson <[email-masked]>
bcc:
Subject: Re: [PWE3] draft-martini-pwe3-mh-pw-requirements-01.txt to WG draft?

Hi Stewart,

> a WG draft (see minutes of meeting).

As pointed out in the PWE3 meeting by other folks, I would like to see the
following addressed, before it is re-issued as a WG document.

>From the draft:

"6.4. MS-PW Setup Mechanisms.

....

There are four different SS-PW signaling protocols that are defined
to signal PWs:

-i. Static configuration of the SS-PW (MPLS or L2TPv3).

-ii. LDP using PWid FEC 128

-iii. LDP using the generalized PW FEC 129

-iv. L2TPv3

Any combination of these signaling protocols MUST be supported."

The above text can be interpreted in many ways. I think the intent is that
the MS-PW setup mechanism should be able to co-exist with existing SS-PW
setup mechanisms. The intent is *not* to mandate one or more of the
existing SS-PW setup protocols as the MS-PW setup protcol and limit the
MS-PW setup protocol to one or more of these. This is a fundamental issue
as a requirements draft cannot mandate the solutions.

Hence I propose the following revision of the above text

"6.4. MS-PW Setup Mechanisms.

....

MS-PW setup mechanisms SHOULD be able to co-exist with existing SS-PW
setup mechanisms that have been defined by the IETF. "

Thanks,
rahul

---

From: [email-masked]
Date: Wed, 23 Mar 2005 09:32:39 -0000

I agree that this text needs revising. As Rahul points out, it could be interpreted in a number of ways. I would say the two extremes would be:

[1] MS-PW segment setup must be supported using static configuration, LDP with PWid FEC 128, LDP with generalized PW FEC 129, and L2TPv3. Any combination of setup mechanisms across different segments must also be supported, and therefore interworking between these mechanisms must be supported.

[2] Rahul’s interpretation: ”MS-PW setup mechanisms SHOULD be able to co-exist with existing SS-PW setup mechanisms that have been defined by the IETF.”

I don’t agree with [1], as already expressed by others the requirements document should not define which MS-PW setup mechanisms must be supported. The whole point of establishing the requirements first is to from a basis on which to decide what the best mechanisms to reuse are (or if new mechanisms are required). Ideally we would just define a single best of breed MS-PW setup mechanism based on the requirements. However, due to different operators having different requirements, and different vendors having their own preference for whatever reasons, no doubt we will end up having multiple mechanisms.

Saying that, I don’t think there is much point in specifying [2] as this is just common sense. Its like saying RSVP-TE should be able to co-exist with LDP, or in general, new mechanism X should be able to co-exist with existing mechanism Y. If [2] is included then shouldn’t we also include: “MS-PW discovery mechanisms SHOULD be able to co-exist with existing SS-PW discovery mechanisms...”, “MS-PW authentication mechanisms SHOULD be able to co-exist with existing SS-PW authentication mechanisms...”, etc? 

I don’t think there is any need for the requirements document to mention the existing SS-PW setup mechanisms at all. However, we do need to say in the requirements document that MPLS labels and L2TPv3 session IDs must both be supported for MS-PW demultiplexing, along with interworking between them. Unfortunately, there is no getting around this as it seems providers that have deployed L2TPv3 PWs want to use L2TPv3 for MS-PWs and to interoperate with providers that use MPLS based MS-PWs.

Regards,

Richard

-----Original Message----- 
From: [email-masked] on behalf of [email-masked] 
Sent: Tue 22/03/2005 12:51 
To: Rahul Aggarwal 
Cc: Danny McPherson; pwe3; Stewart Bryant 
Subject: Re: [PWE3] draft-martini-pwe3-mh-pw-requirements-01.txt to WG draft?

	

	Hi Stewart,

	

		....

			
			
			-iv. L2TPv3

	

		....

	Thanks,
	rahul