Subject: Re: PWE3 Charter Update

From: Luca Martini <[email-masked]>
Date: Wed, 16 Mar 2005 13:13:24 -0700

Danny,

The three point below will need some careful consideration:

"Define requirements for and mechanisms to provide interconnection
of PWs. "

This is fine , as it does not create a service , nor does it necessarily 
put new requirements on the defines service.

"Define requirements for and mechanisms to provide inter-domain
operation of PWs. "

This is a little tricky. I believe that if we do this here , we will 
need to pull in VPWS service from L2VPN.
L2VPN already has WG drafts defining this item. So I think this 
duplicates the work here.

For example : are we going to deal with VPN security at the border of a 
domain/AS ? or just worry about PW security ?

I believe that unless VPWS is moved here, there is too much overlap , 
with L2VPN , and it is better to add this item to L2VPN WG.

"Define the requirements for and mechanisms needed to allow the
operation of switched virtual circuits over a PSN."

I believe that OAM is already in pwe3 , so this item is long overdue 
...  shouldn't it say "operation and management" ?

Luca

Danny McPherson wrote:

>
> Folks,
> Here's a proposed update to the PWE3 charter.  Once
> we complete this we'll work on getting the goals and
> milestones updated accordingly.  Stewart and I will also
> provide a complete draft status report in MSP.
>
> If you've got input we'd like to receive it within the next
> two weeks.  Comments and discussion welcome!
>
> Thanks!
>
> -danny & Stewart
>
> -----
> Pseudo Wire Emulation Edge to Edge (PWE3) WG
>
> Description of Working Group:
>
> Network operators and their subscribers are seeking to rationalize
> their networks by migrating to a single, IP or MPLS based packet
> switched network (PSN). This migration requires communications
> services that can emulate the essential properties of traditional
> communications links over a PSN.
>
> Pseudowire Emulation Edge to Edge (PWE3) will specify the
> encapsulation, transport, control, management, interworking and
> security of services emulated over IETF specified PSNs.
>
> A pseudowire emulates a point-to-point link, and provides a
> service which is perceived by its user as an unshared link
> or circuit of the chosen service.
>
> It is not intended that an emulated service will be
> indistinguishable from the service that is being emulated.
> The emulation need only be sufficient for the satisfactory
> operation of the service. Emulation necessarily involves
> a degree cost-performance trade-off. In some cases it may
> be necessary to design more than one emulation mechanism in
> order to resolve these design conflicts. All emulated
> service definitions will include an applicability statement
> describing the faithfulness of the emulation.
>
> Switching, multiplexing, modification or other operation on
> the traditional service, unless required as part of the
> emulation, is out of the scope of the PWE3 WG.
>
> PWE3 will make use of existing IETF specified mechanisms
> unless there are technical reasons why the existing mechanisms
> are insufficient or unnecessary.
>
> PWE3 will not exert control on the underlying PSN, other than
> to use any existing QoS or path control mechanism to provide
> the required connectivity between the two endpoints of the PW.
>
> PWE3 will investigate mechanisms necessary to perform clock
> recovery and other real-time signaling functions.  This work will
> be coordinated with the AVT WG and RTP will be used where
> appropriate.
>
>
> WG Objectives (in order of priority):
>
> Specify the following PW types and consider specification of
> additional PW types contingent on WG consensus and AD approval:
>
> Ethernet, Frame Relay, PPP, HDLC, ATM, TDM and SONET
>
> Specify the control and management of the PW types
> identified above.
>
> Specify OAM mechanisms for all PW types, suitable for
> operation over both IP and MPLS PSNs, and capable of
> providing the necessary interworking with the OAM mechanisms
> of the emulated service.
>
> Enhance packet-based PW specifications as necessary to
> allow the emulated service to be carried transparently
> over the PSN, for example by the retention of the FCS
> across the PW.
>
> Define mechanisms to permit the operation of a PW over
> a PSN that deploys equal cost multiple path packet (ECMP)
> switching.
>
> A PW operating over a shared PSN does not have the same
> intrinsic security as a dedicated, purpose built, network.
> In some cases this is satisfactory, while in other cases it
> will be necessary to enhance the security of the PW
> to emulate the intrinsic security of the emulated service.
> PW specifications MUST include a description of how they
> are to be operated over a shared PSN with adequate security.
>
> Whilst a service provider may traffic engineer their network
> is such a way that PW traffic will not cause significant
> congestion, a PW deployed by an end-user may cause
> congestion of the underlying PSN. Suitable congestion
> mechanisms are therefore needed to protect the Internet
> from the unconstrained deployment of PWs.
>
> Define requirements for and mechanisms to provide interconnection
> of PWs.
>
> Define requirements for and mechanisms to provide inter-domain
> operation of PWs.
>
> Define the reqiurements for and mechanisms needed to allow the
> operation of switched virtual circuits over a PSN.
>
>
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Rahul Aggarwal <[email-masked]>
Date: Fri, 18 Mar 2005 14:13:05 -0800 (PST)

Hi Danny,

A comment inline.

> Define requirements for and mechanisms to provide inter-domain

I am not aware of any other application of interconnection of PWs other
than interdomain operation of PWs. Hence the real charter item is:
"requirements for and mechanisms to provide inter-domain operation of
PWs".

Interconnection of PWs is one possible mechanism to build inter-domain
operation of PWs. Hence there is no need to mention it in the charter.

thanks,
rahul

---

From: Bruce Davie <[email-masked]>
Date: Fri, 18 Mar 2005 18:00:08 -0500

> "requirements for and mechanisms to provide inter-domain operation of

draft-ietf-l2vpn-signaling-03.txt describes the interconnection of PWs to 
support distributed VPLS. Such interconnection happens within a domain. So 
I guess the charter items should probably stay as they are.

Bruce

---

From: David McDysan <[email-masked]>
Date: Tue, 22 Mar 2005 08:37:29 -0500

Rahul,

The MS-PW requirements document states several use cases that are
intra-domain (e.g., metro access, large number of nodes). Therefore, I
suggest that "inter-domain" be expanded to "inter- and intra-domain" in the
charter statement. Some mention of scalability and interoperability could be
used to qualify the intra-domain applicaiton.

Dave

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Rahul Aggarwal
> Sent: Friday, March 18, 2005 5:13 PM
> To: Danny McPherson
> Cc: pwe3
> Subject: Re: [PWE3] PWE3 Charter Update
> 
> 
> Hi Danny,
> 
> A comment inline.
> 
> >
> > Define requirements for and mechanisms to provide 
> interconnection of 
> > PWs.
> >
> I am not aware of any other application of interconnection of 
> PWs other than interdomain operation of PWs. Hence the real 
> charter item is:
> "requirements for and mechanisms to provide inter-domain 
> operation of PWs".
> 
> Interconnection of PWs is one possible mechanism to build 
> inter-domain operation of PWs. Hence there is no need to 
> mention it in the charter.
> 
> thanks,
> rahul
> 
>