Subject: Re: draft-raggarwa-rsvpte-pw-01.txt

From: Luca Martini <[email-masked]>
Date: Wed, 23 Mar 2005 10:04:46 -0700

Shahram,

Neither does the RSVP-TE method. It might appear on the surface that 
rsvp-te supports these functions , but it would need a lot of work to 
actually support multi-hop PWs or even PWs .

If the question is : can we make RSVP-TE fit this application ? then the 
answer is yes , but it will need a lot of new protocol specification.
CAC for PW ? RSVP-TE does not do CAC. The routing algorithm does. All 
that we have in RSVP-TE is the ability to carry QoS parameters , that 
might not even fit the PW specification. Can you specify a Sustained 
Cell Rate in RSVP ? No.
We do not have any of  the control protocol extensions that we specified 
in the PWE3 control protocol.

Of course this would be yet another way to setup PWs, with not much 
advantage either.

Luca

Shahram Davari wrote:

>Does the existing signaling method support MH-PW signaling, CAC and BW reservation?
>
>-Shahram
>
>  
>
>>-----Original Message-----
>>From: [email-masked] [mailto:[email-masked]]On Behalf Of
>>Thomas D. Nadeau
>>Sent: Wednesday, March 23, 2005 10:41 AM
>>To: Stewart Bryant
>>Cc: pwe3
>>Subject: Re: [PWE3] draft-raggarwa-rsvpte-pw-01.txt
>>
>>
>>-----BEGIN PGP SIGNED MESSAGE-----
>>Hash: SHA1
>>
>>
>>	Personally speaking, I don't think that it is useful
>>for the WG to spend time and effort re-inventing
>>the wheel, so to speak, which is what this draft
>>represents. We already have a protocol for
>>signaling PWs that works, and is deployed. If
>>there were some significant advantage to signaling
>>PWs using an alternative means, I would think
>>otherwise, but it seems this is just being proposed
>>as an alternative means for achieving the same
>>end result.
>>
>>	--Tom
>>
>>
>>
>>    
>>
>>>At IETF62 the authors of
>>>
>>>Setup and Maintenance of Pseudowires using RSVP-TE
>>>ftp://www.ietf.org/internet-drafts/draft-raggarwa-rsvpte-pw-01.txt
>>>
>>>asked for the draft to become a WG draft.
>>>
>>>What is the view of members of the PWE3 WG?
>>>
>>>Stewart
>>>
>>>_______________________________________________
>>>pwe3 mailing list
>>>[email-masked]
>>>https://www1.ietf.org/mailman/listinfo/pwe3
>>>
>>>      
>>>
>>-----BEGIN PGP SIGNATURE-----
>>Version: GnuPG v1.2.4 (Darwin)
>>
>>iD8DBQFCQY4dHwfkLUURkkwRAgbtAJ9Bpc/zSm0TungLQ/LOQOD8VXDr+ACfXkWS
>>obq/1BEDNhqeTW+u8DzaYGU=
>>=s7XE
>>-----END PGP SIGNATURE-----
>>
>>_______________________________________________
>>pwe3 mailing list
>>[email-masked]
>>https://www1.ietf.org/mailman/listinfo/pwe3
>>
>>    
>>
>
>_______________________________________________
>pwe3 mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/pwe3
>  
>

---

From: Kireeti Kompella <[email-masked]>
Date: Wed, 23 Mar 2005 12:10:30 -0800 (PST)

Hi Luca,

> actually support multi-hop PWs or even PWs .

RSVP-TE would need work to support PWs.  That is it.  The other
aspects (such as multi-hop, QoS, CAC, protection) have been addressed.

> answer is yes , but it will need a lot of new protocol specification.

"A lot" is debatable.

> CAC for PW ? RSVP-TE does not do CAC.

!!!

Perhaps you should learn more about RSVP-TE before making statements
about what it does and does not do.

Kireeti.
-------

---

From: Luca Martini <[email-masked]>
Date: Wed, 23 Mar 2005 17:57:51 -0700

>about what it does and does not do.
To quote somebody else .....

"CAC is a local phenomenon that - by itself - would not
normally require a protocol.  The question is whether
or not a signaling protocol allows for behaviors that 
will be present when CAC is applied during signaling."

So you should be more specific ....
I, for example, would like to perform a CAC function based on a class of PW , not on Bandwidth.
That can be done today with the current PWE3 protocol ....

Luca