Subject: RE: [PWE3] PWE3 IANA policy

From: "Gray, Eric" <[email-masked]>
Date: Thu, 14 Jul 2005 11:10:15 -0400

Stewart,

	To a certain extent, I agree with Eric Rosen on this one.

	To directly respond to your question, I brought these exact
same points up at the IETF meeting and the sense of attendants was
that the types of abuse you mention assume wanton irresponsibility
on the part of people requesting assignments that is just not all
that much in evidence from the past.

	Where Eric Rosen and I disagree is that I feel that not at
least making an attempt to document the use of specific assignments
will likely lead to multiple assignments for intended uses that are
both obvious and clearly the same.  By requesting that a draft, or
informational RFC is written, we may ensure that at least an attempt
is made to publicly document the intended use of an assignment.

	I agreed, at the end of the meeting - with both Eric Rosen
and Luca Martini - that requiring that the document be officially
made an RFC was tantamount to requiring IETF consensus.

	IETF consensus is also subject to abuses, and that is clearly
evident from past behavior.  Someone simply wanting to obtain code
points can find themselves entrenched and beseiged by other people
who apparently only want to "understand better" or "clarify" what
the requester is asking for. Irrespective of unmeasurable parameters
- such as actual intent - the effect of these activities is to block
the requester from being able to accomplish their goals (and, very
likely, satisfy a specific customer need).

--
Eric (Gray)

--> -----Original Message-----
--> From: [email-masked] 
--> [mailto:[email-masked]]On Behalf Of
--> Eric Rosen
--> Sent: Thursday, July 14, 2005 10:24 AM
--> To: Stewart Bryant
--> Cc: W. Mark Townsley; pwe3; Danny McPherson
--> Subject: Re: [PWE3] PWE3 IANA policy 
--> 
--> 
--> 
--> > The PWE3  IANA draft reflects the  discussion that we had 
-->  at IETF-62, and
--> > only requires the existence of an ID for IANA to allocate 
--> a codepoint. 
--> 
--> Already too strong a condition, in my opinion, it should 
--> just be FCFS. 
--> 
--> > The  IESG are  concerned that  this  is open  to abuse.  
--> As things  stand,
--> > authors could submit  an incomplete or inaccurate draft  
--> with no intention
--> > of taking it further simply in order to get a codepoint allocated.
--> 
--> If it were FCFS,  this issue would not arise ;-) But  as 
--> things stand, there
--> is this consequence, and the WG has accepted it.
--> 
--> > his view is that if we submit it to the IESG it is likely 
--> to be rejected. 
--> 
--> I do not see any reasonable grounds  by which the IESG can 
--> reject this.  The
--> IETF processes make it the responsibility  of the WG to 
--> make this call.  The
--> IESG  is not  empowered to  reject something  just because  
--> they  would have
--> preferred the WG to have done something different.
--> 
--> > A compromise proposal that is more likely to gain IESG
--> > acceptance 
--> 
--> I strongly believe that the IESG  should be presented with 
--> the WG consensus.
--> If the IESG attempts to substitute its  own judgment for 
--> that of the WG, the
--> appeals process can (and will) be invoked. 
--> 
--> > It is important that we agree a mutually acceptable 
--> solution with the IESG
--> > ASAP 
--> 
--> Then how about  we submit the doc and follow the  process, 
--> instead of making
--> "backroom deals" and reopening issues that have already 
--> been settled? 
--> 
--> 
--> 
--> 
--> _______________________________________________
--> pwe3 mailing list
--> [email-masked]
--> https://www1.ietf.org/mailman/listinfo/pwe3
--> 

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 14 Jul 2005 11:45:54 -0400

Like Eric (Rosen), I advocated FCFS for all PWE3 allocations at the 
meeting.  I still prefer it, and as As Eric (Gray) points out, there's no 
history to suggest that this policy  would be abused.  I went along with 
the final agreement since writing a draft isn't a huge barrier to getting 
an allocation.

Let's look at what the IESG wants (from Stewart's email):

1) Expert review or IETF consensus (to be decided)

2) Vendor Specific.

I agree with the Erics that IETF consensus is as open to abuse as FCFS, if 
not more.

I've been the victim in the past of "Expert review", which only adds 
unnecessary delay to the process.

And how does "Vendor Specific" differ from FCFS?

So let's stay with the original agreement, or just use FCFS.

Cheers,
Andy

----------