Subject: RE: [PWE3] PWE3 IANA policy

From: "Gray, Eric" <[email-masked]>
Date: Fri, 22 Jul 2005 19:09:10 -0400

Stewart,

	One question for clarification: does the second range end
at 4915 and the third start at 4915, is it 49152 for both or is 
it intended that there should be a gap from 4916 to 49151?

	I think the sense is that most people would like to have 
as large an unconstrained range as possible.

	Also, what is the policy for Vendor Specific - i.e. - how 
does it differ from Expert Review and FCFS?  I was thinking more 
along the lines of:

	0-1024	expert review
	1025-4096	Reserved
	4097-		FCFS

--
Eric

--> -----Original Message-----
--> From: Stewart Bryant [mailto:[email-masked]]
--> Sent: Friday, July 22, 2005 5:43 PM
--> To: Gray, Eric
--> Cc: [email-masked]'; Alex Zinin; [email-masked]
--> Subject: Re: [PWE3] PWE3 IANA policy
--> 
--> 
--> 
--> 
--> Gray, Eric wrote:
--> 
--> > Folks,
--> > 
--> > Based on Alex's "fresh eye" (and in particular, the reference to
--> > TCP/UDP port numbers), Eric Rosen's comments and all the earlier 
--> > discussions I have seen or been a part of, I wonder if it might 
--> > not be acceptable as a compromise to allocate a significantly
--> > smaller chunk to "Expert Review" (including a-piori assignments),
--> > possibly a similar size chunk as "Reserved" and the remainder as
--> > FCFS?
--> 
--> Well UDP/TCP works with
--> 
--> The Well Known Ports are those from 0 through 1023.
--> The Registered Ports are those from 1024 through 49151
--> The Dynamic and/or Private Ports are those from 49152 through 65535
--> 
--> Would something similar work for us?
--> 
--> i.e. expert review from 0 to 1023, vendor specific from
--> 1024 to 4915, do as you please from 49152 to 65535
--> 
--> - Stewart
--> 
--> > 
--> > One thing that is certain - both from past discussion and from
--> > this debate - is that a much smaller assignment space is needed
--> > for allocation based on any form of dialogue more complex than
--> > "Please" and "Thankyou".  Allocating this much smaller space may 
--> > make some people more comfortable with setting aside a similar 
--> > size space that might be used either way later on - as long as 
--> > the combination of "Expert Review" and "Reserved" is (possibly 
--> > significantly) smaller than the currently suggested half of the 
--> > proposed available space.
--> > 
--> > --
--> > Eric Gray
--> > 
--> > --> -----Original Message-----
--> > --> From: [email-masked] 
--> > --> [mailto:[email-masked]]On Behalf Of
--> > --> Eric Rosen
--> > --> Sent: Friday, July 22, 2005 2:21 PM
--> > --> To: Alex Zinin
--> > --> Cc: [email-masked]
--> > --> Subject: Re: [PWE3] PWE3 IANA policy 
--> > --> 
--> > --> 
--> > --> 
--> > --> I disagree with one aspect of your statement:
--> > --> 
--> > -->         "I consider other things like long delays, biased 
--> > --> reviewer etc.
--> > -->          a bug that can be dealt with and wouldn't optimize 
--> > --> for it." 
--> > --> 
--> > --> Experience in a wide variety of settings (including, but 
--> > --> not limited to, the
--> > --> IETF), shows that no matter how  well-intended a process 
--> > --> is, the process can
--> > --> be deflected from its intended goal by politics and 
--> > --> bureaucracy.  This isn't
--> > --> a "bug"  that creeps  in unexpectedly, it  is an inherent  
--> > --> characteristic of
--> > --> process, and it is something that is to be expected. 
--> > --> 
--> > --> That's why  process A is  usually associated with  a second 
--> > --> process  B whose
--> > --> purpose  is to  allow  the reversal  of  process A.   
--> > --> ("Don't  worry if  the
--> > --> reviewer turns  you down because he  works for one of  your 
--> > --> competitors, you
--> > --> can appeal to the IESG.  Don't worry if the IESG turns you 
--> > --> down because they
--> > --> are resistant  to unorthodox ideas, you  can appeal to the  
--> > --> IAB.  Just fill
--> > --> out these forms in triplicate and wait six years.") 
--> > --> 
--> > --> So  if  you are  considering  a process  which  provides  
--> > --> "sanity by  expert
--> > --> review", you can't defend it just  by saying "review is 
--> > --> good", you also have
--> > --> to take into account the likelihood  that the process will 
--> > --> be delayed and/or
--> > --> deflected by  bureaucratic and/or political considerations. 
--> > -->   Of course, the
--> > --> folks in charge of running the process never take this 
--> > --> seriously, and always
--> > --> insist that  everything is working  fine, or at  least will 
--> > --> be  working fine
--> > --> starting tomorrow, after the last bug is removed.
--> > --> 
--> > --> On the purported disadvantages of "freedom":
--> > --> 
--> > --> - SPs don't benefit from sanity checking
--> > --> 
--> > -->   This is a little overstated, it would be more accurate to 
--> > --> say "SPs are not
--> > -->   forced to await the results of the IETF processes".  Of 
--> > --> course, if you put
--> > -->   it that way, it doesn't sound so bad ;-)
--> > --> 
--> > --> - Potential proliferation of proprietary solutions,
--> > --> 
--> > -->   Actual  marketplace  competition  before  a  single  
--> > --> standard  is  chosen?
--> > -->   Heavens. 
--> > --> 
--> > -->   Note  also  that  "sanity  checking"  does not  prevent  
--> > --> proliferation  of
--> > -->   standard solutions, as we certainly know in the 
--> > --> MPLS-related areas. 
--> > --> 
--> > --> - other SDOs can work on their versions of PWs. 
--> > --> 
--> > -->   And why shouldn't they? 
--> > --> 
--> > --> > Regarding the specific proposal of FCFS + I-D. I think it 
--> > --> does not solve
--> > --> > any problem
--> > --> 
--> > --> On the contrary, it solved the  problem of finding 
--> > --> something to which the WG
--> > --> could agree ;-)
--> > --> 
--> > --> 
--> > --> 
--> > --> _______________________________________________
--> > --> pwe3 mailing list
--> > --> [email-masked]
--> > --> https://www1.ietf.org/mailman/listinfo/pwe3
--> > --> 
--> > 
--> > _______________________________________________
--> > pwe3 mailing list
--> > [email-masked]
--> > https://www1.ietf.org/mailman/listinfo/pwe3
--> > 
--> > 
--> 

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 25 Jul 2005 12:11:11 +0100

> it intended that there should be a gap from 4916 to 49151?

I was just using the TCP/UDP ranges as an example to show how
it worked elsewhere

> does it differ from Expert Review and FCFS?  I was thinking more 

VS is the same as FCFS, however I think that the name VS was proposed
by the IESG to state that other SDOs should not use it.

> 	4097-		FCFS

That would be fine with me.

- Stewart