Subject: RE: [PWE3] PWE3 IANA policy

From: "Gray, Eric" <[email-masked]>
Date: Tue, 19 Jul 2005 13:46:48 -0400

Thomas,

	One reason to object to ranges is that the allocation is
necessarily arbitrary.  This means that it's possible for part 
of the entire range to be depleted prematurely, potentially 
making it necessary for the range allocations to be modified 
(which might be a problem in some cases). If there are just two 
sub-groupings, it would be possible to avoid this problem by 
selecting values from opposite ends (much like heap and stack
allocations may be differentiated).

--
Eric

--> -----Original Message-----
--> From: [email-masked] 
--> [mailto:[email-masked]]On Behalf Of
--> Thomas Narten
--> Sent: Tuesday, July 19, 2005 1:32 PM
--> To: [email-masked]
--> Cc: W. Mark Townsley; Stewart Bryant; pwe3; Danny McPherson
--> Subject: Re: [PWE3] PWE3 IANA policy 
--> 
--> 
--> Eric Rosen <[email-masked]> writes:
--> 
--> > > If the policy is FCFS, those arguing that they want to 
--> get code points
--> > > no question asked can do so, but they will at least be 
--> clearly labeled
--> > > as being vendor specific and not an IETF standard of any sort. 
--> 
--> > I  don't  think it  is  appropriate  to have  one  range  
--> of codepoints  for
--> > standards and  another for non-standards.
--> 
--> Why not?
--> 
--> I see nothing wrong with having a range that is clearly marked "IETF
--> reviewed and approved" and a different  range for "Vendor specific".
--> 
--> If what folk care about is being able to get a code point FCFS, no
--> questions asked, you get it with this range.
--> 
--> What you don't get is being able to claim that it is an 
--> IETF-approved
--> extension. That is a very good thing!
--> 
--> > If a  deployed non-standard later
--> > becomes a standard, you end up with a codepoint in the 
--> "wrong" range.  
--> 
--> Big deal. If folk care, they allocate a second code point 
--> and require
--> that implementations of the standard support both for backwards
--> compatability. This is not a problem.
--> 
--> Thomas
--> 
--> _______________________________________________
--> pwe3 mailing list
--> [email-masked]
--> https://www1.ietf.org/mailman/listinfo/pwe3
--> 

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Thomas Narten <[email-masked]>
Date: Tue, 19 Jul 2005 13:52:05 -0400

Eric,

> of the entire range to be depleted prematurely,

Um, aren't we talking about ranges that are rather large, like 16
bits? E.g., pseudowire types are 15 bits. And if half of the space is
reserved for Expert review, presumably the reviewing criteria would
notice that they were in scarce supply should that ever become a real
issue (not that I think that would happen with 14 bits...)

Thomas

---

From: Mark Townsley <[email-masked]>
Date: Tue, 19 Jul 2005 20:06:07 +0200

>allocations may be differentiated).
The proposal is for just two groupings. However, if we divide it down 
the middle I really don't think we will run into a depletion problem 
however we allocate the values. How many PW types can you envision?

- Mark