Subject: [PWE3] RE: comments on draft-ietf-pwe3-fcs-retention-03.txt

From: "Malis, Andrew G." <[email-masked]>
Date: Fri, 22 Jul 2005 08:30:38 -0700

Stewart,
 
Thanks for the comments.  We're past the submission window, so I'll get another revision ready in time for when it reopens.  Do you want to see it first before I resubmit it?
 
Cheers,
Andy

________________________________

From: Stewart Bryant [mailto:[email-masked]]
Sent: Fri 7/22/2005 11:23
To: Malis, Andrew G.
Cc: pwe3
Subject: comments on draft-ietf-pwe3-fcs-retention-03.txt

Andy

I was doing a final check on

Document: draft-ietf-pwe3-fcs-retention-03.txt
PWE3 Frame Check Sequence Retention

- Stewart

=============

The draft does not pass the nits checker

=============

Since the draft covers frame relay and the FR draft
says that the PW MAY change the FECN and/or BECN
bits, it is probably worth noting that the FCS
will have to change. It may also be worth noting
that to preserve data integrity this means
checking the FCS at the egress PE (perhaps with
an overlapping check method).

=============

As defined for MPLS, not only can a PW-aware device
internally corrupt an encapsulated payload, but ANY MPLS LSR in the
path can corrupt the encapsulated payload.

SB> This applies to both IP and MPLS PSNs.

=============

  4. Signaling FCS Retention With MPLS-based Pseudowires

     When using the signaling procedures in [4], there is a Pseudowire
     Interface Parameter Identifier value used to signal the desire to
     retain the FCS when advertising a VC label [5]:

SB> It is now called a
SB> Pseudowire Interface Parameter Sub-TLV type

  8. IANA Considerations

     This document does not specify any new registries for IANA to
     maintain.

     This document requires IANA to allocate a PWE3 Virtual Circuit FEC
     element parameter ID [5].

It might be better to say that [5] - which is a blocking
ref does this - so no additional IANA action needed.

===============

     This specification also requires one value within the L2TP "Control
     Message Attribute Value Pairs" section to be assigned by IANA as
     per [8]. The new AVP is encoded as L2TP-TBA-1 in this document, and
     should be referred to in the IANA L2TP parameters registry as "FCS
     Retention."

... but make it clear that IANA does have an action here.
Does this allocation need review and signoff by the L2TPext WG?

===============

============================================================
The information contained in this message may be privileged
and confidential and protected from disclosure. If the reader
of this message is not the intended recipient, or an employee
or agent responsible for delivering this message to the
intended recipient, you are hereby notified that any reproduction,
dissemination or distribution of this communication is strictly
prohibited. If you have received this communication in error,
please notify us immediately by replying to the message and
deleting it from your computer. Thank you. Tellabs
============================================================
_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Sasha Vainshtein <[email-masked]>
Date: Mon, 25 Jul 2005 18:08:10 +0300

Hi all,
Wrt to to coverage/applicability issue raised by Stewart:
 
IMO FCS retention draft applies only to the PW services that do not modify
in any way the original frame.
This definition excludes FR "Single DLCI" PW services (that strip the FR
header at ingress and re-buiild it at egress, possibly with a new DLCI
value) and Ethernet PW services which strip/insert service-delimiting VLAN
tags. 
 
On the other hand, the FR Port Mode PW services are now undistinguishable
from the HDLC services and hence do not modify any bits in the FR frame
including FECN/BECN (because HDLC PWs do not recognize them).
 
After some off-the-list discussion with Stewart and Andy it seems like the
appropriate resolution of this issue would be to state explicitly to which
modes of FR and Ethernet PW the FCS retention draft applies.
 
With best regards,
                         Sasha Vainshtein
 
 -----Original Message-----
From: Malis, Andrew G. [mailto:[email-masked]]
Sent: Friday, July 22, 2005 5:31 PM
To: Stewart Bryant
Cc: pwe3
Subject: [PWE3] RE: comments on draft-ietf-pwe3-fcs-retention-03.txt

Stewart,
 
Thanks for the comments.  We're past the submission window, so I'll get
another revision ready in time for when it reopens.  Do you want to see it
first before I resubmit it?
 
Cheers,
Andy

  _____  

Andy

- Stewart

=============

=============

=============

=============

SB> It is now called a

  8. IANA Considerations

===============

===============