Subject: RE: [PWE3] PWE3 IANA policy

From: "Gray, Eric" <[email-masked]>
Date: Mon, 18 Jul 2005 13:26:24 -0400

Moreover, such a timeout should include provisions for a 
negotiated delay in the event that the "expert" believes 
that more than the usual amount of research/investigation
is required in a specific case. This is not always known
in advance, not is IANA particularly well qualfied to be
able to judge/arbitrate negotiations of this type.

However, the complexity of the Expert Review process is
not something we can fix on this thread.

One annoying aspect of this entire discussion is that it 
is largely a repeat of the discussion at the meeting.  We
should settle this problem once and for all - either on
this mailing list or at the meeting.

Based on all the beating around the bush discussions, I'm
thinking that we should forgo "Expert Review" entirely - 
at least for this case.

--> -----Original Message-----
--> From: [email-masked] 
--> [mailto:[email-masked]]On Behalf Of
--> Eric Rosen
--> Sent: Monday, July 18, 2005 1:03 PM
--> To: Mark Townsley
--> Cc: Yaakov Stein; pwe3
--> Subject: Re: [PWE3] PWE3 IANA policy 
--> 
--> 
--> 
--> > In fact IANA does have the processes in place to support 
--> contacting one 
--> > or more individuals as Experts. 
--> 
--> That's not  what I was  questioning.  I don't  think they 
--> have a  process in
--> place for  timing out the request  to the expert and  
--> granting the codepoint
--> automatically if the timer expires before the expert responds. 
--> 
--> _______________________________________________
--> pwe3 mailing list
--> [email-masked]
--> https://www1.ietf.org/mailman/listinfo/pwe3
--> 

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Stewart Bryant <[email-masked]>
Date: Tue, 19 Jul 2005 11:43:35 +0100

> this mailing list or at the meeting.

The IANA document as it stands reflects the outcome of the
last IETF.

Mark may care to comment, but as I understand it, the issue
of IANA codepoints and access to them by other SDOs has
been the subject of considerable IESG thought since the last
IETF. Against this background, the views of various IESG
members were sought WRT our IANA draft, and the conclusion
was that if we submitted the draft unmodified it would be
rejected.

I note that the WG members that have so far expressed a
view have stated that we should take the draft to the IESG
unmodified and manage the consequences. Do other WG members
agree?

I also note that the opponents of the expert review process
have had bad experiences in the past. I would find it easier
to argue their case if I could quote what happened. If you
could share the details I would appreciate it.

Regards

Stewart

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 19 Jul 2005 09:35:33 -0400

Stewart,

I support either keeping the document as is, or just making everything FCFS.

In my particular experience, I needed a codepoint allocation for an RSVP 
class number in what was supposed to be the FCFS range.  IANA still 
insisted on an expert review (and it took them a long time to come to that 
conclusion), and because there was no longer an RSVP working group, it took 
a while to find an expert, and then the expert review took another while 
because the expert was a busy person.  It required the active intervention 
of a sympathetic AD (thanks again, Scott!!!) to finally make this all happen.

Cheers,
Andy

At 7/19/2005 11:43 +0100, Stewart Bryant wrote:

>>One annoying aspect of this entire discussion is that it is largely a 
>>repeat of the discussion at the meeting.  We

---

From: Yakov Rekhter <[email-masked]>
Date: Tue, 19 Jul 2005 08:40:48 -0700

Stewart,

> unmodified and manage the consequences. Do other WG members

In deciding on whether to "take the draft to the IESG unmodified and
manage the consequences" it would help to find out whether the IESG
is empowered to  reject something  just because they would have
preferred the WG to have done something different.

With this in mind, I'd like to hear the IESG's position on whether
it is empowered to  reject something  just because the IESG would
have preferred the WG to have done something different.

Yakov.

---

From: Eric Rosen <[email-masked]>
Date: Tue, 19 Jul 2005 12:15:25 -0400

Yakov> I'd like  to hear the IESG's  position on whether it  is empowered to
Yakov> reject something just because the IESG would have preferred the WG to
Yakov> have done something different. 

You may wish to look at draft-iesg-discuss-criteria-00.

---

From: Eric Rosen <[email-masked]>
Date: Tue, 19 Jul 2005 12:24:27 -0400

Stewart> I would  find it easier to argue  their case if I  could quote what
Stewart> happened. 

I don't  believe that  there is  any part of  the document  approval process
which requires the WG chair to argue the WG's case before the IESG.

Stewart> the conclusion  was that  if we submitted  the draft  unmodified it
Stewart> would be rejected.

The only "technical"  objection was that IANA must not  be required to judge
the truth of a requester's claim  that a particular i-d describes the use of
a particular proposed  codepoint.  This could be solved  by making the field
FCFS, or  even by stating explicitly  that IANA's only  responsibility is to
include the draft name in the registry along with the codepoint assignment.

---

From: Thomas Narten <[email-masked]>
Date: Tue, 19 Jul 2005 13:46:17 -0400

> In my particular experience, I needed a codepoint allocation for an
> RSVP class number in what was supposed to be the FCFS range.

Not so, as you later clarify. The problem in this case was there were
no written IANA considerations, so IANA didn't have a process to
follow.

> IANA still insisted on an expert review (and it took them a long
> time to come to that conclusion), and because there was no longer an
> RSVP working group, it took a while to find an expert, and then the
> expert review took another while because the expert was a busy
> person.  It required the active intervention of a sympathetic AD
> (thanks again, Scott!!!) to finally make this all happen.

Water under the bridge. Today, if IANA has clear instructions (like
get the expert to review) they know how to do this.

Thomas