Subject: RE: [PWE3] Draft Charter - IP and MPLS enabled IP networks

From: [email-masked]
Date: Tue, 26 Jul 2005 22:57:30 +0100

Colleagues,
> > Enhance packet-based PW specifications as necessary to allow the 
> > emulated service to be carried transparently over the PSN, 
> for example 
> > by the retention of the FCS across the PW.
> >
> This seems to be a contradiction to the above statement:
> " It is not intended that
> an emulated service will be indistinguishable from the 
> service that is being emulated. "
> 
> I'm not sure that the FCS retention draft needs anything in 
> the charter 
> specific to it .
> What other work is this paragraph intended for ?
> 
> I think that this should be made clear or removed.
> 
> Luca

Speaking as an operator, I believe the intention should be to try and
transparently transfer the client (emulated service) wherever possible.
I interpret the sentence "It is not intended that an emulated service
will be indistinguishable from the service that is being emulated." to
mean that it is not always possible to transparently transfer the client
(emulated service), and that's fine, but the 'default' should still be
to transparently transfer the client wherever possible as IMO this leads
to the lowest complexity solutions (and therefore the lowest capex &
opex cost to operators) and provides the maximum capability for
functional re-use between PW types (e.g. common OAM mechanisms).

Ben

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Eric Rosen <[email-masked]>
Date: Tue, 26 Jul 2005 18:33:14 -0400

> to transparently transfer the client wherever possible

This was  all discussed when the WG  was first chartered, and  I don't think
the  revised charter  is intended  to make  a change  here.  The  charter as
written leaves it to the WG to  decide these issues on a case by case basis,
based on the technical details of the particular case.

---

From: Luca Martini <[email-masked]>
Date: Wed, 27 Jul 2005 17:03:26 -0600

Ben,

So what we need is something like this at the top of the charter:

" It is not intended that
an emulated service will be indistinguishable from the 
service that is being emulated. However PW specifications should strive to carry the emulated service transparently. "

ok?

Luca

---

From: Eric Rosen <[email-masked]>
Date: Thu, 28 Jul 2005 11:11:21 -0400

> PW   specifications  should   strive   to  carry   the  emulated   service
> transparently. 

I don't like this very much.  What  does it even mean for a specification to
strive to do something?  I can see the arguments now: "we can't approve this
specification, it doesn't strive hard enough". 

Really,  the  principles  guiding  development of  PWE3  specifications  are
recordd  in the  PWE3 architecture  document,  there is  no need  to try  to
summarize them in the charter.