Subject: RE: [PWE3] PWE3 IANA policy

From: [email-masked]
Date: Wed, 20 Jul 2005 07:44:33 +0100

In my view, the original proposal (as agreed by the WG in Minneapolis) that requires the submission of a draft should be adequate to prevent a DoS attack.

>From what I have learned about expert review through reading this thread, its purpose in this case would be to provide some regulation to the allocation of PW types. As long as the necessary rules and procedures are put in place, then expert review will indeed provide this. However, the regulation of allocation will not ensure that PW types are:

1. Used for the purpose they were allocated for
2. Ever used at all

Unless the use/implementation of PW types is also regulated, then I see little value in regulating the allocation.

Regards,
Richard 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Mark Townsley
> Sent: 19 July 2005 21:15
> To: Gray, Eric
> Cc: 'Thomas Narten'; [email-masked]; Danny McPherson; pwe3; Stewart
> Bryant
> Subject: Re: [PWE3] PWE3 IANA policy
> 
> 
> Gray, Eric wrote:
> 
> >Mark,
> >
> >	As long as we constrain their usage to actual, legitimate
> >pseudo-wire types, I don't anticipate that we will need that many.
> >But, that's not the point.  We're talking about allocating two
> >ranges - one with rules and the other with good intentions.
> >
> >	If you're assuming that someone is watching to ensure that
> >the latter range is in fact being used as expected, then you 
> >have two ranges with rules.  If you're not assuming that, than
> >you might expect that the latter range may be depleted somewhat
> >faster than you think, however slowly that may be.
> >  
> >
> I am in fact making no assumption of review about the latter 
> range. If 
> Company X wanted to launch a denial of service attack against 
> the range, 
> there is nothing to stop them. That's true with the current "internet 
> draft exists" policy as well though.
> 
> >	I thought the WG had agreed to have a single range with 
> >(somewhat weak) rules. This is preferable - from my perspective - 
> >to having any part of the range allocated completely without rules.
> >It is also a more acceptable compromise than having two ranges.
> >  
> >
> But the "somewhat weak" rule the WG decided upon is 
> instituting a policy 
> which is rife with problems (see my earlier email). WGs may not last 
> forever, as has been pointed out on this thread, but the IANA 
> policies 
> we create do. Thus, they need to be constructed in a way which can be 
> managed long-term.
> 
> >	Again, it is interesting that we can hammer out compromise
> >after compromise only to have someone else step into the fray and
> >suggest that the previous compromise is unacceptable. Where does
> >it all stop?
> >
> I hope soon, but not until the compromise is acceptable not 
> only to the 
> WG asking for it, but for the body who has to manage it long 
> after the 
> WG is disbanded.
> 
> - Mark
> 
> >--
> >Eric
> >
> >--> -----Original Message-----
> >--> From: Mark Townsley [mailto:[email-masked]]
> >--> Sent: Tuesday, July 19, 2005 2:06 PM
> >--> To: Gray, Eric
> >--> Cc: 'Thomas Narten'; [email-masked]; Stewart Bryant; 
> pwe3; Danny
> >--> McPherson
> >--> Subject: Re: [PWE3] PWE3 IANA policy
> >--> 
> >--> 
> >--> Gray, Eric wrote:
> >--> 
> >--> >Thomas,
> >--> >
> >--> >	One reason to object to ranges is that the allocation is
> >--> >necessarily arbitrary.  This means that it's possible for part 
> >--> >of the entire range to be depleted prematurely, potentially 
> >--> >making it necessary for the range allocations to be modified 
> >--> >(which might be a problem in some cases). If there are just two 
> >--> >sub-groupings, it would be possible to avoid this problem by 
> >--> >selecting values from opposite ends (much like heap and stack
> >--> >allocations may be differentiated).
> >--> >  
> >--> >
> >--> The proposal is for just two groupings. However, if we 
> >--> divide it down 
> >--> the middle I really don't think we will run into a 
> >--> depletion problem 
> >--> however we allocate the values. How many PW types can 
> you envision?
> >--> 
> >--> - Mark
> >--> 
> >--> >--
> >--> >Eric
> >--> >
> >--> >--> -----Original Message-----
> >--> >--> From: [email-masked] 
> >--> >--> [mailto:[email-masked]]On Behalf Of
> >--> >--> Thomas Narten
> >--> >--> Sent: Tuesday, July 19, 2005 1:32 PM
> >--> >--> To: [email-masked]
> >--> >--> Cc: W. Mark Townsley; Stewart Bryant; pwe3; Danny McPherson
> >--> >--> Subject: Re: [PWE3] PWE3 IANA policy 
> >--> >--> 
> >--> >--> 
> >--> >--> Eric Rosen <[email-masked]> writes:
> >--> >--> 
> >--> >--> > > If the policy is FCFS, those arguing that they want to 
> >--> >--> get code points
> >--> >--> > > no question asked can do so, but they will at least be 
> >--> >--> clearly labeled
> >--> >--> > > as being vendor specific and not an IETF standard 
> >--> of any sort. 
> >--> >--> 
> >--> >--> > I  don't  think it  is  appropriate  to have  one  range  
> >--> >--> of codepoints  for
> >--> >--> > standards and  another for non-standards.
> >--> >--> 
> >--> >--> Why not?
> >--> >--> 
> >--> >--> I see nothing wrong with having a range that is 
> >--> clearly marked "IETF
> >--> >--> reviewed and approved" and a different  range for 
> >--> "Vendor specific".
> >--> >--> 
> >--> >--> If what folk care about is being able to get a code 
> >--> point FCFS, no
> >--> >--> questions asked, you get it with this range.
> >--> >--> 
> >--> >--> What you don't get is being able to claim that it is an 
> >--> >--> IETF-approved
> >--> >--> extension. That is a very good thing!
> >--> >--> 
> >--> >--> > If a  deployed non-standard later
> >--> >--> > becomes a standard, you end up with a codepoint in the 
> >--> >--> "wrong" range.  
> >--> >--> 
> >--> >--> Big deal. If folk care, they allocate a second code point 
> >--> >--> and require
> >--> >--> that implementations of the standard support both 
> for backwards
> >--> >--> compatability. This is not a problem.
> >--> >--> 
> >--> >--> Thomas
> >--> >--> 
> >--> >--> _______________________________________________
> >--> >--> pwe3 mailing list
> >--> >--> [email-masked]
> >--> >--> https://www1.ietf.org/mailman/listinfo/pwe3
> >--> >--> 
> >--> >
> >--> >  
> >--> >
> >--> 
> >
> >  
> >
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
> 

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Mark Townsley <[email-masked]>
Date: Wed, 20 Jul 2005 11:17:11 +0200

>In my view, the original proposal (as agreed by the WG in Minneapolis) that requires the submission of a draft should be adequate to prevent a DoS attack.
Since IANA is not tasked to review the submitted draft for technical 
relevance, one could just as well submit a single sentence allocating 
the entire space and there would be no process in place for IANA to 
refuse the allocation. Thus, the net sum of this policy is FCFS with a 
misuse of the ID repository tossed in on the side.

Richard, this isn't directed at your comment per se, but I would like to 
state again for the thread that the "internet draft exists" policy has 
significant long-term management problems, and I personally don't think 
that IANA is beholden to accept it, even if one of our 120+ WGs says it 
is the compromise they have reached and is what they want to happen. If 
a consensus of WGs or persons in the IETF at large formed and stated 
that there should be an "internet draft exists" policy for IANA, this 
would be different, but I don't hear that from where I am sitting. If 
there was such a movement, it would most certainly open up the 
long-running draft-expiration debate, as well as whether drafts may be 
cited in publications, etc. In short, there are ramifications to this 
policy that go well-beyond the scope of PWE3, so I don't think it is 
PWE3's place to create said policy on behalf of the IETF and expect it 
to be held up.

>1. Used for the purpose they were allocated for
The purpose of the Expert Review policy is to at least check to see if 
the values are being used for what they were intended (and yes there is 
some trust extended to the Experts that must go along with this), but 
the IETF certainly has no way to regulate what an equipment vendor or 
operator ends up doing.

>Unless the use/implementation of PW types is also regulated, then I see little value in regulating the allocation.
The proper use of values, protocols, nay the entire output of the IETF, 
is incumbant upon you and your peers. The community is, put simply, 
self-regulated.

- Mark

---

From: Thomas Narten <[email-masked]>
Date: Wed, 20 Jul 2005 07:20:13 -0400

<[email-masked]> writes:

> Unless the use/implementation of PW types is also regulated, then I
> see little value in regulating the allocation.

Clearly, we are not the protocol police and will not be able to
prevent intentional misuse. But where an expert review is indeed
helpful is in (the not uncommon case) of someone making a proposal
that is not well thought out and that has gotten absolutely no review
from someone with expertise in the field. Often, such review alerts
the proposer to the reality that "things are more complicated than I
thought" and they then modify their proposal, get additional review,
etc.

This is goodness and is something that we should be striving for, as
it helps reduce the introduction/deployment of poorly thought out
extensions.

Thomas