Subject: RE: [PWE3] Draft Charter - IP and MPLS enabled IP networks

From: [email-masked]
Date: Tue, 26 Jul 2005 14:01:44 +0100

Loa, Colleagues,

> I would like to change this to:
> 
> Network transport service providers and their users are
> seeking to rationalize their networks by migrating their 
> existing services and platforms onto IP or MPLS enabled IP 
> networks (PSN).  This migration requires communications 
> services that can emulate the essential properties of 
> traditional communications links over a PSN.
> 
> This is to clearly say that mpls is part of the IP protocol suite.

I am not sure I know what MPLS enabled IP networks means.  My
understanding is that MPLS is a data forwarding mechanism that is
controlled by a suite of IP protocols.  It is possible to have MPLS data
forwarding without any IP data forwarding in the 'user plane'.  MPLS
enabled IP networks implies to me a network with IP forwarding in the
'user plane' that simultaneously supports MPLS forwarding in the 'user
plane' as well, almost as though MPLS forwarding is a 'bolt on' to IP
forwarding and is unable to exist on its own separately from IP
forwarding - this is certainly one scenario but not IMO the only
scenario.  I can forsee a future in which a co-ps data forwarding
network (which may or may not be MPLS) is controlled by a cl-ps control
plane (which may or may not be IP), e.g. G.motnni & the work of WG7 in
ITU-T FGNGN), but this is not IMO captured by the statement 'MPLS
enabled IP network'.

Now, playing Devil's Advocate - Why do we need to 'clearly say that MPLS
is part of the IP protocol suite'?  What do we gain from such a
statement, what ambiguity does it alleviate?

Ben

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: [email-masked]
Date: Wed, 27 Jul 2005 10:12:20 +0100

> 
> The current proposal for the pwe3 charter says:
> 
> existing services and platforms onto IP or MPLS based packet 
> switched networks (PSN).  This migration requires 
> communications services that can emulate the essential 
> properties of traditional communications links over a PSN.
> 
> /Loa

Is GMPLS part of the IP protocol suite?  

regards, neil

---

From: [email-masked]
Date: Thu, 28 Jul 2005 08:22:21 +0100

Luca, Colleagues,

> Ben,
> 
> So what we need is something like this at the top of the charter:
> 
> " It is not intended that
> an emulated service will be indistinguishable from the 
> service that is being emulated. However PW specifications 
> should strive to carry the emulated service transparently. "
> 
> ok?

I'd be very happy with that.

Thanks
Ben

> Luca