Subject: [PWE3] Draft Charter

From: Danny McPherson <[email-masked]>
Date: Tue, 19 Jul 2005 08:04:46 -0600

Folks,
Please give the following charter a review and let Stewart
and I (and/or the entire mailing list) know if you have
any comments.  The window for comments will close
July 29, 2005.

http://pwe3.tcb.net/pwe3-charter-2005071901.txt

Thanks!

-danny

---------
Pseudo Wire Emulation Edge to Edge (PWE3) WG

Description of Working Group:

Network operators and their subscribers are seeking to rationalize
their networks by migrating to a single IP or MPLS based packet
switched network (PSN). This migration requires communications
services that can emulate the essential properties of traditional
communications links over a PSN.

Pseudowire Emulation Edge to Edge (PWE3) will specify the
encapsulation, transport, control, management, interworking and
security of services emulated over IETF specified PSNs.

A pseudowire emulates a point-to-point link, and provides a
service which is perceived by its user as an unshared link
or circuit of the chosen service.  It is not intended that
an emulated service will be indistinguishable from the service
that is being emulated.  The emulation need only be sufficient
for the satisfactory operation of the service.  Emulation
necessarily involves a degree cost-performance trade-off.  In
some cases it may be necessary to design more than one
emulation mechanism in order to resolve these design
conflicts.  All emulated service definitions will include an
applicability statement describing the faithfulness of the
emulation.  Switching, multiplexing, modification or other
operation on the traditional service, unless required as
part of the emulation, is out of the scope of the PWE3 WG.

PWE3 will make use of existing IETF specified mechanisms
unless there are technical reasons why the existing mechanisms
are insufficient or unnecessary.

PWE3 will not exert control on the underlying PSN, other than
to use any existing QoS or path control mechanism to provide
the required connectivity between the two endpoints of the PW.

PWE3 will investigate mechanisms necessary to perform clock
recovery and other real-time signaling functions.  This work will
be coordinated with the AVT WG and RTP will be used where
appropriate.

PWE3 will work closely with the L2VPN WG to ensure a clear
demarcation is defined for where PWE3 stops and L2VPN starts.

WG Objectives (in order of priority):

Specify the following PW types and consider specification of
additional PW types contingent on WG consensus and AD approval:

Ethernet, Frame Relay, PPP, HDLC, ATM, low-rate TDM and SONET.

PWE3 will evaluate the use of PW mechanisms for an "MPLS Pseudowire"
to transparently carry an MPLS label stack and payload between two
PE routers.

Specify a PW type that supports transparent carriage of IP payloads
between disparate access services (e.g., ATM and Ethernet).

Specify the control and management functions of chartered PW
types, to include PW setup, configuration, maintenance and
tear-down.

Specify OAM mechanisms for all PW types, suitable for
operation over both IP and MPLS PSNs, and capable of
providing the necessary interworking with the OAM mechanisms
of the emulated service.

Enhance packet-based PW specifications as necessary to allow
the emulated service to be carried transparently over the PSN,
for example by the retention of the FCS across the PW.

Define mechanisms to permit the operation of a PW over
a PSN that employs equal cost multiple path (ECMP) packet
switching mechanism.

A PW operating over a shared PSN does not have the same
intrinsic security as a dedicated, purpose built, network.
In some cases this is satisfactory, while in other cases it
will be necessary to enhance the security of the PW
to emulate the intrinsic security of the emulated service.
PW specifications MUST include a description of how they
are to be operated over a shared PSN with adequate security.

Whilst a service provider may traffic engineer their network
is such a way that PW traffic will not cause significant
congestion, a PW deployed by an end-user may cause
congestion of the underlying PSN.  Suitable congestion
avoidance mechanisms are therefore needed to protect the
Internet from the unconstrained deployment of PWs.

Define requirements for and mechanisms to provide
interconnection of PWs (to include inter-domain PWs).

Define the reqiurements for and mechanisms needed to allow
the operation of switched virtual circuits over a PSN.

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 19 Jul 2005 15:59:34 +0100

Hi Danny,

Can you add something to show that PWE3 will coordinate with the WGs that
"own" the protocols that are extended by PWE3?

Thanks,
Adrian

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 19 Jul 2005 11:20:45 -0400

And also add text to coordinate with other working groups that are 
extending the protocols owned by PWE3.  A current example of this is the 
AVT working group, which is discussing 
draft-ash-avt-hc-over-mpls-protocol-01.txt.

Thanks,
Andy

---------

---

From: [email-masked]
Date: Thu, 21 Jul 2005 20:53:02 +0100

Danny,

The last paragraph states the following:

"Define the reqiurements for and mechanisms needed to allow
the operation of switched virtual circuits over a PSN."

If I recall, we discussed this point on the list back in March. I think
that the meaning of this was related to interworking between, say, ATM or
Frame Relay signalling, and PWE3. However, there are already a number of
existing specifications either in existence or in an advanced state of
development (e.g. in the ITU-T and the MFA Forum).

A number of people commented that this item should be removed, so I was
surprised to see that it is still in the draft charter.

Please could you clarify the situation,

Regards,

Matthew

                      Danny McPherson                                                                                                  
                      <[email-masked]>          To:      pwe3 <[email-masked]>                                                           
                      Sent by:                 cc:                                                                                     
                      pwe3-bounces@iet         Subject: [PWE3] Draft Charter                                                           
                      f.org                                                                                                            

                      19/07/2005 15:04                                                                                                 

Folks,

Thanks!

-danny

---------

---

From: Danny McPherson <[email-masked]>
Date: Thu, 21 Jul 2005 19:12:21 -0600

On Jul 19, 2005, at 9:20 AM, Andrew G. Malis wrote:

> extending the protocols owned by PWE3.  A current example of this is 
> the AVT working group, which is discussing 

While I fell as though we're reaching a bit, I've went ahead
and added the following [arguably gratuitous] text:

"PWE3 will work closely with the L2VPN WG to ensure a clear
demarcation is defined for where PWE3 stops and L2VPN starts.
PWE3 will coordinate very closely with any WG that is
responsible for protocols which PWE3 intends to extend (e.g.,
the MPLS WG for LDP), as well as foster interaction with WGs
that intend to extend PWE3 protocols."

-danny

---

From: Danny McPherson <[email-masked]>
Date: Sun, 24 Jul 2005 14:44:05 -0600

> Please could you clarify the situation,

Matthew,
As you well know, simply because other organizations begin working
on something before we formally pick it up it's no reason for us
to defer control to them unless we have no interest in performing
work on the item.  If this weren't the case, adoption of most
PWE3 work taken on by those organizations would have required
complete disbanding of PWE3 :-)

As you might well suspect, we absolutely welcome participation and
contributions (individual or formal) from those organizations regarding
these items.  If folks believe there are other reasons why we should
not take on this work, please bring it up on the mailing list under
a different thread - but as of the last check and feedback we've
collected, there seems to be general interest in performing this work
in PWE3.

Thanks!

-danny

---

From: Luca Martini <[email-masked]>
Date: Tue, 26 Jul 2005 11:19:06 -0600

> that intend to extend PWE3 protocols."
Danny,
I do not think that this is appropriate in a charter. Delineation of the 
scope of work should be done by the charter and should be clear !
Just stating that it the WG will work on it , does not define a delineation.
We should state explicitly what areas are included , and ( if not clear 
) what areas are excluded in this charter.
More to follow ...

Luca

---

From: Danny McPherson <[email-masked]>
Date: Tue, 26 Jul 2005 11:23:30 -0600

On Jul 26, 2005, at 11:19 AM, Luca Martini wrote:
>>
> Danny,
> I do not think that this is appropriate in a charter. Delineation of 
> the scope of work should be done by the charter and should be clear !
> We should state explicitly what areas are included , and ( if not 
> clear ) what areas are excluded in this charter.

Some of this is done in other places in the charter..

If you've got text about what you'd like to see in addition,
please do send it along..

-danny