Subject: RE: [PWE3] PWE3 IANA policy

From: "Gray, Eric" <[email-masked]>
Date: Tue, 19 Jul 2005 14:47:16 -0400

Mark,

	As long as we constrain their usage to actual, legitimate
pseudo-wire types, I don't anticipate that we will need that many.
But, that's not the point.  We're talking about allocating two
ranges - one with rules and the other with good intentions.

	If you're assuming that someone is watching to ensure that
the latter range is in fact being used as expected, then you 
have two ranges with rules.  If you're not assuming that, than
you might expect that the latter range may be depleted somewhat
faster than you think, however slowly that may be.

	I thought the WG had agreed to have a single range with 
(somewhat weak) rules. This is preferable - from my perspective - 
to having any part of the range allocated completely without rules.
It is also a more acceptable compromise than having two ranges.

	Again, it is interesting that we can hammer out compromise
after compromise only to have someone else step into the fray and
suggest that the previous compromise is unacceptable. Where does
it all stop?

--
Eric

--> -----Original Message-----
--> From: Mark Townsley [mailto:[email-masked]]
--> Sent: Tuesday, July 19, 2005 2:06 PM
--> To: Gray, Eric
--> Cc: 'Thomas Narten'; [email-masked]; Stewart Bryant; pwe3; Danny
--> McPherson
--> Subject: Re: [PWE3] PWE3 IANA policy
--> 
--> 
--> Gray, Eric wrote:
--> 
--> >Thomas,
--> >
--> >	One reason to object to ranges is that the allocation is
--> >necessarily arbitrary.  This means that it's possible for part 
--> >of the entire range to be depleted prematurely, potentially 
--> >making it necessary for the range allocations to be modified 
--> >(which might be a problem in some cases). If there are just two 
--> >sub-groupings, it would be possible to avoid this problem by 
--> >selecting values from opposite ends (much like heap and stack
--> >allocations may be differentiated).
--> >  
--> >
--> The proposal is for just two groupings. However, if we 
--> divide it down 
--> the middle I really don't think we will run into a 
--> depletion problem 
--> however we allocate the values. How many PW types can you envision?
--> 
--> - Mark
--> 
--> >--
--> >Eric
--> >
--> >--> -----Original Message-----
--> >--> From: [email-masked] 
--> >--> [mailto:[email-masked]]On Behalf Of
--> >--> Thomas Narten
--> >--> Sent: Tuesday, July 19, 2005 1:32 PM
--> >--> To: [email-masked]
--> >--> Cc: W. Mark Townsley; Stewart Bryant; pwe3; Danny McPherson
--> >--> Subject: Re: [PWE3] PWE3 IANA policy 
--> >--> 
--> >--> 
--> >--> Eric Rosen <[email-masked]> writes:
--> >--> 
--> >--> > > If the policy is FCFS, those arguing that they want to 
--> >--> get code points
--> >--> > > no question asked can do so, but they will at least be 
--> >--> clearly labeled
--> >--> > > as being vendor specific and not an IETF standard 
--> of any sort. 
--> >--> 
--> >--> > I  don't  think it  is  appropriate  to have  one  range  
--> >--> of codepoints  for
--> >--> > standards and  another for non-standards.
--> >--> 
--> >--> Why not?
--> >--> 
--> >--> I see nothing wrong with having a range that is 
--> clearly marked "IETF
--> >--> reviewed and approved" and a different  range for 
--> "Vendor specific".
--> >--> 
--> >--> If what folk care about is being able to get a code 
--> point FCFS, no
--> >--> questions asked, you get it with this range.
--> >--> 
--> >--> What you don't get is being able to claim that it is an 
--> >--> IETF-approved
--> >--> extension. That is a very good thing!
--> >--> 
--> >--> > If a  deployed non-standard later
--> >--> > becomes a standard, you end up with a codepoint in the 
--> >--> "wrong" range.  
--> >--> 
--> >--> Big deal. If folk care, they allocate a second code point 
--> >--> and require
--> >--> that implementations of the standard support both for backwards
--> >--> compatability. This is not a problem.
--> >--> 
--> >--> Thomas
--> >--> 
--> >--> _______________________________________________
--> >--> pwe3 mailing list
--> >--> [email-masked]
--> >--> https://www1.ietf.org/mailman/listinfo/pwe3
--> >--> 
--> >
--> >  
--> >
--> 

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Mark Townsley <[email-masked]>
Date: Tue, 19 Jul 2005 22:15:20 +0200

>faster than you think, however slowly that may be.
I am in fact making no assumption of review about the latter range. If 
Company X wanted to launch a denial of service attack against the range, 
there is nothing to stop them. That's true with the current "internet 
draft exists" policy as well though.

>It is also a more acceptable compromise than having two ranges.
But the "somewhat weak" rule the WG decided upon is instituting a policy 
which is rife with problems (see my earlier email). WGs may not last 
forever, as has been pointed out on this thread, but the IANA policies 
we create do. Thus, they need to be constructed in a way which can be 
managed long-term.

>suggest that the previous compromise is unacceptable. Where does
I hope soon, but not until the compromise is acceptable not only to the 
WG asking for it, but for the body who has to manage it long after the 
WG is disbanded.

- Mark