Subject: [PWE3] Alignment of TotalPerf tables in PW MIBs

From: "Ron Cohen" <[email-masked]>
Date: Tue, 25 Oct 2005 11:20:26 +0200

Hi,

I suggest to align the definition of TotalPereformance tables across the various PW MIBs as well as align with already defined Total performance tables in published RFCs. 

In particular, I suggest to align the definition in PW-MIB, TDM-MIB and CEP-MIB to that of RFC-3895:

 "The (place name here) Total Table contains the cumulative sum
  of the various statistics for the 24 hour period
  preceding the current interval."

And to align the names to always include Total and structured in the same way, i.e. change in TDM-MIB the name pwVcTDMPerfTable to pwTDMPerfTotalTable.

The different definitions for total tables in the relevant MIBs can be found below.

Best
Ron

PW-MIB:

pwPerfTotalTable  OBJECT-TYPE 
      SYNTAX        SEQUENCE OF PwPerfTotalEntry 
      MAX-ACCESS    not-accessible 
      STATUS        current 
      DESCRIPTION 
           "This table provides per-PW Performance information from  
            PW start time or management application reset." 
      ::= { pwObjects 5 } 

CEP-MIB:

pwCepPerfTotalTable OBJECT-TYPE 
      SYNTAX        SEQUENCE OF PwCepPerfTotalEntry 
      MAX-ACCESS    not-accessible 
      STATUS        current 
      DESCRIPTION 
          "This table provides per CEP PW performance information 
           much like the pwCepPerfIntervalTable above. However, 
           these counts represent complete historical information. 

TDM-MIB:

pwVcTDMPerfTable OBJECT-TYPE
     SYNTAX        SEQUENCE OF PwVcTDMPerfEntry
     MAX-ACCESS    not-accessible
     STATUS        current
     DESCRIPTION
         "This table provides performance information per TDM PW
          similar to the pwVcTDMPerfIntervalTable above. However,
          these counters represent complete historical information. "
     ::= { pwVcTDMObjects 7 }

RFC-3895: Definitions of Managed Objects for the DS1, E1, DS2, and E2 Interface Types

dsx1TotalTable OBJECT-TYPE
     SYNTAX  SEQUENCE OF Dsx1TotalEntry
     MAX-ACCESS  not-accessible
     STATUS  current
     DESCRIPTION
            "The DS1 Total Table contains the cumulative sum
            of the various statistics for the 24 hour period
            preceding the current interval."
     ::= { ds1 9 }

RFC-2558: Definition of Managed Objects for the SONET/SDH interface type:

No total table, only current and interval tables

Ron Cohen
CTO
Resolute Networks
Redux and Lycium Unite 

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Tue, 25 Oct 2005 10:48:08 -0400

This suggestion looks okay to me.

     --Tom

> Hi,
>
> I suggest to align the definition of TotalPereformance tables  
> across the various PW MIBs as well as align with already defined  
> Total performance tables in published RFCs.
>
> And to align the names to always include Total and structured in  
> the same way, i.e. change in TDM-MIB the name pwVcTDMPerfTable to  
> pwTDMPerfTotalTable.
>