Subject: [PWE3] Re: New Version Notification - draft-ietf-pwe3-iana-allocation-14.txt

From: Luca Martini <[email-masked]>
Date: Mon, 31 Oct 2005 01:41:00 -0700

Brian,

I sent the document out , as there where many changes to it , and I 
wanted to start from a fresh copy of the draft , with most of the 
changes incorporated. I think that reving a draft is the best way to 
document the changes , and making sure that we are all on the same page ...

Brian E Carpenter wrote:
> Most of my DISCUSS comments are fixed, thanks, but I still have two points
> I'm afraid.
> 
>> 3.3. Interface Parameters Sub-TLV type
> ...
>>    For each allocation a length field MUST also be specified in one of
>>    the following formats:
>>      - A decimal integer
>>      - Text as follows:"up to X", where X is a decimal integer
>>      - Up to 3 different decimal integers.
> 
> 
> Why is "A decimal integer" listed? It is a subset of "Up to 3 different 
> decimal integers".
Yes, it is redundant. I will edit it to include only the "Up to 3 
different decimal integers."

> Does "up to X" mean "up to and including X"?

yes. I will edit the text to make it clear by adding the following comment:

"The text "up to X" is meant to mean up to and including X."

> 
>> 3.4.1. Attachment Individual Identifier Type
> ...
>>    For each allocation a length field MUST also be specified as a
>>    decimal integer.
> 
> This is a substantive change since the document was submitted to
> the IESG, since the -12 version had the same three alternatives
> as above. Has this change got WG consensus?
> 
>> 3.4.2. Attachment Group Identifier (AGI) Type
> ...
>>    For each allocation a length field MUST also be specified as a
>>    decimal integer.
> 
> Ditto.
I do not believe that there is any question on this point in the WG. The 
  length was already included in the protocol specification.  The length 
was omitted from this allocation by an oversight. This has been 
corrected, and I have not heard any comments on this topic in the WG.
( And I CCed the WG )
Thanks.
Luca

>     Brian

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 31 Oct 2005 18:25:55 +0100

OK, if -15 has those fixes I will be happy. Thanks.

     Brian

Luca Martini wrote:
>> Why is "A decimal integer" listed? It is a subset of "Up to 3 
>> different decimal integers".
>