Subject: [PWE3] Query Regarding pwe3-enet-mib

From: "Kulkarni, Hrishikesh (Hrishikesh)" <[email-masked]>
Date: Wed, 26 Oct 2005 16:18:31 +0530

> Hi,
> 
>  in Section "5.4  Service Delimiting Modes of
> draft-ietf-pwe3-enet-mib-06.txt:
> 
> "
>   2b) One to one mapping: the service delimiting tag change it's value 
>   (to value of 6) on the PW. 
>    
>          pwEnetPwVlan        6, 
>          pwEnetVlanMode      changeVlan, 
>          pwEnetPortVlan      5, 
>    
>   pwType MAY equal 'Ethernet' or 'EthernetTagged', 'EthernetTagged' 
>   is RECOMMENDED. 
> "
> 
> Query:
> In the above example the service de-limiting tag is changed to 6 on the
> PW.
> so how can the pwType be equal 'Ethernet' if the encap on the pw is having
> a service
> delimiting tag.
> 
> My understanding is that pwType = Ethernet is raw-mode pw which doesnt
> carry  
> service delimiting tag, if one is present then its stripped.
> Please help clarify this query. do correct if am wrong
> 
> Thanks,
> Rishi.
> 

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "David Zelig" <[email-masked]>
Date: Wed, 26 Oct 2005 16:08:49 +0200

Rishi,
Strictly speaking about the text in draft-ietf-pwe3-ethernet-encap-10.txt you are correct, but draft-ietf-l2vpn-vpls-ldp-07.txt, based on appendix A, when a PW is attached to VPLS service, only 'Ethernet' mode is used. You may want to use VLAN rewrite for PW connected to VPLS service.
Maybe the correct wording is "SHOULD" instead of "RECOMENDED".

David

---

From: "Kulkarni, Hrishikesh (Hrishikesh)" <[email-masked]>
Date: Wed, 26 Oct 2005 19:55:40 +0530

David,

The correct wording will then be applicable for 
sections 1a, 2a, 2b, 2c, 2e and 2f in draft-ietf-pwe3-enet-mib-06.txt

and for section 2d the pwtype SHOULD be 'Ethernet'

Thanks,
Rishi

> From: David Zelig [mailto:[email-masked]]
> Sent: Wednesday, October 26, 2005 7:39 PM
> To: Kulkarni, Hrishikesh (Hrishikesh); [email-masked]
> Cc: [email-masked]
> Subject: RE: Query Regarding pwe3-enet-mib
> 
> 
> Rishi,
> Strictly speaking about the text in 
> draft-ietf-pwe3-ethernet-encap-10.txt you are correct, but 
> draft-ietf-l2vpn-vpls-ldp-07.txt, based on appendix A, when a 
> PW is attached to VPLS service, only 'Ethernet' mode is used. 
> You may want to use VLAN rewrite for PW connected to VPLS service.