Subject: RE: [PWE3] Re: PW Protection and Restoration in charter?

From: "Yaakov Stein" <[email-masked]>
Date: Mon, 17 Oct 2005 12:15:03 +0200

> Eschew reification.  "Layer network" is not a thing, it's 
> just an abstract concept.  

If you mean that "layer network" is not the same kind of things as "IP
network".
then I agree.

> We create requirements.  If 
> someone comes along and says "hey, that's a layer network", 
> it doesn't change the requirements at all, although it might 
> help us talk about them.  The next step, saying "since it's a 
> layer network it must also do these seven other things" is 
> illegitimate.  

Here is where I possibly disagree.

Yes, "layer network" is an abstract concept,
and thus unlike "IP network" we can not enforce
specific header formats, etc.

However, the whole concept of layer networks
was invented to ensure certain functionality
and more specifically, manageability.

So if we say that something is a layer network,
then we mean that it will require some sort of OAM,
and also protection switching - if the service it is supporting requires
it.

> We can base requirements in engineering 
> experience as embodied in models, and we can question where 
> to put the complexity, but requirements need to be based in 
> reality, not in abstract descriptions of it.  So I'm not 
> worried about whether something is a layer network or not, if 
> the requirements are real.

Yes, but the formalism is a good checklist.
PWs are not the first layer network to be considered,
and so once we establish that PWs are truly layer networks
(which I have been claiming from day one)
we realize that we are going to have to supply certain
minimal functionality (of course the precise mechanisms are up to us).

The "fullness" of  these mechanisms depends
on what the user expects and what the network operator 
is willing or able to manage.

Y(J)S

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Scott W Brim <[email-masked]>
Date: Mon, 17 Oct 2005 09:10:07 -0400

> is willing or able to manage.

Yaakov, this is what I meant by "base requirements in engineering
experience as embodied in models".  As long as the models match what
is needed, realizing that a model is applicable can lead you to
further requirements you hadn't thought of.  That's a good thing.
However, if what the model leads you to does not match what you know
you need, then you are not necessarily wrong -- the model, based on
previous experience, might not be applicable to your new situation.
That's why Adrian's dire statement about turning something into a
layer network doesn't worry me.  The real world comes first, and if
the model is useful we use it (otherwise we can change it).

By the way I think it's clear that they are layer networks too.

swb