Subject: RE: [PWE3] OAM capability indication issue

From: "Yaakov Stein" <[email-masked]>
Date: Sun, 9 Oct 2005 10:39:15 +0200

Tom, 

	I think there is a fundamental misunderstanding of what the
capability 
	indication should do. The intent is not for the other side of
the PW (PE2 in 
	the example above) to look at what PE1 sent it and determine
what subset
	of that it can support and then insert that into the LDP reply
-- although it
	certainly can do that.  The idea is to simply remember what it
sent and
	also indicate to the other side what it can understand, and then
when it comes 
	time to send VCCV to that peer, look at what it told you it
wishes to
	accept.  If the PE wants to make an intelligent decision at that
point
	and see if there are any similarities in what it told the other
end that
	it wishes to entertain, then that is IMHO a local optimization.
	Then either side is free to choose whatever method you told it 
	it should send you (including nothing).  This is the most
flexible way of 
	doing this that supports cases where even one side doesn't want
to
	receive ANY vccv.

I don't understand what you mean by "a local optimization".
 
The idea behind all such capabilities messages
is to indicate to the other side what you are capable of handling.
 
Of course if the overlap is not a single element there is a bit
of local policy about which common option to use,
but it doesn't make sense for PE2 to use an option that it knows PE1
doesn't support.
 
Perhaps there should be a wording with a SHOULD about
what PE2 needs to do.
 
(BTW - I am ignoring the possibility of asymmetric PEs,
e.g. capable of sending LSP-ping, but not receiving it.)
 
Y(J)S
 
_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Tue, 11 Oct 2005 08:30:01 -0400

On Oct 9, 2005, at 4:39 AM, Yaakov Stein wrote:

> Tom,
>
> I think there is a fundamental misunderstanding of what the capability
> indication should do. The intent is not for the other side of the  
> PW (PE2 in
> the example above) to look at what PE1 sent it and determine what  
> subset
> of that it can support and then insert that into the LDP reply --  
> although it
> certainly can do that.  The idea is to simply remember what it sent  
> and
> time to send VCCV to that peer, look at what it told you it wishes to
> accept.  If the PE wants to make an intelligent decision at that point
> and see if there are any similarities in what it told the other end  
> that
> it should send you (including nothing).  This is the most flexible  
> way of
> doing this that supports cases where even one side doesn't want to
> receive ANY vccv.
>

     To me, "local optimization" == "implementation decision" ==  
"local policy"

> is to indicate to the other side what you are capable of handling.

     Yep, and I hope that is the point I made above.

> Perhaps there should be a wording with a SHOULD about

     Do you have some text in mind that we can all look
at?

     --Tom