Subject: RE: [PWE3] Re: PW Protection and Restoration in charter?

From: [email-masked]
Date: Mon, 17 Oct 2005 12:38:55 +0100

Jixiong Dong wrote 17 October 2005 02:54
> Scott,
> 
> I agree with you entirely. The real requirements are the key 
> fact.
NH=> Well yes, but who is setting these requirements, for what purpose
and are they based on sound networking principles?  There are some
underlying truths about networking that should underpin the
requirements....else you can generate some rather non-optimal
(understatement) solutions to the requirements.  

> Maybe We 
> need to  give the requirement list and then discuss on it. If 
> these requirements can be implemented by the underlying PSN, 
> then PW protection is not needed, thus PW is not a layer 
> network. Otherwise, PW protection is needed.
NH=> This is an incorrect view.  If MH-PWs are created there is a route
computation problem in 2 layers here.....indeed it's more than a routing
function that has to be replicated now.  However, a routing process in a
client layer network CANNOT progress until a lower layer routing process
has completed and installed the link-connections in the client layer
network (remember these are provided by trails in a lower layer
network....and this is a process which recurses until you hit the
duct....this is indeed how we create topology).  Now you cannot, in
general, proxy for nodal failures in a client layer network by prot-sw
measures in a server layer network.....this is obvious when you consider
the ownership of different layer networks and the fact that the network
span of the client vs the server is not usually congruent.

regards, Neil
> 
> Dong
> 
> ----- Original Message ----- 
> From: "Scott W Brim" <[email-masked]>
> To: "Adrian Farrel" <[email-masked]>
> Cc: "pwe3" <[email-masked]>; "Danny McPherson" <[email-masked]>
> Sent: Sunday, October 16, 2005 9:46 PM
> Subject: Re: [PWE3] Re: PW Protection and Restoration in charter?
> 
> 
> > On 10/16/2005 07:21 AM, Adrian Farrel allegedly wrote:
> > > Danny,
> > > 
> > > I'm not going to object, but (for the reasons that Neil 
> stated) you 
> > > need to watch what is happening here.
> > > 
> > > Rather than PW being a service that you offer over a 
> network (where 
> > > your service request would request that the underlying network 
> > > provided a certain level of protection) you have moved PW 
> to being a 
> > > network layer in its own right. Thus you are talking 
> about setting 
> > > up protection PWs and
> > > (presumably) the request you will make at the service 
> interface is for
> > > diversity.
> > > 
> > > As you follow this along a bit you will discover that you need to 
> > > control the path of the PW not just at its hop end 
> points, but also 
> > > through the network.
> > 
> > > From a signaling point of view you are re-inventing many 
> aspects of 
> > > MPLS-TE and GMPLS.
> > >
> > > 1. You may not want to do this.
> > > 2. You may be told by the IESG that you are in the wrong 
> Area to do 
> > > this. 3. You should be told the IESG that you shouldn't 
> do this work
> > > without consulting existing WGs that have already done this work.
> > 
> > Eschew reification.  "Layer network" is not a thing, it's just an 
> > abstract concept.  We create requirements.  If someone 
> comes along and 
> > says "hey, that's a layer network", it doesn't change the 
> requirements 
> > at all, although it might help us talk about them.  The next step, 
> > saying "since it's a layer network it must also do these 
> seven other 
> > things" is illegitimate.  We can base requirements in engineering 
> > experience as embodied in models, and we can question where 
> to put the 
> > complexity, but requirements need to be based in reality, not in 
> > abstract descriptions of it.  So I'm not worried about whether 
> > something is a layer network or not, if the requirements are real. 
> > Your point about redundant capabilities is a good one.
> > 
> > (Nit: s/network layer/layer network/).
> > 
> > swb
> > 
> > _______________________________________________
> > pwe3 mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/pwe3
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
> 

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Jixiong Dong <[email-masked]>
Date: Tue, 18 Oct 2005 17:52:52 +0800

Neil,

The essential of this problem is whether the PW is a layer.

When MS-PW is introduced into PWE3 WG, the PW layer is born. If PW is 
not a layer, it is only adaptation function and only appear at the edge of the
PSN layer network. It's suitable for PW segment. But from the viewpoint of end-to-end
MS-PW, PW function doesn't only appear at the edge of the layer network.

Best Regards,
Dong

----- Original Message ----- 
From: <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Monday, October 17, 2005 7:38 PM
Subject: RE: [PWE3] Re: PW Protection and Restoration in charter?

regards, Neil