Subject: RE: [PWE3] Re: PW Protection and Restoration in charter?

From: Sasha Vainshtein <[email-masked]>
Date: Tue, 11 Oct 2005 15:55:05 +0200

Danny, Dong and all,

IMHO PW protection (and restoration) become relevant when 
it comes to multi-segment PWs (MS-PW). 

The difference between SS-PWs and MS-PWs wrt protection is
that the latter may require protection against failure of S-PEs.
And, of course, such protection does not have to influence
the underlying PSN.

(To the best of my understanding, my considerations
in this regard actually match Neil's in his recent email
on this thread - even if the wording is quite different.)

The requirement for protection of MS-PWs against S-PE 
failures has been already defined in the appropriate WG 
draft (draft-ietf-pwe3-ms-pw-requirements-00.txt), 
including an explicit reference to "1:1 protected PWs".

Protection of MS-PWs against S-PE failures is also one 
of the issues that ALL the proposals currently on the 
table for dynamic setup and maintenance of MS-PWs try 
to cope with.

Hence explicit inclusion of some appropriate text in
the Charter looks perfectly reasonable to me - it would
simply align the Charter with the facts on the ground.

Regards,
			Sasha

> -----Original Message-----
> From: Danny McPherson [mailto:[email-masked]]
> Sent: Tuesday, October 11, 2005 3:55 AM
> To: pwe3; Jixiong Dong
> Subject: Re: [PWE3] Re: PW Protection and Restoration in charter?
> 
> 
> 
> On Oct 10, 2005, at 7:34 PM, Jixiong Dong wrote:
> 
> > Danny,
> >
> > Yes, It's me for asking for adding the PW protection switching and  
> > restoration to the charter.
> >
> > PW protection switching&restoration will not influcence the  
> > underlying PSN. And the layer of
> > PW protection is different from PSN protection. Of course, PSN  
> > fault must cause PW fault. But,
> > PW fault donen't mean PSN fault.
> 
> Are other folks in support of adding this to the charter?
> 
> Also, it'd be useful to understand how much of this would be 
> a function
> bits on the wires as opposed to implementation specific.
> 
> -danny
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
> 

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Danny McPherson <[email-masked]>
Date: Thu, 13 Oct 2005 21:19:14 -0600

Thanks Sasha, Neil and Dong.

Does anyone object to adding an item akin to this to the objectives
section of the charter?

Define requirements for, and subsequently, mechanisms to enable
protection and restoration of PWs.

Note that I am intentionally avoiding explicit scoping to multi and/or
single segment PWs.

-danny

---

From: "Mustapha Aissaoui" <[email-masked]>
Date: Fri, 14 Oct 2005 13:57:36 -0400

Danny,
I support adding such an item.

Mustapha.

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Danny McPherson
> Sent: Thursday, October 13, 2005 11:19 PM
> To: pwe3
> Does anyone object to adding an item akin to this to the
> objectives section of the charter?
>
> Define requirements for, and subsequently, mechanisms to
> enable protection and restoration of PWs.
>
> Note that I am intentionally avoiding explicit scoping to
> multi and/or single segment PWs.
>
> -danny
>
> > The difference between SS-PWs and MS-PWs wrt protection is that the
> > latter may require protection against failure of S-PEs.
> > And, of course, such protection does not have to influence the
> > underlying PSN.
> >
> > (To the best of my understanding, my considerations in this regard
> > actually match Neil's in his recent email on this thread -
> even if the
> > wording is quite different.)
> >
> > The requirement for protection of MS-PWs against S-PE failures has
> > been already defined in the appropriate WG draft
> > (draft-ietf-pwe3-ms-pw-requirements-00.txt),
> > Protection of MS-PWs against S-PE failures is also one of
> the issues
> > that ALL the proposals currently on the table for dynamic setup and
> > maintenance of MS-PWs try to cope with.
> >
> > Hence explicit inclusion of some appropriate text in the
> Charter looks
> > perfectly reasonable to me - it would simply align the Charter with
> > the facts on the ground.
> >
> > Regards,
> >             Sasha
> >
> >
> >>> underlying PSN. And the layer of PW protection is
> different from PSN
> >>> protection. Of course, PSN fault must cause PW fault.
> But, PW fault
> >>> donen't mean PSN fault.
> >>>
> >>
> >> Also, it'd be useful to understand how much of this would be a
> >> function bits on the wires as opposed to implementation specific.
> >>
> >> -danny
> >>

---

From: "Adrian Farrel" <[email-masked]>
Date: Sun, 16 Oct 2005 12:21:23 +0100

Danny,

I'm not going to object, but (for the reasons that Neil stated) you need
to watch what is happening here.

Rather than PW being a service that you offer over a network (where your
service request would request that the underlying network provided a
certain level of protection) you have moved PW to being a network layer in
its own right. Thus you are talking about setting up protection PWs and
(presumably) the request you will make at the service interface is for
diversity.

As you follow this along a bit you will discover that you need to control
the path of the PW not just at its hop end points, but also through the
network.

>From a signaling point of view you are re-inventing many aspects of
MPLS-TE and GMPLS.

1. You may not want to do this.
2. You may be told by the IESG that you are in the wrong Area to do this.
3. You should be told the IESG that you shouldn't do this work without
consulting existing WGs that have already done this work.

Thanks,
Adrian

---

From: Scott W Brim <[email-masked]>
Date: Sun, 16 Oct 2005 09:46:34 -0400

> 3. You should be told the IESG that you shouldn't do this work
> without consulting existing WGs that have already done this work.

Eschew reification.  "Layer network" is not a thing, it's just an
abstract concept.  We create requirements.  If someone comes along and
says "hey, that's a layer network", it doesn't change the requirements
at all, although it might help us talk about them.  The next step,
saying "since it's a layer network it must also do these seven other
things" is illegitimate.  We can base requirements in engineering
experience as embodied in models, and we can question where to put the
complexity, but requirements need to be based in reality, not in
abstract descriptions of it.  So I'm not worried about whether
something is a layer network or not, if the requirements are real.
Your point about redundant capabilities is a good one.

(Nit: s/network layer/layer network/).

swb

---

From: Jixiong Dong <[email-masked]>
Date: Mon, 17 Oct 2005 09:53:56 +0800

Scott,

I agree with you entirely. The real requirements are the key fact. Maybe We 
need to  give the requirement list and then discuss on it. If these requirements
can be implemented by the underlying PSN, then PW protection is not needed,
thus PW is not a layer network. Otherwise, PW protection is needed.

Dong