Subject: RE: [PWE3] Re: PW-TC-MIB and PW-MIB

From: "Orly Nicklass" <[email-masked]>
Date: Mon, 24 Oct 2005 15:38:20 +0200

Tom,
 
Before we get to other issues, I think you missed my point regarding the
root name.  XXX and YYY are minor typo that you happen to have.
The root name is either 
pwMIB
or pwStdMIB.
 
In the IANA consideration section you refer to pwStdMIB, but it the
modules you used pwMIB. If indeed you meant pwMIB, then the module
identity should be different and so are the nodes coming off it as shown
below.
 
see in line, I marked in RED the way I think it should be.

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Thomas D. Nadeau
Sent: Monday, October 24, 2005 15:15
To: Orly Nicklass
Cc: [email-masked]; [email-masked]
Subject: [PWE3] Re: PW-TC-MIB and PW-MIB

On Oct 23, 2005, at 4:40 PM, Orly Nicklass wrote:

	Tom,

	There is naming confusion with the recent MIBs in draft version
06 that affects other MIBs rooted under the same name space.
	I assume the desired root should be pwStdMIB and not pwMIB, or
alternatively all should be rearranged.
	 
	I copied below few sections from PW-MIB and from the PW-TC-MIB
that show the inconsistency:

	draft-ietf-pwe3-pw-mib-06 has the following:

	pwMIB MODULE-IDENTITY ...

	         ::= { pwMIB 799 } -- RFC Editor: To be assigned by IANA
[Orly Nicklass] --should be pwStdMIB and not pwMIB 
	                              -- the value 2 is requested for
this 
	                              -- specific Module.  Please
replace XXX
	                              -- with the assigned value.

    Dang, that is a typo: 799 should be "XXX"[Orly Nicklass]  right 

	   -- Top-level components of this MIB. 
	    
	   -- Notifications 
	   pwNotifications OBJECT IDENTIFIER  
	                                 ::= { pwMIB 0 } 
	   -- Tables, Scalars 
	   pwObjects       OBJECT IDENTIFIER 
	                                 ::= { pwMIB 1 } 
	   -- Conformance 
	   pwConformance   OBJECT IDENTIFIER  
	                                 ::= { pwMIB 2 } 
	
------------------------------------------------------------------------
-----------------------------
	draft-ietf-pwe3-tc-mib-06 has the following:
	 
	pwTcMIB MODULE-IDENTITY ...
	 
	  ::= { pwMIB XXXX }  -- RFC Editor: please replace [Orly
Nicklass]  --should be pwStdMIB and not pwMIB 
	                               
	                            -- XXXX with IANA assigne value. 
	                            -- See IANA considerations sect.
	 
	  pwMIB OBJECT IDENTIFIER [Orly Nicklass]  --should be pwStdMIB
and not pwMIB 
	                               
	         -- This object identifier needs to be assigned by IANA.

	         ::= { transmission YYYY } 

    Yes, "XXXX" should be "YYYY"

	11.  IANA Considerations 
	  IANA is requested to make a MIB OID assignment under the 
	  transmission branch, that is, assign the pwStdMIB under  
	  { transmission TBD }. 
	  -- RFC Editor: Please assign TBD based on IANA-requested
assignment
	   
	  In the future, PWE3 related standards track PW modules should
be 
	  rooted under the pwStdMIB subtree.  The IANA is requested to
manage 
	  that namespace. 
	 
	11.1  IANA Considerations for PW-TC-STD-MIB 
	 
	  This document also requests IANA to assign { pwStdMIB 1 } to
the PW 
	  MIB specified in this document.

	
-----------------------------------------------------------------------

	Other problematic issues in those drafts are not addressed in
this mail, but they do exist and need some fixing.

    Cool. Please post them ASAP. We are trying to close out the base
MIBs
now so we need as much review as possible.

    --Tom

	Orly Nicklass, 

	Associate VP R&D,

	RAD Data Communications Ltd,

	24 Raoul Wallenberg St.

	Tel Aviv, 69719, Israel

	Tel : +972 3 765 9969; Fax : +972 3 644 0930

	email: [email-masked]

	RAD's web site : www.rad.com <outbind://80/www.rad.com> 

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Mon, 24 Oct 2005 10:04:51 -0400

On Oct 24, 2005, at 9:38 AM, Orly Nicklass wrote:

> Tom,
>
> Before we get to other issues, I think you missed my point  
> regarding the root name.  XXX and YYY are minor typo that you  
> happen to have.
> The root name is either
> pwMIB
> or pwStdMIB.

     pwStdMIB.

> identity should be different and so are the nodes coming off it as  
> shown below.

     OK.

     --tom

> From: [email-masked] [mailto:[email-masked]] On  
> Behalf Of Thomas D. Nadeau
>> There is naming confusion with the recent MIBs in draft version 06  
>> that affects other MIBs rooted under the same name space.
>>                               -- the value 2 is requested for this
>>                               -- specific Module.  Please replace XXX
>> --------------------------------------------------------------------- 
>> --------------------------------
>>   -- RFC Editor: Please assign TBD based on IANA-requested assignment
>>
>>   In the future, PWE3 related standards track PW modules should be
>>   rooted under the pwStdMIB subtree.  The IANA is requested to manage
>>   that namespace.
>>
>>   This document also requests IANA to assign { pwStdMIB 1 } to the PW
>> Other problematic issues in those drafts are not addressed in this  
>> mail, but they do exist and need some fixing.
>
>     Cool. Please post them ASAP. We are trying to close out the  
> base MIBs
>> RAD's web site : www.rad.com
>>
>>
>>
>