Subject: RE: [PWE3] Re: PW Protection and Restoration in charter?

From: [email-masked]
Date: Tue, 11 Oct 2005 06:40:37 +0100

Danny McPherson wrote 11 October 2005 02:55
> On Oct 10, 2005, at 7:34 PM, Jixiong Dong wrote:
> 
> > Danny,
> >
> > Yes, It's me for asking for adding the PW protection switching and
> > restoration to the charter.
> >
> > PW protection switching&restoration will not influcence the
> > underlying PSN. And the layer of
> > PW protection is different from PSN protection. Of course, PSN  
> > fault must cause PW fault. But,
> > PW fault donen't mean PSN fault.
> 
> Are other folks in support of adding this to the charter?
> 
> Also, it'd be useful to understand how much of this would be 
> a function bits on the wires as opposed to implementation specific.
> 
> -danny

Danny,

I believe Dong is correct to identify this.  This is a direct
consequence of creating a new PW layer network.  However, unless one has
a good understanding of this topic (ie func arch and what layer networks
are) then you probably won't have a clue what I am talking about.
However, the bottom-line is this:  If we create a (new) layer network
then we will require to specify all of its functional components....so
its much more than 'PW prot-sw'.  You may also want to refer back to my
mail of 12 Aug 2005 to Chris Metz on the thread "RE: [PWE3] RE:
Appropriate addressing" where I try and provide an explanation for why a
new PW layer has been created......but I know why we have arrived here
and I also know its almost impossible now to do much about it. 

regards, Neil 

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Drake, John E" <[email-masked]>
Date: Sun, 16 Oct 2005 18:32:16 -0700

Adrian,

An excellent note.  I couldn't agree more.

Thanks,

John 

-----Original Message-----
From: Adrian Farrel [mailto:[email-masked]] 
Sent: Sunday, October 16, 2005 4:21 AM
To: Danny McPherson; pwe3
Subject: Re: [PWE3] Re: PW Protection and Restoration in charter?

Danny,

I'm not going to object, but (for the reasons that Neil stated) you need
to watch what is happening here.

Rather than PW being a service that you offer over a network (where your
service request would request that the underlying network provided a
certain level of protection) you have moved PW to being a network layer
in its own right. Thus you are talking about setting up protection PWs
and
(presumably) the request you will make at the service interface is for
diversity.

As you follow this along a bit you will discover that you need to
control the path of the PW not just at its hop end points, but also
through the network.

>From a signaling point of view you are re-inventing many aspects of
MPLS-TE and GMPLS.

1. You may not want to do this.
2. You may be told by the IESG that you are in the wrong Area to do
this. 3. You should be told the IESG that you shouldn't do this work
without consulting existing WGs that have already done this work.

Thanks,
Adrian

----- Original Message ----- 
From: "Danny McPherson" <[email-masked]>
To: "pwe3" <[email-masked]>
Sent: Friday, October 14, 2005 4:19 AM
Subject: Re: [PWE3] Re: PW Protection and Restoration in charter?

>
> Thanks Sasha, Neil and Dong.
>
> Does anyone object to adding an item akin to this to the objectives 
> section of the charter?
>
> Define requirements for, and subsequently, mechanisms to enable 
> protection and restoration of PWs.
>
> Note that I am intentionally avoiding explicit scoping to multi and/or

> single segment PWs.
>
> -danny
>
> On Oct 11, 2005, at 7:55 AM, Sasha Vainshtein wrote:
>
> > Danny, Dong and all,
> >
> > IMHO PW protection (and restoration) become relevant when it comes 
> > to multi-segment PWs (MS-PW).
> >
> > The difference between SS-PWs and MS-PWs wrt protection is that the 
> > latter may require protection against failure of S-PEs. And, of 
> > course, such protection does not have to influence the underlying 
> > PSN.
> >
> > (To the best of my understanding, my considerations
> > in this regard actually match Neil's in his recent email
> > on this thread - even if the wording is quite different.)
> >
> > The requirement for protection of MS-PWs against S-PE failures has 
> > been already defined in the appropriate WG draft 
> > (draft-ietf-pwe3-ms-pw-requirements-00.txt),
> > including an explicit reference to "1:1 protected PWs".
> >
> > Protection of MS-PWs against S-PE failures is also one
> > of the issues that ALL the proposals currently on the
> > table for dynamic setup and maintenance of MS-PWs try
> > to cope with.
> >
> > Hence explicit inclusion of some appropriate text in
> > the Charter looks perfectly reasonable to me - it would simply align

> > the Charter with the facts on the ground.
> >
> > Regards,
> >             Sasha
> >
> >
> >> -----Original Message-----
> >> From: Danny McPherson [mailto:[email-masked]]
> >> Sent: Tuesday, October 11, 2005 3:55 AM
> >> To: pwe3; Jixiong Dong
> >> Subject: Re: [PWE3] Re: PW Protection and Restoration in charter?
> >>
> >>
> >>

> >>> underlying PSN. And the layer of PW protection is different from 
> >>> PSN protection. Of course, PSN fault must cause PW fault. But,
> >> Also, it'd be useful to understand how much of this would be a 
> >> function bits on the wires as opposed to implementation specific.
> >>
> >> -danny
> >>