Subject: RE: [PWE3] Inter-op is not necessary

From: "Drake, John E" <[email-masked]>
Date: Thu, 17 Nov 2005 10:55:52 -0800

Tom,

I don't think you and Luca should be judging consensus, but since you are, I would say that the consensus in the Vancouver meeting seemed to be overwhelmingly in favor of advancing both.

Thanks,

John

> -----Original Message-----
> From: Thomas D. Nadeau [mailto:[email-masked]]
> Sent: Thursday, November 17, 2005 7:36 AM
> To: Mark Townsley
> Cc: Yaakov Stein; [email-masked]
> Subject: Re: [PWE3] Inter-op is not necessary
> 
> 
> > LE ROUX Jean-Louis RD-CORE-LAN wrote:
> >
> >> Hi Andrew,
> >>
> >>
> >>> I'm not a fan of "let the market decide" because in the end, as a
> >>> vendor you have to do both -
> >>
> >> Look at the RSVP-TE vs CR-LDP case, this is a good example, a bit
> >> related to our case here by the way:-), were the market decided,
> >> and it seems to me that not many vendors implemented both...
> >>
> > Ironically, the more split the WG is, the more important it is to
> > pick one path forward now. The closer we are to a 50/50 split, the
> > more likely everyone will end up implementing both, as well as the
> > interop between each given the interprovider requirements. This
> > additional overhead to interoperability only serves to inhibit
> > market forces.
> 
> 	I think its clear from the 2 or 3 times we have taken
> a poll on this that its not even close to 50-50; its more
> like 85-15. Luca raised this point during the last meeting, and it
> was evident from those in the room in Paris that there was a clear
> majority for the LDP-based solution. It might be true that
> the RSVP-TE-based solution gets implemented, but the question in
> my mind is who is actually going to *deploy and use* it? Following
> this argument, given its small potential for being deployed, would
> you ever need multiple vendors to interoperate on that solution
> based on an IETF standard? And should the IETF spend essentially
> equal WG resources developing such a solution?
> 
> 	I say we stop wasting the WG's resources and move
> forward on making the solution supported by the clear majority
> as solid and complete as possible.
> 
> 	--Tom
> 
> 
> > Letting the "market decide" between our own protocols is a red
> > herring. SDOs such as the IETF exist to *create* markets by
> > engineering an interoperable foundation for vendors to then compete
> > on price/performance/features. Not making an engineering decision
> > on that now only reduces the ability for the market to operate
> > where it operates best.
> >
> > - Mark
> >
> >> Regards,
> >>
> >> JL
> >>
> >>
> >>> -----Message d'origine-----
> >>> De : [email-masked] [mailto:[email-masked]] De la
> >>> part de Andrew G. Malis
> >>> Envoyé : lundi 14 novembre 2005 21:59
> >>> À : Gray, Eric
> >>> Cc : Mark Townsley; 'Yaakov Stein'; [email-masked]
> >>> Objet : RE: [PWE3] Inter-op is not necessary
> >>>
> >>> Eric,
> >>>
> >>> Yeah, but we don't want to restrict it to a single administrative
> >>> domain.  I also agree with many of the others in the meeting -
> >>> let's choose one and move on.  I'm not a fan of "let the market
> >>> decide" because in the end, as a vendor you have to do both -
> >>> especially if big vendor a goes one way, big vendor b goes the
> >>> other, and everyone else needs to interoperate with both a and
> >>> b.  And most times, even the big vendors find that their
> >>> customers want them to interoperate with their competition, so
> >>> they end up doing it both ways as well.
> >>>
> >>> The only way we should approve both is if we can define a
> >>> completely dynamic interface between the two that requires no
> >>> more provisioning by the service providers than if we had only
> >>> chosen one.  Otherwise, we're shortchanging the operators and the
> >>> rest of the community.
> >>>
> >>> Cheers,
> >>> Andy
> >>>
> >>> -------
> >>>
> >>> At 11/14/2005 18:39 -0200, Gray, Eric wrote:
> >>>
> >>>> Yaakov,
> >>>>
> >>>>        This is a very narrow view of the purpose for multi-
> >>>> segment pseudo-wires.  There are applications for pseudo-wire
> >>> stitching within
> >>>> a single administrative domain.
> >>>>
> >>>> --
> >>>> Eric
> >>>>
> >>>> --> -----Original Message-----
> >>>> --> From: [email-masked] [mailto:[email-masked]]
> >>>> On --> Behalf Of Yaakov Stein
> >>>> --> Sent: Monday, November 14, 2005 3:14 PM
> >>>> --> To: Mark Townsley; [email-masked]
> >>>> --> Subject: RE: [PWE3] Inter-op is not necessary
> >>>> -->
> >>>> -->
> >>>> --> > To be clear, I said that "coexistance" was a necessity to be
> >>>> --> documented by the WG.
> >>>> --> > Whether coexistance equates to interworking depends on the MS
> >>>> --> requirements.
> >>>> -->
> >>>> --> Since the whole idea of MPLS MS-PWs is to facilitate the -->
> >>>> interworking of different operators, as far as I see coexistence
> >>>> --> must mean either
> >>>> -->
> >>>> --> 1) fully interwork
> >>>> --> 2) mandate that they never have to cooperate.
> >>>> -->
> >>>> --> The latter would probably end up with everyone having to
> >>>> support --> both signaling protocols, and often setting up
> >>> additional PWs just
> >>>> --> to circumvent the limitation.
> >>>> -->
> >>>> --> Y(J)S
> >>>>
> >>> _______________________________________________
> >>> pwe3 mailing list
> >>> [email-masked]
> >>> https://www1.ietf.org/mailman/listinfo/pwe3
> >>>
> >>>
> >>
> >> _______________________________________________
> >> pwe3 mailing list
> >> [email-masked]
> >> https://www1.ietf.org/mailman/listinfo/pwe3
> >>
> >>
> >
> > _______________________________________________
> > pwe3 mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/pwe3
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 17 Nov 2005 14:28:14 -0500

John,

This is quoting from the minutes:

Dynamic Multi-Segment Pseudo Wire Signaling Procedures Using LDP
Florin Balus ([email-masked])
draft-balus-bocci-martini-dyn-ms-pwe3-00.txt
....
Stewart Bryant: Who thinks this should be a WG draft: Large number in favour

Setup and Maintenance of Pseudowires using RSVP-TE
Dimitri Papadimitriou
draft-raggarwa-rsvpte-pw-02.txt
.....
Stewart Bryant: Is there consensus to make this a WG draft?: a few. 
Will ask the question to the list.

The minutes also reflect what I saw at the meeting.

Cheers,
Andy

---------

At 11/17/2005 10:55 -0800, Drake, John E wrote:
>Tom,
>
>I don't think you and Luca should be judging consensus, but since 
>you are, I would say that the consensus in the Vancouver meeting 
>seemed to be overwhelmingly in favor of advancing both.
>
>Thanks,
>
>John
>

---

From: dimitri papadimitriou <[email-masked]>
Date: Thu, 17 Nov 2005 21:00:23 +0100

Andrew G. Malis wrote:
> Stewart Bryant: Is there consensus to make this a WG draft?: a few. Will 
> ask the question to the list.

as i stated in my previous e-mail this was not the question that 
generated this answer of "a few"

> The minutes also reflect what I saw at the meeting.

the only difference we have today is that there is few people being 
totally opposed to RSVP-TE for PW signaling ... probably they do not 
have the same application as those that are in favour but i don't think 
this provides any rationale for not progressing both solution

>> I don't think you and Luca should be judging consensus, but since you 
>> are, I would say that the consensus in the Vancouver meeting seemed to 
>> be overwhelmingly in favor of advancing both.
>>
>> Thanks,
>>
>> John
>>
> .

---

From: Stewart Bryant <[email-masked]>
Date: Fri, 18 Nov 2005 09:32:52 +0000

John

This is what I saw from the chair:

1) Do we wish to make a decision on MS-LDP vs MS-RSVP?
     - Significant majority for don't make a decision.

2) Do we wish MS-LDP to become a WG draft?
     - Significant majority to it to become a WG draft.

3) Do we wish MS-RSVP to become a WG draft
     - A non-trivial number of hands saying yes, but by
       no means as many as in the previous two cases.

It was interesting that there was a significant difference
in numbers between cases 1 and 3, and this was noted by
a number of people after the meeting as surprising.

We did ask the list about case 3 earlier in the year
and there was no consensus in favour of this.

I said earlier I wish to consult with Danny and Mark
and then we will conduct the poll on the list on
how to move forward.

- Stewart

---

From: David McDysan <[email-masked]>
Date: Fri, 18 Nov 2005 08:00:37 -0500

As I stated in the meeting, a way of putting these proposals in context and
driving toward a decision would be to further expand the applicability
scenarios of the proposed solution(s). This should include the
(in)applicability of SS-PW, which is was initial motivation for MS-PW.

Dave 

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Stewart Bryant
> Sent: Friday, November 18, 2005 4:33 AM
> To: Drake, John E
> Cc: Thomas D. Nadeau; Yaakov Stein; [email-masked]; Mark Townsley
> >I don't think you and Luca should be judging consensus, but 
> since you are, I would say that the consensus in the 
> Vancouver meeting seemed to be overwhelmingly in favor of 
> advancing both.
> >
> >Thanks,
> >
> >John
> >  
> >
> 
> John
> 
> It was interesting that there was a significant difference in 
> numbers between cases 1 and 3, and this was noted by a number 
> of people after the meeting as surprising.
> 
> We did ask the list about case 3 earlier in the year and 
> there was no consensus in favour of this.
> 
> I said earlier I wish to consult with Danny and Mark and then 
> we will conduct the poll on the list on how to move forward.
> 
> - Stewart
> 
> 
> 
> 
> 
>   
>