Subject: RE: [PWE3] LDP & RSVP for MS-PWs

From: "Busschbach, Peter B (Peter)" <[email-masked]>
Date: Tue, 22 Nov 2005 17:30:47 -0500

"pseudo-poll", "formalize things a bit": how much vaguer can we be? It is not clear to me if we are trying to figure out what happened in Vancouver or if there is another purpose to this pseudo poll.

Personally, I have a problem with the last question. Of course I prefer a single solution, as long as it is the right one. The question is if and when we should decide to select one solution and stop work on the other. In my opinion, it is premature to do so. I think that a continued discussion on the pros and cons of the two solutions will help to clarify requirements and tradeoffs. 

Peter

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Danny McPherson
> Sent: Tuesday, November 22, 2005 12:05 PM
> To: pwe3
> Subject: [PWE3] LDP & RSVP for MS-PWs
> 
> 
> 
> Folks,
> To continue this pseudo-poll on the MS-RSVP v. MS-LDP, I'd like
> to formalize things a bit and ask folks to respond to the following
> questions (on list, ideally, but directly to the chairs if you'd  
> prefer).
> 
> If you've already responded to these no need to reply again,
> we heard you.
> 
> YES or NO answers only please, although you're welcome to
> follow-up a YES or NO with comments as to why.
> 
> And yes, I realize this is somewhat arbitrary, but we'll see how it
> goes..
> 
> Thanks!
> 
> -danny & Stewart
> 
> 
> [snip]
> 
> Q1. Are you in favor of moving MS-LDP forward as WG draft?
> 
> Q2. Are you against moving MS-LDP forward?
> 
> Q3. Are you in favor of moving MS-RSVP forward as WG draft?
> 
> Q4. Are you against moving MS-RSVP forward?
> 
> Q5. Are you in favor of a single solution?
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
> 

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Yakov Rekhter <[email-masked]>
Date: Tue, 22 Nov 2005 18:25:12 -0800

Peter,

> "pseudo-poll", "formalize things a bit": how much vaguer can we be?
> It is not clear to me if we are trying to figure out what happened
> in Vancouver or if there is another purpose to this pseudo poll.

This is a good question and I am looking forward for the WG chairs 
to give us a clear answer on this.

> Personally, I have a problem with the last question. Of course I
> prefer a single solution, as long as it is the right one. The
> question is if and when we should decide to select one solution
> and stop work on the other. In my opinion, it is premature to do
> so. I think that a continued discussion on the pros and cons of
> the two solutions will help to clarify requirements and tradeoffs.

As I said (many times) before, deciding whether there should be 
one or more than one solution is best done by the market, not
by the debates in the WG.

Yakov.

---

From: Danny McPherson <[email-masked]>
Date: Tue, 22 Nov 2005 21:03:16 -0700

> "pseudo-poll", "formalize things a bit": how much vaguer can we be?

I.e., try to better gauge consensus.

> in Vancouver or if there is another purpose to this pseudo poll.

No, I'm not trying to figure out what happened in Vancouver, as should
be evident from earlier emails.  I'm simply attempting to qualify and  
quantify
support for each of the solutions in order to make a more educated
recommendation about how to move forward.

> prefer a single solution, as long as it is the right one.

So you believe IETF WGs should simply work on anything anyone brings
to the table and let the "market" decide at some undetermined point  
in the
future whether it actually makes sense or not - regardless of how much
or little support there is for the item within the WG?

[side: Yakov, I'll remember this next time something wacky appears in
IDR :-)]

I suspect even you agree that a bit of qualifying and quantifying of  
support
for any item is in order, and this is surely an implicit expectation  
from the
community of the WG and the IETF.

Comments regarding this entire discussion largely stem from which of the
two solutions (or three solutions, should we push both forward) vendor X
believes themselves is the "right solution".  That's fine, but we as  
a WG owe
it to that "market" to consider where we've been, where we're at, and
where we're going, and certainly, what seems to make sense technically
and architecturally - the latter of which seems to take a back seat  
to politics
more often than not.

> The question is if and when we should decide to select one solution  
> and stop work on the other. In my opinion, it is premature to do so.

So you believe both should be working group items and progressed in
the working group?  Very well.  Why couldn't you of just answered the
questions as such?

> I think that a continued discussion on the pros and cons of the two  
> solutions will help to clarify requirements and tradeoffs.

I certainly welcome this discussion, in particular if anyone actually  
has
anything new to say.

-danny

---

From: George Swallow <[email-masked]>
Date: Wed, 23 Nov 2005 09:55:10 -0500

> prefer a single solution, as long as it is the right one. The question
> is if and when we should decide to select one solution and stop work
> on the other. In my opinion, it is premature to do so. I think that a
> continued discussion on the pros and cons of the two solutions will
> help to clarify requirements and tradeoffs.

My experience is that if you have two approaches that are techinally
viable, then the only way to have one is to kill the other.  The longer
one waits the more difficult this becomes.  You develop two camps that
are each investing (both personal capital as well as their employers'
$$$) in their solution.  So the stakes just keep getting higher and the
battle will either be bloody or a truce will be called and we'll have
two solutions.  

If both solutions succeed in the market-place then all non-niche vendors
will have to support both.  

So if I were doing the poll, I'd have put question 5 first.

...George

========================================================================
George Swallow             Cisco Systems                  (978) 936-1398
                           1414 Massachusetts Avenue
                           Boxborough, MA 01719