Subject: RE: [PWE3] Inter-op is not necessary

From: Shahram Davari <[email-masked]>
Date: Tue, 22 Nov 2005 09:17:41 -0800

Hi Ping,

> (6) OAM and OAM interworking: How would it work? Actually, would 
> carriers allow the OAM packets going over the boundary of the 
> network? 
> If I am a carrier, I probably will not allow some guys on 
> either end of 
> my network to run some performance monitoring tests. Then how 
> do we get 
> edge-to-edge OAM?
> 

An OAM architecture similar to IEEE 802.1ag or ITU Y.17ethoam, might be
useful. In these drafts the OAM flows are divided to 3 spaces:

- User OAM
- Network Operator (Carrier) OAM
- Service Provider OAM

Service provider contracts with a number of carriers to provide the service.
Service provider is responsible for e-2-e performance, and has access to
e-2-e OAM. While each carrier can only run OAM in its own network. This architecture
requires a method to distinguish/filter these 3 types of OAM flows.

Yours,
Shahram

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Ping Pan <[email-masked]>
Date: Tue, 22 Nov 2005 09:55:17 -0800

:-) Thought the same when reading 802.1ag....

- Ping

---

From: Jixiong Dong <[email-masked]>
Date: Wed, 23 Nov 2005 10:29:39 +0800

Hi Shahram, Hi Ping,

I agree with you. IMO, user OAM is transparency in PW, because it is user
traffic. Carrier OAM is pw segment OAM. SP OAM is end-to-end OAM.
In my ms-pw oam draft, I give a method to distinguish the different OAM flows.

Best Regards,
Dong