Subject: RE: [PWE3] Inter-op is not necessary

From: "LE ROUX Jean-Louis RD-CORE-LAN" <[email-masked]>
Date: Tue, 15 Nov 2005 22:32:36 +0100

Hi Andrew,

>I'm not a fan 
> of "let the market decide" 
> because in the end, as a vendor you have to do both - 

Look at the RSVP-TE vs CR-LDP case, this is a good example, a bit related to our case here by the way:-), were the market decided, and it seems to me that not many vendors implemented both...

Regards,

JL

> -----Message d'origine-----
> De : [email-masked] [mailto:[email-masked]] De 
> la part de Andrew G. Malis
> Envoyé : lundi 14 novembre 2005 21:59
> À : Gray, Eric
> Cc : Mark Townsley; 'Yaakov Stein'; [email-masked]
> Objet : RE: [PWE3] Inter-op is not necessary
> 
> Eric,
> 
> Yeah, but we don't want to restrict it to a single 
> administrative domain.  I also agree with many of the others 
> in the meeting - let's choose one and move on.  I'm not a fan 
> of "let the market decide" 
> because in the end, as a vendor you have to do both - 
> especially if big vendor a goes one way, big vendor b goes 
> the other, and everyone else needs to interoperate with both 
> a and b.  And most times, even the big vendors find that 
> their customers want them to interoperate with their 
> competition, so they end up doing it both ways as well.
> 
> The only way we should approve both is if we can define a 
> completely dynamic interface between the two that requires no 
> more provisioning by the service providers than if we had 
> only chosen one.  Otherwise, we're shortchanging the 
> operators and the rest of the community.
> 
> Cheers,
> Andy
> 
> -------
> 
> At 11/14/2005 18:39 -0200, Gray, Eric wrote:
> >Yaakov,
> >
> >         This is a very narrow view of the purpose for multi-segment 
> >pseudo-wires.  There are applications for pseudo-wire 
> stitching within 
> >a single administrative domain.
> >
> >--
> >Eric
> >
> >--> -----Original Message-----
> >--> From: [email-masked] [mailto:[email-masked]] On 
> >--> Behalf Of Yaakov Stein
> >--> Sent: Monday, November 14, 2005 3:14 PM
> >--> To: Mark Townsley; [email-masked]
> >--> Subject: RE: [PWE3] Inter-op is not necessary
> >-->
> >-->
> >--> > To be clear, I said that "coexistance" was a necessity to be
> >--> documented by the WG.
> >--> > Whether coexistance equates to interworking depends on the MS
> >--> requirements.
> >-->
> >--> Since the whole idea of MPLS MS-PWs is to facilitate the 
> >--> interworking of different operators, as far as I see coexistence 
> >--> must mean either
> >-->
> >--> 1) fully interwork
> >--> 2) mandate that they never have to cooperate.
> >-->
> >--> The latter would probably end up with everyone having to support 
> >--> both signaling protocols, and often setting up 
> additional PWs just 
> >--> to circumvent the limitation.
> >-->
> >--> Y(J)S
> 
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
> 

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 15 Nov 2005 17:49:45 -0500

JL,

Actually, some vendors did do both before it was 
clear where the market was going - and in this 
case, we had the advantage that both of the 
dominant router vendors went the same way, as did 
their customers.  But that was really the exception rather than the rule.

Cheers,
Andy

--------

At 11/15/2005 22:32 +0100, LE ROUX Jean-Louis RD-CORE-LAN wrote:
>Look at the RSVP-TE vs CR-LDP case, this is a 
>good example, a bit related to our case here by 
>the way:-), were the market decided, and it 
>seems to me that not many vendors implemented both...
>
>Regards,
>
>JL
>
>

---

From: Mark Townsley <[email-masked]>
Date: Thu, 17 Nov 2005 16:18:20 +0100

>Look at the RSVP-TE vs CR-LDP case, this is a good example, a bit related to our case here by the way:-), were the market decided, and it seems to me that not many vendors implemented both...
Ironically, the more split the WG is, the more important it is to pick 
one path forward now. The closer we are to a 50/50 split, the more 
likely everyone will end up implementing both, as well as the interop 
between each given the interprovider requirements. This additional 
overhead to interoperability only serves to inhibit market forces.

Letting the "market decide" between our own protocols is a red herring. 
SDOs such as the IETF exist to *create* markets by engineering an 
interoperable foundation for vendors to then compete on 
price/performance/features. Not making an engineering decision on that 
now only reduces the ability for the market to operate where it operates 
best.

- Mark

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 17 Nov 2005 10:36:16 -0500

>>> I'm not a fan of "let the market decide" because in the end, as a  
>>> vendor you have to do both -
>>
>> Look at the RSVP-TE vs CR-LDP case, this is a good example, a bit  
>> related to our case here by the way:-), were the market decided,  
>> and it seems to me that not many vendors implemented both...
>>
> Ironically, the more split the WG is, the more important it is to  
> pick one path forward now. The closer we are to a 50/50 split, the  
> more likely everyone will end up implementing both, as well as the  
> interop between each given the interprovider requirements. This  
> additional overhead to interoperability only serves to inhibit  
> market forces.

	I think its clear from the 2 or 3 times we have taken
a poll on this that its not even close to 50-50; its more
like 85-15. Luca raised this point during the last meeting, and it
was evident from those in the room in Paris that there was a clear
majority for the LDP-based solution. It might be true that
the RSVP-TE-based solution gets implemented, but the question in
my mind is who is actually going to *deploy and use* it? Following
this argument, given its small potential for being deployed, would
you ever need multiple vendors to interoperate on that solution
based on an IETF standard? And should the IETF spend essentially
equal WG resources developing such a solution?

	I say we stop wasting the WG's resources and move
forward on making the solution supported by the clear majority
as solid and complete as possible.

	--Tom

> Letting the "market decide" between our own protocols is a red  
> herring. SDOs such as the IETF exist to *create* markets by  
> engineering an interoperable foundation for vendors to then compete  
> on price/performance/features. Not making an engineering decision  
> on that now only reduces the ability for the market to operate  
> where it operates best.
>
> - Mark
>
>> Regards,
>>
>> JL
>>
>>
>>> De : [email-masked] [mailto:[email-masked]] De la  
>>> part de Andrew G. Malis
>>> Yeah, but we don't want to restrict it to a single administrative  
>>> domain.  I also agree with many of the others in the meeting -  
>>> let's choose one and move on.  I'm not a fan of "let the market  
>>> decide" because in the end, as a vendor you have to do both -  
>>> especially if big vendor a goes one way, big vendor b goes the  
>>> other, and everyone else needs to interoperate with both a and  
>>> b.  And most times, even the big vendors find that their  
>>> customers want them to interoperate with their competition, so  
>>> they end up doing it both ways as well.
>>>
>>> more provisioning by the service providers than if we had only  
>>> chosen one.  Otherwise, we're shortchanging the operators and the  
>>> rest of the community.
>>>
>>> Cheers,
>>> Andy
>>>
>>> -------
>>>
>>>>        This is a very narrow view of the purpose for multi- 
>>>> segment pseudo-wires.  There are applications for pseudo-wire
>>> stitching within
>>>> --> From: [email-masked] [mailto:[email-masked]]  
>>>> On --> Behalf Of Yaakov Stein
>>>> --> Since the whole idea of MPLS MS-PWs is to facilitate the -->  
>>>> interworking of different operators, as far as I see coexistence  
>>>> --> must mean either
>>>> -->
>>>> --> 1) fully interwork
>>>> --> The latter would probably end up with everyone having to  
>>>> support --> both signaling protocols, and often setting up
>>> additional PWs just

---

From: dimitri papadimitriou <[email-masked]>
Date: Fri, 18 Nov 2005 12:37:51 +0100

mark, would it be possible that you clarify the following points:

Mark Townsley wrote:

>> related to our case here by the way:-), were the market decided, and 
>> it seems to me that not many vendors implemented both...
>

your reasoning relies on the fact that the market needs are uniform and 
homogeneous which is something really difficult to in/validate, it is 
also not clear why you are putting in the loop of discussion the 
question of co-existence/inter-operability as at the end strongly 
Dependant on use case(s) ? needless also to remember that the issue of 
"co-existence" is present even without considering the MS-PW case

there has been some very good discussion during the paris meeting where 
it has been stated that there are different needs in different parts of 
the network:

copied from <http://www3.ietf.org/proceedings/05aug/index.html>

"we should not make a choce between the two. Sometimes we need explicit 
routing, sometimes we don't. So we should continue to work on both 
protocols"

this has also been recorded during the last vancouver meeting where 
during various polls there was a significant majority for don't make a 
"selection" decision (at least at this point in time)

this said, we are usually very eagerly asking for user community 
feedback/input and once we got it i am not necessarily sure we are 
always correctly interpreting their message/thoughts

thanks,
- dimitri.

>>> De : [email-masked] [mailto:[email-masked]] De la part 
>>> de Andrew G. Malis
>>> domain.  I also agree with many of the others in the meeting - let's 
>>> choose one and move on.  I'm not a fan of "let the market decide" 
>>> because in the end, as a vendor you have to do both - especially if 
>>> big vendor a goes one way, big vendor b goes the other, and everyone 
>>> else needs to interoperate with both a and b.  And most times, even 
>>> the big vendors find that their customers want them to interoperate 
>>> with their competition, so they end up doing it both ways as well.
>>>
>>> The only way we should approve both is if we can define a completely 
>>> dynamic interface between the two that requires no more provisioning 
>>> by the service providers than if we had only chosen one.  Otherwise, 
>>> we're shortchanging the operators and the rest of the community.
>>>
>>> Cheers,
>>> Andy
>>>
>>> -------
>>>
>>>> interworking of different operators, as far as I see coexistence --> 
>>>> must mean either
>>>> -->
>>>> --> 1) fully interwork
> .