Subject: RE: [PWE3] Inter-op is not necessary

From: "Gray, Eric" <[email-masked]>
Date: Mon, 14 Nov 2005 18:39:16 -0200

Yaakov,

	This is a very narrow view of the purpose for multi-segment
pseudo-wires.  There are applications for pseudo-wire stitching 
within a single administrative domain.

--
Eric

--> -----Original Message-----
--> From: [email-masked] [mailto:[email-masked]] 
--> On Behalf Of Yaakov Stein
--> Sent: Monday, November 14, 2005 3:14 PM
--> To: Mark Townsley; [email-masked]
--> Subject: RE: [PWE3] Inter-op is not necessary
--> 
-->  
--> > To be clear, I said that "coexistance" was a necessity to be
--> documented by the WG. 
--> > Whether coexistance equates to interworking depends on the MS
--> requirements.
--> 
--> Since the whole idea of MPLS MS-PWs is to facilitate the 
--> interworking of different operators, as far as I see 
--> coexistence must mean either
--> 
--> 1) fully interwork
--> 2) mandate that they never have to cooperate.
--> 
--> The latter would probably end up with everyone having to 
--> support both signaling protocols, and often setting up 
--> additional PWs just to circumvent the limitation.
--> 
--> Y(J)S
--> 
--> _______________________________________________
--> pwe3 mailing list
--> [email-masked]
--> https://www1.ietf.org/mailman/listinfo/pwe3
--> 

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 14 Nov 2005 15:59:01 -0500

Eric,

Yeah, but we don't want to restrict it to a single administrative 
domain.  I also agree with many of the others in the meeting - let's 
choose one and move on.  I'm not a fan of "let the market decide" 
because in the end, as a vendor you have to do both - especially if 
big vendor a goes one way, big vendor b goes the other, and everyone 
else needs to interoperate with both a and b.  And most times, even 
the big vendors find that their customers want them to interoperate 
with their competition, so they end up doing it both ways as well.

The only way we should approve both is if we can define a completely 
dynamic interface between the two that requires no more provisioning 
by the service providers than if we had only chosen one.  Otherwise, 
we're shortchanging the operators and the rest of the community.

Cheers,
Andy

-------

---

From: David McDysan <[email-masked]>
Date: Fri, 18 Nov 2005 08:00:37 -0500

I agree. 

Please note that
http://ietf.org/internet-drafts/draft-ietf-pwe3-ms-pw-requirements-01.txt
uses the term "inter-domain," which can be domains within a single providers
or domains that are part of multiple providers.

Dave

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Gray, Eric
> Sent: Monday, November 14, 2005 3:39 PM
> To: 'Yaakov Stein'; Mark Townsley; [email-masked]
> Subject: RE: [PWE3] Inter-op is not necessary
> 
> Yaakov,
> 
> 	This is a very narrow view of the purpose for 
> multi-segment pseudo-wires.  There are applications for 
> pseudo-wire stitching within a single administrative domain.
> 
> --
> Eric
> 
> --> From: [email-masked] 
> [mailto:[email-masked]] On Behalf 
> --> Of Yaakov Stein
> --> interworking of different operators, as far as I see coexistence 
> --> must mean either
> --> 
> --> 1) fully interwork
> --> The latter would probably end up with everyone having to support 
> --> both signaling protocols, and often setting up additional 
> PWs just 
> --> to circumvent the limitation.
> --> 
> --> Y(J)S
> -->