Subject: RE: [PWE3] Inter-op is not necessary

From: "Busschbach, Peter B (Peter)" <[email-masked]>
Date: Fri, 18 Nov 2005 14:06:16 -0500

The interop discussion has many facets. One of them seems to be the notion that there are existing SS-PW devices supporting LDP, with which any new solution must be able to interwork. 

The answer is easy: upgrade the legacy equipment with new software so that it supports whatever solution is selected for MS-PWs. However, from comments in the Vancouver meeting and on the mailing list, I got the impression that that is not an acceptable view. Let's therefore assume that there are existing SS-PW devices that can not be upgraded and that have to operate as they exist today. Such devices would not support the globally-unique AIIs that the balus-bocci-martini draft requires for MS-PWs. Therefore, if a new device would have to interface with one of these old, unupgradable devices, it would have to know that it cannot use the MS-PW signaling protocol but that it would have to fall back on LDP with the AIIs that exist today. Hence, from this perspective it does not make any difference whether we select RSVP-TE or CR-LDP for MS-PWs, the interoperability with legacy devices is problematic in both cases.

Peter

> -----Original Message-----
> From: Shah, Himanshu [mailto:[email-masked]]
> Sent: Thursday, November 17, 2005 5:17 PM
> To: Busschbach, Peter B (Peter); Gray, Eric; Andrew G. Malis; Drake,
> John E
> Cc: Thomas D. Nadeau; Yaakov Stein; [email-masked]; Mark Townsley
> Subject: RE: [PWE3] Inter-op is not necessary
> 
> 
> Hi Peter,
> 
> Perhaps you should have made that case when SS-PW 
> with LDP was being standardized. 
> 
> I did not ask if RSVP-TE would work for SS-PW.
> That I know. I asked for positioning, given that
> there are deployed LDP based solution for SS-PW.
> How much messy should we make?
> 
> Also, remember, the number of PWs are orders of magnitude
> higher than the number of LSPs. But before we get into
> scalability discussions why don't we discuss other technical
> issues..
> 
> /himanshu
> 
> > -----Original Message-----
> > From: Busschbach, Peter B (Peter) [mailto:[email-masked]]
> > Sent: Thursday, November 17, 2005 4:26 PM
> > To: Shah, Himanshu; Gray, Eric; Andrew G. Malis; Drake, John E
> > Cc: Thomas D. Nadeau; Yaakov Stein; [email-masked]; Mark Townsley
> > Subject: RE: [PWE3] Inter-op is not necessary
> > 
> > 
> > 
> > 
> > > -----Original Message-----
> > > From: [email-masked] 
> > [mailto:[email-masked]]On Behalf Of
> > > Shah, Himanshu
> > > Sent: Thursday, November 17, 2005 3:50 PM
> > > To: Gray, Eric; Andrew G. Malis; Drake, John E
> > > Cc: Thomas D. Nadeau; Yaakov Stein; [email-masked]; Mark Townsley
> > > Subject: RE: [PWE3] Inter-op is not necessary
> > > 
> > > 
> > > The reality is that the show of hands at these meetings 
> > > is hardly a good measure of true consensus. It only shows
> > > which companies were able to send how many people to 
> > > attend such meetings.
> > > 
> > > I am not a supporter of two solutions. As a co-author of
> > > LDP based solution, I was surprised that Dave McDyson (MCI), 
> > > another co-author of LDP based solution, spoke in favor of 
> > > progressing 
> > > RSVP based solution for now. Talking to other SPs in the hallway
> > > yielded the same feedback.
> > > 
> > > So I think we should leave the 'consensus' discussions for now
> > > and pick up on merit of each solution again.
> > > 
> > > To that end, I would like to hear from proponents of RSVP based
> > > solution 
> > > 1) to respond to Luca's technical question about the 
> > >    overlapping addresses. 
> > > 2) Is RSVP based solution limited to MS-PW? I know technically
> > >    it can be made to work for SS-PW. However, as far as 
> deployments
> > >    are concerned would SPs deploy SS-PW using both LDP and RSVP?
> > >    What is the positioning from RSVP camp?
> > 
> > Himanshu,
> > 
> > Of course, RSVP_TU would work for single-hop PWs. 
> > Furthermore, RSVP-TE works for optical networks, SHD 
> > networks, MPLS networks and Ethernet networks (if GELS 
> > becomes a reality). It is obviously the protocol of choice 
> > for connection setup. It amazes me that the LDP camp wants to 
> > progress a solution that ONLY works for PWs.
> > 
> > Peter
> > 
> > > 
> > > etc, etc..
> > > 
> > > /himanshu
> > > 
> > > > -----Original Message-----
> > > > From: [email-masked] 
> > > [mailto:[email-masked]]On Behalf Of
> > > > Gray, Eric
> > > > Sent: Thursday, November 17, 2005 3:01 PM
> > > > To: 'Andrew G. Malis'; Drake, John E
> > > > Cc: Thomas D. Nadeau; Yaakov Stein; [email-masked]; Mark Townsley
> > > > Subject: RE: [PWE3] Inter-op is not necessary
> > > > 
> > > > 
> > > > Andy,
> > > > 
> > > > 	That's not how I recall the discussion at all, and that
> > > > is because the minutes fail to capture the actual results.
> > > > 
> > > > 	As I recall, there was a lot of hands to accept each
> > > > draft as a working group document.  What was different was 
> > > > that for the LDP version there were no objections while for
> > > > the RSVP-TE version there were a few.
> > > > 
> > > > 	This is one of the failings of our present basis for
> > > > "consensus shaving" in the IETF.  Whether or a minority is
> > > > in the way of a "rough consensus" depends a lot on who is
> > > > playing the part of "barber".
> > > > 
> > > > 	Where the issue may have become confusing was when it
> > > > was pointed out (by several people) that this was equivalent
> > > > to indicating that both proposals should become WG drafts
> > > > and that would mean extra work to advance both through the
> > > > IETF, most people were - stated mildly - not in favor of 
> > > > that.
> > > > 
> > > > 	Subsequent efforts to determine what that "state of
> > > > confusion" boiled down to were inconclusive.  That does not
> > > > mean that anyone is free to provide their personal spin as
> > > > to what we concluded at that meeting. The only determination
> > > > That is legitimate is that we determined nothing.
> > > > 
> > > > --
> > > > Eric
> > > > 
> > > > --> -----Original Message-----
> > > > --> From: [email-masked] [mailto:[email-masked]] 
> > > > --> On Behalf Of Andrew G. Malis
> > > > --> Sent: Thursday, November 17, 2005 2:28 PM
> > > > --> To: Drake, John E
> > > > --> Cc: Thomas D. Nadeau; Yaakov Stein; [email-masked]; 
> > Mark Townsley
> > > > --> Subject: RE: [PWE3] Inter-op is not necessary
> > > > --> 
> > > > --> John,
> > > > --> 
> > > > --> This is quoting from the minutes:
> > > > --> 
> > > > --> Dynamic Multi-Segment Pseudo Wire Signaling Procedures 
> > > > --> Using LDP Florin Balus ([email-masked]) 
> > > > --> draft-balus-bocci-martini-dyn-ms-pwe3-00.txt
> > > > --> ....
> > > > --> Stewart Bryant: Who thinks this should be a WG draft: Large 
> > > > --> number in favour
> > > > --> 
> > > > --> Setup and Maintenance of Pseudowires using RSVP-TE Dimitri 
> > > > --> Papadimitriou draft-raggarwa-rsvpte-pw-02.txt .....
> > > > --> Stewart Bryant: Is there consensus to make this a WG 
> > > > draft?: a few. 
> > > > --> Will ask the question to the list.
> > > > --> 
> > > > --> 
> > > > --> The minutes also reflect what I saw at the meeting.
> > > > --> 
> > > > --> Cheers,
> > > > --> Andy
> > > > --> 
> > > > --> ---------
> > > > --> 
> > > > --> At 11/17/2005 10:55 -0800, Drake, John E wrote:
> > > > --> >Tom,
> > > > --> >
> > > > --> >I don't think you and Luca should be judging consensus, 
> > > > --> but since you 
> > > > --> >are, I would say that the consensus in the Vancouver 
> > > > --> meeting seemed to 
> > > > --> >be overwhelmingly in favor of advancing both.
> > > > --> >
> > > > --> >Thanks,
> > > > --> >
> > > > --> >John
> > > > --> >
> > > > --> > > -----Original Message-----
> > > > --> > > From: Thomas D. Nadeau [mailto:[email-masked]]
> > > > --> > > Sent: Thursday, November 17, 2005 7:36 AM
> > > > --> > > To: Mark Townsley
> > > > --> > > Cc: Yaakov Stein; [email-masked]
> > > > --> > > Subject: Re: [PWE3] Inter-op is not necessary
> > > > --> > >
> > > > --> > >
> > > > --> > > > LE ROUX Jean-Louis RD-CORE-LAN wrote:
> > > > --> > > >
> > > > --> > > >> Hi Andrew,
> > > > --> > > >>
> > > > --> > > >>
> > > > --> > > >>> I'm not a fan of "let the market decide" because in 
> > > > --> the end, as 
> > > > --> > > >>> a vendor you have to do both -
> > > > --> > > >>
> > > > --> > > >> Look at the RSVP-TE vs CR-LDP case, this is a good 
> > > > --> example, a bit 
> > > > --> > > >> related to our case here by the way:-), were the 
> > > > --> market decided, 
> > > > --> > > >> and it seems to me that not many vendors 
> > > > implemented both...
> > > > --> > > >>
> > > > --> > > > Ironically, the more split the WG is, the more 
> > > > --> important it is to 
> > > > --> > > > pick one path forward now. The closer we are to a 
> > > > --> 50/50 split, the 
> > > > --> > > > more likely everyone will end up implementing both, 
> > > > --> as well as the 
> > > > --> > > > interop between each given the interprovider 
> > > > --> requirements. This 
> > > > --> > > > additional overhead to interoperability only serves 
> > > > --> to inhibit 
> > > > --> > > > market forces.
> > > > --> > >
> > > > --> > >       I think its clear from the 2 or 3 times we have 
> > > > --> taken a poll 
> > > > --> > > on this that its not even close to 50-50; its more like 
> > > > --> 85-15. Luca 
> > > > --> > > raised this point during the last meeting, and it was 
> > > > --> evident from 
> > > > --> > > those in the room in Paris that there was a clear 
> > > > --> majority for the 
> > > > --> > > LDP-based solution. It might be true that the 
> > > > --> RSVP-TE-based solution 
> > > > --> > > gets implemented, but the question in my mind is who is 
> > > > --> actually 
> > > > --> > > going to *deploy and use* it? Following this argument, 
> > > > --> given its 
> > > > --> > > small potential for being deployed, would you ever need 
> > > > --> multiple 
> > > > --> > > vendors to interoperate on that solution based on an 
> > > > --> IETF standard? 
> > > > --> > > And should the IETF spend essentially equal WG 
> > > > --> resources developing 
> > > > --> > > such a solution?
> > > > --> > >
> > > > --> > >       I say we stop wasting the WG's resources and move 
> > > > --> forward on 
> > > > --> > > making the solution supported by the clear majority as 
> > > > --> solid and 
> > > > --> > > complete as possible.
> > > > --> > >
> > > > --> > >       --Tom
> > > > --> > >
> > > > --> 
> > > > --> 
> > > > --> _______________________________________________
> > > > --> pwe3 mailing list
> > > > --> [email-masked]
> > > > --> https://www1.ietf.org/mailman/listinfo/pwe3
> > > > --> 
> > > > 
> > > > _______________________________________________
> > > > pwe3 mailing list
> > > > [email-masked]
> > > > https://www1.ietf.org/mailman/listinfo/pwe3
> > > > 
> > > 
> > > _______________________________________________
> > > pwe3 mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/pwe3
> > > 
> > 
> 

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Ray Qiu <[email-masked]>
Date: Fri, 18 Nov 2005 11:15:20 -0800

It is so obvious that the answer came from a vendor not a provider.

--Ray

On 11/18/05, Busschbach, Peter B (Peter) <[email-masked]> wrote:
>
> The interop discussion has many facets. One of them seems to be the notion
> that there are existing SS-PW devices supporting LDP, with which any new
> solution must be able to interwork.
>
> The answer is easy: upgrade the legacy equipment with new software so that
> it supports whatever solution is selected for MS-PWs. However, from comments
> in the Vancouver meeting and on the mailing list, I got the impression that
> that is not an acceptable view. Let's therefore assume that there are
> existing SS-PW devices that can not be upgraded and that have to operate as
> they exist today. Such devices would not support the globally-unique AIIs
> that the balus-bocci-martini draft requires for MS-PWs. Therefore, if a new
> device would have to interface with one of these old, unupgradable devices,
> it would have to know that it cannot use the MS-PW signaling protocol but
> that it would have to fall back on LDP with the AIIs that exist today.
> Hence, from this perspective it does not make any difference whether we
> select RSVP-TE or CR-LDP for MS-PWs, the interoperability with legacy
> devices is problematic in both cases.
>
> Peter
>