Subject: RE: [PWE3] Inter-op is not necessary

From: "Shah, Himanshu" <[email-masked]>
Date: Mon, 14 Nov 2005 17:29:00 -0500

Hi Eric,

My appologies if I misunderstood your response.
Hope you arrive at the conclusion that means 
simpler single solution. Please also consider
the need for transparency at T-PEs between SS and 
MS-PWs.

Not saying RSVP or LDP, but if as a group we select
RSVP as the best way to proceed then it must also 
address SS-PW.

/himanshu

> -----Original Message-----
> From: Gray, Eric [mailto:[email-masked]]
> Sent: Monday, November 14, 2005 5:17 PM
> To: Shah, Himanshu; Gray, Eric; Yaakov Stein; Mark Townsley;
> [email-masked]
> Subject: RE: [PWE3] Inter-op is not necessary
> 
> 
> Himanshu,
> 
> 	You and Andy would apparently like to have people believe that
> I suggested an even narrower view than Yaakov did.  Of course we want
> any solution we come up with to be useful in a multiple administrative
> domain application.  And certainly this must be the case by the time
> such applications are in use.
> 
> 	I objected to Yaakov's statement that the "whole idea" is to 
> support multiple domains and the continuation of that idea to infer 
> that solutions must either interoperate or "never" cooperate.  In the
> first place, it is not too difficult to determine that it is possible
> to make the proposed solutions interoperate.  That was demonstrated
> some time ago and interoperability can be shown to be largely - if not
> entirely - a local matter.  And, in the second place, never is a big
> word when applied to a subset of the possible applications.
> 
> 	That does not mean I disagree with Yaakov's (or your) assertions
> about protocol complexity, etc.
> 
> 	There are other issues that I am trying to get my head around,
> however, and - until I do - I am not yet ready to agree with you and
> Andy...
> 
> --
> Eric
> 
> --> -----Original Message-----
> --> From: Shah, Himanshu [mailto:[email-masked]] 
> --> Sent: Monday, November 14, 2005 4:36 PM
> --> To: Gray, Eric; Yaakov Stein; Mark Townsley; [email-masked]
> --> Subject: RE: [PWE3] Inter-op is not necessary
> --> 
> --> Hi Eric,
> --> 
> --> I disagree with your assertion on narrow view. 
> --> MS-PW would very well be used across multiple admin domains.
> --> We certainly do not want two solutions of MS-PW; one for 
> --> single and other for multiple admin domain.
> --> 
> --> If two solutions are allowed to progress, all S-PEs will 
> --> have to support both solutions.
> --> 
> --> I support selecting one (whatever that may be) solution only.
> --> The co-existence argument is rather weak.
> --> 
> --> /himanshu
> --> 
> --> > -----Original Message-----
> --> > From: [email-masked] 
> --> [mailto:[email-masked]]On Behalf Of 
> --> > Gray, Eric
> --> > Sent: Monday, November 14, 2005 3:39 PM
> --> > To: 'Yaakov Stein'; Mark Townsley; [email-masked]
> --> > Subject: RE: [PWE3] Inter-op is not necessary
> --> > 
> --> > 
> --> > Yaakov,
> --> > 
> --> > 	This is a very narrow view of the purpose for 
> multi-segment 
> --> > pseudo-wires.  There are applications for pseudo-wire 
> --> stitching within 
> --> > a single administrative domain.
> --> > 
> --> > --
> --> > Eric
> --> > 
> --> > --> -----Original Message-----
> --> > --> From: [email-masked] 
> [mailto:[email-masked]] On 
> --> > --> Behalf Of Yaakov Stein
> --> > --> Sent: Monday, November 14, 2005 3:14 PM
> --> > --> To: Mark Townsley; [email-masked]
> --> > --> Subject: RE: [PWE3] Inter-op is not necessary
> --> > --> 
> --> > -->  
> --> > --> > To be clear, I said that "coexistance" was a 
> necessity to be
> --> > --> documented by the WG. 
> --> > --> > Whether coexistance equates to interworking depends 
> --> on the MS
> --> > --> requirements.
> --> > --> 
> --> > --> Since the whole idea of MPLS MS-PWs is to facilitate the 
> --> > --> interworking of different operators, as far as I see 
> --> coexistence 
> --> > --> must mean either
> --> > --> 
> --> > --> 1) fully interwork
> --> > --> 2) mandate that they never have to cooperate.
> --> > --> 
> --> > --> The latter would probably end up with everyone having 
> --> to support 
> --> > --> both signaling protocols, and often setting up 
> --> additional PWs just 
> --> > --> to circumvent the limitation.
> --> > --> 
> --> > --> Y(J)S
> --> > --> 
> --> > --> _______________________________________________
> --> > --> pwe3 mailing list
> --> > --> [email-masked]
> --> > --> https://www1.ietf.org/mailman/listinfo/pwe3
> --> > --> 
> --> > 
> --> > _______________________________________________
> --> > pwe3 mailing list
> --> > [email-masked]
> --> > https://www1.ietf.org/mailman/listinfo/pwe3
> --> > 
> --> 
> 

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: David McDysan <[email-masked]>
Date: Fri, 18 Nov 2005 08:00:37 -0500

Himanshu makes a criticial point here. Whatever MS-PW signaling and routing
solution(s) the PWE3 WG specifies, it will NOT BE SS-PW, but IMHO,
interoperation with SS_PW is a mandatory requirement. Therefore,
interoperability (with at least SS-PW) is a firm requirement.

Dave

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Shah, Himanshu
> Sent: Monday, November 14, 2005 5:29 PM
> To: Gray, Eric; Yaakov Stein; Mark Townsley; [email-masked]
> Hope you arrive at the conclusion that means simpler single 
> solution. Please also consider the need for transparency at 
> T-PEs between SS and MS-PWs.
> 
> Not saying RSVP or LDP, but if as a group we select RSVP as 
> the best way to proceed then it must also address SS-PW.
> 
> /himanshu
> 
> > 	You and Andy would apparently like to have people 
> believe that I 
> > suggested an even narrower view than Yaakov did.  Of course we want 
> > 	I objected to Yaakov's statement that the "whole idea" 
> is to support 
> > multiple domains and the continuation of that idea to infer that 
> > solutions must either interoperate or "never" cooperate.  
> In the first 
> > place, it is not too difficult to determine that it is possible to 
> > make the proposed solutions interoperate.  That was 
> demonstrated some 
> > time ago and interoperability can be shown to be largely - if not 
> > --> We certainly do not want two solutions of MS-PW; one for single 
> > --> and other for multiple admin domain.
> > --> 
> > --> If two solutions are allowed to progress, all S-PEs 
> will have to 
> > --> support both solutions.
> > -->