Subject: RE: [PWE3] Inter-op is not necessary

From: "Shah, Himanshu" <[email-masked]>
Date: Thu, 17 Nov 2005 15:49:43 -0500

The reality is that the show of hands at these meetings 
is hardly a good measure of true consensus. It only shows
which companies were able to send how many people to 
attend such meetings.

I am not a supporter of two solutions. As a co-author of
LDP based solution, I was surprised that Dave McDyson (MCI), 
another co-author of LDP based solution, spoke in favor of progressing 
RSVP based solution for now. Talking to other SPs in the hallway
yielded the same feedback.

So I think we should leave the 'consensus' discussions for now
and pick up on merit of each solution again.

To that end, I would like to hear from proponents of RSVP based
solution 
1) to respond to Luca's technical question about the 
   overlapping addresses. 
2) Is RSVP based solution limited to MS-PW? I know technically
   it can be made to work for SS-PW. However, as far as deployments
   are concerned would SPs deploy SS-PW using both LDP and RSVP?
   What is the positioning from RSVP camp?

etc, etc..

/himanshu

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Gray, Eric
> Sent: Thursday, November 17, 2005 3:01 PM
> To: 'Andrew G. Malis'; Drake, John E
> Cc: Thomas D. Nadeau; Yaakov Stein; [email-masked]; Mark Townsley
> Subject: RE: [PWE3] Inter-op is not necessary
> 
> 
> Andy,
> 
> 	That's not how I recall the discussion at all, and that
> is because the minutes fail to capture the actual results.
> 
> 	As I recall, there was a lot of hands to accept each
> draft as a working group document.  What was different was 
> that for the LDP version there were no objections while for
> the RSVP-TE version there were a few.
> 
> 	This is one of the failings of our present basis for
> "consensus shaving" in the IETF.  Whether or a minority is
> in the way of a "rough consensus" depends a lot on who is
> playing the part of "barber".
> 
> 	Where the issue may have become confusing was when it
> was pointed out (by several people) that this was equivalent
> to indicating that both proposals should become WG drafts
> and that would mean extra work to advance both through the
> IETF, most people were - stated mildly - not in favor of 
> that.
> 
> 	Subsequent efforts to determine what that "state of
> confusion" boiled down to were inconclusive.  That does not
> mean that anyone is free to provide their personal spin as
> to what we concluded at that meeting. The only determination
> That is legitimate is that we determined nothing.
> 
> --
> Eric
> 
> --> -----Original Message-----
> --> From: [email-masked] [mailto:[email-masked]] 
> --> On Behalf Of Andrew G. Malis
> --> Sent: Thursday, November 17, 2005 2:28 PM
> --> To: Drake, John E
> --> Cc: Thomas D. Nadeau; Yaakov Stein; [email-masked]; Mark Townsley
> --> Subject: RE: [PWE3] Inter-op is not necessary
> --> 
> --> John,
> --> 
> --> This is quoting from the minutes:
> --> 
> --> Dynamic Multi-Segment Pseudo Wire Signaling Procedures 
> --> Using LDP Florin Balus ([email-masked]) 
> --> draft-balus-bocci-martini-dyn-ms-pwe3-00.txt
> --> ....
> --> Stewart Bryant: Who thinks this should be a WG draft: Large 
> --> number in favour
> --> 
> --> Setup and Maintenance of Pseudowires using RSVP-TE Dimitri 
> --> Papadimitriou draft-raggarwa-rsvpte-pw-02.txt .....
> --> Stewart Bryant: Is there consensus to make this a WG 
> draft?: a few. 
> --> Will ask the question to the list.
> --> 
> --> 
> --> The minutes also reflect what I saw at the meeting.
> --> 
> --> Cheers,
> --> Andy
> --> 
> --> ---------
> --> 
> --> At 11/17/2005 10:55 -0800, Drake, John E wrote:
> --> >Tom,
> --> >
> --> >I don't think you and Luca should be judging consensus, 
> --> but since you 
> --> >are, I would say that the consensus in the Vancouver 
> --> meeting seemed to 
> --> >be overwhelmingly in favor of advancing both.
> --> >
> --> >Thanks,
> --> >
> --> >John
> --> >
> --> > > -----Original Message-----
> --> > > From: Thomas D. Nadeau [mailto:[email-masked]]
> --> > > Sent: Thursday, November 17, 2005 7:36 AM
> --> > > To: Mark Townsley
> --> > > Cc: Yaakov Stein; [email-masked]
> --> > > Subject: Re: [PWE3] Inter-op is not necessary
> --> > >
> --> > >
> --> > > > LE ROUX Jean-Louis RD-CORE-LAN wrote:
> --> > > >
> --> > > >> Hi Andrew,
> --> > > >>
> --> > > >>
> --> > > >>> I'm not a fan of "let the market decide" because in 
> --> the end, as 
> --> > > >>> a vendor you have to do both -
> --> > > >>
> --> > > >> Look at the RSVP-TE vs CR-LDP case, this is a good 
> --> example, a bit 
> --> > > >> related to our case here by the way:-), were the 
> --> market decided, 
> --> > > >> and it seems to me that not many vendors 
> implemented both...
> --> > > >>
> --> > > > Ironically, the more split the WG is, the more 
> --> important it is to 
> --> > > > pick one path forward now. The closer we are to a 
> --> 50/50 split, the 
> --> > > > more likely everyone will end up implementing both, 
> --> as well as the 
> --> > > > interop between each given the interprovider 
> --> requirements. This 
> --> > > > additional overhead to interoperability only serves 
> --> to inhibit 
> --> > > > market forces.
> --> > >
> --> > >       I think its clear from the 2 or 3 times we have 
> --> taken a poll 
> --> > > on this that its not even close to 50-50; its more like 
> --> 85-15. Luca 
> --> > > raised this point during the last meeting, and it was 
> --> evident from 
> --> > > those in the room in Paris that there was a clear 
> --> majority for the 
> --> > > LDP-based solution. It might be true that the 
> --> RSVP-TE-based solution 
> --> > > gets implemented, but the question in my mind is who is 
> --> actually 
> --> > > going to *deploy and use* it? Following this argument, 
> --> given its 
> --> > > small potential for being deployed, would you ever need 
> --> multiple 
> --> > > vendors to interoperate on that solution based on an 
> --> IETF standard? 
> --> > > And should the IETF spend essentially equal WG 
> --> resources developing 
> --> > > such a solution?
> --> > >
> --> > >       I say we stop wasting the WG's resources and move 
> --> forward on 
> --> > > making the solution supported by the clear majority as 
> --> solid and 
> --> > > complete as possible.
> --> > >
> --> > >       --Tom
> --> > >
> --> 
> --> 
> --> _______________________________________________
> --> pwe3 mailing list
> --> [email-masked]
> --> https://www1.ietf.org/mailman/listinfo/pwe3
> --> 
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
> 

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: David McDysan <[email-masked]>
Date: Fri, 18 Nov 2005 08:00:37 -0500

Himanshu,

Let me try to explain my motivation further.

As I mentioned in the meeting, there are some use cases (e.g., complex
inter-domain topologies)  where the LDP-based approach that we have specifed
to date may be less efficient or take longer than some other approach. 

It is this space where I see that we will likely either need to add CR-LDP
style things back into MS-PW signaling, or else use the equivalent semantics
in RSVP-TE derived signaling to improve efficiency and performance.

I think that one solution would be preferable, but it MUST interoperate with
LDP-based SS-PW. It must also do things similar to capabilities already
specified in CR-LDP or RSVP-TE. If the IETF members believe that past
history and precedent preculde CR-LDP, then the choices would seem to be
something RSVP-TE based, or else something completely new.

Dave

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Shah, Himanshu
> Sent: Thursday, November 17, 2005 3:50 PM
> To: Gray, Eric; Andrew G. Malis; Drake, John E
> The reality is that the show of hands at these meetings is 
> hardly a good measure of true consensus. It only shows which 
> companies were able to send how many people to attend such meetings.
> 
> I am not a supporter of two solutions. As a co-author of LDP 
> based solution, I was surprised that Dave McDyson (MCI), 
> another co-author of LDP based solution, spoke in favor of 
> progressing RSVP based solution for now. Talking to other SPs 
> in the hallway yielded the same feedback.
> 
> So I think we should leave the 'consensus' discussions for 
> now and pick up on merit of each solution again.
> 
> To that end, I would like to hear from proponents of RSVP 
> based solution
> > From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of 
> > Gray, Eric
> is because 
> > the minutes fail to capture the actual results.
> > 
> > 	As I recall, there was a lot of hands to accept each draft as a 
> > working group document.  What was different was that for the LDP 
> > version there were no objections while for the RSVP-TE 
> version there 
> > were a few.
> > 
> > 	This is one of the failings of our present basis for "consensus 
> > shaving" in the IETF.  Whether or a minority is in the way 
> of a "rough 
> > consensus" depends a lot on who is playing the part of "barber".
> > 
> was pointed out 
> > (by several people) that this was equivalent to indicating 
> that both 
> > proposals should become WG drafts and that would mean extra work to 
> > advance both through the IETF, most people were - stated 
> mildly - not 
> > in favor of that.
> > 
> confusion" boiled 
> > down to were inconclusive.  That does not mean that anyone 
> is free to 
> > provide their personal spin as to what we concluded at that 
> meeting. 
> > The only determination That is legitimate is that we determined 
> > nothing.
> > 
> > --
> > Eric
> > 
> > --> From: [email-masked] [mailto:[email-masked]] On 
> > --> Behalf Of Andrew G. Malis
> Using LDP 
> > --> Florin Balus ([email-masked]) 
> > --> Stewart Bryant: Who thinks this should be a WG draft: 
> Large number 
> > --> in favour
> > -->

---

From: Mark Townsley <[email-masked]>
Date: Fri, 18 Nov 2005 14:56:22 +0100

>history and precedent preculde CR-LDP, then the choices would seem to be
PWE3 is not bound by the decisions of RFC 3468. That decision was made 
at a different time, for a different situation.

- Mark

---

From: David McDysan <[email-masked]>
Date: Fri, 18 Nov 2005 11:52:03 -0500

Mark,

Thak you for making this clarification. This does differ from past
discussion and comments regarding use of CR-LDP TLVs and procedures for
MS-PW.  We had been trying to avoid CR-LDP in the MS-PW draft, but kept
finding that we needed encodings and proedures to meet some of the more
challenging MS-PW requirements. My support of MS-RSVP and interworking with
MS-LDP assumed that the IETF did not want to use CR-LDP for certain TLV
encodings and procedures.

On the other hand, it does seem somewhat inefficient to encode and define
two protocols that do similar things, which is the argument that I believe
some people are making for doing (G)MPLS style, RSVP-based signaling
(including PW control) in a consistent manner. IMO, this is a higher level
architectural issue that goes beyond the scope of the PWE3 working group,
and involves (at least) the MPLS and CCAMP working groups in IETF as well.
Other SDOs may also have an opinion in this area as well. Is there some
process or discussion underway that will address this higher level issue? Is
there another IETF list that would be better suited to such discussion?

We may have a some discussion on the above topics, so I have changed the
subject line.

Dave

> Behalf Of Mark Townsley
> Sent: Friday, November 18, 2005 8:56 AM
> To: David McDysan
> Cc: 'Thomas D. Nadeau'; 'Yaakov Stein'; [email-masked]; 'Shah, 
> Himanshu'
> Subject: Re: [PWE3] Inter-op is not necessary
> 
> David McDysan wrote:
> 
> >history and precedent preculde CR-LDP, then the choices 
> would seem to 
> >be
> >  
> >
> PWE3 is not bound by the decisions of RFC 3468. That decision 
> was made at a different time, for a different situation.
> 
> - Mark
>

---

From: Mark Townsley <[email-masked]>
Date: Fri, 18 Nov 2005 18:36:31 +0100

>there another IETF list that would be better suited to such discussion?
I have no problem evaluating the pros and cons of RSVP vs. LDP at a 
technical and architectural level, even taking the discussion outside 
the scope of PWE3 if need be. At the end of the day, however, the burden 
of proof for any architectural advantage must be high enough to outweigh 
the costs of dealing with our own past in PWE3. We cannot pretend to go 
back in time and wish we had done things differently, or that existing 
code and deployments do not exist. I think we are in aggreement on this, 
as we both consider MS-PW interoperability with existing SS-PW 
deployments as a MUST.

In a nutshell, I suppose I am saying that while PWE3 consistency with 
GMPLS may be important, I think that PWE3 consistency with itself is 
even more important.

- Mark

>>>specified in CR-LDP or RSVP-TE. If the IETF members believe 
>>>      
>>>
>>that past 
>>    
>>

---

From: Kireeti Kompella <[email-masked]>
Date: Fri, 18 Nov 2005 10:30:34 -0800 (PST)

On Fri, 18 Nov 2005, Mark Townsley wrote:

> In a nutshell, I suppose I am saying that while PWE3 consistency 
> with GMPLS may be important, I think that PWE3 consistency with 
> itself is even more important.

If so, the first item on the "consistency" agenda should be interop of 
FEC 128 and FEC 129 -- these are just about to be standardized, and 
there is no document either on the interop front or on the 
applicability front (to follow up on Dave's suggestion).

In fact, if *one* solution is the goal, then why do we have two 
solutions *within* LDP (not to speak of L2TP as yet another solution)?

If we are going to have 'principles of standardization', we should 
apply them across the board, not just when they are convenient for 
some.  If the principle [of a single solution] is broken (in this 
case, shattered) in the base case of SS-PW, let it quietly die.  I 
agree that this is in general a good goal, but it just doesn't work 
for PWs.

CCAMP makes a good case study.  We could not apply this principle for 
signaling (until CR-LDP was officially deprecated), so we didn't try.
But we could and did apply this principle for new applications, like
LMP, by stating this goal *up front*.

Kireeti.
-------

---

From: Mark Townsley <[email-masked]>
Date: Sat, 19 Nov 2005 00:53:17 +0100

Kireeti Kompella wrote:

>  If so, the first item on the "consistency" agenda should be interop
>  of FEC 128 and FEC 129 -- these are just about to be standardized,
>  and there is no document either on the interop front or on the

draft-ietf-pwe3-segmented-pw-01.txt:

"6.1.3. LDP using FEC 128 to LDP using the generalized FEC 129"

>  solutions *within* LDP (not to speak of L2TP as yet another

The intention is for LDP deployments to migrate to FEC 129 over time, 
eventually deprecating FEC 128. This can be done in a very seamless 
manner, autodetecting presence of which FEC is received in a given LDP 
message. This is quite different than allowing two different, 
non-interoperable, protocols targeted for the same functionality to 
progress at the same time - particularly without any strategy for 
migration or interoperability.

>  some.

I have said several times that if target applications can be deemed 
separable, if the target networks or network equipment which is expected 
to interoperate are largely different, then I am not nearly as concerned 
(it would still be nice if all used the same mechanism, but not as vital 
if the camps want to split).

In the LDP/RSVP case we face today, the application is the same, the 
networks are the same, the network equipment is the same, and there are 
interprovider considerations to boot.

>  If the principle [of a single solution] is broken (in this case,
>  shattered) in the base case of SS-PW, let it quietly die. I agree
>  that this is in general a good goal, but it just doesn't work for
>  PWs.

SS-PWs are different than MS-PWs. Interprovider MS-PW is a very 
different case, one where the operational gain of having one rather than 
many protocols is more significant.

>  LMP, by stating this goal *up front*.

Given that niether MS-LDP nor MS-RSVP are WG documents yet (not to 
mention the WG charter which covers MS-PWs not yet approved), I dare say 
it seems we are still in the "up front" stage.

- Mark

>
>  Kireeti. -------
>
>  _______________________________________________ pwe3 mailing list
>  [email-masked] https://www1.ietf.org/mailman/listinfo/pwe3
>