Subject: Issues with MS-LDP (was: RE: [PWE3] Inter-op is not necessary)

From: Sasha Vainshtein <[email-masked]>
Date: Tue, 22 Nov 2005 18:39:14 +0200

Ping, Florin and all,
Please see inline below a couple of brief comments wtt the issues raised by
Ping.
Since this does not actauuly deal with MS-PDP vs. MS-RSVP, I have changed
the name of the thread).

Regards,
		Sasha

> -----Original Message-----
> From: Ping Pan [mailto:[email-masked]]
> Sent: Tuesday, November 22, 2005 6:27 PM
> To: Florin Balus
> Cc: pwe3
> Subject: Re: [PWE3] Inter-op is not necessary
> 
> 
> OK.
> 
> Are we done with one vs. two protocols yet? ;-)
> 
> OK, let's get back into the technical side of the LDP MS-PW. 
> There are a 
> number of issues we need to resolve:
> 
> (1) FEC 128 interfacing with FEC 129: FEC128 will not go through 
> multi-hop (or PWid collision). So how would a 128 user signal through 
> the network?
>
[Sasha] This must be resolved, but it does not look difficult to me. 
>
> (2) AII format: AII-2 is good for MS. But we are going to use 
> it for all 
> other applications, we need to have a consistent AII format (Andy and 
> George: that ATM-AII and Frame-AII in MFA need to be compatible with 
> this, right? :-))
> 
> (3) QoS format: I don't care if it is RSVP-TE or CR-LDP (the operator 
> won't care neither), so let's decide one. If it is the RSVP-TE format 
> (IntServ Controlled Load format, by default), is there any 
> way to deal with tricolor, and preemption?
> 
> (4) "Congestion Control": Any thoughts on the mapping of EXP bit in 
> MS-PW? This can be an issue if the PW's run through a trunk 
> without the underlying LSP's. ;-)
>
[Sasha] A good point that has been missed, IMO, in the MS-PW architecture
draft.
> 
> (5) Redundancy: I have submitted a draft on this topic. No 
> MS-PW in it 
> yet, but would that be a good starting point?
> 
> (6) OAM and OAM interworking: How would it work? Actually, would 
> carriers allow the OAM packets going over the boundary of the 
> network? 
> If I am a carrier, I probably will not allow some guys on 
> either end of my network to run some performance monitoring tests. Then
how 
> do we get edge-to-edge OAM?
>
[Sasha] A good point too. Input from the SPs would be very important here.
>
> I think this is what I have.
> 
> Thanks!
> 
> - Ping
> 
> 
> Florin Balus wrote:
> > If a re-vote was needed my opinion would be identical with the one
> > expressed by Vach below.
> > 
> > Still I don't think there is a need to ask a question on 
> whether an LDP
> > solution is required! The time has passed for that: LDP is already
> > implemented and deployed for SS-PWs. And the strong support 
> we saw for
> > draft-balus-bocci-martini-dyn-ms-pwe3 during the WG meeting in
> > Vancouver, with nobody against, seem to indicate people 
> agree we should
> > work on expanding the current SS-PW solution to cover MS-PWs. 
> > 
> > So the question on the above draft should be asked in my opinion the
> > same way as it was for the MS-PW architecture draft: e.g. " 
> ... there
> > was strong consensus to make it a WG draft .. Anybody 
> against say so by
> > the <date>..." 
> > 
> > Florin
> > 
> > 
> >>-----Original Message-----
> >>From: [email-masked] [mailto:[email-masked]] On 
> >>Behalf Of Vach Kompella
> >>Sent: Monday, November 21, 2005 2:36 PM
> >>To: 'pwe3'
> >>Subject: RE: [PWE3] Inter-op is not necessary
> >>
> >>
> >>I second Danny's call for re-judging consensus.
> >>
> >>So here is my re-vote:
> >>
> >>Q1. Are you in favor of moving MS-LDP forward as WG draft?
> >>A1. Favor moving MS-LDP forward as WG draft
> >>  - need to have a section of interop with FEC 128
> >>
> >>Q2. Are you against moving MS-LDP forward?
> >>A2. No.
> >>
> >>Q3. Are you in favor of moving MS-RSVP forward as WG draft?
> >>A3. Withhold judgment on MS-RSVP until these are visible:
> >> - provider support
> >> - app stmt in some rudimentary form
> >> - interop with FEC 128 (the dominant PW FEC type deployed)
> >>
> >>Q4. Are you against moving MS-RSVP forward?
> >>A4. Can't answer since I don't have A3.
> >>
> >>Q5. Are you in favor of a single solution?
> >>A5. Need to answer A3.  My preference would be to have a 
> >>single solution.  However, without A3, it seems pointless to 
> >>continue this argument.  Having implemented FEC 128, I can see 
> >>how to implement some form of interop with FEC 129.  Not 
> >>having implemented any SS-RSVP, I don't see that as 
> >>straightforward with MS-RSVP and SS-LDP.  So the beginnings of 
> >>that interop description would be helpful.
> >>
> >>As for the broader question of interop between MS-LDP (which 
> >>seems likely to move forward) and MS-RSVP (which may), can we 
> >>wait on that until after A3?
> >>
> >>Essentially, I don't want stuff gating MS-LDP.
> >>
> >>-Vach 
> >>
> >>
> >>>-----Original Message-----
> >>>From: [email-masked] [mailto:[email-masked]] On
> >>>Behalf Of Danny McPherson
> >>>Sent: Friday, November 18, 2005 2:34 PM
> >>>To: pwe3
> >>>Subject: Re: [PWE3] Inter-op is not necessary
> >>>
> >>>
> >>>
> >>>Eric et al.,
> >>>This is one of the primary reasons why true consensus should
> >>>only be obtained via the mailing list - things are much 
> >>>easier qualified, quantified, and .. [re]verified.
> >>>
> >>>Folks, I suggest we let what we each recollect pass and if
> >>>you've not voiced your preference/opinions on the mailing 
> >>>list please consider this the place which you need to be heard.
> >>>
> >>>Thanks!
> >>>
> >>>-danny
> >>>
> >>>
> >>>On Nov 18, 2005, at 10:28 AM, Gray, Eric wrote:
> >>>
> >>>
> >>>>Stewart,
> >>>>
> >>>>	Your version below is pretty much aligned with mine
> >>>
> >>>except for two
> >>>
> >>>>points:
> >>>>
> >>>>1) "significant difference" is not quantified (or quantifiable);
> >>>>   a good many people raised hands in both of the two latter cases
> >>>>   (more than 20 - possibly more than 30 - in both cases), so a
> >>>>   "significant difference" might be as little as 25% in actual
> >>>>   difference in numbers.  If we're going to treat this as a vote,
> >>>>   then we need to count hands.
> >>>>2) you also asked if any one objected in both of the latter cases
> >>>>   and no one objected in one case (MS-LDP) and a few did in the
> >>>>   other case (MS-RSVP).
> >>>>
> >>>>I am certain that this is what Dimitri is referring to 
> when he said
> >>>>that "a few" was associated with a different question than as is 
> >>>>reported in the minutes.
> >>>>
> >>>>	Also, I do not see how your recollection is different from (or
> >>>>inconsistent with) John's interpretation.  The first 
> >>>
> >>>question (in your
> >>>
> >>>>list of three below) was answered in a way that implies a clear
> >>>>majority wanting to advance both.
> >>>
> >>>_______________________________________________
> >>>pwe3 mailing list
> >>>[email-masked]
> >>>https://www1.ietf.org/mailman/listinfo/pwe3
> >>>
> >>
> >>
> >>_______________________________________________
> >>pwe3 mailing list
> >>[email-masked]
> >>https://www1.ietf.org/mailman/listinfo/pwe3
> >>
> >>
> > 
> > 
> > _______________________________________________
> > pwe3 mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/pwe3
> > 
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
> 

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Ping Pan <[email-masked]>
Date: Tue, 22 Nov 2005 08:50:49 -0800

> [Sasha] This must be resolved, but it does not look difficult to me. 

This is not hard. In fact it may not require protocol changes at all. I 
can send out what we do in a draft.

> [Sasha] A good point that has been missed, IMO, in the MS-PW architecture

Yeap! Thanks!

> [Sasha] A good point too. Input from the SPs would be very important here.

Last time I was trying to figure this out, my little head starts to 
hurt... ;-) If I am to locate failure from one edge, should the 
detection (or loopback...) at provider-level, or node-level. I have a 
feeling that this is beyond the scope of this draft. This is an 
architecture/operation issue that needs to be captured somewhere. No?

Regards,

- Ping