Subject: RE: [PWE3] Inter-op is not necessary

From: "Gray, Eric" <[email-masked]>
Date: Fri, 18 Nov 2005 15:28:48 -0200

Stewart,

	Your version below is pretty much aligned with mine except
for two points: 

1) "significant difference" is not quantified (or quantifiable);
   a good many people raised hands in both of the two latter cases 
   (more than 20 - possibly more than 30 - in both cases), so a 
   "significant difference" might be as little as 25% in actual 
   difference in numbers.  If we're going to treat this as a vote,
   then we need to count hands.
2) you also asked if any one objected in both of the latter cases 
   and no one objected in one case (MS-LDP) and a few did in the
   other case (MS-RSVP).

I am certain that this is what Dimitri is referring to when he 
said that "a few" was associated with a different question than
as is reported in the minutes.

	Also, I do not see how your recollection is different from
(or inconsistent with) John's interpretation.  The first question
(in your list of three below) was answered in a way that implies
a clear majority wanting to advance both.

--
Eric

--> -----Original Message-----
--> From: [email-masked] [mailto:[email-masked]] 
--> On Behalf Of Stewart Bryant
--> Sent: Friday, November 18, 2005 4:33 AM
--> To: Drake, John E
--> Cc: Thomas D. Nadeau; Yaakov Stein; [email-masked]; Mark Townsley
--> Subject: Re: [PWE3] Inter-op is not necessary
--> 
--> Drake, John E wrote:
--> 
--> >Tom,
--> >
--> >I don't think you and Luca should be judging consensus, 
--> but since you are, I would say that the consensus in the 
--> Vancouver meeting seemed to be overwhelmingly in favor of 
--> advancing both.
--> >
--> >Thanks,
--> >
--> >John
--> >  
--> >
--> 
--> John
--> 
--> This is what I saw from the chair:
--> 
--> 1) Do we wish to make a decision on MS-LDP vs MS-RSVP?
-->      - Significant majority for don't make a decision.
--> 
--> 2) Do we wish MS-LDP to become a WG draft?
-->      - Significant majority to it to become a WG draft.
--> 
--> 3) Do we wish MS-RSVP to become a WG draft
-->      - A non-trivial number of hands saying yes, but by
-->        no means as many as in the previous two cases.
--> 
--> It was interesting that there was a significant difference 
--> in numbers between cases 1 and 3, and this was noted by a 
--> number of people after the meeting as surprising.
--> 
--> We did ask the list about case 3 earlier in the year and 
--> there was no consensus in favour of this.
--> 
--> I said earlier I wish to consult with Danny and Mark and 
--> then we will conduct the poll on the list on how to move forward.
--> 
--> - Stewart
--> 
--> 
--> 
--> 
--> 
-->   
--> 
--> _______________________________________________
--> pwe3 mailing list
--> [email-masked]
--> https://www1.ietf.org/mailman/listinfo/pwe3
--> 

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Danny McPherson <[email-masked]>
Date: Fri, 18 Nov 2005 15:34:15 -0700

Eric et al.,
This is one of the primary reasons why true consensus should
only be obtained via the mailing list - things are much easier
qualified, quantified, and .. [re]verified.

Folks, I suggest we let what we each recollect pass and if you've
not voiced your preference/opinions on the mailing list please
consider this the place which you need to be heard.

Thanks!

-danny

---

From: "Vach Kompella" <[email-masked]>
Date: Mon, 21 Nov 2005 11:36:18 -0800

I second Danny's call for re-judging consensus.

So here is my re-vote:

Q1. Are you in favor of moving MS-LDP forward as WG draft?
A1. Favor moving MS-LDP forward as WG draft
   - need to have a section of interop with FEC 128

Q2. Are you against moving MS-LDP forward?
A2. No.

Q3. Are you in favor of moving MS-RSVP forward as WG draft?
A3. Withhold judgment on MS-RSVP until these are visible:
  - provider support
  - app stmt in some rudimentary form
  - interop with FEC 128 (the dominant PW FEC type deployed)

Q4. Are you against moving MS-RSVP forward?
A4. Can't answer since I don't have A3.

Q5. Are you in favor of a single solution?
A5. Need to answer A3.  My preference would be to have a single
solution.  However, without A3, it seems pointless to continue this
argument.  Having implemented FEC 128, I can see how to implement some
form of interop with FEC 129.  Not having implemented any SS-RSVP, I
don't see that as straightforward with MS-RSVP and SS-LDP.  So the
beginnings of that interop description would be helpful.

As for the broader question of interop between MS-LDP (which seems
likely to move forward) and MS-RSVP (which may), can we wait on that
until after A3?

Essentially, I don't want stuff gating MS-LDP.

-Vach 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Danny McPherson
> Sent: Friday, November 18, 2005 2:34 PM
> To: pwe3
> Subject: Re: [PWE3] Inter-op is not necessary
> 
> 
> 
> Eric et al.,
> only be obtained via the mailing list - things are much 
> easier qualified, quantified, and .. [re]verified.
> 
> Folks, I suggest we let what we each recollect pass and if 
> you've not voiced your preference/opinions on the mailing 
> list please consider this the place which you need to be heard.
> 
> Thanks!
> 
> -danny
> 
> 
> > 	Your version below is pretty much aligned with mine 
> except for two 
> > points:
> >
> > I am certain that this is what Dimitri is referring to when he said 
> > that "a few" was associated with a different question than as is 
> > reported in the minutes.
> >
> > 	Also, I do not see how your recollection is different from (or 
> > inconsistent with) John's interpretation.  The first 
> question (in your 
> > list of three below) was answered in a way that implies a clear 
> > majority wanting to advance both.
>

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 21 Nov 2005 16:26:21 -0500

Here is my revote:

Q1. Are you in favor of moving MS-LDP forward as WG draft?
A1. Yes, including interoperability with SS-LDP using FEC 128

Q3. Are you in favor of moving MS-RSVP forward as WG draft?
A3. No, unless there is a demonstrated requirement from the SPs that 
absolutely cannot be satisfied using MS-LDP.

A4. Yes (see A3).

A5. Yes (see A3).

Cheers,
Andy

---

From: Luca Martini <[email-masked]>
Date: Mon, 21 Nov 2005 18:26:13 -0700

First I have to say that I am surprised that anybody would propose two 
similar solutions, and state that it is not necessary to inter operate 
them. The assumption is that no service provider is ever going to use 
one of them, other wise how can anybody deploy and inter-provider 
network ....

on the other topic...
Here is my revote:

Q1. Are you in favor of moving MS-LDP forward as WG draft?
A1. Yes, the WG will need to clearly define what kind of FEC 128 support 
is required.

Q3. Are you in favor of moving MS-RSVP forward as WG draft?
A3. No, unless there is a demonstrated requirement from the SPs that
absolutely cannot be satisfied using extensions to LDP. The MS-RSVP 
draft would also needs a lot
of work. for example how would this solution handle the case where every 
service provider uses private addressing ?
Clearly it is not ready to be a WG draft, perhaps the authors can add 
the  necessary detail to meet the multi segment PW requirements.

A5. Yes

Luca

---

From: Luca Martini <[email-masked]>
Date: Mon, 21 Nov 2005 18:26:33 -0700

First I have to say that I am surprised that anybody would propose two 
similar solutions, and state that it is not necessary to inter operate 
them. The assumption is that no service provider is ever going to use 
one of them, other wise how can anybody deploy an inter-provider network 
....

on the other topic...
Here is my revote:

Luca

---

From: "Vach Kompella" <[email-masked]>
Date: Mon, 21 Nov 2005 20:31:43 -0800

Andy, I didn't mean to ask the questions instead of the chairs.  I was
just amplifying in real electrons what *I* said at the IETF, since there
was some doubt about what the questions and answers were.

To John's point, and for the official tally, the chairs should ask the
questions again on the mailing list.  We sure don't need any more
ratholes.

-Vach 

> Behalf Of Vach Kompella
> Sent: Monday, November 21, 2005 11:36 AM
> To: 'pwe3'
> Subject: RE: [PWE3] Inter-op is not necessary
> 
> 
> A5. Need to answer A3.  My preference would be to have a 
> single solution.  However, without A3, it seems pointless to 
> continue this argument.  Having implemented FEC 128, I can 
> see how to implement some form of interop with FEC 129.  Not 
> having implemented any SS-RSVP, I don't see that as 
> straightforward with MS-RSVP and SS-LDP.  So the beginnings 
> of that interop description would be helpful.
> 
> As for the broader question of interop between MS-LDP (which 
> seems likely to move forward) and MS-RSVP (which may), can we 
> wait on that until after A3?
>