Subject: RE: [PWE3] Change to PWE# atm encapsulation draft - removing strict requirement of ATM SDU mode to use rfc4447

From: "Sasha Vainshtein" <[email-masked]>
Date: Wed, 24 May 2006 10:41:32 +0200

Luca (and all),

If I understand correctly, the text in version 10 seems to ignore the fact that all PWs (including this one)
can be also set up manually.

If this is the problem you try to address, please consider the following:

	"If the protocol defined in [RFC4447] is used to setup a PW that uses this encapsulation,
	the PW Type value of 0x0002 (see [RFC 4447]) MUST be used."

And probably similar statements for the rest of encapsulations defined in the draft?
My 2c.

Regards,
                 Sasha
> -----Original Message-----
> From: Luca Martini [mailto:[email-masked]]
> Sent: Tuesday, May 23, 2006 7:23 PM
> To: pwe3
> Subject: [PWE3] Change to PWE# atm encapsulation draft - 
> removing strict requirement of ATM SDU mode to use rfc4447
> 
> 
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> WG,
> 
> MAtthew, and I noticed the following text i nthe currrent 
> version 10 of
> the atm encapsulation draft:
> 
> 
> "This OPTIONAL encapsulation supports the AAL5 model. This mode allows
> the transport of ATM AAL5 CSPS-SDUs traveling on a particular ATM PVC
> across the network to another ATM PVC. The protocol described in
> [RFC4447] MUST be used to setup a PW of type 0x0002 "ATM AAL5 SDU VCC
> transport" as allocated in [RFC4446]."
> 
> 
> THe text was imported into version 8 from the control draft ( now
> rfc4447 ), because of a comment fro mthe AD at the time  ( Thomas ).
> 
> I do not remember why the "MUST" is in this text. and I would like to
> suggest that we change it to the following:
> 
> This encapsulation mode is used by a  PW of type 0x0002 "ATM AAL5 SDU
> VCC transport" as allocated in [RFC4446].
> 
> Please let me know if there are any ojections.
> 
> Thanks.
> Luca
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.1 (GNU/Linux)
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org
> 
> iD8DBQFEc0TqLusgS1q/2yYRAniLAKC9ByXffkWjMNPEVVXJV94Fyh6N+gCfeikn
> X/M5yq0Rgm3rSqX63vaeqQM=
> =HEKi
> -----END PGP SIGNATURE-----
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
> 
> 

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: [email-masked]
Date: Wed, 24 May 2006 12:28:59 +0100

Sasha,

This statement does not show up for any of the other encapsulations, so we
should probably either remove it entirely, or repeat it (with the correct
code point). However, for some PW types, e.g. N:1 cell mode, the code point
is dependent on the application as well as the encap. For example, ATM cell
VCCs use a different code point from ATM transparent cell transport, but
use the same encap.

My personal preference is to remove the statement entirely.

Matthew

             "Sasha                                                        
             Vainshtein"                                                   
             <[email-masked]                                          To 
             >                         "Luca Martini" <[email-masked]> 
                                                                        cc 
             24/05/2006 09:41          "PWE3 WG \(E-mail\)"                
                                       <[email-masked]>                     
                                                                   Subject 
                                       RE: [PWE3] Change to PWE# atm       
                                       encapsulation draft - removing      
                                       strict     requirement of ATM SDU   
                                       mode to use rfc4447                 

                                                                           

Luca (and all),

If I understand correctly, the text in version 10 seems to ignore the fact
that all PWs (including this one)
can be also set up manually.

             "If the protocol defined in [RFC4447] is used to setup a PW
that uses this encapsulation,
             the PW Type value of 0x0002 (see [RFC 4447]) MUST be used."

And probably similar statements for the rest of encapsulations defined in
the draft?
My 2c.

Regards,
                 Sasha

---

From: Luca Martini <[email-masked]>
Date: Wed, 24 May 2006 10:36:56 -0600

> can be also set up manually.
no.
rfc4447 actually supports "manual" setup of PWs.
The point here is that none of the other drafts mention this, and we do
not want to preclude using other protocols in the future.

Thanks.
Luca