Subject: [PWE3] Suggestion of a new mode for Ethernet PW for 802.1ah

From: Cao Wei <[email-masked]>
Date: Tue, 30 May 2006 20:02:47 +0800

Hi, all
   I am doing some work on ethernet PW to support 802.1ah. At present, two ethernet pw modes are defined: "raw mode" and "vlan mode". But to support 802.1ah, NSP may have to inspect I-TAG rather than the outmost tag only. So I suggust to introduce a new mode for this.
   Is there any need or interest for this? I am writing a draft to describe this and hope to recive advices.

Best Regards,
    Cao Wei
_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Florin Balus" <[email-masked]>
Date: Tue, 30 May 2006 08:21:50 -0400

See in-line... 

-----Original Message-----
From: Cao Wei [mailto:[email-masked]] 
Sent: Tuesday, May 30, 2006 8:03 AM
To: [email-masked]
Subject: [PWE3] Suggestion of a new mode for Ethernet PW for 802.1ah

Hi, all
   I am doing some work on ethernet PW to support 802.1ah. At present,
two ethernet pw modes are defined: "raw mode" and "vlan mode". But to
support 802.1ah, NSP may have to inspect I-TAG rather than the outmost
tag only. So I suggust to introduce a new mode for this.
[FB:] I agree. Same as QinQ/regular Ethernet, this is just another ETH
AC that is out there, implemented and deployed...
 
   Is there any need or interest for this? 
[FB:] Yes I think there is. 

I am writing a draft to describe this and hope to recive advices.
[FB:] I am interested and will help with the draft.
 
Best Regards,
    Cao Wei

---

From: "Yaakov Stein" <[email-masked]>
Date: Wed, 31 May 2006 17:07:34 +0200

Cao, 
 
>From the pure encap point of view, nothing is needed.
 
There is, however, an interesting issue regarding the interaction with
MS-PWs.
 
One could map BVIDs into VPWS PW labels for each domain,
or one could try to to map an ISID using PW-switching.
 
Another issue is when we have a concatenation of PBNs, PBBNs,
and MPLS networks. Some portions will be 1ad, some 1ah,
and some supported by PWs.
 
Y(J)S

________________________________

From: Cao Wei [mailto:[email-masked]] 
Sent: Tuesday, May 30, 2006 14:03
To: [email-masked]
Subject: [PWE3] Suggestion of a new mode for Ethernet PW for 802.1ah

Hi, all
   I am doing some work on ethernet PW to support 802.1ah. At present,
two ethernet pw modes are defined: "raw mode" and "vlan mode". But to
support 802.1ah, NSP may have to inspect I-TAG rather than the outmost
tag only. So I suggust to introduce a new mode for this.
   Is there any need or interest for this? I am writing a draft to
describe this and hope to recive advices.
 
Best Regards,
    Cao Wei