Subject: RE: [PWE3] VCCV BFD mode

From: "Busschbach, Peter B (Peter)" <[email-masked]>
Date: Fri, 26 May 2006 10:09:29 -0400

> > BFD message are not addressed to the target node, but have 
> a non-routable address. 
>  >
> 
> Where is this specified?

See draft-ietf-bfd-mpls-02, section 7.

Actually, the text is somewhat ambiguous. It states that the ingress LER uses an adress from 127/8, whereas the egress LER copies the source IP address of the received packet and uses that as destination address in the reply.

My interpretation is that the actual address is only used in the echo mode by the egress LER and that in the case of assynchronous mode both LERs use addresses from 127/8.

> Thanks
> Stewart

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Stewart Bryant <[email-masked]>
Date: Fri, 26 May 2006 15:40:15 +0100

> My interpretation is that the actual address is only used in the echo mode by the egress LER and that in the case of assynchronous mode both LERs use addresses from 127/8.

    "The BFD control packet sent by the ingress LSR MUST be a UDP packet
    with a well known destination port TBD and a source port assigned by
    the sender. The source IP address is a routable address of the
    sender. The destination IP address is a (randomly chosen) address
    from 127/8. The IP TTL is set to 1."

So how does this work between two non-adjacent MPLS nodes
(for example to test a FRR node repair target)?

What about when you are running between two non-adjacent
nodes (again perhaps for IPFRR) and you only have
partial MPLS connectivity?

Don't you need to be able to set TTL > 1, and use routable
source and destination addresses?

- Stewart