Subject: [PWE3] Question about FEC 128 vs 129

From: "Yaakov Stein" <[email-masked]>
Date: Fri, 14 Jul 2006 04:58:26 +0200

How does a PE decide to use 128 vs 129?
If it receives a label using one method, it will obviously
send its own label in the same way,
but how does the initiatior decide which to use?
 
Does anyone here give the user a choice via some CLI command or menu? 
If not, what is the criterion ?
 
>From my point of view, 129 is for VPLS or situations
where there is, or may be, an autodiscovery mechanism.
But there is nothing to rule out using 129 e.g. for a point-to-point ATM
PW.
 
Do we need to standardize how a PE tells another
which FEC type is supports?
 
Y(J)S
 
_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: [email-masked]
Date: Fri, 14 Jul 2006 10:20:21 +0800

My opinion:
We can set a priority to the 128 and 129 TLV through [PW-CTRL-DRAFT], or 
only CLI command.
Take the LDP based PW for example. And 129 TLV get higher priority.
One PE that supports both 128 and 129 TLV, it will send 129 TLV.
If the received PE does not support 129 TLV, it will send LDP notification 
message with status code 0x0000000C which indicats
unknown FEC. When the initiated PE received the LDP notification message, 
it will switch to send 128 TLV.

"Yaakov Stein" <[email-masked]>

2006-07-14 10:58
 
        收件人：        <[email-masked]>
        抄送： 
        主题：  [PWE3] Question about FEC 128 vs 129

 
 
PW.

>Y(J)S

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is 
solely property of the sender's organization. This mail communication is 
confidential. Recipients named above are obligated to maintain secrecy and 
are not permitted to disclose the contents of this communication to 
others.
This email and any files transmitted with it are confidential and intended 
solely for the use of the individual or entity to whom they are addressed. 
If you have received this email in error please notify the originator of 
the message. Any views expressed in this message are those of the 
individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam 
system.
_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.
_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Sasha Vainshtein" <[email-masked]>
Date: Fri, 14 Jul 2006 13:41:33 +0200

Yaakov,
IMO you can find a generic answer in Section 3.1.1 of http://www.ietf.org/internet-drafts/draft-ietf-l2vpn-signaling-08.txt 
that discusses dual-sided vs. single-sided provisioning provisioning modes and applicability of FEC 128/129 to these modes.
Further, this draft also describes the difference between provisioning models of individual PWs and those of VPLS.
(Of course this draft does not refer to any specific CLI commands.)
 
Regards,
                   Sasha

________________________________

From: Yaakov Stein [mailto:[email-masked]]
Sent: Fri 7/14/2006 5:58 AM
To: [email-masked]
Subject: [PWE3] Question about FEC 128 vs 129

 
 
where there is, or may be, an autodiscovery mechanism.
But there is nothing to rule out using 129 e.g. for a point-to-point ATM PW.

Y(J)S

---

From: "Yaakov Stein" <[email-masked]>
Date: Sun, 16 Jul 2006 12:43:34 +0200

Sasha, 
 
I do not see anything relevant to my question in Section 1.1.1
or any other section of draft-ietf-l2vpn.
I am not asking when it is best to use which FEC
(I think that is well known to everyone on the list)
I am asking about the influence of having 2 FECs available,
and no statement that either MUST be supported,
and no way of negotiating which IS supported.
 
Let us assume that PE1 wants to set up an ATM PW
with PE2 with which it has an active LDP session.
 
For this purpose it sends a mapping message with FEC 128.
 
Unfortunately, no-one ever said that PWE-capable PEs
have to support BOTH FEC 128 and 129, and PE2
only supports FEC129. 
So PE2 sends an error notification back to PE1,
and the session is terminated.
 
But maybe PE1 supports 129 too. 
Had it used 129 the PW would have been set up.
How does it know which to use?
 
Of course in the case mentioned above
a meta layer application could try again with the other FEC, 
but the error was not necessarily due to the FEC problem,
and in any case it is messy to carry this kind of
information from LDP session to another session.
 
Y(J)S

From: Sasha Vainshtein [mailto:[email-masked]] 
Sent: Friday, July 14, 2006 13:42
To: Yaakov Stein; [email-masked]
Subject: RE: [PWE3] Question about FEC 128 vs 129

Yaakov,
IMO you can find a generic answer in Section 3.1.1 of
http://www.ietf.org/internet-drafts/draft-ietf-l2vpn-signaling-08.txt 
that discusses dual-sided vs. single-sided provisioning provisioning
modes and applicability of FEC 128/129 to these modes.
Further, this draft also describes the difference between provisioning
models of individual PWs and those of VPLS.
(Of course this draft does not refer to any specific CLI commands.)
 
Regards,
                   Sasha

 

 
 
Y(J)S

---

From: "Andrew G. Malis" <[email-masked]>
Date: Sun, 16 Jul 2006 07:40:17 -0400

Yaakov,

In typical deployments, this is currently either provisioned manually 
via a CLI or via a "point and click" or similar NMS system.  Either 
the operators or the NMS (or both) are aware of which FEC is 
supported by a particular router, and do the provisioning accordingly 
(and make sure that it's consistent on both sides of each pseudowire).

For the future, it sounds like this is a good application for the LDP 
capabilities drafts discussed during the MPLS WG session.

Cheers,
Andy

------------

At 7/16/2006 12:43 +0200, Yaakov Stein wrote:
>Content-class: urn:content-classes:message
>Content-Type: multipart/alternative;
>         boundary="----_=_NextPart_001_01C6A8C4.ACEFDCB6"
>
>Sasha,
>
>----------
><http://www.ietf.org/internet-drafts/draft-ietf-l2vpn-signaling-08.txt>http://www.ietf.org/internet-drafts/draft-ietf-l2vpn-signaling-08.txt 
>
>Further, this draft also describes the difference between 
>provisioning models of individual PWs and those of VPLS.
>----------

---

From: "Yaakov Stein" <[email-masked]>
Date: Sun, 16 Jul 2006 16:13:05 +0200

In typical deployments, this is currently either provisioned manually
via a CLI or via a "point and click" or similar NMS system.  Either the
operators or the NMS (or both) are aware of which FEC is supported by a
particular router, and do the provisioning accordingly (and make sure
that it's consistent on both sides of each pseudowire).

>From what I have seen, there is essentially no choice at present.
For example, PEs opening ATM PWs support 128, VPLS PEs support 129.
 
However. going forward we need a better mechanism.

Agreed.
 
Y(J)S

From: Andrew G. Malis [mailto:[email-masked]] 
Sent: Sunday, July 16, 2006 13:40
To: Yaakov Stein
Cc: Sasha Vainshtein; [email-masked]
Subject: RE: [PWE3] Question about FEC 128 vs 129

Yaakov,

In typical deployments, this is currently either provisioned manually
via a CLI or via a "point and click" or similar NMS system.  Either the
operators or the NMS (or both) are aware of which FEC is supported by a
particular router, and do the provisioning accordingly (and make sure
that it's consistent on both sides of each pseudowire).

Cheers,
Andy

------------

	
	Sasha, 

	 

	 
	 
	Y(J)S

	From: Sasha Vainshtein [ mailto:[email-masked]
<mailto:[email-masked]> ] 
	Sent: Friday, July 14, 2006 13:42
	To: Yaakov Stein; [email-masked]
	Subject: RE: [PWE3] Question about FEC 128 vs 129
	
	Yaakov,
	IMO you can find a generic answer in Section 3.1.1 of
http://www.ietf.org/internet-drafts/draft-ietf-l2vpn-signaling-08.txt 
	that discusses dual-sided vs. single-sided provisioning
provisioning modes and applicability of FEC 128/129 to these modes.
	Further, this draft also describes the difference between
provisioning models of individual PWs and those of VPLS.
	(Of course this draft does not refer to any specific CLI
commands.)
	 
	Regards,
	                   Sasha

	From: Yaakov Stein [ mailto:[email-masked]
<mailto:[email-masked]> ]
	Sent: Fri 7/14/2006 5:58 AM
	To: [email-masked]
	Subject: [PWE3] Question about FEC 128 vs 129

	Does anyone here give the user a choice via some CLI command or
menu? 
	If not, what is the criterion ?
	 
	From my point of view, 129 is for VPLS or situations
	where there is, or may be, an autodiscovery mechanism.
	But there is nothing to rule out using 129 e.g. for a
point-to-point ATM PW.

	Y(J)S