Subject: RE: [PWE3] Should we carry this principle over to ATM PWs, etc.?

From: "O'Connor, Don" <[email-masked]>
Date: Tue, 11 Jul 2006 18:27:31 -0500

Vach

For Ethernet VPWS / VPLS, should a service provider support

1) Both Y.1731 / IEEE 802.1ag Ethernet Service OAM (which measures Ethernet Service Frame Loss Ratio, Delay and Delay Variation) and VCCV / BFD (which provides less service relevant OAM information) 

or

2) Just VCCV / BFD and no Ethernet Service OAM

or

3) Use one OAM flow which is VCCV / Y.1731 which provides full service visibility and (compared to option 1) eliminates one EE OAM flow for VPWS and multiple OAM flows for VPLS

I vote for Option 3 which can be used for a MPLS PSN

Don

-----Original Message-----
From: Vach Kompella [mailto:[email-masked]]
Sent: Tuesday, July 11, 2006 5:42 PM
To: 'David Allan'; 'pwe3'
Subject: RE: [PWE3] Should we carry this principle over to ATM PWs,
etc.?

Essentially, we develop layers of abstraction with PWE3oMPLS only to
resort to the underlying L2.  So what if the underlying L2 isn't
ethernet?  Do we use the fallback VCCV?  In other words, we have to
implement two OAMs for each L2?

-Vach 

> -----Original Message-----
> From: David Allan [mailto:[email-masked]] 
> Sent: Tuesday, July 11, 2006 3:33 PM
> To: Vach Kompella; pwe3
> Subject: RE: [PWE3] Should we carry this principle over to 
> ATM PWs, etc.?
> 
> 
> Hi Vach
> 
> If PWs were carried by the L2 they were also emulating it may 
> not be a bad idea...gets you to the option of one system. 
> Rather than simply imposing a competely new system simply to 
> instrument an adaptation layer.
> 
> I think the essence of Dinesh's proposal is to converge on 
> the high runner, rather than mandating the imposition of a 
> third system....
> 
> Works for me...
> Dave
> 
> 
> 
> -----Original Message-----
> From: Vach Kompella [mailto:[email-masked]] 
> Sent: Tuesday, July 11, 2006 6:13 PM
> To: 'pwe3'
> Subject: [PWE3] Should we carry this principle over to ATM PWs, etc.?
> 
> Would we stop the VCCV work and put the L2 OAM flows of each 
> PW type and just stick a control word and label stack on 
> them?  I'm sure we can find ITU specs for each L2 we're 
> trying to emulate.
> 
> -Vach
> 
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
> 

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Yang Yang" <[email-masked]>
Date: Wed, 12 Jul 2006 07:53:02 +0800

Don,
   I fully agree that only VCCV/Y.1731 is used in Ethernet VPWS/VPLS. It's
more efficient.

   Since there are several OAM mechanisms such as BFD, LSP Ping,
Y.1711defined by ITU-T and
Y.1731 defined by ITU-T, it is suggested that VCCV could be more flexible.

    Best Regards!
       Yang

On 7/12/06, O'Connor, Don <[email-masked]> wrote:
> 1) Both Y.1731 / IEEE 802.1ag Ethernet Service OAM (which measures
> Ethernet Service Frame Loss Ratio, Delay and Delay Variation) and VCCV / BFD
> (which provides less service relevant OAM information)
>
> or
>
> 3) Use one OAM flow which is VCCV / Y.1731 which provides full service
> visibility and (compared to option 1) eliminates one EE OAM flow for VPWS
> and multiple OAM flows for VPLS
>