Subject: RE: [PWE3] Inband/out-of-band TDM OAM format for MPLS PSNs

From: "Yaakov Stein" <[email-masked]>
Date: Thu, 1 Feb 2007 09:16:17 +0200

Sorry for the delay in processing.
 
I have not suggested a special-purpose replacement for the TDMoIP OAM
message format,
as I believe that the performance measurement PDUs of Y.1731 fill the
gap.
 
So, if PWE accepts the use of Y.1731 PDUs as VCCV payloads,
we will automatically get everything needed.
 
(This means we will need another PWACH type)
 
However, if we do not get agreement on this issue
I will rebake the old protocol based on ICMP,
add everything needed, and issue an ID.
I hope I won't have to do this.
 
Y(J)S

________________________________

From: Ramalingam, Swaminathan (Swaminathan)
[mailto:[email-masked]] 
Sent: Thursday, January 25, 2007 08:58
To: Yaakov Stein; Ahluwalia, Ajit (Ajit); [email-masked]
Subject: RE: [PWE3] Inband/out-of-band TDM OAM format for MPLS PSNs

Y(J)S,

Is that mean VCCV need to signal one of the BFD CV type if an
implementation wants to send TDM OAM inband?. In that case, what is the
payload format (for TDM OAM)? 

Thanks,

Swami

________________________________

From: Yaakov Stein [mailto:[email-masked]] 
Sent: Thursday, January 04, 2007 10:42 PM
To: Ahluwalia, Ajit (Ajit); [email-masked]
Subject: RE: [PWE3] Inband/out-of-band TDM OAM format for MPLS PSNs

Ajit

The inband format relies on VCCV, which is the reason the CW is the
PWACH one

rather than the user traffic CW. VCCV based on BFD could be used for
most of the

functionality, but indeed it would be better to have a full-functioned
OAM here

(for example, a Y.1731 format one).

The out-of-band OAM format is presently limited to the UDP/IP case.

There is no intent to extend it to the MPLS case, unless extending

the VCCV-based approach proves impossible. Incidentally, I admit

that there are advantages to the out-of-band approach for MPLS

where there may be many PWs in a single MPLS tunnel - 

but that is not the direction the WG wanted us to go.

Y(J)S

________________________________

From: Ahluwalia, Ajit (Ajit) [mailto:[email-masked]]
Sent: Thu 04/01/2007 14:38
To: [email-masked]
Subject: [PWE3] Inband/out-of-band TDM OAM format for MPLS PSNs

Hi,
1. Could anyone describe the format of inband TDM OAM format for MPLS
PSNs, section D.2 of draft-ietf-pwe3-tdmoip-06 just mentions first
nibble being 0001.
2. draft-ietf-pwe3-tdmoip-06.txt talks about out-of-band OAM format
where forward/reverse PW labels are 16 bit each, appropriate for UDP/IP
PSNs but how would this work for MPLS PSNs where more bits are required.

Thanks
Ajit

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 1 Feb 2007 11:17:27 -0500

On Feb 1, 2007, at 2:16 AM, Yaakov Stein wrote:

> I have not suggested a special-purpose replacement for the TDMoIP  
> OAM message format,
> as I believe that the performance measurement PDUs of Y.1731 fill  
> the gap.
>

	I am reluctant to do this, as I was when it was originally proposed.

	--Tom

> From: Ramalingam, Swaminathan (Swaminathan) [mailto:swamir@alcatel- 
> lucent.com]
> implementation wants to send TDM OAM inband?. In that case, what is  
> the payload format (for TDM OAM)?
>
>
>
>
>
> Thanks,
>
> Swami
>
>
>
> rather than the user traffic CW. VCCV based on BFD could be used  
> for most of the
>
> functionality, but indeed it would be better to have a full- 
> functioned OAM here
>

---

From: "Yaakov Stein" <[email-masked]>
Date: Thu, 1 Feb 2007 19:53:13 +0200

So, if PWE accepts the use of Y.1731 PDUs as VCCV payloads,   we will
automatically get everything needed.

--Tom

[YJS] So what do you suggest ? 
_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Ramalingam, Swaminathan \(Swaminathan\)" <[email-masked]>
Date: Thu, 15 Feb 2007 17:37:34 +0530

Tom,

Do you have some other idea?

As Yaakov specified, how about going ICMP way?

Thanks,

Swami

From: Yaakov Stein [mailto:[email-masked]] 
Sent: Thursday, February 01, 2007 11:23 PM
To: Thomas D. Nadeau
Cc: Ramalingam, Swaminathan (Swaminathan); Ahluwalia, Ajit (Ajit);
[email-masked]
Subject: RE: [PWE3] Inband/out-of-band TDM OAM format for MPLS PSNs

--Tom