Subject: [PWE3] draft-ietf-mpls-icmp-08.txt

From: Stewart Bryant <[email-masked]>
Date: Mon, 05 Feb 2007 11:50:13 +0000

This draft explains what to do if you have
IP over MPLS, but not what to do if you
are carrying something other than IP - for
example a pseudowire.

It occurs to me that in some cases it would
be useful to resolve the MPLS destination
label to the destination IP address, and
send the diagnostic packet forward.

Clearly that does not work if you have
an unknown label or an unknown next hop,
but there may be other circumstances where it
is useful.

- Stewart

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Ron Bonica <[email-masked]>
Date: Wed, 07 Feb 2007 15:36:50 -0500

Hi Stewart,

As currently defined, the ICMP message is a response to the unroutable
IP datagram. In an application like pseudowires, you wouldn't send an
ICMP packet.

However, now that ICMP messages are extensible, people might find new
applications form them. But let's say that this is beyond the scope of
this draft and fair game for future drafts.

                                     Ron

Stewart Bryant wrote:
> mpls mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mpls
>