Subject: [PWE3] WG LC:draft-ietf-pwe3-pw-tc-mib-10.txt

From: Danny McPherson <[email-masked]>
Date: Tue, 5 Jun 2007 06:35:10 -0600

Folks,
Please consider today the start of a two week WG LC for
this document.  The call for comments from the WG will end
on 6/19.  Please provide feedback to the mailing list or
authors ASAP.

Thanks!

-danny

Begin forwarded message:

> From: [email-masked]
> Date: February 8, 2007 4:50:02 PM MST
> To: [email-masked]
> Cc: [email-masked]
> Subject: [PWE3] I-D ACTION:draft-ietf-pwe3-pw-tc-mib-10.txt
>
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> This draft is a work item of the Pseudowire Emulation Edge to Edge  
> Working Group of the IETF.
>
> 	Title		: Definitions for Textual Conventions and for Managing  
> Pseudo-Wires over PSN
> 	Author(s)	: T. Nadeau, et al.
> 	Filename	: draft-ietf-pwe3-pw-tc-mib-10.txt
> 	Pages		: 11
> 	Date		: 2007-2-8
> 	
> This memo defines a Management Information Base (MIB) module which
>    contains Textual Conventions (TCs) to represent commonly-used  
> Pseudo
>    Wire (PW) management information.  The intent is that these TCs  
> will
>    be imported and used in PW-related MIB modules that would otherwise
>    define their own representations.
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-pwe3-pw-tc-mib-10.txt
>
> To remove yourself from the I-D Announcement list, send a message to
> [email-masked] with the word unsubscribe in the body of
> the message.
> You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
> to change your subscription settings.
>
> Internet-Drafts are also available by anonymous FTP. Login with the
> username "anonymous" and a password of your e-mail address. After
> logging in, type "cd internet-drafts" and then
> "get draft-ietf-pwe3-pw-tc-mib-10.txt".
>
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
> Internet-Drafts can also be obtained by e-mail.
>
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE /internet-drafts/draft-ietf-pwe3-pw-tc-mib-10.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
>
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> Content-Type: text/plain
> Content-ID: <[email-masked]>
>
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Danny McPherson <[email-masked]>
Date: Tue, 5 Jun 2007 06:51:19 -0600

> Danny McPherson wrote:

Oops, folks, I forwarded the wrong I-D announcement, it should
have been the -11 revision, available here:

http://tools.ietf.org/id/draft-ietf-pwe3-pw-tc-mib-11.txt

-danny

>>> This draft is a work item of the Pseudowire Emulation Edge to  
>>> Edge Working Group of the IETF.
>>>
>>>     Title        : Definitions for Textual Conventions and for  
>>> Managing Pseudo-Wires over PSN
>>>    Wire (PW) management information.  The intent is that these  
>>> TCs will

---

From: Stewart Bryant <[email-masked]>
Date: Tue, 05 Jun 2007 14:18:52 +0100

A few comments:

The current version is -11

======

There are instances of the term "pseudo wire" and "pseudo-wire" when we 
agreed a little while ago to use the term pseudowire.

======

DESCRIPTION
           "Pseudo-Wire Identifier. Used to identify the PW
            (together with some other fields) in the signaling
            session."
      SYNTAX  Unsigned32

Shouldn't this be a 1..2^32-1 (control spec says non-zero)

========

I am suprised that the PwOperStatusTC ::= TEXTUAL-CONVENTION states
do not have a one to one mapping with Pseudo Wire Status Codes Registry 
at least to the point of having the registry name in the text.

- Stewart

Danny McPherson wrote:
>>    contains Textual Conventions (TCs) to represent commonly-used Pseudo
>>    Wire (PW) management information.  The intent is that these TCs will

---

From: "David Zelig" <[email-masked]>
Date: Wed, 6 Jun 2007 12:18:34 +0300

Stewart,
Please see inline 

-----Original Message-----
From: Stewart Bryant [mailto:[email-masked]] 
Sent: Tuesday, June 05, 2007 4:19 PM
To: Danny McPherson
Cc: pwe3 WG ((((((((E-mail))))))))
Subject: Re: [PWE3] WG LC:draft-ietf-pwe3-pw-tc-mib-10.txt

A few comments:

======

[DZ] OK, will fix.

======

DESCRIPTION

[DZ} We allow the value of zero in PW-STD-MIB module to allow manual
configuration or when the generalized FEC is used - The PW ID is not
applicable.
========

I am suprised that the PwOperStatusTC ::= TEXTUAL-CONVENTION states do
not have a one to one mapping with Pseudo Wire Status Codes Registry at
least to the point of having the registry name in the text.

[DZ] This OperStatus is based on standard SNMP OperStatus, PwStatus ::=
TEXTUAL-CONVENTION is the one that intends to match the Pseudo Wire
Status Codes Registry - I see that the object names can be phrased
better to match RFC 4446.

David

- Stewart

Pseudo
will
>> You can also visit
https://www1.ietf.org/mailman/listinfo/I-D-announce

---

From: "Orly Nicklass" <[email-masked]>
Date: Sat, 9 Jun 2007 11:11:11 +0300

PwOperStatusTC is aligned with ifOperStatus---- operational state of an
interface

  _____  

From: Stewart Bryant [mailto:[email-masked]] 
Sent: Tuesday, June 05, 2007 16:19
To: Danny McPherson
Cc: pwe3 WG ((((((((E-mail))))))))
Subject: Re: [PWE3] WG LC:draft-ietf-pwe3-pw-tc-mib-10.txt

A few comments:

======

======

DESCRIPTION

========

I am suprised that the PwOperStatusTC ::= TEXTUAL-CONVENTION states do not
have a one to one mapping with Pseudo Wire Status Codes Registry at least to
the point of having the registry name in the text.

- Stewart