Subject: RE: [PWE3] question on the "independent mode" of draft-muley-dutta

From: "MULEY Praveen" <[email-masked]>
Date: Tue, 1 Jan 2008 21:27:41 -0600

Hello Yaakov :
        Please see section 5.3.1 
 
     d. If while waiting for the acknowledgment, the requesting endpoint
      receives a request from its peer to switchover to the same or a
      different PW path, it must perform the following:

            i. If its system IP address is higher than that of the peer,
               this endpoint ignores the request and continues to wait
               for the acknowledgement from its peer.

           ii. If its system IP address is lower than that of its peer,
               it aborts the timer and immediately starts the
               procedures of the receiving endpoint in Section 5.3.2
<http://tools.ietf.org/html/draft-muley-dutta-pwe3-redundancy-bit-02#sec
tion-5.3.2> .

I am not suer whether there will infinite flapping. Hope this helps.
 
Thanks,
Praveen

________________________________

From: Yaakov Stein [mailto:[email-masked]] 
Sent: Thursday, December 27, 2007 3:39 AM
To: [email-masked]
Cc: Keren Zik-Meirom
Subject: [PWE3] question on the "independent mode" of draft-muley-dutta

Hi all (and especially co-authors of draft-muley-dutta)
 
Section 4.1. (Independent Mode) In
draft-muley-dutta-pwe3-redundancy-bit-02
<http://smakd.potaroo.net/ietf/idref/draft-muley-dutta-pwe3-redundancy-b
it/rfcmarkup?repository=/away/ietf&url=/away/ietf/all-ids/draft-muley-du
tta-pwe3-redundancy-bit-02.txt>  says:
 
   PW endpoint nodes independently select which PW they intend to make 
   active and which PWs they intend to make standby. They advertise the 
   corresponding Active/Standby forwarding state for each PW. Each PW 
   endpoint compares local and remote status and uses the PW that is 
   operationally UP at both endpoints and that shows Active states at 
   both the local and remote endpoint.
 
After which there is a discussion about what happens if an active PW is
not found.
 
I have a question about what happens when there are two perfectly good
PWs.
 
What happens if initially the two endpoints choose different PWs as the
active ones ?

I am assuming that an endpoint, seeing that the other declares the PW it
intended as backup
to be the active one, then chooses to switch and sends an active
indication on the other PW.
Meanwhile the other endpoint does the same, causing infinite flapping.
 
Did I misunderstand something ?
 
Y(J)S
_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "MULEY Praveen" <[email-masked]>
Date: Tue, 1 Jan 2008 21:58:04 -0600

For misconfig, we haven't adddressed currently. But if there is
situation due to failures then the section 5.3.1 handles it.
 
Thanks,
Praveen

From: Yaakov Stein [mailto:[email-masked]] 
Sent: Sunday, December 30, 2007 3:25 AM
To: Alexander Vainshtein
Cc: Keren Zik-Meirom; [email-masked]
Subject: RE: [PWE3] question on the "independent mode" of
draft-muley-dutta

Sasha
 
Yes, I agree that yours is another possible interpretation.
 
However, I'm not sure that the behavior is much better.
 
\personal ON
 Glad to see that you are still monitoring PWE at your new email
address.
\personal OFF
 
Y(J)S

From: Alexander Vainshtein [mailto:[email-masked]] 
Sent: Thursday, December 27, 2007 1:52 PM
To: Yaakov Stein
Cc: Keren Zik-Meirom; [email-masked]
Subject: RE: [PWE3] question on the "independent mode" of
draft-muley-dutta

Yaakov and all,
The cited section defines two PW states:
<quote>

	   o Active State

	   A PW is considered to be in Active state when the PW labels
are 
	   exchanged between its two endpoints in control plane, and the
status 
	   bits exchanged between the endpoints indicate the PW is UP
and Active 
	   at both endpoints. In this state user traffic can flow over
the PW in 
	   both directions. 
	
	   o Standby State 
	
	   A PW is considered to be in Standby state when the PW labels
are 
	   exchanged between its two endpoints in the control plane, but
the 
	   status bits exchanged indicate the PW is in Standby state at
one or 
	   both endpoints. In this state the endpoints MUST NOT forward
data 
	   traffic over the PW but MAY allow PW OAM packets, e.g., VCCV,
to be 
	   sent and received in order to test the liveliness of standby
PWs

<end quote>
My conclusion from these definitions is that, in the scenario described
in Yaakov's message, both PWs shall be in the Standby state (without any
flapping) because each one shall be declared as Standby by one of the
EPs. As a consequence, no traffic will be forwarded to any of the two
PWs. 
 
Did I miss something?
 
Regards,
               Sasha

From: Yaakov Stein [mailto:[email-masked]] 
Sent: Thursday, December 27, 2007 1:39 PM
To: [email-masked]
Cc: Keren Zik-Meirom
Subject: [PWE3] question on the "independent mode" of draft-muley-dutta

 

 

 
Y(J)S