Subject: [PWE3] few clarifications on pwe3-dynamic-ms-pw

From: "roman krzanwski" <[email-masked]>
Date: Sat, 5 Jan 2008 10:29:16 -0500

I am suggesting few clarifications in draft-ietf-pwe3-dynamic-ms-pw...

Section 5.. Applicability.
Should mention in the draft that FEC 128 is left out for further study. Most
of the current implementations are FEC 128 - based
so this whole segment of the technology will be left out  with this draft ?
The draft should explicitly address the whole PW technology.- in my view;
even by saying - it is left out for another study.

Section 6.2 S-PE addressing

There is a sentence "... at least one AI address of the format similar to
AII type 2..."

The word "similar" is not clear enough. Is it to be of the same format ? or
similar format or it is explicated somewhere in the document ( where ?)

Section 7. Dynamic placement ...

Just a clarification of the sentence structure..

Is:

The procedures in the following sections describe  an method to extend
[PW-SEG <http://www3.tools.ietf.org/html/draft-ietf-pwe3-dynamic-ms-pw-06#ref-PW-SEG>]
by allowing the automatic selection of
   pre-defined S-PEs, and automatically setting up a MS-PW between two    T-PEs.

 suggested:

The procedures in the following sections describe  >>an<< method to
extend [PW-SEG <http://www3.tools.ietf.org/html/draft-ietf-pwe3-dynamic-ms-pw-06#ref-PW-SEG>]
by allowing the automatic selection of
   pre-defined S-PEs, and the automatic setup of  a MS-PW between two   T-PEs.

as well

should  be >>> a method..not >> an method...

and  a small point:

I prefer >> automated selection <<< rather than >>automatic<<< selection...
but this is my personal thing...

Section 7.1

In the second para there is a term "AII PW routing table "

as this is a new term the draft should provide the forward reference to it
something like :

AII PW routing table ( see section 7.1.1 for the definition of the PW
routing table)

or similar

Section 8.1

the text is :

If the   PSN is unable to re-establish the PSN tunnel, then the S-PE SHOULD
   follow the procedures defined in Section 8
<http://www3.tools.ietf.org/html/draft-ietf-pwe3-dynamic-ms-pw-06#section-8>
of [PW-SEG <http://www3.tools.ietf.org/html/draft-ietf-pwe3-dynamic-ms-pw-06#ref-PW-SEG>].

Section 8 of PW-SEG is

PW-MPLS to PW-L2TPv3 Control Plane Switching

Is this an intention of this draft ? I guess this should be section 9

Section 9 OAM

I guess this draft should be a better job on this- I am looking into this
now...and send comments if any...

As well, the second sentence in this para ( after >>) is kind of left
without much clarification  or link with the first one
- at least in my view or I do not see something -  I guess this is a part of
some (unfinished) thought..?.

The OAM procedures defined in [PW-SEG
<http://www3.tools.ietf.org/html/draft-ietf-pwe3-dynamic-ms-pw-06#ref-PW-SEG>]
may be used also for MS-PWs.>>>>> A
   PW switching point TLV is used [PW-SEG
<http://www3.tools.ietf.org/html/draft-ietf-pwe3-dynamic-ms-pw-06#ref-PW-SEG>]
to record the switching
   points that the PW traverses.

As well:

Is the intention of this draft to address only Inter-AS MS-PWs?

thx
roman k
_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "BALUS Florin" <[email-masked]>
Date: Tue, 8 Jan 2008 13:10:02 -0600

Roman,
Thanks for your detailed review, comments.
See in-line...

________________________________

	From: roman krzanwski [mailto:[email-masked]] 
	Sent: Saturday, January 05, 2008 7:29 AM
	To: [email-masked]
	Cc: BALUS Florin; [email-masked]
	Subject: few clarifications on pwe3-dynamic-ms-pw

	I am suggesting few clarifications in
draft-ietf-pwe3-dynamic-ms-pw...
	
	Section 5.. Applicability.
	Should mention in the draft that FEC 128 is left out for further
study. Most of the current implementations are FEC 128 - based 
	so this whole segment of the technology will be left out  with
this draft ? The draft should explicitly address the whole PW
technology.- in my view; even by saying - it is left out for another
study.
	[[FB]] Interoperability with FEC 128 for MS-PWs is addressed in
the Segmented PW draft - see
http://www.ietf.org/internet-drafts/draft-ietf-pwe3-segmented-pw-06.txt
. We had initially here some discussion on FEC 128 but it was decided
some time ago in the PWE3 working group to keep in the PW routing just
FEC 129, in-line also with the procedure used for BGP-AD for VPLS.

	There is a sentence "... at least one AI address of the format
similar to AII type 2..."
	
	The word "similar" is not clear enough. Is it to be of the same
format ? or similar format or it is explicated somewhere in the document
( where ?) 
	[[FB]] You are right and actually we should have also used AII
instead of AI. What about in the next iteration of the draft the text
you mentioned above to: "... at least one AII address of the AII Type 2
format..."

	
	Is:
	
	The procedures in the following sections describe  an method to
extend [PW-SEG
<http://www3.tools.ietf.org/html/draft-ietf-pwe3-dynamic-ms-pw-06#ref-PW
-SEG> ] by allowing the automatic selection of
	   pre-defined S-PEs, and automatically setting up a MS-PW
between two    T-PEs.

	  suggested:
	
	The procedures in the following sections describe  >>an<< method
to extend [PW-SEG
<http://www3.tools.ietf.org/html/draft-ietf-pwe3-dynamic-ms-pw-06#ref-PW
-SEG> ] by allowing the automatic selection of
	   pre-defined S-PEs, and the automatic setup of  a MS-PW
between two  T-PEs.
	as well
	
	[[FB]] Ok. 
	
	and  a small point:

	I prefer >> automated selection <<< rather than >>automatic<<<
selection... but this is my personal thing... 
	
	[[FB]] Either way sounds right for me. We will talk about this
one for the next iteration.  
	
	Section 7.1 

	as this is a new term the draft should provide the forward
reference to it something like :
	
	AII PW routing table ( see section 7.1.1 for the definition of
the PW routing table) 
	
	or similar
	
	[[FB]] Ok 

	Section 8.1
	
	the text is :
	
	If the   PSN is unable to re-establish the PSN tunnel, then the
S-PE SHOULD follow the procedures defined in Section 8
<http://www3.tools.ietf.org/html/draft-ietf-pwe3-dynamic-ms-pw-06#sectio
n-8>  of [PW-SEG
<http://www3.tools.ietf.org/html/draft-ietf-pwe3-dynamic-ms-pw-06#ref-PW
-SEG> ].

	Section 8 of PW-SEG is 

	Is this an intention of this draft ? I guess this should be
section 9
	
	[[FB]] Yes you are right section 9 should replace section 8, we
forgot to update this reference. Will do it for the next iteration.
	 
	Section 9 OAM 
	
	I guess this draft should be a better job on this- I am looking
into this now...and send comments if any...
	
	As well, the second sentence in this para ( after >>) is kind of
left without much clarification  or link with the first one 
	- at least in my view or I do not see something -  I guess this
is a part of some (unfinished) thought..?.
	
	The OAM procedures defined in [PW-SEG
<http://www3.tools.ietf.org/html/draft-ietf-pwe3-dynamic-ms-pw-06#ref-PW
-SEG> ] may be used also for MS-PWs.>>>>> A PW switching point TLV is
used [PW-SEG
<http://www3.tools.ietf.org/html/draft-ietf-pwe3-dynamic-ms-pw-06#ref-PW
-SEG> ] to record the switching points that the PW traverses.
	[[FB]]  The procedures described in
http://www.ietf.org/internet-drafts/draft-ietf-pwe3-segmented-pw-06.txt
apply here, we did not want to duplicate the description. 
	The only item we needed here was a new identifier (based on AII
Type 2 format) for the PW Switching Point TLV.

	As well:
	
	Is the intention of this draft to address only Inter-AS MS-PWs? 
	[[FB]] We are describing in this draft how to build the PW
routing table using a new BGP AFI, SAFI and static routes. Service
Providers thought this will address Inter-AS  and also MAN-WAN
Inter-domain scenarios. 
	Also there is a draft that describes how to do build the PW
Routing table using OSPF - see
ftp://ftp.isi.edu/internet-drafts/draft-dolganow-pwe3-ospf-ms-pw-ext-01.
txt that expands these procedures. 
	
	thx
	roman k