Subject: [PWE3] Ad Hoc committee on T-MPLS issues with G.8113 and G.8114

From: Stewart Bryant <[email-masked]>
Date: Fri, 11 Jan 2008 14:03:01 +0000

To:

[email-masked] <[email-masked]>
Georges Sebek <[email-masked]>
ITU-T SG13 Question 5 <[email-masked]>
Huub van Helvoort <[email-masked]>
Brian Moore <[email-masked]>
Neal Seitz <[email-masked]>

CC:

Russ Housley <[email-masked]>
IESG <[email-masked]>
IAB <[email-masked]>
Mark Townsley <[email-masked]>
Jari Arkko <[email-masked]>
David Ward <[email-masked]>
Ross Callon <[email-masked]>
pwe3 <[email-masked]>
[email-masked]
Danny McPherson <[email-masked]>
Stewart Bryant <[email-masked]>
George Swallow <[email-masked]>
Loa Andersson <[email-masked]>

[email-masked]

For Action:

As a direct result of the activities at the Stuttgart
meeting, the IAB formed a technical Ad Hoc committee on
T-MPLS.  It was chartered to prepare the IETF for the
proposed cooperation on T-MPLS between the IETF and ITU-T.

At the IETF meeting in Vancouver the Ad Hoc committee was
approached by people active on T-MPLS in the ITU-T who
proposed a joint effort to resolve outstanding issues on
two OAM documents (G.8113 and G.8114) that are scheduled
for approval in Seoul January 2008. A very aggressive joint
plan to resolve the issues were created. Since then the Ad Hoc
committee put in a huge effort to review the relevant
documents and compiled a list of outstanding issues. The
list has more than 60 issues and the process of resolving
those has only just started. The compiled list of issues
is attached to this liaison.

In addition, as the Ad Hoc committee further considered
the G.8114 design it became clear that it proposes
two applications for label 14, an endpoint OAM alert, a P
router OAM alert (i.e. requires the P router to take
special action on packets with label 14 in the stack),
and we have also see a proposal to further extend use
of label 14 to provide a messaging channel for
control plane traffic. In addition to the detailed
review of G.8113 and G.8114, the IETF MPLS and PWE3 Working
Groups therefore have to question whether the proposed
approach of using a single reserved label (or indeed
any reserved label) is the right approach for the
applications that SG13 have in mind, and we believe that
this should be added to the issues list as an
additional significant concern.

The Ad Hoc committee on T-MPLS have come to the
conclusion that G.8113 and G.8114 are not ready to be
approved. This conclusion was endorsed by the Internet
and Routing Area Directors jointly responsible for
this technology.

The outstanding issues include technical, architectural,
and procedural issues.  We think it is important that
these documents be put "on hold" until these issues
are resolved.

The method of resolving the issues should involve expedient
implementation of the proposed agreement that was drafted
in Stuttgart, should follow the MPLS change process, and
should be based on the  liaison statement sent by the
IAB and IESG to you last summer.

The documents are available at:

http://www.tla-group.com/~loa/IETF-TMPLS-Issues-6.pdf

and are attached to this liaison.

The issues list and the conclusions above represent the
consensus of the IETF MPLS and PWE3 Working Groups.

Regards

Loa Andersson
Stewart Bryant
Danny McPherson
George Swallow

IETF MPLS and PWE3 Working Group Co-Chairs

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Brian Moore" <[email-masked]>
Date: Fri, 11 Jan 2008 14:14:02 -0000

Stewart,
We will issue this as a liaison TD to Working Party 4/13. The decision on 
the Recommendations, in line with ITU-T working procedures and practices, 
will taken by the study group after consideration by Q5/13 and Working Party 
4/13 of the technical issues raised in contributions to the meeting.
Brian.

----- Original Message ----- 
From: "Stewart Bryant" <[email-masked]>
To: <[email-masked]>; <[email-masked]>; "Huub van Helvoort" 
<[email-masked]>; "Q5/13" <[email-masked]>; <[email-masked]>; 
<[email-masked]>
Cc: "Russ Housley" <[email-masked]>; <[email-masked]>; "IAB" 
<[email-masked]>; "Mark Townsley" <[email-masked]>; "Jari Arkko" 
<[email-masked]>; "Ross Callon" <[email-masked]>; "pwe3" 
<[email-masked]>; <[email-masked]>; "Danny McPherson" <[email-masked]>; 
"Stewart Bryant" <[email-masked]>; "George Swallow (swallow)" 
<[email-masked]>; "Loa Andersson" <[email-masked]>; <[email-masked]>
Sent: Friday, January 11, 2008 2:03 PM
Subject: Ad Hoc committee on T-MPLS issues with G.8113 and G.8114