Subject: Re: [PWE3] Can we use VCCV-BFD Diagnostic code when the session is UP ?

From: Carlos Pignataro <[email-masked]>
Date: Wed, 13 Feb 2008 16:51:14 -0500

Hi Damodharan,

I think this case is covered in Section 6.8.17 of draft-ietf-bfd-base-07
http://tools.ietf.org/html/draft-ietf-bfd-base-07#section-6.8.17

    Two diagnostic codes are defined for this purpose:  Concatenated Path
    Down and Reverse Concatenated Path Down.
...
    A system MAY signal one of these failure states by simply setting
    bfd.LocalDiag to the appropriate diagnostic code.  Note that the BFD
    session is not taken down.

The inconsistency seems to be a nit in the draft-ietf-bfd-base-07.

Thanks,

--Carlos.

On 2/4/2008 11:12 PM, Damodharan SP - TLS , Chennai said the following:
> Hi,
> 
>  
> 
>   As per my understanding of draft-ietf-bfd-base-07
> 
>   Diagnostic code should be used only when the BFD session goes to Down 
> or Admin Down.
> 
>   “A diagnostic code specifying the local system's reason for the
> 
>   last session state change to states* Down or AdminDown*.”
> 
>  
> 
>   But as per draft-ietf-pwe3-oam-msg-map-04 status codes 6 & 8 can be 
> used to signal AC fault.
> 
>   In this case VCCV-BFD session state is UP.
> 
>  
> 
>   Does it mean that “diagnostic code” can be used even when bfd state is 
> “up”?
> 
>  
> 
>  
> 
>  
> 
>  
> 
> /*/Regards,/*/
> 
> /*/Damodharan.S/*/
> 
>  
> 
>  
> 
> DISCLAIMER:
> -----------------------------------------------------------------------------------------------------------------------
> 
> The contents of this e-mail and any attachment(s) are confidential and 
> intended for the named recipient(s) only.
> It shall not attach any liability on the originator or HCL or its 
> affiliates. Any views or opinions presented in
> this email are solely those of the author and may not necessarily 
> reflect the opinions of HCL or its affiliates.
> Any form of reproduction, dissemination, copying, disclosure, 
> modification, distribution and / or publication of
> this message without the prior written consent of the author of this 
> e-mail is strictly prohibited. If you have
> received this email in error please delete it and notify the sender 
> immediately. Before opening any mail and
> attachments please check them for viruses and defect.
> 
> -----------------------------------------------------------------------------------------------------------------------
> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> http://www.ietf.org/mailman/listinfo/pwe3

-- 
--Carlos Pignataro.
Escalation RTP - cisco Systems

_______________________________________________
pwe3 mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/pwe3

---

From: "Damodharan SP - TLS , Chennai" <[email-masked]>
Date: Thu, 21 Feb 2008 21:54:36 +0530

Hi
  As per my understanding of vccv-bfd and pwe3-oam-msg-map-04. I have
the following questions.

1)If there is a AC side failure and if BFD session is UP, we would send
messages with the diag code 6 or 8. If the AC defect is clear then we
can reset this value ( i.e set to 0 -Zero), is this correct?. If this is
not possible then how else can we communicate via BFD to the remote peer
that the AC fault is clear.

2)If after the AC fault there is a PW fault as well, which causes the
BFD session to go down. Then if the BFD session comes up (while the AC
is still down) , can we continue to carry the diag code 6 or 8

3)If BFD session goes down and then comes up and there are no AC faults
, should we set the diag code corresponding to the previous down reason
or not. 

Regards,
Damodharan.S

-----Original Message-----
From: Carlos Pignataro [mailto:[email-masked]] 
Sent: Thursday, February 14, 2008 3:21 AM
To: Damodharan SP - TLS , Chennai
Cc: [email-masked]; Raman Rangaswamy; Vijayanand C - TLS, Chennai.
Subject: Re: [PWE3] Can we use VCCV-BFD Diagnostic code when the session
isUP ?

Hi Damodharan,

    Two diagnostic codes are defined for this purpose:  Concatenated
Path

Thanks,

--Carlos.

On 2/4/2008 11:12 PM, Damodharan SP - TLS , Chennai said the following:
>   "A diagnostic code specifying the local system's reason for the
> 
>   last session state change to states* Down or AdminDown*."
> 
>  
> 
>   Does it mean that "diagnostic code" can be used even when bfd state
is 
> "up"?
------------------------------------------------------------------------
-----------------------------------------------

------------------------------------------------------------------------
-----------------------------------------------