Subject: [PWE3] Clarification on L/M bits

From: Chad McCarthy <[email-masked]>
Date: Sun, 3 Feb 2008 13:17:21 -0500

The following question is regarding the L/M bit description outlined within RFC5086.  When the M bit is set to "10", must we play out "as received"? It seems like the obvious answer is Yes, considering the following entry in "Table 1.  Interpretation of bits L and M in the CESoPSN CW":  | 0 | 10  | CESoPSN data packet, RDI condition of the AC.  All    |  |   |     | CESoPSN implementations MUST support this codepoint:  |  |   |     | payload MUST be played out "as received", and, if      |  |   |     | so configured, the receiving CESoPSN IWF instance     |  |   |     | SHOULD be able to command the NSP to force the RDI    |  |   |     | condition on the outgoing TDM trunk.                  | But, later on in section "6.2. IWF Operation" , it doesn't list play out as received as an option, unless it's covered under "None". Is this the case? 6.2. IWF OperationIf the data packets received are marked with L bit cleared and M bits set to '10' or with R bit set, the CE-bound CESoPSN IWF will be locally configured to command its local NSP to perform one of the following     o  None (MUST be supported by all the implementations)   o  Transmit the RAI pattern towards the local CE on the E1 or  actions:T1      trunk carrying the local attachment circuit (support of this      action is RECOMMENDED)    o  Send the "Channel Idle" signal to the local CE for all the DS0      channels comprising the local attachment circuit (support of this      action is OPTIONAL and requires also that the CE-bound CES IWF      replaces the actually received payload with the equivalent amount      of the locally configured "idle" bit pattern. Thanks in advance,Chad 
_________________________________________________________________

_______________________________________________
pwe3 mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/pwe3

---

From: Alexander Vainshtein <[email-masked]>
Date: Sun, 3 Feb 2008 21:23:10 +0200

Hi Chad,
Please see answers inline below.
 
Regards,
               Sasha Vainshtein

________________________________

From: [email-masked] on behalf of Chad McCarthy
Sent: Sun 2/3/2008 8:17 PM
To: [email-masked]
Subject: [PWE3] Clarification on L/M bits

The following question is regarding the L/M bit description outlined within RFC5086.  When the M bit is set to "10", must we play out "as received"? 
It seems like the obvious answer is Yes, considering the following entry in "Table 1.  Interpretation of bits L and M in the CESoPSN CW":
  | 0 | 10  | CESoPSN data packet, RDI condition of the AC.  All    |
  |   |     | CESoPSN implementations MUST support this codepoint:  |
  |   |     | payload MUST be played out "as received", and, if      |
  |   |     | so configured, the receiving CESoPSN IWF instance     |
  |   |     | SHOULD be able to command the NSP to force the RDI    |
  |   |     | condition on the outgoing TDM trunk.                  |
 
But, later on in section "6.2. IWF Operation" , it doesn't list play out as received as an option, unless it's covered under "None". Is this the case?
[Sasha] Yes, this is the case. I.e., L=0 and M=01 usually results in playout of
valid payload. On top of that, it is possible  (if the IWF has been so configured) 
to transmit RAI towards the local CE (note that RAI is a certain pattern in the 
framing, not in the payload.)
6.2. IWF Operation
If the data packets received are marked with L bit cleared and M bits set to '10' or with R bit set, the CE-bound CESoPSN IWF will be locally configured to command its local NSP to perform one of the following  
   o  None (MUST be supported by all the implementations)
   o  Transmit the RAI pattern towards the local CE on the E1 or  actions:T1
      trunk carrying the local attachment circuit (support of this
      action is RECOMMENDED)
 
   o  Send the "Channel Idle" signal to the local CE for all the DS0
      channels comprising the local attachment circuit (support of this
      action is OPTIONAL and requires also that the CE-bound CES IWF
      replaces the actually received payload with the equivalent amount
      of the locally configured "idle" bit pattern.
 
Thanks in advance,
Chad

________________________________